Hatena::Groupnadesiko

うたブロ専用ブラウザ

うたブロ専用ブラウザ

#うたブロ専用ブラウザ

#基本的な変数の設定
ベースURL=「http://www.gyao.jp/utablog/play.php?contents_id=uta」
ホームURL=「http://www.gyao.jp/utablog/」
オキニイリファイル=「お気に入り.txt」
バックアップファイル=「お気に入り.bak」
欠番ファイル=「欠番.txt」
最大ナンバー=13491
自動切換え隔=420000
オキニイリとは配列

母艦のタイトルは「うたブロ専用ブラウザ母艦の幅は950。母艦の高さは600。母艦を最大化。

うたブロブラウザとはブラウザ
のXは0。のYは18。
#の幅は900。の高さは712。
の幅は850。の高さは550。
のURLはホームURL
の禁止項目は「画像」
の完了した時は~
    アドレス=うたブロブラウザのURL
    #もし、アドレス≠ゼンカイアドレスならばもし、(うたブロブラウザのURLでベースURLを文字検索)≠0ならば
      もし、モードの値≠2ならば
        #「曲情報表示します」と言う。
        曲情報表示違えば
      母艦=「うたブロ専用ブラウザ」
    #状況=うたブロブラウザのURL
    ゼンカイアドレス=アドレス

ホームボタンとはボタン
のXは0。のYは0。
の幅は55。の高さは20。
のクリックした時は
    うたブロブラウザのURLは「{ホームURL}」

アドレスとはエディタ
のXは55。のYは0。
の幅は765。
のダブルクリック時は~
    アドレスを全選択
のキー押した時は~
    #アドレスの押された仮想キーを言うもし、アドレスの押された仮想キーが13なら
        移動する。

オキニイリラベルとはラベルのテキストは「お気に入り」。
のXは875。のYは150。

ランダムラベルとはラベルのテキストは「ランダム」。
のXは875。のYは250。

移動ラベルとはラベルのテキストは「移動」。
のXは875。のYは375。

オプションラベルとはラベルのテキストは「オプション」。
のXは875。のYは475。

モードとはラジオ
のアイテムは「0.オール
1.お気に入り
2.おまけ」
のテキストは「モード」
の値は0。
のXは875。のYは50。
の高さは85。の幅は125。

インターバルとはエディタのXは850。のYは20。
の幅は25。
の可視はオフ

自動移動モードとはチェック
のXは880。のYは0。の幅は125。
のテキストは「自動移動モード」
の可視はオフ
のクリックした時は~
    もし、自動移動モードの値がオンなら
        自動切換タイマーを開始。
    違えば
        自動切換タイマー停止。

ホットキーモードとはチェック
のXは880。のYは500。の幅は125。
のテキストは「ホットキー使用」
の値はオフ
のクリックした時は~
    もし、ホットキーモードの値がオンなら
      ホットキー全登録
    違えば
      ホットキー全削除

●ホットキートグル
    もし、ホットキーモードの値がオンなら
        ホットキーモードの値はオフ
        ホットキー全削除
    違えば
        ホットキーモードの値はオン
        ホットキー全登録
        #母艦最前面表示オン

●ホットキー全登録
        「1」に「オキニイリ前移動」をホットキー登録
        「2」に「曲情報表示ボタン表示」をホットキー登録
        「3」に「オキニイリ次移動」をホットキー登録
        「4」に「前移動」をホットキー登録
        「6」に「次移動」をホットキー登録
        「7」に「ランダム移動」をホットキー登録
        「8」に「おまけ実行」をホットキー登録
        「5」に「おまけ選択実行」をホットキー登録
        「9」に「オキニイリランダム移動」をホットキー登録

●ホットキー全削除
        「1」のホットキー解除
        「2」のホットキー解除
        「3」のホットキー解除
        「4」のホットキー解除
        「6」のホットキー解除
        「7」のホットキー解除
        「8」のホットキー解除
        「5」のホットキー解除
        「9」のホットキー解除

●曲情報表示ボタン表示
  曲情報表示ボタンの可視はオン
  

自動切換タイマーとはタイマー
の値は自動切換えの時満ちた時は~
    オキニイリランダム移動。
    #ランダム移動移動ボタンとはボタンのXは810。のYは0。の幅は40。の高さは20。
これをクリックした時は~
    移動する。

●移動
    自動移動モードの値はオフ。
    自動切換タイマー停止。
    うたブロブラウザを注目。
    うたブロブラウザのURLは「{アドレス}」

前ボタンとはボタンのテキストは「前(&4)」
のXは875。のYは400。の幅は60。の高さは25。
これをクリックした時は~
    前移動

●前移動
    もし、自動移動モードの値がオンなら
        自動切換タイマー停止。
        自動切換タイマーを開始。
    モードの値で条件分岐
     0ならば
        ナンバーRIGHT(アドレス,7)
        ナンバー=ナンバー-1
        ナンバー=ナンバーを7でゼロ埋め。
        状況=「{ベースURL}{ナンバー}」
        うたブロブラウザのURLは「{ベースURL}{ナンバー}」
     1ならば
        もし、自動移動モードの値がオンなら
            自動切換タイマー停止。
            自動切換タイマーを開始。
        インデックス=インデックス-1
        状況=「{ベースURL}{オキニイリ【インデックス,3】}」
        うたブロブラウザを注目。
        うたブロブラウザのURLは「{ベースURL}{オキニイリ【インデックス,3】}」
     2ならば
        対象ファイルリスト要素数を候補数に代入。
        選択曲番号=選択曲番号-1
        状況=対象ファイルリスト【選択曲番号】
        うたブロブラウザのURLは対象ファイルリスト【選択曲番号】

次ボタンとはボタンのテキストは「次(&6)」
のXは940。のYは400。の幅は60。の高さは25。
これをクリックした時は~
    次移動

●次移動
    もし、自動移動モードの値がオンなら
        自動切換タイマー停止。
        自動切換タイマーを開始。
    モードの値で条件分岐
     0ならば
        ナンバーRIGHT(アドレス,7)
        ナンバー=ナンバー+1
        ナンバー=ナンバーを7でゼロ埋め。
        状況=「{ベースURL}{ナンバー}」
        うたブロブラウザのURLは「{ベースURL}{ナンバー}」
     1ならば
        もし、自動移動モードの値がオンなら
            自動切換タイマー停止。
            自動切換タイマーを開始。
        インデックス=インデックス+1
        状況=「{ベースURL}{オキニイリ【インデックス,3】}」
        うたブロブラウザを注目。
        うたブロブラウザのURLは「{ベースURL}{オキニイリ【インデックス,3】}」
     2ならば
        対象ファイルリスト要素数を候補数に代入。
        選択曲番号=選択曲番号+1
        状況=対象ファイルリスト【選択曲番号】
        うたブロブラウザのURLは対象ファイルリスト【選択曲番号】

直接ジャンプボタンとはボタンのテキストは「直接ジャンプ(&5)」
のXは875。のYは425。の幅は125。の高さは25。
これをクリックした時は~
    ジャンプ

クリップボタンとはボタンのテキストは「クリップ」
のXは875。のYは550。の幅は125。の高さは25。
これをクリックした時は~
    曲情報クリップ

●曲情報クリップ
  曲情報取得して曲データに代入。
  #曲歌手=「 ♪ 曲名/歌手名…{曲データ@曲名}」
  #投稿者=「 ♪ 投稿者…{曲データ@歌手名}さん」
  #URL=「|{うたブロブラウザのURL}」
  「/───────────────────────[ う た ブ ロ ]──\
| ♪ 曲名/歌手名
|  ♪  {曲データ@曲名}/{曲データ@歌手名}
| ♪ 投稿者 … {曲データ@投稿者} さん
|{うたブロブラウザのURL}
\───────────────────────────────/」をコピー

●ジャンプ
    もし、自動移動モードの値がオンなら
        自動切換タイマー停止。
        自動切換タイマーを開始。
    モードの値で条件分岐
     0ならば
       オール選択実行
     1ならば
        オキニイリ選択実行
     2ならば
       おまけ選択実行

オールランダムボタンとはボタンのテキストは「オール(&7)」
のXは875。のYは275。の幅は125。
これをクリックした時は~
    ランダム移動。

欠番ボタンとはボタンのXは730。のYは20。の幅は40。
の可視はオフこれをクリックした時は~
    ナンバーRIGHT(アドレス,7)
    「{ナンバー}{改行}」を欠番ファイルに追加保存
    状況=「{ナンバー}を欠番に記録しました。」

星ヒトツボタンとはボタンのテキストは「★」
のXは770。のYは20。の幅は40。
の可視はオフこれをクリックした時は~
    ナンバーRIGHT(アドレス,7)
    「{ナンバー}★{改行}」を欠番ファイルに追加保存
    状況=「{ナンバー}を★に記録しました。」

表とはグリッドのXは0。のYは570。
の幅は720。の高さは160。
文字サイズ=8
の自動ソートはオフのダブルクリックした時は~
    I=オキニイリ【表の値,3】
    状況=I
    うたブロブラウザのURLはI
    うたブロブラウザを注目。
    モードの値=1
    アドレス=うたブロブラウザのURL
    #もし、アドレス≠ゼンカイアドレスならば、
    #もし、(うたブロブラウザのURLでベースURLを文字検索)≠0ならば
    #  もし、モードの値≠2ならば
    #    「曲情報表示します」と言う。
    #    曲情報表示。
        


ソース閲覧ボタンとはボタンのテキストは「ソース閲覧」
のXは760。のYは575。の幅は100。
の可視はオンこれをクリックした時は~
    ソース=うたブロブラウザのテキスト
    #ソースを言う
    #ソースの「」を「/」に置換
    それからタグ削除してソース2に代入。
    #ソース=それ
    #正規表現=「<[^>]+><[^>]+><[^>]+>([^<]+)<[^>]+><[^>]+><[^>]+>([^<]+)<[^>]+><[^>]+><[^>]+><[^>]+>」
    #ソース【352】の正規表現を「$1,$2」へ正規表現置換
    #ソース=それ。
    ソース2を言う。
    ソース2=ソース2を「{~}」で区切る
    ソース25=ソース2の「,」を「○」に置換
    ソース3=ソース25【441】
    ソース4=ソース25【470】
    #ソース3を言う。
    #ソース4を言う。

オキニイリ再読込ボタンとはボタンのテキストは「お気に入り再読込」
の可視はオフのXは700。のYは600。の幅は160。
これをクリックした時は~
    オキニイリ読込。

オキニイリ編集ボタンとはボタンのテキストは「編集」
のXは875。のYは205。の幅は125。
これをクリックした時は~
    #オキニイリファイルを起動する。
    テキスト=オキニイリファイルを開いてメモ記入もしテキスト≠「」ならば
        オキニイリファイルからバックアップファイルへファイルコピー
        テキストをオキニイリファイルに保存。
        オキニイリ読込。
        状況=「保存しました。」
    違えば
        状況=「キャンセルしました。」

オキニイリ追加ボタンとはボタンのテキストは「追加のXは875。のYは180。の幅は125。
これをクリックした時は~
  S=RIGHT(アドレス,4)を大文字変換
  もし、(S=「.MOV」)または(S=「.MP4」)ならば
    曲情報=「曲名={~}歌手名={~}投稿者=」で項目記入
    もし曲情報≠「」ならば
        オキニイリテキスト=「{曲情報@曲名},{曲情報@歌手名},{曲情報@投稿者},{アドレス}{改行}」
        オキニイリテキストをオキニイリファイルに追加保存
        オキニイリ読込。
        状況=「{アドレス}をお気に入りに追加しました。」
    違えば
        状況=「キャンセルしました。」
  違えば
    ナンバーRIGHT(アドレス,7)
    曲情報取得して曲データに代入。
    曲情報=「曲名={曲データ@曲名}{~}歌手名={曲データ@歌手名}{~}投稿者={曲データ@投稿者}」で項目記入
    もし曲情報≠「」ならば
        オキニイリテキスト=「{曲情報@曲名},{曲情報@歌手名},{曲情報@投稿者},{アドレス}{改行}」
        オキニイリテキストをオキニイリファイルに追加保存
        オキニイリ読込。
        状況=「{ナンバー}をお気に入りに追加しました。」
    違えば
        状況=「キャンセルしました。」

オキニイリランダムボタンとはボタンのテキストは「お気に入り(&9)」
のXは875。のYは325。の幅は125。
これをクリックした時は~
    オキニイリランダム移動。

マイビデオランダムボタンとはボタンのテキストは「マイビデオ(&8)」
のXは875。のYは300。の幅は100。
これをクリックした時は~
    おまけ実行。

マイビデオ開クボタンとはボタンのテキストは「開」
のXは975。のYは300。の幅は25。
これをクリックした時は~
    「{マイドキュメント}My Videos」を起動。


●おまけ実行
    「{マイドキュメント}My Videos\*.MOV;*.3G2;*.mp4」の全ファイル列挙それ対象ファイルリスト代入。
    #対象ファイルリスト言う対象ファイルリスト要素数を候補数に代入乱数初期化
    選択曲番号=候補数の乱数
    状況=対象ファイルリスト【選択曲番号】
    うたブロブラウザのURLは対象ファイルリスト【選択曲番号】
    モードの値は2。

●オール選択実行
    「ナンバー」を尋ねる
    ナンバーそれ
    もし、ナンバー≠「」ならば
        ナンバー=ナンバーを7でゼロ埋め。
        状況=「{ベースURL}{ナンバー}」
        うたブロブラウザを注目。
        うたブロブラウザのURLは「{ベースURL}{ナンバー}」
        状況=「{ベースURL}{ナンバー}」
        モードの値は0。

●オキニイリ選択実行
    一時変数=「」
    Cで0からオキニイリの要素数まで繰り返す
        もし、C≠0ならば
            もし、オキニイリ【C,0】≠「」ならば
                「{C},{オキニイリ【C,0】}/{オキニイリ【C,1】}{改行}」を一時変数追加。
    一時変数リスト選択。
    一時テキスト=それもし、一時テキスト≠「」ならば
        一時配列=一時テキストを「,」で区切る
        選択曲番号=一時配列【0】
        うたブロブラウザを注目。
        うたブロブラウザのURLは「{オキニイリ【選択曲番号,3】}」
        状況=「[{選択曲番号}]{オキニイリ【選択曲番号,3】}」
        モードの値は1。

●おまけ選択実行
    一時変数=「」
    一時カウンタ=0
    「{マイドキュメント}My Videos\*.MOV;*.3G2;*.mp4」の全ファイル列挙それ対象ファイルリスト代入
    対象ファイルリスト反復
        対象からファイル名抽出
        「{一時カウンタ},{それ}{改行}」を一時変数追加。
        一時カウンタ=一時カウンタ+1
    #対象ファイルリスト言う。
    一時変数配列逆順
    一時変数リスト選択。
    一時テキスト=それもし、一時テキスト≠「」ならば
        一時配列=一時テキストを「,」で区切る
        選択曲番号=一時配列【0】
        うたブロブラウザのURLは対象ファイルリスト【選択曲番号】
        状況=対象ファイルリスト【選択曲番号】
        #うたブロブラウザのURLは「{マイドキュメント}My Videos\{対象ファイル}」
        モードの値は2。

状況とはステータスバー。

●オキニイリ読込
  オキニイリファイルを読んでオキニイリに代入。
  表のアイテムはオキニイリ。

●ランダム移動
  #自動移動モードの値はオフもし、自動移動モードの値がオンなら
      自動切換タイマー停止。
      自動切換タイマーを開始。
  必要乱数初期化。
      ナンバー=(最大ナンバー乱数+1)を7でゼロ埋め。
      #欠番チェック
      状況=「欠番チェック中」
      チェックリストに欠番ファイルを開くチェックリストでナンバー文字検索もしそれが0なら
          抜ける。
  状況=「[{ナンバー}] ⇒ チェックOK!」
  うたブロブラウザを注目。
  うたブロブラウザのURLは「{ベースURL}{ナンバー}」
  モードの値は0。

●オキニイリランダム移動
    #自動移動モードの値はオフもし、自動移動モードの値がオンなら
        自動切換タイマー停止。
        自動切換タイマーを開始。
    乱数初期化。
    #オキニイリの要素数言う
    インデックス=(オキニイリの要素数-1)の乱数+1
    #「{インデックス}」を言う。
    状況=「[{インデックス}]{オキニイリ【インデックス,3】}」
    うたブロブラウザを注目。
    うたブロブラウザのURLはオキニイリ【インデックス,3】
    モードの値は1。

●オキニイリ次移動
    もし、自動移動モードの値がオンなら
        自動切換タイマー停止。
        自動切換タイマーを開始。
    インデックス=インデックス+1
    状況=「{オキニイリ【インデックス,3】}」
    うたブロブラウザを注目。
    うたブロブラウザのURLは「{オキニイリ【インデックス,3】}」

●オキニイリ前移動
    もし、自動移動モードの値がオンなら
        自動切換タイマー停止。
        自動切換タイマーを開始。
    インデックス=インデックス-1
    状況=「{オキニイリ【インデックス,3】}」
    うたブロブラウザを注目。
    うたブロブラウザのURLは「{オキニイリ【インデックス,3】}」

曲情報表示ボタンとはボタン
のXは5。のYは570。
の幅は1014。の高さは160。
文字サイズは30
のテキストは「曲ラベルの可視はオフ
のクリックした時は
  曲情報表示ボタンの可視はオフ

●曲情報表示
    曲情報取得して曲データに代入。
    曲情報=「{曲データ@曲名}/{曲データ@歌手名}/{曲データ@投稿者}」
    #曲情報を言うもし曲情報≠「/」ならば
        母艦=「うたブロ専用ブラウザ ~ {曲情報} ~」
        曲情報表示ボタンのテキスト=曲情報        
    違えば
        母艦=「うたブロ専用ブラウザ」

●曲情報取得
    #アドレスを言う
    ソース=うたブロブラウザのテキスト
    #ソースの「」を「/」に置換
    #ソースを言う
    #正規表現=「<[^>]+><[^>]+><[^>]+>([^<]+)<[^>]+><[^>]+><[^>]+>([^<]+)<[^>]+><[^>]+><[^>]+><[^>]+>」
    #ソース【352】の正規表現を「$1{~}$2」へ正規表現置換
    #ソース【352】を正規表現で正規表現マッチそれからタグ削除してソース2に代入。
    #ソース2を言う。
    #ソース2=ソース2を「{~}」で区切る
    ソース3=ソース2の「,」を「□」に置換
    #一時変数=ソース【480】の正規表現を「$1{~}$2」へ正規表現置換
    曲データとはハッシュ
    #X1=ソース3【389-1】を「/」で区切る
    #曲データ@曲名=X1【0】
    #曲データ@歌手名=X1【1】
    曲データ@曲名=ソース3【389-1】
    曲データ@歌手名=ソース3【390-1】
    曲データ@投稿者=ソース3【419-1】
    #曲データ@曲名=一時変数【0】
    #曲データ@歌手名=一時変数【1】
    #曲データを言う
    それ=曲データ

オキニイリ読込
状況=最大ナンバー
「Ctrl+0」に「ホットキートグル」をホットキー登録
うたブロブラウザを注目。