Hatena::Groupnadesiko

99円のへたれ学習帳

2009-10-25

問題

| 15:59

問1

名前を尋ねて、の人に挨拶するプログラムを書いてください。

命令:「尋ねる」「言う」「(文字列連結)」

余裕があれば:エディタ部品やボタン部品も使ってみてください。

問2

ひつじを1秒ごとに10匹数えるプログラムを書いてください。

余裕があれば:しゃべらせてみてください。

問3

年を尋ねて、の年の13日の金曜日をすべて表示するプログラムを書いてください。

問4

九九の表を表示するプログラムを書いてください。数字は揃えて表示してください。

命令:「繰り返す 構文」「継続表示」「改行(定数)」

ヒント:「継続表示」は文字を表示した後、改行ない命令です。

問5

なでしこがインストールされているフォルダ以下に含まれているすべての「.nako」ファイルのファイル名と、の個数を表示するプログラムを書いてください。

ヒント:なでしこのインストールされているフォルダは「ランタイムパス」です。

問6

コンピュータとじゃんけんをするプログラムを書いてください。ただし、人対人用にも改造できるようにしてください。

命令:「ボタン選択

ヒント:勝ち負けの判定は、手を数に変換すると簡単になります。

問7

3桁の数を尋ねて、それを漢数字に変換するプログラムを書いてください。

(例:256→二百五十六 101→百一)

余裕があれば、3桁以外の数にも対応させてみてください。

kujirahandkujirahand2009/10/25 16:01===
「名前は?」と尋ねる。
「{それ}さん、こんにちは」と言う。
===
普通ですが・・・

kujirahandkujirahand2009/10/25 16:04問2:
~~~~~
!「aquestalk.nako」を取り込む
10回
  母艦=回数
  「ひつじ;が」とAQT話す
  「<NUMK VAL={回数} COUNTER=ひき>」とAQT話す
  1秒待つ。
終わる。
~~~~~

kujirahandkujirahand2009/10/25 16:41問6 じゃんけんプログラム
~~~
#-----------------------------------------------------------------------
# じゃんけんプログラム
#-----------------------------------------------------------------------
相手一覧=「人間
コンピューター」

手一覧=「0:ぐー
1:ちょき
2:ぱー」

「誰と勝負しますか?」を相手一覧で、
ボタン選択して相手に代入。

真の間
 勝負実行
 勝負判定
 「続けますか?」と二択。
 もし、それがいいえならば、終わる。

●勝負実行
 「先手:どの手を出しますか」を手一覧でボタン選択して、
 先手に代入。
 もし、相手=「人間」ならば
  「後手:どの手を出しますか」を手一覧でボタン選択して、
  後手に代入。
 違えば
   手番号=3の乱数
   後手=手一覧¥手番号
 
●勝負判定
 先手N=INT(先手)
 後手N=INT(後手)
 判定番号は、(先手N - 後手N + 3) % 3
 判定番号で条件分岐
  0ならば
   結果=「あいこ」
  1ならば
   結果=「後手の勝ち」
  2ならば
   結果=「先手の勝ち」
 「先手:{先手} 後手:{後手}」を表示
 「結果:{結果}」を表示。
#-----------------------------------------------------------------------

kujirahandkujirahand2009/10/25 16:42問7 3桁限定とのことで、以下のように。本来は、割ってくと良いのですが・・・
~~~
候補=「,壱,弐,参,四,五,六,七,八,九」を「,」で区切る。
「数字を入力してください」と尋ねて、NOに代入。
NOを文字列分解
「{候補\それ\0}百{候補\それ\1}十{候補\それ\2}」を表示  
~~~

kujirahandkujirahand2009/10/25 16:44問4
~~~
LIST=ランタイムパス&「*.nako」の全ファイル列挙
F個数=LISTの要素数
「ファイルの個数:{F個数}
{LIST}」をメモ記入。
~~~

nade_sochanade_socha2009/10/30 18:20問4
「回」を使うと、「回数」が混乱するということですが、
変数を使うことで回避できます。
~~~
文字サイズは12
9回
  Tateは回数。
  10,Tate*30へ回数を文字表示。
  Tate*50-10,0へ「{回数}の段」を文字表示。
  9回
    Yokoは回数。Kekka=Tate*Yokoを2で文字列右寄せ。
    Yoko*50,Tate*30へKekkaを文字表示。
~~~

MusbauMusbau2012/03/26 18:26There are no words to describe how bdoacious this is.

pgqkzqrfhrpgqkzqrfhr2012/03/28 08:32BaNCyg , [url=http://crektuepblbg.com/]crektuepblbg[/url], [link=http://keiuxdrlhjgl.com/]keiuxdrlhjgl[/link], http://ekqugbkcooat.com/

rzsaqzrzsaqz2012/03/28 15:03jdyw6Y <a href="http://dhabbkooczwv.com/">dhabbkooczwv</a>