Hatena::Groupnadesiko

99円のへたれ学習帳

2011-05-22

sleep sort

| 21:10

http://d.hatena.ne.jp/gfx/20110519/1305810786

sleep sortいうソートアルゴリズムが話題になっているようなので、なでしこでも書いてみました。

タイマー部品にポケットがないので、こだけ拡張したPタイマーを定義して使っています。

# スリープソート  99yen 2011/5/22

ソート対象=「5,3,6,3,6,3,1,4,7」を「,」で区切る
N=ソート対象の要素数

# ソート済みの個数
CNT=0
# 係数 待機秒=対象*C
C=0.1

ソート対象を反復
	ソートタイマー[回数-1]をPタイマーとして作成
	ソートタイマー[回数-1]→間隔=対象*C
	ソートタイマー[回数-1]→ポケット=対象
	ソートタイマー[回数-1]→時満ちた時は~
		自身→停止
		自身→ポケットを表示
		CNT=CNT+1
		もし、CNT>=Nならば、「ソート完了」と言う
	ソートタイマー[回数-1]→開始

■Pタイマー +タイマー
	・ポケット

f:id:kyuuzyuu9yen:20110522211010p:image

こいつ…動くぞ!w

ElsieElsie 2014/07/21 16:00 Glad I've finally found sonemhitg I agree with!

ゲスト



トラックバック - http://nadesiko.g.hatena.ne.jp/kyuuzyuu9yen/20110522