matumatuのなでしこ学習帳

2007-12-16なでしこ本 P.19の学習です

本日は、なでしこ本 P.19の学習です。

00:12

RPGレベルを判定した結果

LV              =     1

HP              =   72 →  132 ↑ 改善

MP              =  100

学習完了までの日数    =  688 →  701 ↑  悪化

学習完了予想年月日    = 2009/10/30 → 11/16 ↑  悪化

はてな学習帳カウンター値 =     ---  →  2274 --- ---

でした。

最近、学習をさぼったため、数値が悪化した。

ただし、HPは判定プログラムの改良(?)で

上昇した。 (^^;)


第1章 基礎編のうち、ようやくSTEP-3に入った。

00:12

「はじめてのプログラム」を学習した。

下記のプログラム「 はじめて.nako 」

は、なでしこ本CDROM → sample → 01-03

に入っているプログラムです。


「こんにちは」と表示。


  1. 動作結果 : さすが、サンプルプログラムなので、

        正常に表示された。                            


次に、なでしこ本 P.19に書いてあるように

00:12

「 」をわざと省略してみた。

下記のプログラム「 はじめてA.nako 」

は、改良(?)版です。


# わざと、「 」を省略してみた。
こんにちはと表示。


  1. 動作結果 : なでしこ本 P.19に書いてあるとおり、

        何も表示されなかった。 (^^;)


なでしこRPGレベル判定プログラム(その4)です

00:12

下記のプログラム「 RPGレベル判定4.nako 」

は、私の「なでしこ本」学習レベルを表示するプログラムです。

本日の改良点

00:12

  1. 判定する変数に、はてな学習帳のカウンター値を組み込んだ。

これは、なでしこ本の学習が進むと、内容が高度になるので、

レベルが上がるほどHPを増加させる必要ありますが、

のころには、カウンター値も増加しているだろうと、

想定して、組み込みました。


#------------------------------------------------------------------------------
# なでしこRPG学習レベル判定4      Ver 0.4
#
# (学習状況(なでしこ本を学習したページ数)の入力をします           )
# (LVは、第1章 P.38までを学習中なので、1です。               )
# (HPは、LV=1の場合、初期値=50+カウンター値÷20で、学習開始日の )
#  (    2007年11月14日から、1日当たり1減少し、            )
#  (        HP=0で学習不能状態と判定されます。                 )
#  (MPは、LV=1の場合、初期値100で、1回魔法を使うと            )
#  (    50減少する代わりに、HPが50回復しますが、未完成です。      )
#  (LV1のパラメーターは上記ですが、ゲームバランスによって            )
#  (は、途中で自分の都合に合わせて突然変更します。                 )
#  (LV2以上については、遠い将来なので、想定の範囲外です。 (^^;)       )
#  (学習完了まで後、何日か表示します。 完了予想年月日も、表示します。    )
#------------------------------------------------------------------------------

# 現在、学習中の、なでしこ本ページ数
「現在、学習中の、なでしこ本ページ数は?」と尋ねる。
P=それ

# 現在の、はてな学習帳のカウンター数
「現在の、はてな学習帳のカウンター値は?」と尋ねる。
C=それ

# LVの判定        (第1章はP.38でクリアーする)
もし、P<=38 ならば
   「LV=1」と、表示。
違えば
   「LV=2」と、表示。

# 学習開始日(2007年11月14日)から、今日までの日数計算
D=「2007/11/14」と今日の日数差

# HPの判定
HP=50 + ROUND(C/20 - D)
もし、HP>0 ならば
   「HP={HP}」と、表示。
違えば
   「学習不能状態です!! 3秒後に魔法を使います」と、表示。
    3秒待つ。
        M=1
    HP=50 + ROUND(C/20 - D)+50*M
      「HP={HP}」と、表示。

# MPの判定
MP=100-50*M
もし、MP>0 ならば
   「MP={MP}」と、表示。
違えば
   「学習スピードを早くしてください」と、表示。

# 学習完了まで後、何日か表示
DC1=ROUND((435-P)/P*D)
「学習完了までの日数 = {DC1}日」と、表示。

今日に「+0/0/{DC1}」を日付加算。
DC2=それ
「学習完了予想年月日 = {DC2}」と、表示。

明日の予定

00:12

なでしこ本 P.20に進みます。

なでしこRPGレベル判定プログラムの改良としては、

ろ、プログラムとデーターの分離が必要

痛感しています。