matumatuのなでしこ学習帳

2007-12-30本日は、なでしこ本 P.28の学習です

f:id:matumatuh18:20071229141412j:image

学習レベルを判定した結果 LV = 1 : HP = 60 : MP = 100

22:39

  • 完了予想日数 = 695 → 669 改善
    • 完了予想年月日 = 2009/11/24 → 10/29 改善
      • はてなカウンター値 = 3967 → 4069 キリ番をえました。

久しぶりに、学習レベル判定プログラムを改良し、バージョンアップ

22:39

しました。

これに伴い、一気にHPが減少したので、しばらく様子を見て

再度、パラメーターを微調整する可能性があります

休暇中なのと、昨日 大阪日本橋で、食べた巨大な定食の

22:39

効果で、がんばって、なでしこ本を学習し、数値が改善した。


第1章 基礎編 STEP-4

22:39

「時の計算」、「時を加算する」、「日付の計算」を学習した。

下記のプログラム「 時を計算する.nako 」、「 時を加算する.nako 」

「 日付計算.nako 」は、なでしこ本CDROM → sample → 01-04

に入っているプログラムです。


「08:10:00」と「08:20:30」の秒差を表示。

「09:32:10」に「1:00:00」を時間加算して表示。

「2005/01/01」と「2006/01/01」の日数差を表示。
「2005/01/01」に「0/0/05」を日付加算して表示。

  • 動作結果 : 「時を計算する」さすが、サンプルプログラムなので、

        正常に、「 630 」

         と小さな文字で表示された。     

  • 動作結果 : 「時を加算する」さすが、サンプルプログラムなので、

        正常に、「 10:32:10 」

        と小さな文字で表示された。  

  • 動作結果 : 「日付計算」さすが、サンプルプログラムなので、

        正常に、「 365 」と「 2005/01/06 」

        と小さな文字で表示された。  


次に、時間値を、原本と逆にしたら、どうなるかをテスト。

22:39

さらに、なでしこ本 P.110を参考にして、計算結果を大きな

数字で表示するように改造した。

下記のプログラム「 時を計算するA.nako 」、

「 時を加算するA.nako 」、「 日付計算A.nako 」は、

改造版です。


# なでしこ本 P.110を参考にして、文字を大きく表示
# 時間値を、原本と逆にしたらどうなるかを、テストしてみます。

文字書体は「MS 明朝」
文字サイズは64

A = 「08:20:30」と「08:10:00」の秒差
Aを表示。

# なでしこ本 P.110を参考にして、文字を大きく表示
# 時間値を、原本と逆にしたらどうなるかを、テストしてみます。

文字書体は「MS 明朝」
文字サイズは64

A = 「1:00:00」に「09:32:10」を時間加算
Aを表示。

# なでしこ本 P.110を参考にして、文字を大きく表示
# 時間値を、原本と逆にしたらどうなるかを、テストしてみます。
# 計算専門の行と、表示専門の行に分離する改造をしています。

文字書体は「MS 明朝」
文字サイズは32

A = 「2006/01/01」と「2005/01/01」の日数差
# B = 「0/0/05」に「2005/01/01」を日付加算
B = 「計算式Bは、エラーが出るのでコメント化した」
C = 「2005/01/01」に「0/0/05」を日付加算


「A = {A}」を表示。
「B = {B}」を表示。
「C = {C}」を表示。

  • 動作結果 : 「時を計算するA」

        正常に、「 -630 」

         と大きな文字で表示された。     

         時値を、原本と逆にしたら、マイナスに

         なることを学習した。

  • 動作結果 : 「時を加算するA」

        正常に、「 10:32:10 」

         と大きく表示された。

         時値を、原本と逆にしても、影響が無い

         ことを学習した。

  • 動作結果 : 「日付計算A」

        計算式Aは、正常に「 -365 」

        と大きな文字で表示された。  

         時値を、原本と逆にしたら、マイナスに

         なることを学習した。

         計算式Bは、エラーが出た。

         つまり、時値を逆にすることが、

         許されないことを学習した。

        計算式Cは、正常に「 2005/01/06 」

         と大きな文字で表示された。

         これは、時値を逆にしなかったので正常な結果になった。


なでしこ本学習レベル判定プログラム(その5)です

22:39

下記のプログラム「 なでしこ本学習レベル判定5.nako 」

は、私の「なでしこ本」学習レベルを表示するプログラムです。

本日の改良点

22:39

  1. 12月16日に、判定する変数として、はてな学習帳のカウンター値を組み込

ましたが、それ以降、どんどんHPが上昇したので、HPがカウンター値で増加する

効果を1/2に抑え、HPが経過日数で減少する効果を2にしました。

  1. の改良で、HPが前日202だったのが、

一気に60に減少しています。

様子を見て、再度ゲームバランスを調整しないと、

なでしこ本の学習途中で、ゲームオーバーになる

可能性があります。 (^^;)


#------------------------------------------------------------------------------
# なでしこ本学習レベル判定5      Ver 0.5
#
# 学習状況(なでしこ本を学習したページ数)の入力をします
# LVは、第1章 P.38までを学習中なので、1です。
# HPは、LV=1の場合、初期値=50+カウンター値÷40で、学習開始日の
#      2007年11月14日から、1日当たり2減少し、
#          HP=0で学習不能状態と判定されます。
#  MPは、LV=1の場合、初期値100で、1回魔法を使うと
#      50減少する代わりに、HPが50回復しますが、未完成です。
#  LV1のパラメーターは上記ですが、ゲームバランスによって
#  は、途中で自分の都合に合わせて突然変更します。
#  LV2以上については、遠い将来なので、想定の範囲外です。 (^^;)
#  学習完了まで後、何日か表示します。 完了予想年月日も、表示します。
#------------------------------------------------------------------------------

# 現在、学習中の、なでしこ本ページ数
「現在、学習中の、なでしこ本ページ数は?」と尋ねる。
P=それ

# 現在の、はてな学習帳のカウンター数
「現在の、はてな学習帳のカウンター値は?」と尋ねる。
C=それ

# LVの判定        (第1章はP.38でクリアーする)
もし、P<=38 ならば
   「LV=1」と、表示。
違えば
   「LV=2」と、表示。

# 学習開始日(2007年11月14日)から、今日までの日数計算
D=「2007/11/14」と今日の日数差

# HPの判定
HP=50 + ROUND(C/40 - 2*D)          # Ver 0.5で係数見直し実施した
もし、HP>0 ならば
   「HP={HP}」と、表示。
違えば
   「学習不能状態です!! 3秒後に魔法を使います」と、表示。
    3秒待つ。
        M=1
    HP=50 + ROUND(C/40 - 2*D)+50*M    # Ver 0.5で係数見直し実施した
      「HP={HP}」と、表示。

# MPの判定
MP=100-50*M
もし、MP>0 ならば
   「MP={MP}」と、表示。
違えば
   「学習スピードを早くしてください」と、表示。

# 学習完了まで後、何日か表示
DC1=ROUND((435-P)/P*D)
「学習完了までの日数 = {DC1}日」と、表示。

今日に「+0/0/{DC1}」を日付加算。
DC2=それ
「学習完了予想年月日 = {DC2}」と、表示。

明日の予定

22:39

なでしこ本 P.29のプログラムに進みます。