matumatuのなでしこ学習帳

2008-01-04本日は、なでしこ本 P.35の学習です

学習レベルを判定した結果 LV = 1 : HP = 68 : MP = 100

22:35

  • 完了予想日数 = 590 → 594 悪化
    • 完了予想年月日 = 2009/08/15 → 08/21 悪化
      • はてなカウンター値 = 4721 → 4865

今日から新年初出勤で、なでしこ本の学習ペースが落ち、数値が悪化した。

22:35

実は、年末に初めてDS Lite(新品ハード)と、FFⅦ(中古ソフト)

を購入し、最近FFⅦに夢中になっているのが、学習ペースが落ちた

根本原因の可能性があります。 (^^;)


第1章 基礎編 STEP-6

22:36

「健康チェック~BMIで肥満度を確認」を学習した。


下記のプログラム「 肥満度チェック.nako 」は、

22:36

なでしこ本CDROM → sample → 01-06

に入っているプログラムです。


「身長(cm)は?」と尋ねる。
身長はそれ
「体重(kg)は?」と尋ねる。
体重はそれ

理想体重=((身長÷100)^2)×22
肥満度は体重÷理想体重×100

「身長が{身長}cmで体重が{体重}kgの場合:
-----------
理想体重は{理想体重}kgです。
肥満度は{肥満度}%です。」と表示。

  • 動作結果 : 「肥満度チェック」さすが、サンプルプログラムなので、

        正常に、「 身長(cmは? 」

             「 体重(kg)は?」

         と尋ねられたので、なでしこ本

         のとおり、「 160 」、「 60 」と入力した。

        正常に、「 理想体重は56.32kgです。 」

             「 肥満度は106.534090909091%です。 」

         と表示された。

         ただし、インターネットで検索した結果、

         肥満度は、計算結果 -100 = 6.534090909091%

         が正しいと思われるので、後で改造します。


下記のプログラム「 肥満度チェックA.nako 」は、

22:36

やせ~高度肥満まで判定結果を表示するようにした、改造版です。


# BMIを自動的に判定するように改造しました。
# なでしこ本 P.45を参考にしました。

「身長(cm)は?」と尋ねる。
身長はそれ
「体重(kg)は?」と尋ねる。
体重はそれ

理想体重=((身長÷100)^2)×22
肥満度は体重÷理想体重×100-100

「身長が{身長}cmで体重が{体重}kgの場合:
-----------
理想体重は{理想体重}kgです。
肥満度は{肥満度}%です。」と表示。

# BMI判定基準
やせの肥満度 = ROUND((18.5÷22.0)×100)-100
標準の肥満度 = ROUND((25  ÷22.0)×100)-100
肥満の肥満度 = ROUND((30  ÷22.0)×100)-100

# BMI判定
もし、肥満度 ≧ 肥満の肥満度ならば
  「あなたは、高度肥満です。」と言う。
違えば、もし、肥満度 ≧ 標準の肥満度ならば
  「あなたは、肥満です。」と言う。
違えば、もし、肥満度 ≧ やせの肥満度ならば
  「あなたは、標準です。」と言う。
違えば
  「あなたは、やせです。」と言う。

        このプログラムのテスト用データーとして、

         身長は、全て160cmに統一して入力し、

         体重45kgを入力すると、「あなたは、やせです。」

         体重60kgを入力すると、「あなたは、標準です。」

         体重70kgを入力すると、「あなたは、肥満です。」

         体重80kgを入力すると、「あなたは、高度肥満です。」

         と、全て正常に表示された。

       

明日の予定

22:36

なでしこ本 P.36のプログラムに進みます。