matumatuのなでしこ学習帳

2008-01-04本日は、なでしこ本 P.35の学習です

下記のプログラム「 肥満度チェックA.nako 」は、

22:36

やせ~高度肥満まで判定結果を表示するようにした、改造版です。


# BMIを自動的に判定するように改造しました。
# なでしこ本 P.45を参考にしました。

「身長(cm)は?」と尋ねる。
身長はそれ
「体重(kg)は?」と尋ねる。
体重はそれ

理想体重=((身長÷100)^2)×22
肥満度は体重÷理想体重×100-100

「身長が{身長}cmで体重が{体重}kgの場合:
-----------
理想体重は{理想体重}kgです。
肥満度は{肥満度}%です。」と表示。

# BMI判定基準
やせの肥満度 = ROUND((18.5÷22.0)×100)-100
標準の肥満度 = ROUND((25  ÷22.0)×100)-100
肥満の肥満度 = ROUND((30  ÷22.0)×100)-100

# BMI判定
もし、肥満度 ≧ 肥満の肥満度ならば
  「あなたは、高度肥満です。」と言う。
違えば、もし、肥満度 ≧ 標準の肥満度ならば
  「あなたは、肥満です。」と言う。
違えば、もし、肥満度 ≧ やせの肥満度ならば
  「あなたは、標準です。」と言う。
違えば
  「あなたは、やせです。」と言う。

        このプログラムのテスト用データーとして、

         身長は、全て160cmに統一して入力し、

         体重45kgを入力すると、「あなたは、やせです。」

         体重60kgを入力すると、「あなたは、標準です。」

         体重70kgを入力すると、「あなたは、肥満です。」

         体重80kgを入力すると、「あなたは、高度肥満です。」

         と、全て正常に表示された。