matumatuのなでしこ学習帳

2008-01-13本日は、なでしこ本 P.43~44の学習です

学習レベルを判定した結果 LV = 2: HP = 28 : MP = 200

00:03

  • 完了予想日数 = 524 → 533 悪化
    • 完了予想年月日 = 2009/06/17 → 2009/06/29 悪化
      • はてなカウンター値 = 6470
        • 学習開始日から本日までの日数 =60日

「はてなダイアリー」の裏技を見つけました。

00:04

と言っても単純な方法ですが、先日過去に遡って

日記を書けるのを発見しましたが、

は、それが「日記を書き始めた日」以前も

可能な事を確認しました。

なるべく、隔を開けないように、過去の日記

を書くと、極端な話、「はてなダイアリー」

で日記を書き始めた初日に、1日づつ過去の

日記を29書けば、すぐ「はてなダイアリー市民」

とみなされると思います。

将来の日記も、書けますが日数としてカウントされません。

過去の日記は、8日以上隔を開けずに、日を入力するのが

コツのようです。

上記の方法で、「はてなダイアリー市民」と一時的にみなされ

ていますが、インチキな方法なので、テストした

の日記(非公開分)は全て削除し、

正規の方法で、コツコツと日記を30日書いてから、

正式な、「はてなダイアリー市民」になります。 <(_ _)>


下記のプログラム「 成年未成年.nako 」は、

00:04

なでしこ本CDROM → sample → 02-01

に入っているプログラムです。


「判定する年齢は?」と尋ねる。
年齢はそれ。
もし、(年齢≧20)ならば
  「{年齢}才は成年」と言う。
違えば
  「{年齢}才は未成年」と言う。

  • 動作結果 : 「成年未成年」さすが、サンプルプログラムなので、

        正常に、「判定する年齢は?」

         と尋ねられたので、なでしこ本

         のとおり、「 19 」と入力すると、

        正常に、「 19才は未成年 」

         と表示された。


下記のプログラム「 お肌の曲がり角A.nako 」は、

00:04

お肌の曲がり角を判定するように改造した

プログラムです。


# お肌の曲がり角を判定するように改造しました。

「判定する年齢は?」と尋ねる。
年齢はそれ。
もし、(年齢≧25)ならば
  「{年齢}才は、お肌の曲がり角を過ぎました」と言う。
違えば
  「{年齢}才は、お肌がピチピチです」と言う。

  • 動作結果 : 「お肌の曲がり角A」

        正常に、「 判定する年齢は? 」

         と尋ねられたので、なでしこ本

         のとおり、「 19 」と入力すると、

        正常に、「 19才は、お肌がピチピチです 」

         と表示された。


本日2ページ目の学習として、

01:47

なでしこ本 P.44のプログラムに進みました。


下記のプログラム「 糖尿病チェック.nako 」は、

01:47

なでしこ本CDROM → sample → 02-01

に入っているプログラムです。


点数は0
# 質問して点数を加算する---------------------------------------------(1)
「甘いものや脂肪の多いものが好き」と二択。
もし、それが、はいならば、点数=点数+1
「あまり運動していない」と二択。
もし、それが、はいならば、点数=点数+1
「イライラすることが多い」と二択。
もし、それが、はいならば、点数=点数+1
「最近体重が増えている」と二択。
もし、それが、はいならば、点数=点数+1
「家族に糖尿病の人がいる」と二択。
もし、それが、はいならば、点数=点数+2
# 点数により診断結果を表示する---------------------------------------(2)
もし、点数≧4ならば
  「危険です。食事は控えめにして運動をしましょう。」と言う。
違えば、もし、点数≧3ならば
  「注意が必要です。食事・運動・睡眠を意識しましょう。」と言う。
違えば、もし、点数≧2ならば
  「ちょっと注意が必要です。健康に気をつけましょう。」と言う。
違えば
  「まず大丈夫です。しかし油断は禁物です。」と言う。

  • 動作結果 : 「糖尿病チェック」さすが、サンプルプログラムなので、

        質問に適当に答えたところ正常に、

        「注意が必要です。食事・運動・睡眠を意識しましょう。」

         と表示された。


下記のプログラム「 メタボチェックA.nako 」は、

01:47

メタボリックシンドロームをチェックするように改造した

プログラムです。


# メタボリックシンドロームの診断をするように改造した。
# 日本ケミファ(株)の健康情報ホームページ 「うらりねっと」
# http://www.uralynet.com/ms/msgl.htm から引用しました。

点数は0
# 質問して点数を加算する---------------------------------------------(1)
「ウエスト周囲径が男性で85cm、女性で90cm以上」と二択。
もし、それが、はいならば、点数=点数+10
「血清脂質異常(トリグリセリド値150mg/dL以上、またはHDLコレステロール値40mg/dL未満」と二択。
もし、それが、はいならば、点数=点数+1
「血圧高値(最高血圧130mmHg以上、または最低血圧85mmHg以上」と二択。
もし、それが、はいならば、点数=点数+1
「高血糖(空腹時血糖値110mg/dL)」と二択。
もし、それが、はいならば、点数=点数+1
# 点数により診断結果を表示する---------------------------------------(2)
もし、点数≧12ならば
  「メタボリックシンドロームです。」と言う。
違えば、もし、点数≧10ならば
  「要注意です。」と言う。
違えば
  「まず大丈夫です。しかし油断は禁物です。」と言う。

  • 動作結果 : 「メタボチェックA」

        ウエスト周囲径が男性で85cmとして、

         検査値が2項目以上「はい」の場合正常に、

        「メタボリックシンドロームです。」

         と表示された。


明日の予定

01:47

なでしこ本 P.45のプログラムに進む予定です。