matumatuのなでしこ学習帳

2008-01-14本日は、なでしこ本 P.45~46の学習です

学習レベルを判定した結果 LV = 2: HP = 29 : MP = 200

23:28

  • 完了予想日数 = 533 → 516 改善
    • 完了予想年月日 = 2009/06/29 → 2009/06/13 改善
      • はてなカウンター値 = 6714
        • 学習開始日から本日までの日数 =61日

昨日の日記に書きましたが、

23:28

「はてなダイアリー」の裏技を使って、

一時的に、「はてなダイアリー市民」

になりすましましたが、反省し

非公開の日記を全て削除し、

本日より、新規に公開版の日記を書き始め、

matumatuのなでしこ学習帳に、リンクを置きました。

非公開の日記では、どうしても実験的な操作を

したくなるので、公開版の日記に切り替えました。

このため、当分のは、キーワードを

作る資格が無いので、mrさんの下記テクニックは、似られません。

はてな記法  : id:mr-80b:20071008

では、キーワード = うたブロ専用ブラウザ


下記のプログラム「 夏目漱石オタク度チェック.nako 」は、

23:28

なでしこ本CDROM → sample → 02-01

に入っているプログラムです。


オタク度は0
# 質問して点数を加算する---------------------------------------------(1)
「夏目漱石の作品を5つ以上言える」と二択。
もし、それが、はいならば、オタク度=オタク度+2
「漱石の本名を知っている」と二択。
もし、それが、はいならば、オタク度=オタク度+1
「生年と没年が言える」と二択。
もし、それが、はいならば、オタク度=オタク度+1
「『吾輩は猫である』の冒頭の段落を暗記している」と二択。
もし、それが、はいならば、オタク度=オタク度+1
「『漱石』という名の由来を知っている。」と二択。
もし、それが、はいならば、オタク度=オタク度+1
# 点数により診断結果を表示する---------------------------------------(2)
もし、オタク度≧6ならば
  「完璧な漱石通です!すごいです!」と言う。
違えば、もし、オタク度≧4ならば
  「なかなか詳しいですね。あと一歩!」と言う。
違えば、もし、オタク度≧2ならば
  「まぁまぁです。もう少し興味を持ってみよう。」と言う。
違えば
  「もう少し文学に興味を持っても良いのでは?」と言う。

  • 動作結果 : 「夏目漱石オタク度チェック」さすが、サンプルプログラムなので、

        正常に、全ての質問に、「 はい 」と答えたところ、

        正常に、「 完璧な漱石通です!すごいです! 」

         と表示された。


下記のプログラム「 夏目漱石オタク度チェックA.nako 」は、

23:28

事前にヒントを表示するように改造した、プログラムです。

このプログラムを改造するときに、

ヒント5部分だけ、当初はエラーだらけになりました。

これは、たまたま引用した文章の中に「 」が

多く含まれていたのに、「  」を使用する表示命令

表示文として使用したためで、表示文の中身だけ『 』に置き換えると、

エラーが消えました。


# ヒントを表示した後に、オタク度をチェックするようにした改造版
# ヒントの出典は、ヒント1から4が、フリー百科事典『ウィキペディア(Wikipedia)』です。
# ヒント5は、http://www.geocities.jp/sou_nihonshi/natume1.htm から引用しました。

オタク度は0
# 質問して点数を加算する---------------------------------------------(1)
「ヒント1:夏目漱石の主な作品は、『吾輩は猫である』、『坊っちゃん』、『倫敦塔』、
      『虞美人草』、『三四郎』などです。」と表示。
「夏目漱石の作品を5つ以上言える」と二択。
もし、それが、はいならば、オタク度=オタク度+2
「ヒント2:漱石の本名は、夏目金之助です。」と表示。
「漱石の本名を知っている」と二択。
もし、それが、はいならば、オタク度=オタク度+1
「ヒント3:生年と没年は、1867年2月9日(慶応3年1月5日)
             ~ 1916年(大正5年)12月9日です。」と表示。
「生年と没年が言える」と二択。
もし、それが、はいならば、オタク度=オタク度+1
「ヒント4:『吾輩は猫である』の冒頭の段落は、
           吾輩(わがはい)は猫である。
       名前はまだ無い。どこで生れたかとんと見当(けんとう)がつかぬ。
       何でも薄暗いじめじめした所でニャーニャー泣いていた事だけは記憶している。
       吾輩はここで始めて人間というものを見た。
       しかもあとで聞くとそれは書生という人間中で一番獰悪(どうあく)な種族であった
       そうだ。この書生というのは時々我々を捕(つかま)えて煮(に)て食うという話
       である。しかしその当時は何という考もなかったから別段恐しいとも思わなかった。」と表示。
「『吾輩は猫である』の冒頭の段落を暗記している」と二択。
もし、それが、はいならば、オタク度=オタク度+1
「ヒント5:『漱石』という名の由来は、漱石とは、『漱石枕流(そうせきちんりゅう)』から
        きているのである。これは昔の中国のことわざで、本当は『枕石漱流』
       (川の流れに口を漱すすいで、石を枕にして寝る)というところを、
        間違って『漱石枕流』と言ってしまった孫楚という男がおって、
       『それじゃ意味が通じない、お前間違えただろーーー』と指摘した友人に孫楚は、
       『いやいや俺は石に口を漱すすいで歯を磨き、川の流れを枕にして耳を洗って
        るんだ。だからこれでいいのだ』と、自分の間違いをごまかすために、
        強引にことわざを変えてしまった。これ以来『漱石枕流』は『がんこ者』
       『へそまがり』『負けず嫌い』という意味のことわざになったんである。
        我輩、このエピソードが気に入っていて、『漱石枕流』の『漱石』を
        ペンネームにしたんである。」と表示。
「『漱石』という名の由来を知っている。」と二択。
もし、それが、はいならば、オタク度=オタク度+1
# 点数により診断結果を表示する---------------------------------------(2)
もし、オタク度≧6ならば
  「完璧な漱石通です!すごいです!」と言う。
違えば、もし、オタク度≧4ならば
  「なかなか詳しいですね。あと一歩!」と言う。
違えば、もし、オタク度≧2ならば
  「まぁまぁです。もう少し興味を持ってみよう。」と言う。
違えば
  「もう少し文学に興味を持っても良いのでは?」と言う。

  • 動作結果 : 「夏目漱石オタク度チェックA」

        正常に、ヒントが表示された後に、質問が出るので

         全て「 はい 」と答えられ、

         正常に、「 完璧な漱石通です!すごいです! 」

         と表示された。


本日2ページ目の学習として、

01:15

なでしこ本 P.46に進みました。


P.46は、サンプルプログラムが無い代わりに、

課題が2つ示されています。


下記のプログラム「 毎朝の身だしなみチェックA.nako 」は、

01:15

P.46で示された、「課題1」用として改造したプログラムです。


# 毎朝の身だしなみをチェックするようにした改造版
# ヒントの出典は、http://www.digital-sense.co.jp/cc_new/sub/01_top.html から引用しました。

身だしなみ度は0
# 質問して点数を加算する---------------------------------------------(1)
「スーツに皺が出ないように手入れしている」と二択。
もし、それが、はいならば、身だしなみ度=身だしなみ度+2
「正しくネクタイを結んでいる」と二択。
もし、それが、はいならば、身だしなみ度=身だしなみ度+1
「シャツは、ビジネスシャツですか」と二択。
もし、それが、はいならば、身だしなみ度=身だしなみ度+1
「ヒゲは剃った」と二択。
もし、それが、はいならば、身だしなみ度=身だしなみ度+1
「ハンカチを用意した」と二択。
もし、それが、はいならば、身だしなみ度=身だしなみ度+1
# 点数により診断結果を表示する---------------------------------------(2)
もし、身だしなみ度≧6ならば
  「完璧な身だしなみです!すごいです!」と言う。
違えば、もし、身だしなみ度≧4ならば
  「なかなか良い身だしなみですね。あと一歩!」と言う。
違えば、もし、身だしなみ度≧2ならば
  「まぁまぁです。もう少し身だしなみに注意しよう。」と言う。
違えば
  「もう少し身だしなみに注意しても良いのでは?」と言う。

  • 動作結果 : 「毎朝の身だしなみチェックA」

        正常に、質問が5問出たので、

         全て「 はい 」と答えたところ、

         正常に、「 完璧な身だしなみです!すごいです! 」

         と表示された。


下記のプログラム「 地震対策してますかチェックA.nako 」は、

01:15

P.46で示された、「課題2」用として改造したプログラムです。

「なでしこ」には、置換機能があるので、「身だしなみ」箇所を

「地震対策」に修正する箇所がたくさんありますが、一瞬の

改造できました。


# 地震対策をチェックするようにした改造版
# ヒントの出典は、http://www.pref.gifu.lg.jp/pref/s11117/maniaru/jisincheck/01manu.htm
# から引用しました。

地震対策度は0
# 質問して点数を加算する---------------------------------------------(1)
「家屋の耐震補強を、実施済み」と二択。
もし、それが、はいならば、地震対策度=地震対策度+2
「家具の倒壊防止を、実施済み」と二択。
もし、それが、はいならば、地震対策度=地震対策度+1
「避難路・避難所の確認を、実施済み」と二択。
もし、それが、はいならば、地震対策度=地震対策度+1
「防災倉庫とカギの確認を、実施済み」と二択。
もし、それが、はいならば、地震対策度=地震対策度+1
「備蓄品の用意を、実施済み」と二択。
もし、それが、はいならば、地震対策度=地震対策度+1
「携帯電話の充電池の用意を、実施済み」と二択。
もし、それが、はいならば、地震対策度=地震対策度+1
# 点数により診断結果を表示する---------------------------------------(2)
もし、地震対策度≧7ならば
  「完璧な地震対策です!すごいです!」と言う。
違えば、もし、地震対策度≧5ならば
  「なかなか良い地震対策ですね。あと一歩!」と言う。
違えば、もし、地震対策度≧3ならば
  「まぁまぁです。もう少し地震対策に注意しよう。」と言う。
違えば
  「もう少し地震対策に注意しても良いのでは?」と言う。

  • 動作結果 : 「地震対策してますかチェックA」

        正常に、質問が6問出たので、

         全て「 はい 」と答えたところ、

         正常に、「 完璧な地震対策です!すごいです! 」

         と表示された。


明日の予定

01:15

なでしこ本 P.47 STEP-2に進む予定です。