matumatuのなでしこ学習帳

2008-01-14本日は、なでしこ本 P.45~46の学習です

下記のプログラム「 夏目漱石オタク度チェック.nako 」は、

23:28

なでしこ本CDROM → sample → 02-01

に入っているプログラムです。


オタク度は0
# 質問して点数を加算する---------------------------------------------(1)
「夏目漱石の作品を5つ以上言える」と二択。
もし、それが、はいならば、オタク度=オタク度+2
「漱石の本名を知っている」と二択。
もし、それが、はいならば、オタク度=オタク度+1
「生年と没年が言える」と二択。
もし、それが、はいならば、オタク度=オタク度+1
「『吾輩は猫である』の冒頭の段落を暗記している」と二択。
もし、それが、はいならば、オタク度=オタク度+1
「『漱石』という名の由来を知っている。」と二択。
もし、それが、はいならば、オタク度=オタク度+1
# 点数により診断結果を表示する---------------------------------------(2)
もし、オタク度≧6ならば
  「完璧な漱石通です!すごいです!」と言う。
違えば、もし、オタク度≧4ならば
  「なかなか詳しいですね。あと一歩!」と言う。
違えば、もし、オタク度≧2ならば
  「まぁまぁです。もう少し興味を持ってみよう。」と言う。
違えば
  「もう少し文学に興味を持っても良いのでは?」と言う。

  • 動作結果 : 「夏目漱石オタク度チェック」さすが、サンプルプログラムなので、

        正常に、全ての質問に、「 はい 」と答えたところ、

        正常に、「 完璧な漱石通です!すごいです! 」

         と表示された。