matumatuのなでしこ学習帳

2008-01-14本日は、なでしこ本 P.45~46の学習です

下記のプログラム「 夏目漱石オタク度チェックA.nako 」は、

23:28

事前にヒントを表示するように改造した、プログラムです。

このプログラムを改造するときに、

ヒント5部分だけ、当初はエラーだらけになりました。

これは、たまたま引用した文章の中に「 」が

多く含まれていたのに、「  」を使用する表示命令

表示文として使用したためで、表示文の中身だけ『 』に置き換えると、

エラーが消えました。


# ヒントを表示した後に、オタク度をチェックするようにした改造版
# ヒントの出典は、ヒント1から4が、フリー百科事典『ウィキペディア(Wikipedia)』です。
# ヒント5は、http://www.geocities.jp/sou_nihonshi/natume1.htm から引用しました。

オタク度は0
# 質問して点数を加算する---------------------------------------------(1)
「ヒント1:夏目漱石の主な作品は、『吾輩は猫である』、『坊っちゃん』、『倫敦塔』、
      『虞美人草』、『三四郎』などです。」と表示。
「夏目漱石の作品を5つ以上言える」と二択。
もし、それが、はいならば、オタク度=オタク度+2
「ヒント2:漱石の本名は、夏目金之助です。」と表示。
「漱石の本名を知っている」と二択。
もし、それが、はいならば、オタク度=オタク度+1
「ヒント3:生年と没年は、1867年2月9日(慶応3年1月5日)
             ~ 1916年(大正5年)12月9日です。」と表示。
「生年と没年が言える」と二択。
もし、それが、はいならば、オタク度=オタク度+1
「ヒント4:『吾輩は猫である』の冒頭の段落は、
           吾輩(わがはい)は猫である。
       名前はまだ無い。どこで生れたかとんと見当(けんとう)がつかぬ。
       何でも薄暗いじめじめした所でニャーニャー泣いていた事だけは記憶している。
       吾輩はここで始めて人間というものを見た。
       しかもあとで聞くとそれは書生という人間中で一番獰悪(どうあく)な種族であった
       そうだ。この書生というのは時々我々を捕(つかま)えて煮(に)て食うという話
       である。しかしその当時は何という考もなかったから別段恐しいとも思わなかった。」と表示。
「『吾輩は猫である』の冒頭の段落を暗記している」と二択。
もし、それが、はいならば、オタク度=オタク度+1
「ヒント5:『漱石』という名の由来は、漱石とは、『漱石枕流(そうせきちんりゅう)』から
        きているのである。これは昔の中国のことわざで、本当は『枕石漱流』
       (川の流れに口を漱すすいで、石を枕にして寝る)というところを、
        間違って『漱石枕流』と言ってしまった孫楚という男がおって、
       『それじゃ意味が通じない、お前間違えただろーーー』と指摘した友人に孫楚は、
       『いやいや俺は石に口を漱すすいで歯を磨き、川の流れを枕にして耳を洗って
        るんだ。だからこれでいいのだ』と、自分の間違いをごまかすために、
        強引にことわざを変えてしまった。これ以来『漱石枕流』は『がんこ者』
       『へそまがり』『負けず嫌い』という意味のことわざになったんである。
        我輩、このエピソードが気に入っていて、『漱石枕流』の『漱石』を
        ペンネームにしたんである。」と表示。
「『漱石』という名の由来を知っている。」と二択。
もし、それが、はいならば、オタク度=オタク度+1
# 点数により診断結果を表示する---------------------------------------(2)
もし、オタク度≧6ならば
  「完璧な漱石通です!すごいです!」と言う。
違えば、もし、オタク度≧4ならば
  「なかなか詳しいですね。あと一歩!」と言う。
違えば、もし、オタク度≧2ならば
  「まぁまぁです。もう少し興味を持ってみよう。」と言う。
違えば
  「もう少し文学に興味を持っても良いのでは?」と言う。

  • 動作結果 : 「夏目漱石オタク度チェックA」

        正常に、ヒントが表示された後に、質問が出るので

         全て「 はい 」と答えられ、

         正常に、「 完璧な漱石通です!すごいです! 」

         と表示された。