matumatuのなでしこ学習帳

2008-01-14本日は、なでしこ本 P.45~46の学習です

下記のプログラム「 毎朝の身だしなみチェックA.nako 」は、

01:15

P.46で示された、「課題1」用として改造したプログラムです。


# 毎朝の身だしなみをチェックするようにした改造版
# ヒントの出典は、http://www.digital-sense.co.jp/cc_new/sub/01_top.html から引用しました。

身だしなみ度は0
# 質問して点数を加算する---------------------------------------------(1)
「スーツに皺が出ないように手入れしている」と二択。
もし、それが、はいならば、身だしなみ度=身だしなみ度+2
「正しくネクタイを結んでいる」と二択。
もし、それが、はいならば、身だしなみ度=身だしなみ度+1
「シャツは、ビジネスシャツですか」と二択。
もし、それが、はいならば、身だしなみ度=身だしなみ度+1
「ヒゲは剃った」と二択。
もし、それが、はいならば、身だしなみ度=身だしなみ度+1
「ハンカチを用意した」と二択。
もし、それが、はいならば、身だしなみ度=身だしなみ度+1
# 点数により診断結果を表示する---------------------------------------(2)
もし、身だしなみ度≧6ならば
  「完璧な身だしなみです!すごいです!」と言う。
違えば、もし、身だしなみ度≧4ならば
  「なかなか良い身だしなみですね。あと一歩!」と言う。
違えば、もし、身だしなみ度≧2ならば
  「まぁまぁです。もう少し身だしなみに注意しよう。」と言う。
違えば
  「もう少し身だしなみに注意しても良いのでは?」と言う。

  • 動作結果 : 「毎朝の身だしなみチェックA」

        正常に、質問が5問出たので、

         全て「 はい 」と答えたところ、

         正常に、「 完璧な身だしなみです!すごいです! 」

         と表示された。