matumatuのなでしこ学習帳

2008-01-14本日は、なでしこ本 P.45~46の学習です

下記のプログラム「 地震対策してますかチェックA.nako 」は、

01:15

P.46で示された、「課題2」用として改造したプログラムです。

「なでしこ」には、置換機能があるので、「身だしなみ」箇所を

「地震対策」に修正する箇所がたくさんありますが、一瞬の

改造できました。


# 地震対策をチェックするようにした改造版
# ヒントの出典は、http://www.pref.gifu.lg.jp/pref/s11117/maniaru/jisincheck/01manu.htm
# から引用しました。

地震対策度は0
# 質問して点数を加算する---------------------------------------------(1)
「家屋の耐震補強を、実施済み」と二択。
もし、それが、はいならば、地震対策度=地震対策度+2
「家具の倒壊防止を、実施済み」と二択。
もし、それが、はいならば、地震対策度=地震対策度+1
「避難路・避難所の確認を、実施済み」と二択。
もし、それが、はいならば、地震対策度=地震対策度+1
「防災倉庫とカギの確認を、実施済み」と二択。
もし、それが、はいならば、地震対策度=地震対策度+1
「備蓄品の用意を、実施済み」と二択。
もし、それが、はいならば、地震対策度=地震対策度+1
「携帯電話の充電池の用意を、実施済み」と二択。
もし、それが、はいならば、地震対策度=地震対策度+1
# 点数により診断結果を表示する---------------------------------------(2)
もし、地震対策度≧7ならば
  「完璧な地震対策です!すごいです!」と言う。
違えば、もし、地震対策度≧5ならば
  「なかなか良い地震対策ですね。あと一歩!」と言う。
違えば、もし、地震対策度≧3ならば
  「まぁまぁです。もう少し地震対策に注意しよう。」と言う。
違えば
  「もう少し地震対策に注意しても良いのでは?」と言う。

  • 動作結果 : 「地震対策してますかチェックA」

        正常に、質問が6問出たので、

         全て「 はい 」と答えたところ、

         正常に、「 完璧な地震対策です!すごいです! 」

         と表示された。