matumatuのなでしこ学習帳

2008-01-16本日は、なでしこ本 P.48の学習です

学習レベルを判定した結果 LV = 2: HP = 27 : MP = 200

22:39

  • 完了予想日数 = 512 → 508 改善
    • 完了予想年月日 = 2009/06/10 → 2009/06/07 改善
      • はてなカウンター値 = 6954

  もうすぐ、キリ番ですが、はてなカウンターのトラブル(?)で、増加しません!!

        • 学習開始日から本日までの日数 =63日

下記のテキストファイル「 タブの働き.txt 」は、

22:39

第2章の内容ですが、なでしこ本CDROM → sample → 02-01

に入っていた。


abc	def
a	def
	def

  • 動作結果 : 「タブの働き」さすが、サンプル版のテキストファイルなので、

        正常に、カーソルがタブ文字分移動し、

         タブの効果で、文字がきれいに揃った。


         ただし、テキストファイルの内容を、なでしこの

         プログラムとして動作するかテストすると、

         当然ですが、エラーが出た。 (^_^;)


下記のプログラム「 ひまわりの例.nako 」は、

22:39

なでしこ本CDROM → sample → 02-02

に入っていなかったので、なでしこ本P.48より、

入力作成したプログラムです。


’ ひまわりの場合
天気は「晴れ」
もし、天気が「晴れ」ならば(
	「外に洗濯物を干す」と表示。
)違えば(	
	「洗濯物を家の中に干す」と、表示。
)

  • 動作結果 : 「ひまわりの例」さすが、サンプルプログラムなので、

        正常に、「外に洗濯物を干す」と表示された。

         ただし、ひまわり用のプログラムを

         無理矢理、なでしこ上で動かしたので、

         念のため、後で改造版を作り、

         再度テストします。


下記のプログラム「 なでしこの例.nako 」は、

22:39

なでしこ本CDROM → sample → 02-02

に入っていなかったので、なでしこ本P.48より、

入力作成したプログラムです。


# なでしこの場合
天気は「晴れ」
もし、天気が「晴れ」ならば
	「外に洗濯物を干す」と表示。
違えば	
	「洗濯物を家の中に干す」と、表示。

  • 動作結果 : 「なでしこの例」さすが、サンプルプログラムなので、

        正常に、「外に洗濯物を干す」と表示された。


下記のプログラム「 タブの働きA.nako 」は、

22:39

インデント入りの文字をテストするための、改造版です。


# サンプルテキストファイルを、なでしこ上で正常に動作するように改造しました。

「abc	def」と表示。
「a	def」と表示。
「	def」と表示。

  • 動作結果 : 「タブの働きA」

        正常に、文字がタブで揃えられて表示された。


次に、天気が雨の場合でも、なでしこ上で「ひまわりプログラム」が正常に

22:39

動作するかをテストできるように改造しました。


下記のプログラム「 ひまわりの例A.nako 」は、

22:39

天気が雨の場合でも、正常に動作するかをテスト

する改造版です。


’ 天気が雨の場合でも、なでしこ上で「ひまわりプログラム」が正常に
’ 動作するかをテストできるように改造した。

’ ひまわりの場合
天気は「雨」
もし、天気が「晴れ」ならば(
	「外に洗濯物を干す」と表示。
)違えば(	
	「洗濯物を家の中に干す」と、表示。
)

  • 動作結果 : 「ひまわりの例A」

        正常に、「洗濯物を家の中に干す」と表示された。

         このような単純な「ひまわりプログラム」であれば、

         なでしこ上で正常に動作することが確認できた。

         遠い将来になりますが、「ひまわり本」の付録

         CDROMに入っている、サンプルプログラムを

         改造して、なでしこ上で動作することを、目標

         にしているので、勉強になった。

         本日は多忙なので後日に見送りますが、

         のプログラム程度であれば、

         「ひまわりプログラム」と、「なでしこプログラム」

         のに、下記のような一定の法則があるので、

         下記の3文字を、自動的に置換するような

         初歩的なテクニックで、

        「ひまわりプログラム」→「なでしこプログラム」

         自動変換プログラムを作れそうな気がします。


         「ひまわりプログラム」 「なでしこプログラム」

          ’            #

         (            _

          )           _


次に、天気が雨の場合に、なでしこプログラムが正常に

22:39

動作するかをテストできるように改造しました。


下記のプログラム「 なでしこの例A.nako 」は、

22:39

天気が雨の場合でも、正常に動作するかをテスト

する改造版です。


# 天気が雨の場合でも、正常に動作するかをテスト
# する改造版です。

# なでしこの場合
天気は「雨」
もし、天気が「晴れ」ならば
	「外に洗濯物を干す」と表示。
違えば	
	「洗濯物を家の中に干す」と、表示。

  • 動作結果 : 「なでしこの例A」

        正常に、「洗濯物を家の中に干す」と表示された。


明日の予定

22:39

なでしこ本 P.49のプログラムに進む予定です。