matumatuのなでしこ学習帳

2008-01-18本日は、なでしこ本 P.50の学習です

学習レベルを判定した結果 LV = 2: HP = 21 : MP = 200

22:41

  • 完了予想日数 = 504 → 500 改善
    • 完了予想年月日 = 2009/06/05 → 2009/06/01 改善
      • はてなカウンター値 = 6954

  あいかわらず、キリ番近くなのに、はてなカウンターが故障中です!!

  ろ、はてなに、カウンターが故障ですよ!と連絡しようと

  思っています。

  カウンターが上昇しないと、HPが減る判定プログラムなので、

  このまま放置すると、HP = 0になります。 (^_^;)

  の代わり、本日は別の値がキリ番になりました。

  なでしこ本の学習ページ P.50

  完了予想日数 = 500

  完了予想年月日 = 2009/06/01

  学習開始日から本日までの日数 =65日


下記のプログラム「ニワトリ.nako」は、

22:41

なでしこ本CDROM → sample → 02-03

に入っているプログラムです。


3回、「コケッコッコー」と表示。

  • 動作結果 : 「ニワトリ」さすが、サンプルプログラムなので、

         正常に、なでしこ本のとおり、「コケッコッコー」

         と3行分表示した。


下記のプログラム「ニワトリ2.nako」は、

22:41

なでしこ本CDROM → sample → 02-03

に入っているプログラムです。


3回
  「にわとりが…」と表示。
  「コケッコッコー」と表示。
  「と鳴いた。」と表示。

  • 動作結果 : 「ニワトリ2」さすが、サンプルプログラムなので、

         正常に、なでしこ本のとおり、

        「にわとりが…」

        「コケッコッコー」

        「と鳴いた。」の3行分を、3表示した。


下記のプログラム「星.nako」は、

22:41

なでしこ本CDROM → sample → 02-03

に入っているプログラムです。


Sは空
15回、S=S&「☆」
10回、Sを表示。

  • 動作結果 : 「星」さすが、サンプルプログラムなので、

         正常に、なでしこ本のとおり、

        「☆」が、横15列・縦10行

         合計で150個表示した。


下記のプログラム「 犬A.nako 」は、

22:41

犬が100鳴くようにした、改造版です。


# 犬が100回鳴くように改造しました。

N = 1
100回、「ワン{N}」と表示。
			N = N + 1

  • 動作結果 : 「犬A」

         犬が100、「ワン1」~「ワン100」

         と表示し、画面がスクロールすると思ったが、

         私のパソコンではワン19までしか

         表示できなかった。 (^_^;)

         これは、なでしこが

        「母艦のサイズ範囲しか表示ない

         + 「画面スクロール機能が無い」

         ためだと学習した。

         もっと勉強すると、画面スクロール機能

         が見つかるかも分かりません。 (^_^;)


下記のプログラム「 犬2A.nako 」は、

22:41

執念で、犬が100鳴くようにした、改造版です。


# 執念で、犬が100回鳴くように改造しました。
# なでしこ本P.50「星.nako」で学習した成果です。

Sは空
10回、S=S&「ワン 」
5回
  「{S}」と表示。
  「{S}」と表示。

  • 動作結果 : 「犬2A」

         画面スクロールにより         

         犬を100、「ワン」

         と表示するのは、あきらめましたが

         執念で、犬を100鳴かせたくなり、

         別の方法「星.nako」のテクニックを

         利用して、無理矢理に犬を100、「ワン」

         と表示しました。


下記のプログラム「 星A.nako 」は、

22:41

なでしこ本P.51の記事を参考にして、

計算式を「&」から、「+」に改造し、

2行目、3行目の繰り返し回数

増やした、改造版です。


# なでしこ本P.51の記事を参考にした改造です。

Sは空
20回、S=S+「☆」
15回、Sを表示。

  • 動作結果 : 「星A」

         想定の範囲内ですが、なでしこ本のとおり、

        「0」が、横1列だけ表示され

         縦15行なので、合計で15個表示した。


明日の予定

22:41

なでしこ本 P.51のプログラムに進む予定です。

mr-80bmr-80b2008/01/19 01:26「表示ログ」に、表示した内容のログは格納されているようですよ。スクロールするかどうかとは別の話ですけれど。

matumatuh18matumatuh182008/01/20 23:40コメントありがとうございます。
「表示ログ」の簡単なテストをしてみました。
もっと、「表示ログ」を理解してから、
次の改造プログラムを作ってみます。