matumatuのなでしこ学習帳

2008-01-26本日は、なでしこ本 P.57~59の学習です

学習レベルを判定した結果 LV = 2: HP = 20 : MP = 200

17:41

  • 完了予想日数 = 487 → 465 改善
    • 完了予想年月日 = 2009/05/27 → 2009/05/05 改善
      • はてなカウンター値 = 8320
        • 学習開始日から本日までの日数 =73日

下記のプログラム「無限ループ.nako」は、

17:41

なでしこ本CDROM → sample → 02-04

に入っているプログラムです。


必要の間
  「終わりますか?」と二択。
    もし、それがはいならば、終わる。

         サンプルプログラムなので、

         正常に、なでしこ本のとおり、

         「いいえ」と答え続けると、

         永遠に終わらないプログラムだった。


下記のプログラム「無限ループ2.nako」は、

17:41

なでしこ本CDROM → sample → 02-04

に入っているプログラムです。


1の間
  「終わりますか?」と二択。
    もし、それがはいならば、終わる。

         サンプルプログラムなので、

         正常に、なでしこ本のとおり、

         「いいえ」と答え続けると、

         永遠に終わらないプログラムだった。


下記のプログラム「無限ループA.nako」は、

17:41

無限ループから抜けたかを表示するようにした、改造版です。


# デバッグ機能を追加するように改造しました。
# 無限ループから抜けたかを表示するように改造しました。

デバッグ # <---- この単語を追加
必要の間
  「終わりますか?」と二択。
    もし、それがはいならば、
       「無限ループから抜けたので、終わります!」と言う。 終わる。
	違えば
	   「まだ無限ループから抜けていません!」と言う。

        「いいえ」と答えると、「まだ無限ループから抜けていません!」

         と表示された。

        「はい」と答えると、「無限ループから抜けたので、終わります!」

         と表示された。


下記のプログラム「無限ループ2A.nako」は、

17:41

『3>1』の比較式を条件に変更するようにした、改造版です。


# デバッグ機能を追加するように改造しました。
# なでしこ本P.57を参考にして、『3>1』の比較式を条件に
# 変更するように改造しました。

デバッグ # <---- この単語を追加
3>1の間
  「終わりますか?」と二択。
    もし、それがはいならば、終わる。

        「いいえ」と答えると、永遠に終わらない

        プログラムになった。


本日2ページ目の学習として、

19:34

なでしこ本 P.58~59のプログラムに進みます。


下記のプログラム「抜ける.nako」は、

19:34

なでしこ本CDROM → sample → 02-04

に入っているプログラムです。


必要の間
  「終わりますか?」と二択。
  もし、それがはいならば、抜ける。

「抜けました」と表示。

  • 動作結果 : 「抜ける」さすが、

         サンプルプログラムなので、

         正常に、なでしこ本のとおり、

         「いいえ」と答え続けると、

         永遠に終わらないプログラムだった。

         「はい」と答えると、

         「抜けました」と表示され、

         プログラムが終了した。


下記のプログラム「数当てゲーム.nako」は、

19:34

なでしこ本CDROM → sample → 02-04

に入っているプログラムです。

偶然ですが、「数当てゲーム.nako」と同じ

ファイル名のプログラムが、なでしこをインストールすると、

sample → ゲームに自動的に初期インストール状態で用意されていました。

ところが、初期インストール状態のプログラムは、207行に達し、

画像も表示する高度な内容でした。


点数=0
1の間
  # ゲーム本体
  答えは3の乱数+1
  「1~3のどれか当てて下さい!」と尋ねる。
  もし、それが答えならば
    「当たり!」と言う。
    点数=点数+1
  違えば
    「残念。{答え}でした。」と言う
  # ゲームを終わるか?
  「点数は{点数}です。続けて遊びますか?」と二択。
  もし、それがいいえならば、抜ける。
  
「点数は{点数}でした!」と言う。

  • 動作結果 : 「数当てゲーム」さすが、

         サンプルプログラムなので、

         正常に、なでしこ本のとおり、

         「1~3」の数字を入力し、

         たまに、「当たり」と表示された。


下記のプログラム「抜けるA.nako」は、

19:34

無限ループから抜けていない場合の、表示をするようにした、改造版です。


# デバッグ機能を追加するように改造しました。
# 無限ループから、抜けていない場合の表示をするように改造しました。

デバッグ # <---- この単語を追加
必要の間
  「まだ抜けていません」と表示。
  「終わりますか?」と二択。
  もし、それがはいならば、抜ける。

「抜けました」と表示。

  • 動作結果 : 「抜けるA」

        「いいえ」と答えると、「まだ抜けていません」

         と表示された。

        「はい」と答えると、「抜けました」

         と表示された。


次に、誤動作を承知の上でわざと、『3の乱数>1』の比較式を

19:34

条件に変更するように改造しました。


下記のプログラム「数当てゲームA.nako」は、

19:34

『3の乱数>1』の比較式を条件に変更するようにした、改造版です。


# デバッグ機能を追加するように改造しました。
# 誤動作を承知の上でわざと、『3の乱数>1』の比較式を条件に
# 変更するように改造しました。

デバッグ # <---- この単語を追加
点数=0
3の乱数>1の間
  # ゲーム本体
  答えは3の乱数+1
  「1~3のどれか当てて下さい!」と尋ねる。
  もし、それが答えならば
    「当たり!」と言う。
    点数=点数+1
  違えば
    「残念。{答え}でした。」と言う
  # ゲームを終わるか?
  「点数は{点数}です。続けて遊びますか?」と二択。
  もし、それがいいえならば、抜ける。
  
「点数は{点数}でした!」と言う。

  • 動作結果 : 「数当てゲームA」

        3の乱数は、「0~2」ので変化するので、

        最初から、想定の範囲内でしたが、

        乱数が「0」の場合、このプログラムは

        「点数は0でした!」と表示し、終了する

        プログラムになった。 (^_^;)


明日の予定

19:34

なでしこ本 P.60に進む予定です。