matumatuのなでしこ学習帳

2008-01-27本日は、なでしこ本 P.60~61の学習です

学習レベルを判定した結果 LV = 2: HP = 32 : MP = 200

00:31

  • 完了予想日数 = 465 → 454 改善
    • 完了予想年月日 = 2009/05/05 → 2009/04/26 改善
      • はてなカウンター値 = 9231

  気づかないに、キリ番の9000をえました。 (^^;)

  次のキリ番は、10000のキリ番なので、近づいたら

  宣伝しますので、キリ番を踏んだかたは、コメントを

  お願いします。

        • 学習開始日から本日までの日数 =74日

下記のプログラム「『もし・・・ならば・・・』構文.nako」は、

00:31

なでしこ本CDROM → sample → 02-05

のディレクトリが無く、プログラムが入っていなかったので、

なでしこ本P.60より、

入力作成したプログラムです。


# 成人か未成年を判別するプログラム
年齢は25
もし、年齢≧20ならば
	「成人です」と表示。
違えば
  「未成年です」と表示。

  • 動作結果 : 「『もし・・・ならば・・・』構文」さすが、

         サンプルプログラムなので、

         正常に、なでしこ本のとおり、

         「成人です」と表示された。


下記のプログラム「『?回・・・』構文.nako」は、

00:31

なでしこ本CDROM → sample → 02-05

のディレクトリが無く、プログラムが入っていなかったので、

なでしこ本P.60より、

入力作成したプログラムです。


# 「こんにちわ」を10回表示するプログラム
10回
	「こんにちは」と表示。

  • 動作結果 : 「『?・・・』構文」さすが、

         サンプルプログラムなので、

         正常に、なでしこ本のとおり、

         「こんにちは」と、10表示された。


下記のプログラム「『もし・・・ならば・・・』構文A.nako」は、

00:31

年齢を質問するようにした、改造版です。


# 成人か未成年を判別するプログラム(改造版)
# デバッグ機能を追加するように改造しました。
# 年齢を質問するように改造しました。

デバッグ # <---- この単語を追加
「年齢は?」と尋ねる。
年齢は、それ。
もし、年齢≧20ならば
	「成人です」と表示。
違えば
  「未成年です」と表示。

  • 動作結果 : 「『もし・・・ならば・・・』構文A」

        「20」と答えると、「成人です」

         と表示された。

        「18」と答えると、「未成年です」

         と表示された。


下記のプログラム「『?回・・・』構文A.nako」は、

00:31

「こんにちわ」を100表示するようにした、改造版です。


# 「こんにちわ」を100回表示するプログラム(改造版)
# デバッグ機能を追加するように改造しました。
# mrさんに教えていただいた、「表示ログ」を使って、
# 実際に「こんにちは」を100回分、全てが見えるように改造しました。

デバッグ # <---- この単語を追加
100回
	「こんにちは」と表示。
表示ログを、言う。

  • 動作結果 : 「『?・・・』構文A」

        表示ログの詳細ボタンを押すと「こんにちは」

        が、100表示されたことが、行番号100行目で

        確認できた。 ものぐさな私にとっては、

        「こんにちは」を100回数えるのは面倒なので、

        「表示ログ」で、行番号付きで表示されるのは

        大変助かります。 (^^;)


本日2ページ目の学習として、

01:26

なでしこ本 P.61のプログラムに進みました。


下記のプログラム「『繰り返す』構文.nako」は、

01:26

なでしこ本CDROM → sample → 02-05

のディレクトリが無く、プログラムが入っていなかったので、

なでしこ本P.61より、

入力作成したプログラムです。


# 7の倍数を10個表示するプログラム
数で1から10まで繰り返す
	7×数を表示。

  • 動作結果 : 「『繰り返す』構文」さすが、

         サンプルプログラムなので、

         正常に、なでしこ本のとおり、

         「7」~「70」と、7の倍数が10個、表示された。


下記のプログラム「『・・・の間』構文.nako」は、

01:26

なでしこ本CDROM → sample → 02-05

のディレクトリが無く、プログラムが入っていなかったので、

なでしこ本P.61より、

入力作成したプログラムです。


# AがB以上のとき繰り返し実行されるプログラム
A=20
B=10
(A≧B)の間
	A=A-1
	B=B+1
	「A={A}/B={B}」を表示。

  • 動作結果 : 「『・・・の』構文」さすが、

         サンプルプログラムなので、

         正常に、なでしこ本のとおり、

         6目で、AよりBが大きくなり、プログラムが停止した。


下記のプログラム「『繰り返す』構文A.nako」は、

01:26

7の倍数を100個表示するようにした、改造です。)


# 7の倍数を100個表示するプログラム(改造版)
# デバッグ機能を追加するように改造しました。
# mrさんに教えていただいた、「表示ログ」を使って、
# 実際に、7の倍数を100個分、全てが見えるように改造しました。

デバッグ # <---- この単語を追加
数で1から100まで繰り返す
	7×数を表示。
表示ログを、言う。

  • 動作結果 : 「『繰り返す』構文A」

         正常に、「7」~「700」と、

         7の倍数が100個、表示された。


下記のプログラム「『・・・の間』構文A.nako」は、

01:26

Aが正数、かつBが正数のとき繰り返し実行される

ように改造したプログラムです。


# Aが正数、かつBが正数のとき繰り返し実行されるプログラム(改造版)
# デバッグ機能を追加するように改造しました。
# mrさんに教えていただいた、「表示ログ」を使って、
# 実際にループから抜けるまでの全データーが見えるように改造しました。

デバッグ # <---- この単語を追加
A=20
B=10
(A>0)かつ(B>0)の間
	A=A-1
	B=B+1
	「A={A}/B={B}」を表示。
表示ログを、言う。

  • 動作結果 : 「『・・・の』構文A」

         正常に、20目で、Aが0になり、

         プログラムが停止した。


明日の予定

01:26

なでしこ本 P.62~64に進む予定です。