matumatuのなでしこ学習帳

2008-03-04本日は、なでしこ本 P.87の学習です

下記のプログラム「項目記入とBMI.nako」は、

22:45

なでしこ本CDROM → sample → 03-04

に入っているプログラムです。


# 入力
「身長=
体重=」と項目記入。
身長はそれ@「身長」
体重はそれ@「体重」
# 計算
BMI=体重÷(身長÷100)^2
理想体重=(身長÷100)^2×22
肥満度=INT(体重÷理想体重×100)-100
# 結果
「身長:{身長}
体重:{体重}
BMI :{BMI}
肥満:{肥満度}%」を表示。
もし、BMI>25ならば「体重に注意」と表示。

         サンプルプログラムなので、

         なでしこ本P.87のとおり

         キー「身長」に対して、値「170」を手入力し、

         キー「体重」に対して、値「80 」を手入力し、

         の後、決定ボタンをクリックすると、

        「身長:170」

        「体重:80 」

        「BMI :27.681660899654」

        「肥満:25%」

        「体重に注意」

         と正常に表示された。