matumatuのなでしこ学習帳

2008-04-07本日は、なでしこ本 P.114の学習です

学習レベルを判定した結果 LV = 5: HP = 62 : MP = 500

23:39

  • 完了予想日数 = 407 → 408 悪化
    • 完了予想年月日 = 2009/05/17 → 2009/05/20 悪化
      • はてなカウンター値 = 34851

  までは、カウンターが5,000単位で、キリ番

  宣言をしていましたが、カウンターの増加が

  著しいので、後はカウンターが10,000単位

  で、キリ番宣言をします。 (^_^;)

        • 学習開始日から本日までの日数 =145日

  日曜日の深夜に、なでしこのメルマガ原稿を書くための、

  下準備に没頭したので、通常の学習が止まり、数値が悪化

  した。

4月になったので、久しぶりに「はてなのテーマ」を、

「Hatena2-sepia」から、「Hatena2-pink」に変更した。

画面がピンク色になったので、春らしくなった。 (^_^;)

「はてなのモジュール」として、「最新の画像」を

追加した。

当初の想定では、はてなにアップロードした、最新の

画像が表示されると思っていたが、ナコ画像が複数表示された。

原因が分からないが、後画像をアップロードすると、

順次最新画像に更新されると思うので様子を見ることにした。 (^_^;)

下記のプログラム「キータイピング時.nako」は、

23:39

なでしこ本CDROM → sample → 05-03

に入っているプログラムです。


テストエディタとはエディタ。
そのキータイピング時は~
  テストエディタの押されたキーを表示。

  • 動作結果 : 「キータイピング時」さすが、

         サンプルプログラムなので、

         実行すると、

        「abc」のキーを押すと、

        「abc」と表示された。

         次に、Caps Lockをオンにした

         後に、同様に入力すると、

        「ABC」のキーを押したと見なされ、

        「ABC」と表示された。

         さらに、キーボードの左上にある

        「1」と、テンキーの「1」を入力

         して、表示の違いを比較したが、

         両方とも、「1」と表示された。


下記のプログラム「キー押した時.nako」は、

23:39

なでしこ本CDROM → sample → 05-03

に入っているプログラムです。


テストエディタとはエディタ。
そのキー押した時は~
  テストエディタの押された仮想キーを表示。

  • 動作結果 : 「キー押した時」さすが、

         サンプルプログラムなので、

         実行すると、

        「a」のキーを押すと、

        「65」と、押されたキーの

         仮想番号が表示された。

         次に、Caps Lockをオンにした

         後に、同様に入力すると、

        「A」のキーを押したと見なされ、

        「65」と、同じ仮想番号が表示された。

         さらに、キーボードの左上にある

        「1」と、テンキーの「1」を入力

         して、表示の違いを比較すると、

        「49」と「97」が表示された。


次に、「0」キーをタイピングしたら「正解です (*^_^*)」と表示し、

23:39

3秒後に終了する。

 それ以外のキーをタイピングすると、

でも「0と違います、もう一度キータイピングしてください (^_^;)」

表示するように改造しました。


プログラム名「キータイピング時A.nako」

23:39

# キータイピング時A (改造版)
# 「0」キーをタイピングしたら「正解です (*^_^*)」と表示し、3秒後に終了する。
# それ以外のキーをタイピングすると、
# 何回でも「0と違います、もう一度キータイピングしてください (^_^;)」
# と表示するように改造しました。

テストエディタとはエディタ。
そのキータイピング時は~
  テストエディタの押されたキーを表示。
	もし、テストエディタの押されたキーが「0」ならば
		「正解です (*^_^*)」と表示。
		3秒待つ。
		終わる。
	違えば、「0と違います、もう一度キータイピングしてください (^_^;)」と表示。

  • 動作結果 : の改造プログラムを動作させると、

        エディタ部品が表れ、

       「a」を入力すると、

       「0と違います、もう一度キータイピングしてください (^_^;)」

        と表示された。

        次に、Caps Lockをオンにした

        後に、同様に入力すると、

       「A」のキーを押したと見なされ、

       「0と違います、もう一度キータイピングしてください (^_^;)」

        と表示された。

        さらに、キーボードの左上にある

       「0」と、テンキーの「0」を入力

        して、表示の違いを比較したが、

        両方とも、「正解です (*^_^*)」と表示され、3秒後に、

プログラムが終了した。


次に、なでしこ本 P.115の記事に載っている、

23:39

「Alt」、「Shift」、「Ctrl」キーが押された

か調べるように改造した。

それ以外のキーを押すと、注意されます。 (^_^;)


プログラム名「キー押した時A.nako」

23:39

# キー押した時A (改造版)
# なでしこ本 P.115の記事に載っている、
# 「Alt」、「Shift」、「Ctrl」キーが押された
# か調べるように改造した。
# それ以外のキーを押すと、注意されます。 (^_^;)

テストエディタとはエディタ。
そのキー押した時は~
  テストエディタの押された仮想キーを表示。
	もし、テストエディタの押された仮想キーが「18」ならば
		「押されたキーは、 Alt キーです」と表示。
	違えば、もし、テストエディタの押された仮想キーが「16」ならば
				「押されたキーは、 Shift キーです」と表示。
			違えば、もし、テストエディタの押された仮想キーが「17」ならば
						「押されたキーは、 Ctrl キーです」と表示。
					違えば、「なでしこ本 P.115の記事以外の、キーをタイピングしないでください (^_^;)」と表示。

  • 動作結果 : の改造プログラムを動作させると、

        エディタ部品が表れ、

       「Alt」キーを押すと、

       「押されたキーは、 Alt キーです」と表示された。

       「Shift」キーを押すと、

       「押されたキーは、 Shift キーです」と表示された。

       「Ctrl」キーを押すと、

       「押されたキーは、 Ctrl キーです」と表示された。

        次に、Caps Lockをオンにした

        後に、同様に入力すると、

        同じ結果になった。

        さらに、「Alt」、「Shift」、「Ctrl」キー以外の

        キーを押すテストをすると、

       「なでしこ本 P.115の記事以外の、

        キーをタイピングしないでください (^_^;)」と

        怒られた。 (^_^;)


明日の予定

23:39

なでしこ本 P.115に進む予定です。

AntonioAntonio2012/06/27 18:51That's a well-thought-out ansewr to a challenging question

gligixyvcigligixyvci2012/06/28 13:04K27kB3 <a href="http://jhvqenzuitno.com/">jhvqenzuitno</a>

aulixeiyooaulixeiyoo2012/06/28 18:19AuI66L , [url=http://pbgcwhbspokr.com/]pbgcwhbspokr[/url], [link=http://ukxlscupyfis.com/]ukxlscupyfis[/link], http://iusmfjjprbyw.com/

zuzplqibzuzplqib2012/06/29 07:45mhzUGV <a href="http://yptifqsxptaw.com/">yptifqsxptaw</a>

ajzsjshdgeajzsjshdge2012/07/01 04:54GHjySA , [url=http://oktunprucbva.com/]oktunprucbva[/url], [link=http://giddhyntyrle.com/]giddhyntyrle[/link], http://gqohnnmijyfz.com/

uwjtushvwuuwjtushvwu2014/03/19 17:27ropffobeftjlp, <a href="http://www.qxdolkeagd.com/">pjpkxjgdom</a> , [url=http://www.rfqcvyiitr.com/]senrdzmnhc[/url], http://www.gvslavdixl.com/ pjpkxjgdom