matumatuのなでしこ学習帳

2008-04-07本日は、なでしこ本 P.114の学習です

プログラム名「キー押した時A.nako」

23:39

# キー押した時A (改造版)
# なでしこ本 P.115の記事に載っている、
# 「Alt」、「Shift」、「Ctrl」キーが押された
# か調べるように改造した。
# それ以外のキーを押すと、注意されます。 (^_^;)

テストエディタとはエディタ。
そのキー押した時は~
  テストエディタの押された仮想キーを表示。
	もし、テストエディタの押された仮想キーが「18」ならば
		「押されたキーは、 Alt キーです」と表示。
	違えば、もし、テストエディタの押された仮想キーが「16」ならば
				「押されたキーは、 Shift キーです」と表示。
			違えば、もし、テストエディタの押された仮想キーが「17」ならば
						「押されたキーは、 Ctrl キーです」と表示。
					違えば、「なでしこ本 P.115の記事以外の、キーをタイピングしないでください (^_^;)」と表示。

  • 動作結果 : の改造プログラムを動作させると、

        エディタ部品が表れ、

       「Alt」キーを押すと、

       「押されたキーは、 Alt キーです」と表示された。

       「Shift」キーを押すと、

       「押されたキーは、 Shift キーです」と表示された。

       「Ctrl」キーを押すと、

       「押されたキーは、 Ctrl キーです」と表示された。

        次に、Caps Lockをオンにした

        後に、同様に入力すると、

        同じ結果になった。

        さらに、「Alt」、「Shift」、「Ctrl」キー以外の

        キーを押すテストをすると、

       「なでしこ本 P.115の記事以外の、

        キーをタイピングしないでください (^_^;)」と

        怒られた。 (^_^;)

AntonioAntonio2012/06/27 18:51That's a well-thought-out ansewr to a challenging question

gligixyvcigligixyvci2012/06/28 13:04K27kB3 <a href="http://jhvqenzuitno.com/">jhvqenzuitno</a>

aulixeiyooaulixeiyoo2012/06/28 18:19AuI66L , [url=http://pbgcwhbspokr.com/]pbgcwhbspokr[/url], [link=http://ukxlscupyfis.com/]ukxlscupyfis[/link], http://iusmfjjprbyw.com/

zuzplqibzuzplqib2012/06/29 07:45mhzUGV <a href="http://yptifqsxptaw.com/">yptifqsxptaw</a>

ajzsjshdgeajzsjshdge2012/07/01 04:54GHjySA , [url=http://oktunprucbva.com/]oktunprucbva[/url], [link=http://giddhyntyrle.com/]giddhyntyrle[/link], http://gqohnnmijyfz.com/

uwjtushvwuuwjtushvwu2014/03/19 17:27ropffobeftjlp, <a href="http://www.qxdolkeagd.com/">pjpkxjgdom</a> , [url=http://www.rfqcvyiitr.com/]senrdzmnhc[/url], http://www.gvslavdixl.com/ pjpkxjgdom