matumatuのなでしこ学習帳

2008-03-04本日は、なでしこ本 P.87の学習です

学習レベルを判定した結果 LV = 3: HP = 162 : MP = 300

22:45

  • 完了予想日数 = 446 → 444 改善
    • 完了予想年月日 = 2009/05/24 → 2009/05/22 改善
      • はてなカウンター値 = 20615
        • 学習開始日から本日までの日数 =111日

学習が進み、数値が改善した。


下記のプログラム「項目記入とBMI.nako」は、

22:45

なでしこ本CDROM → sample → 03-04

に入っているプログラムです。


# 入力
「身長=
体重=」と項目記入。
身長はそれ@「身長」
体重はそれ@「体重」
# 計算
BMI=体重÷(身長÷100)^2
理想体重=(身長÷100)^2×22
肥満度=INT(体重÷理想体重×100)-100
# 結果
「身長:{身長}
体重:{体重}
BMI :{BMI}
肥満:{肥満度}%」を表示。
もし、BMI>25ならば「体重に注意」と表示。

         サンプルプログラムなので、

         なでしこ本P.87のとおり

         キー「身長」に対して、値「170」を手入力し、

         キー「体重」に対して、値「80 」を手入力し、

         の後、決定ボタンをクリックすると、

        「身長:170」

        「体重:80 」

        「BMI :27.681660899654」

        「肥満:25%」

        「体重に注意」

         と正常に表示された。


次に、はてな記法 : id:matumatuh18:20080104 を参考にして、

22:45

BMIを自動的に判定するように改造しました。


プログラム名「項目記入とBMIA.nako」

22:45

# BMIを自動的に判定するように改造しました。
# はてな記法  : id:matumatuh18:20080104 を参考にしました。

# 入力
「身長=
体重=」と項目記入。
身長はそれ@「身長」
体重はそれ@「体重」
# 計算
BMI=体重÷(身長÷100)^2
理想体重=(身長÷100)^2×22
肥満度=INT(体重÷理想体重×100)-100
# 結果
「身長:{身長}
体重:{体重}
BMI :{BMI}
肥満:{肥満度}%」を表示。

# BMI判定基準
やせの肥満度 = ROUND((18.5÷22.0)×100)-100
標準の肥満度 = ROUND((25  ÷22.0)×100)-100
肥満の肥満度 = ROUND((30  ÷22.0)×100)-100

# BMI判定
もし、肥満度 ≧ 肥満の肥満度ならば
  「あなたは、高度肥満です。」を表示。
違えば、もし、肥満度 ≧ 標準の肥満度ならば
  「あなたは、肥満です。」を表示。
違えば、もし、肥満度 ≧ やせの肥満度ならば
  「あなたは、標準です。」を表示。
違えば
  「あなたは、やせです。」を表示。

  • 動作結果 :  なでしこ本P.87のとおり

         キー「身長」に対して、値「170」を手入力し、

         キー「体重」に対して、値「80 」を手入力し、

         の後、決定ボタンをクリックすると、

        「身長:170」

        「体重:80 」

        「BMI :27.681660899654」

        「肥満:25%」

        「あなたは、肥満です。」

         と表示された。

         キー「身長」に対して、値「170」を手入力し、

         キー「体重」に対して、値「100」を手入力し、

         の後、決定ボタンをクリックすると、

        「身長:170」

        「体重:100」

        「BMI :34.6020761245675」

        「肥満:57%」

        「あなたは、高度肥満です。」

         と表示された。

         キー「身長」に対して、値「170」を手入力し、

         キー「体重」に対して、値「70 」を手入力し、

         の後、決定ボタンをクリックすると、

        「身長:170」

        「体重:70 」

        「BMI :24.2214532871972」

        「肥満:10%」

        「あなたは、標準です。」

         と表示された。

         キー「身長」に対して、値「170」を手入力し、

         キー「体重」に対して、値「50 」を手入力し、

         の後、決定ボタンをクリックすると、

        「身長:170」

        「体重:50 」

        「BMI :17.3010380622837」

        「肥満:-22%」

        「あなたは、やせです。」

         と表示された。

実は、はてな記法 : id:matumatuh18:20080104 を参考にして、

サンプルプログラムを改造したところ、常に「あなたは、やせです。」

と誤表示した。

こで、肥満度プログラムが載っている、

なでしこ本P.35と本日学習中のP.87を比較すると、


# なでしこ本P.35 は、
肥満度は体重÷理想体重×100

# なでしこ本P.87 は、
肥満度=INT(体重÷理想体重×100)-100

上記の違いが、見つかった。

インターネットで調べた結果、

なでしこ本P.87が正しいことが分かり、

修正すると、正常に動作した。

ついでに、はてな記法 : id:matumatuh18:20080104

の改造プログラムの計算式も、こっりと修正した。 (^_^;)

ただし、サンプルプログラムは、原本を尊重するために、

計算式を修正していません。


明日の予定

22:45

なでしこ本 P.88に進む予定です。

ゲスト



トラックバック - http://nadesiko.g.hatena.ne.jp/matumatuh18/20080304