mrのなでしこ学習帳 RSSフィード

2006-11-06

!母艦設計=「母艦を最大化」
母艦のタイトルは「ためないTODO」

TODOリストとは配列
TODOリスト[0,0]=「項目」
TODOリスト[0,1]=「標準インターバル」

TODOログリストとは配列
「TODOログ.txt」を読んでTODOログリスト代入。

下ボタンとはボタン
の位置は「450,100」
これをクリックした時は~
	配列整理
	選択行=TODOグリッドの値
	ヨウソ=TODOリスト要素数
	もし、(選択行+2>ヨウソ)ならば
		#「できません」と言う
		戻る
	一時項目=「{TODOリスト[選択行,0]}」
	一時時=「{TODOリスト[選択行,1]}」
	一時項目で1から「{改行}」を文字検索
	もしそれが0でないならば、
		特別処理配列=一時項目を「{改行}」で区切る
		一時項目=特別処理配列[0]
		一時時=特別処理配列[1]
	TODOリストの選択行を配列削除
	挿入行=選択行+1
	TODOリストの挿入行に一時項目「,」一時時配列挿入
	TODOグリッドのアイテムはTODOリスト
	TODOグリッドの値=選択行+1

削除ボタンとはボタン
の位置は「450,60」
これをクリックした時は~
	「削除しますか?」で二択もしそれいいえなら、戻る配列整理
	選択行=TODOグリッドの値
	ヨウソ=TODOリスト要素数
	TODOリストの選択行を配列削除
	TODOグリッドのアイテムはTODOリストボタンとはボタン
の位置は「450,25」
これをクリックした時は~
	配列整理
	選択行=TODOグリッドの値
	もし、(選択行=1)ならば
		#「できません」と言う
		戻る
	一時項目=「{TODOリスト[選択行,0]}」
	一時時=「{TODOリスト[選択行,1]}」
	一時項目で1から「{改行}」を文字検索
	もしそれが0でないならば、
		特別処理配列=一時項目を「{改行}」で区切る
		一時項目=特別処理配列[0]
		一時時=特別処理配列[1]
	TODOリストの選択行を配列削除
	挿入行=選択行-1
	TODOリストの挿入行に一時項目「,」一時時配列挿入
	TODOグリッドのアイテムはTODOリスト
	TODOグリッドの値=選択行-1

デバッグボタンとはボタン
の位置は「700,50」
これをクリックした時は~
	TODOリスト言う。

TODOグリッドとはグリッド
の位置は「10,10」
の幅は400。の高さは200。
の編集はオフのアイテムはTODOリスト
これをダブルクリックした時は~
	配列整理
	#特別処理配列とは配列
	選択行=TODOグリッドの値
	一時項目=TODOリスト[選択行,0]
	一時時=TODOリスト[選択行,1]
	#一時項目を言う。
	#一時項目で1から「{改行}」を文字検索
	#もしそれが0でないならば
		#「改行あり」と言う。
	#	特別処理配列=一時項目を「{改行}」で区切る
	#	一時項目=「{特別処理配列[0]}」
	#	一時時=「{特別処理配列[1]}」
	TODOエディタのテキスト=一時項目
	時エディタのテキスト=一時時

TODOロググリッドとはグリッド
の位置は「10,300」
の幅は400。の高さは200。
の編集はオンの背景色は$AAAAAA
のアイテムはTODOログリスト
これをダブルクリックした時は~
	選択行=TODOロググリッドの値
	TODOエディタのテキスト=TODOログリスト[選択行,0]
	時エディタのテキスト=TODOログリスト[選択行,1]

TODOエディタとはエディタの位置は「10,220」
の幅は300。の高さは20。

時エディタとはエディタ
の位置は「320,220」
の幅は70。の高さは20。

進捗コンボとはコンボ
の位置は「400,220」
のテキストは「途中」
の幅は90。の高さは20。
のアイテムは「途中
完了」

実施ボタンとはボタン
の位置は「500,220」
これをクリックした時は~
	TODOログリストの1に「{TODOエディタのテキスト},{時エディタのテキスト}」を配列挿入
	TODOロググリッドのアイテムはTODOログリスト

項目追加ボタンとはボタン
の位置は「500,260」
これをクリックした時は~
    追加行=TODOリスト要素数
	TODOリスト[追加行,0]=TODOエディタのテキスト
	TODOリスト[追加行,1]=時エディタのテキスト
	TODOグリッドのアイテムはTODOリスト

母艦の閉じた時は~
	TODOログリストを「TODOログ.txt」に保存。



●配列整理
	X=TODOリスト要素数
	#Xを言うもし、Xが1ならば戻る。
	Iで1から(X-1)まで繰り返す
	一時項目=TODOリスト[I,0]
	一時項目で1から「{改行}」を文字検索
	もしそれが0でないならば
		#「改行あり」と言う。
		特別処理配列=一時項目を「{改行}」で区切る
		TODOリスト[I,0]=「{特別処理配列[0]}」
		TODOリスト[I,1]=「{特別処理配列[1]}」
	TODOグリッドのアイテムはTODOリスト