mrのなでしこ学習帳 RSSフィード

2008-08-09

モチベーション コントロール

はてなブックマーク - モチベーション コントロール - mrのなでしこ学習帳

ときどき質問掲示板に答したりするのは、モチベーションコントロールの目的もあったりします。

いいレベルの質問をいいタイミングでしてくれるとは大変ありがたいです。といっても、計算してできるもんでもないと思いますが。

初心者用なでしこエディタの動作イメージ

はてなブックマーク - 初心者用なでしこエディタの動作イメージ - mrのなでしこ学習帳

no titleの動作イメージ的なサンプルプログラムを作ってみようと思って書き始めたのですが、いろいろ詰まりまくって、命令入力のダイアログまでたどり着けず力尽きました。

Pとは配列=「,1,『あああ』と言う
,2,『いいい』と言う
,3,#プログラムの最後#」

追加ボタンとはボタン
のクリックした時は
  X=「プログラムを入力してください」を尋ねる
  もし、X≠「」ならば
    #Yとは配列=「,{GUID生成},{X}」
    Y\0=「」
    Y\1=GUID生成
    Y\2=X
    Pの(PTREEの値)にYを配列挿入
    #Pを言う
    PTREEのアイテムはP

編集ボタンとはボタン
のクリックした時は
  プログラム編集

削除ボタンとはボタン
のクリックした時は
  Pの(PTREEの値)を配列削除
  PTREEのアイテムはP

実行ボタンとはボタン
のクリックした時は
  #デバッグ
  C=Pの要素数
  I=0
  T=「」
  #Pを言う
  #「{C}」を言う
  COUNTで1からCまで繰り返す
    #P【I】を言う
    T=T「{P【I,2】}{改行}」
    I=I+1
  #Tを言う
  Tでナデシコする

PTREEとはツリー
のXは100。のYは10
の幅は500
の高さは350
のアイテムはP
のダブルクリックした時は
  プログラム編集

●プログラム編集
  ダイアログ初期値=P【PTREEの値,2】
  Tとは文字列=「プログラムを編集してください」を尋ねる
  ダイアログ初期値=「」
  #P【PTREEの値,2】=P【PTREEの値,2】でメモ記入
  もし、T≠「」ならば
    P【PTREEの値,2】=T
    PTREEのアイテムはP

#PTREEの1をノード開く
#PTREEの2をノード開く

#まだない機能
#切り取り
#コピー
#貼り付け
#コマンドごとのダイアログ
##コメント
##言う
#条件分岐(ツリーでサブノードを作る)

kyuuzyuu9yenkyuuzyuu9yen2008/08/15 10:18なでしこグループのトップにあるチャットが動いていないようですが・・・

mr-80bmr-80b2008/08/15 17:04とりあえず対応してみました。