mrのなでしこ学習帳 RSSフィード

2008-10-13

どう書く?小町算

はてなブックマーク - どう書く?小町算 - mrのなでしこ学習帳

http://ja.doukaku.org/comment/7791/

99さんに触発されて、以前書いていたものをベースに投稿してみました。

※【なでしこ実行モード】cnako

候補[0]に「」を代入する
候補[1]に「+」を代入する
候補[2]に「-」を代入する
候補[3]に「*」を代入する
候補[4]に「/」を代入する

発見数に0を代入する

枠1で0から4まで繰り返す
  枠2で0から4まで繰り返す
    枠3で0から4まで繰り返す
      枠4で0から4まで繰り返す
        枠5で0から4まで繰り返す
          枠6で0から4まで繰り返す
            枠7で0から4まで繰り返す
              枠8で0から4まで繰り返す
                計算式に「1{候補[枠1]}2{候補[枠2]}3{候補[枠3]}4{候補[枠4]}5{候補[枠5]}6{候補[枠6]}7{候補[枠7]}8{候補[枠8]}9」を代入する
                計算式でナデシコする
                もしそれが100ならば
                  発見数に1を直接足す
                  「{発見数}. {計算式} = 100」と表示

「{改行}全部で{発見数}コありました!」と表示

プログラムになじみのない人が、ぱっとみて、何をしているかができるだけわかるように、という意識で書いてみました。

ネストしまくりです。

もっと上手い書き方があったら、是非教えてください「どう書く?」へ投稿してください。

kyuuzyuu9yenkyuuzyuu9yen2008/10/15 22:57参照渡し/値渡しってC言語の言葉ですよね。確かに内部ではそういう実装なのかもしれませんが、なでしこ的にはいい用語ではないかも。