mrのなでしこ学習帳 RSSフィード

2009-07-12

初心者向け課題

はてなブックマーク - 初心者向け課題 - mrのなでしこ学習帳

#解答1
「入力してください」と尋ねる
答はそれ
答を表示

#解答2
「入力してください」と尋ねる
答はそれ
「なでしこ:」答を表示

#解答3
答=「なでしこ:」
「入力してください」と尋ねる
答にそれ追加
答を表示

#解答4
答=「なでしこ:」
「入力してください」と尋ねる
答にそれの2文字左部分追加
答を表示

いわゆるFizzBuzzっぽい課題

はてなブックマーク - いわゆるFizzBuzzっぽい課題 - mrのなでしこ学習帳

100
 もし、(回数を15で割った余り)=0ならば
  「{回数},35」を表示
  続ける
 もし、(回数を3で割った余り)=0ならば
  「{回数},3」を表示
  続ける
 もし、(回数を5で割った余り)=0ならば
  「{回数},5」を表示
  続ける

'表示ログメモ記入

表示ログを「{デスクトップ}結果.csv」に保存

素数の課題

はてなブックマーク - 素数の課題 - mrのなでしこ学習帳

勉強会の中でとりあえず作ったもの。

100
 カウンタ=0
 Y=回数
 Xで1からYまで繰り返す
  もし、(YをXで割った余り=0)ならば、
   カウンタ=カウンタ+1
 もし、A=2ならば
  Yを表示

表示ログメモ記入

後で作り直したもの。

Xで1から100まで繰り返す
 Xを素数判定して、もしそれならば、Xを表示
表示ログメモ記入

●素数判定(Xを)
 #素数とは、1との数自身以外に正の約数がない
 #(つまり1との数以外のどんな自然数によっても割り切れない)
 #1より大きな自然数のこと。(Wikipediaより引用)
 Yで1からXまで繰り返す
  もし、((XをYで割った余り=0)AND(Y≠1)AND(Y≠X))OR(X≦1)ならば戻る
 戻る

なでしこ勉強会kpt

はてなブックマーク - なでしこ勉強会kpt - mrのなでしこ学習帳

今日は勉強会でした。

参加されたみなさん、お疲れ様でしたー。

いうわけで、kptを少しずつ書く。

  • k
    • 事前メールアナウンス(さすがNaviさんだなぁ)
    • 人数分電源タップ(さすがNaviさんだなぁ)
    • 画面を大きく見せる工夫ができた
  • p
    • なでしこ学習帳@はてなの宣伝しようと思ってたのにうっかりした。痛恨。
  • t
    • この形態でなら、継続開催できるなぁ…。会場費も、なんとかなるレベルみたいだし…、家から結構近いし…。ネット環境がないのが残念だけど。

後、なでしこのここをもっとこうしたい!と思ったこと

  • 「(ハ)機能の紹介」に説明を加えたりしたい
    • ・・・と思ったら、ソースの中にテキストデータとかあるっぽい。もしかしたらこれを編集してコミットすればいいのかな?でもWeb上のマニュアルと不整合になるのなかな?

kujirahandkujirahand2009/07/13 10:16KPTありがとうございます!
マニュアルの機能の紹介、ぜひ、加えて下さい!
課題もありがとうございます!

AIAI2009/07/14 09:49勉強会お疲れ様でした^^
関西でもなでしこの勉強会がもっとあると良いですね。
是非継続開催企画してください!!有料でも参加したいです!!