Hatena::Groupnadesiko

雪乃☆雫のなでしこ日和

2017/07/23 (日)

なでしこ3をJavaScriptの代わりに使う?

| 01:58 | なでしこ3をJavaScriptの代わりに使う? - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - なでしこ3をJavaScriptの代わりに使う? - 雪乃☆雫のなでしこ日和 なでしこ3をJavaScriptの代わりに使う? - 雪乃☆雫のなでしこ日和 のブックマークコメント

 代わり・・・って言ったって、JavaScript自体がまったくわからん、いやむしろ、HTMLだって、あんまりわからん。

 でも、果敢にお試ししてみるるるるwww


 HTMLに、なでしこ3を取り込む術はここに書いてあります

https://nadesi.com/doc3/index.php?HTML%E3%81%B8%E3%81%AE%E5%9F%8B%E3%82%81%E8%BE%BC%E3%81%BF%E6%96%B9%E6%B3%95

 コレによれば・・・

<!-- なでしこを使うために必要なスクリプト -->
<script src="https://nadesi.com/v3/0.1.0/release/wnako3.js?run"></script>

<!-- type="なでしこ" のスクリプトが実行される -->
<script type="なでしこ">
「こんにちは」と言う。
</script>

 こうゆうことなのですが、どうもうまくいきません。

 さすがにこれだけじゃダメかと、<HTML>や<HEAD><BODY>などのタグを追加してみましたけれどダメで、やっぱりHTML5からようく学ばないとムリですか?! と思っていたのですが、なんと実は単に文字コードの問題でした。しくしくしくしく。

 UTF-8」で保存ないとダメだったんですね。

 具体例のソースを見たら、確かにちゃんと「<meta charset="utf-8">」と。(このタグ自体が、ワタシの知らない呪文だけどね;;;)

 これまで一度も文字コードなんて気にして生きては来なかったけど、ウチのテキストエディタで何の指定もせずふつーに保存をしたら、「SHIFT-JIS」になるので、文字コード指定して保存してやらなきゃだったのですよ。

 これってわりと、モノスゴク、重要な情報じゃないですか?

 それとも、ワタシの頭が悪いだけで、世の中の方々にとってはフツー知ってるでしょ?!レベルのことだったのですかね。め


 さて、気を取り直して・・・

 とりあえず、「こんにちは」と言ってもらえました♪

 これで、JavaScriptがいっこも分からなくても、なでしこのコードで色々できるということでしょうか。素晴らしい!

 しかし、DOMナントカって、一体なんすか(´д`;

 わからんことばっか(@_@)


 それでも、見よう見まねで取りあえずこんな感じ?

<!DOCTYPE html>
<html>
  <head>
    <meta charset="UTF-8">
    <title>なでしこ3てすと</title>
  </head>

  <body>
    <!-- なでしこを使うために必要なスクリプト -->
    <script src="https://nadesi.com/v3/0.1.0/release/wnako3.js?run"></script>
    <!-- type="なでしこ" のスクリプトが実行される -->
    <script type="なでしこ">
      #--------------------------------------
      # ここになでしこのプログラムを記述
      #-----------------------------------------------------------
      時は「{}」の2だけ文字左部分整数変換もし、時≧0と時<4のANDならば、挨拶=「こんばんは。夜更かしですね。」
      違えばもし、時≧4と時<11のANDならば、挨拶=「おはようございます。」
      違えばもし、時≧11と時<18のANDならば、挨拶=「こんにちは。」
      違えばもし、時≧18と時<23のANDならば、挨拶=「こんばんは。」
      「p#a」のDOM要素取得。
      「  {挨拶}」をDOMテキスト設定。

      年=「{今日}」の4だけ文字左部分。
      月=「{今日}」の6から2をMID。
      日=「{今日}」の2だけ文字右部分。
      「p#b」のDOM要素取得。
      「  今日は{年}年{月}月{日}日です。」をDOMテキスト設定。
      #-----------------------------------------------------------
    </script>

    <H1>なでしこ3のてすと</H1>
    <P id="a">はろー</P>
    <P id="b">日付表示</P>
    <HR>
  </body>
</html>

 定番の(?)時でメッセージが変わるヤツと、単に今日の日付を表示するヤツ。

 なでしこ3では、「かつ」が使えないんですね。

 「AとBのAND」・・・って、なんかすごく妙;

 でも、文字左部分なども助詞の付き方が変わって、v1非互換となっているから、なにか元のようには出来ない事情があるのでしょう。

 それと、なぜか「文字抜出」が使えない。なんでだ;

 とりあえず、MIDが使えたから良いけど。


 んなこんなで・・・

http://www.geocities.jp/snowdrops890/wnako3_test.html

 ちゃんと動いてるっぽい!(喜)

 (これはインターネット上でもちゃんと動くのを確認したいだけのためにジオシティーズに登録したので、他にはなんにもありませんw)

 ああ、スマホからもいちおう見れた!(≧▽≦)

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20170723

2017/07/11 (火)

なでしこ3でしりとり

| 11:12 | なでしこ3でしりとり - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - なでしこ3でしりとり - 雪乃☆雫のなでしこ日和 なでしこ3でしりとり - 雪乃☆雫のなでしこ日和 のブックマークコメント

 とりあえず、末尾語を引数で渡すことでできるようになったから載せとく。

 だけど別に、関数内で使う変数は全部そうしなきゃない仕様になったとゆうわけではないようなので、ナゾはナゾのままなんだよねぇ~;

#なでしこ3でしりとり3
#-----------------------------------------------------------
除去音=「ー-~・‥….。,、?!」。
変換音=「がぎぐげござじずぜぞだぢづでどばびぶべぼぱぴぷぺぽぁぃぅぇぉゃゅょゎっをゐゑ」
変換後=「かきくけこさしすせたちつてとはひふへほはひふへほあいうえおやゆよわつおいえ」
#-----------------------------------------------------------
●先頭語取得(Sから)
  先頭語はSの1だけ文字左部分の変換音変換。
ここまで

●末尾語取得(Sから)
  S=Sから除去音除去。
  末尾語はSの1だけ文字右部分の変換音変換。
ここまで
#-----------------------------------------------------------
●除去音除去(Sから)
  除去音を文字列分解反復
    S=Sの対象置換。
  ここまで
  Sで戻るここまで

●変換音変換(Sの)
  回数=0
  変換文字=変換後を文字列分解。
  変換音を文字列分解反復
    もし、S=対象ならば、S=変換文字@回数
    回数回数+1
  ここまで
  Sで戻るここまで
#-----------------------------------------------------------

#-----テスト------------------------------------------------
ルール=「【ルール説明】
・小さい文字(拗促音)は大きくするよ(カボチャ→やさい)
・濁音半濁音は清音と同様に繋げられるよ(りんご→こまつな)
・長音は無視できるよ(チーター→たぬき)」
ルールと言う。
ルールと表示。

開始語=「なでしこ」
先頭語=。
末尾語=開始語から先頭語取得。

末尾語と開始語でシリトリする。

●シリトリ(MとSで)
  先頭語はSから先頭語取得。
  末尾語=M。
  もし、先頭語=末尾語でなければ、
    「負け!」と言う終わる。
  ここまで。
  末尾語はSから末尾語取得。
  もし、末尾語=「ん」ならば、
    「負け!」と言う終わる。
  ここまで。
  ダイアログIME=「IMEオン」
  「『{S}』{改行}{改行}全角ひらがなで続く単語を入力してね。」と尋ねる。
  もしそれでなければ、
    末尾語とそれでシリトリする。
  違えば、
    「負け!」と言う終わる。
  ここまで。
ここまで
#-----------------------------------------------------------

https://nadesi.com/doc3/index.php?%E3%81%AA%E3%81%A7%E3%81%97%E3%81%933%E7%B0%A1%E6%98%93%E3%82%A8%E3%83%87%E3%82%A3%E3%82%BF

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20170711

2017/07/06 (木)

なでしこ3

| 23:58 | なでしこ3 - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - なでしこ3 - 雪乃☆雫のなでしこ日和 なでしこ3 - 雪乃☆雫のなでしこ日和 のブックマークコメント

 なでしこ3の0.1.0をリリースとゆうことで、まにゅあるもせっせと更新されてる風味だったのでちょっと学んでみようと思ったのです。

 前のしりとりくらいなら、簡単に移植できそうに思ったけど、甘かったorz

 なにしろ、参考に出来る物も少ないから、自分が違ってるのか、3の仕様なのか、まだベータ版ゆえの不備なのかすらわかんないコト多数;;;

 なんとしてもうまくいかず、取りあえずこんな感じ。

 しりとりのルールについて考える前の、とりあえず最後の一文字と先頭の一文字でつないでいくだけのしりとりです。

 は「なでしこ3」なので、万一奇特にもお試ししてみようとゆう方は、ここから。

https://nadesi.com/doc3/index.php?%E3%81%AA%E3%81%A7%E3%81%97%E3%81%933%E7%B0%A1%E6%98%93%E3%82%A8%E3%83%87%E3%82%A3%E3%82%BF

#なでしこ3でしりとり
#-----------------------------------------------------------
ルール=「【ルール説明】
・最後に『ん』のつく単語を入力したら負け!
・濁音半濁音はのまま(りんご→ごりら)
・小さな文字は大きな文字で入力してね(紅茶=こうちや)
・長音は読みの通りの母音で入力してね(チーター=ちいたあ)」
ルールと言う。
ルールと表示。

開始語=「なでしこ」
先頭語=。
末尾語=開始語の1だけ文字左部分。

開始語でシリトリする。

●シリトリ(Sで)
  先頭語はSの1だけ文字左部分。
  もし、先頭語=末尾語でなければ、
    「負け!」と言う終わる。
  ここまで。
  末尾語はSの1だけ文字右部分。
  もし、末尾語=「ん」ならば、
    「負け!」と言う終わる。
  ここまで。
  ダイアログIME=「IMEオン」
  「『{S}』{改行}{改行}全角ひらがなで続く単語を入力してね。」と尋ねる。
  もしそれでなければ、
    それでシリトリする。
  違えば、
    「負け!」と言う終わる。
  ここまで。
ここまで。
#-----------------------------------------------------------

 まず変わったのは、もしや繰り返しや関数の終わりに「ここまで」が必要になったことで、めんどくさいけど、色々のことを考えるとこれはこのほうがイイですよね。

 何しろ、なでしこはインデント一つ狂っただけでも事件が起きるのに、掲示板なんかじゃ当然のよーにタブや半角スペースが消えたり、全角スペースに置き換わったりされてしまうから厄介が起きまくりだけど、ブロックを明示できれば、の心配がないもねー。

 あと、配列も変わってるので、よく確認しないと。

 でもまあ、こはまず問題ないとして・・・


 「終わる」で、エラー表示になるって、一体なんで~?

 まあ、終わるからいいけど;


 「カッコ閉じ」「波カッコ閉じ」が、「undefined」となってしまう。

#-----------------------------------------------------------
「{カッコ}なでしこ3{カッコ閉じ}」と表示。
「{波カッコ}なでしこ3{波カッコ閉じ}」と表示。
#-----------------------------------------------------------

 「カッコ」「波カッコ」はこれでいけるのだから、従来どうりの記述でいいハズだと思うんだけど・・・よくわからん~。

 てゆうか、undefinedってなんすか・・・「定義されていない」・・・・・・むむむ~?

 定数として定義されてないって意味なんでしょうか(?_?)

 二重カギ括弧がふつーに使えるようになっていたから、取りあえずそれにしといたけどねーw(いいのか?!)


 して「反復」の時には、「回数」のカウンター機能が働かなくなったんですかね?

 またまた「undefined」が発生~。

 ところが、「」の時には従来どおりっぽい。

#---------------------------
Aは[1,2,3]
Aを反復
  回数言う
  対象表示
ここまで
#---------------------------
3
  回数言う
  「ワン」と表示ここまで
#---------------------------

 まあ、自分でカウンターせばいいだけなんだけど・・・

 ・・・ここで結構はまったんだよ(>_<)


 して、何よりの最大のナゾは・・・

 直前で、「開始語から先頭語取得」している「末尾語」が、「シリトリ」関数の中で参照できないこと。

 これは、いまだにナゾが解明してません(ToT)

#なでしこ3でしりとり2
#-----------------------------------------------------------
除去音=「ー-~・‥….。,、?!」。
変換音=「がぎぐげござじずぜぞだぢづでどばびぶべぼぱぴぷぺぽぁぃぅぇぉゃゅょゎっをゐゑ」
変換後=「かきくけこさしすせたちつてとはひふへほはひふへほあいうえおやゆよわつおいえ」
#-----------------------------------------------------------
●先頭語取得(Sから)
  先頭語はSの1だけ文字左部分の変換音変換。
ここまで

●末尾語取得(Sから)
  S=Sから除去音除去。
  末尾語はSの1だけ文字右部分の変換音変換。
ここまで
#-----------------------------------------------------------
●除去音除去(Sから)
  除去音を文字列分解反復
    S=Sの対象置換。
  ここまで
  Sで戻るここまで

●変換音変換(Sの)
  回数=0
  変換文字=変換後を文字列分解。
  変換音を文字列分解反復
    もし、S=対象ならば、S=変換文字@回数
    回数回数+1
  ここまで
  Sで戻るここまで
#-----------------------------------------------------------

#-----テスト------------------------------------------------
ルール=「【ルール説明】
・小さい文字(拗促音)は大きくするよ(カボチャ→やさい)
・濁音半濁音は清音と同様に繋げられるよ(りんご→こまつな)
・長音は無視できるよ(チーター→たぬき)」
ルールと言う。
ルールと表示。

開始語=「なでしこ」
先頭語=。
末尾語=開始語から先頭語取得。

開始語でシリトリする。

●シリトリ(Sで)
  先頭語はSから先頭語取得。
  もし、先頭語=末尾語でなければ、
    「負け!」と言う終わる。
  ここまで。
  末尾語はSから末尾語取得。
  もし、末尾語=「ん」ならば、
    「負け!」と言う終わる。
  ここまで。
  ダイアログIME=「IMEオン」
  「『{S}』{改行}{改行}全角ひらがなで続く単語を入力してね。」と尋ねる。
  もしそれでなければ、
    それでシリトリする。
  違えば、
    「負け!」と言う終わる。
  ここまで。
ここまで
#-----------------------------------------------------------

 シリトリ関数内では末尾語が「undefined」になってしまっているため、実行するといきなり「負け!」と言われてしまいます(´д`;

 シリトリ関数自体は、冒頭のものとほとんど変わってないですよ?

 「先頭語取得」関数の方が良くないのかと思いきや、先頭語取得せず、最初のと同様に「末尾語=開始語の1だけ文字左部分」としてもダメ、さらには、末尾語=「な」などとしてもやっぱりダメなんですからね。

 むむむむむ~(@_@)

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20170706

2017/07/02 (日)

しりとりのルール

| 00:00 | しりとりのルール - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - しりとりのルール - 雪乃☆雫のなでしこ日和 しりとりのルール - 雪乃☆雫のなでしこ日和 のブックマークコメント

 しりとりのルールなんて、決まり切っているだろうと思われるところですが、検索してみると色々出てきてなかなか難しい!(@_@)

 主に、濁音・半濁音や、長音・拗音・促音の扱いですかね。

●濁音半濁音は、通常はのままですけど(りんご→ごぼう)、より易しいルールで清音化して扱える場合もあります(りんご→こまつな)

●長音は、通常は無視しますけど(チーター→たぬき)、長音の前の文字の母音を使うというルールもあります(チーター=ちいたあ→あしか)。また、いっこ前の文字とセットでという、より難しいルールもあります(チーター→ターキー)

●拗音は、それを通常の文字として扱える場合(カボチャ→やさい)と、いっこ前の文字とセットで(カボチャ→チャーハン)という場合があります

●促音(ちっちゃい「っ」)で終わる単語って、何かありますかね? 通常の日本語的には、擬音や感嘆詞としてしか無いような気がするんだけど・・・もしあった場合、拗音同様大きくするか、前の文字とセットにするか、長音同様無視するか・・・の三択のように思われます。


 さらに、「ぢ」「づ」「を」「ん」などの扱いをどうするかの問題があります

●「ぢ」「づ」などは、清音化する場合は問題ないんですが(はなぢ→ちりとり)、のままの場合、本当にのままだとかなりキビシイので、あと、「コレは一体どっちなんだ?!」・・・とゆうギロンに発展し、しりとりが中断されかねないので、聞いた音の通り「じ」「ず」でOKという場合もあります

●「を」も同様で、も現代語だと助詞の扱いだから固有名詞しかないと思うんだけど、しかもそれを言ったら、「ゐ」「ゑ」も入ってきちゃうんじゃ?! ってことにもなるので、よっぽどな人達じゃない限り、聞いた音の通り「お」「い」「え」で良いことになってると思います。

●近頃「ん」で始まる語もあるじゃーないか!という話もあるらしいんですが(外国語)、それを認めると、逆に「ん」を言ったもん勝ちみたいな感じになっちゃうじゃないですか? 「ん」で終わる単語は、「ぢ」「づ」「を」の比では無く多いので。

 これは、続けられるかどうかではなく、「ん」は禁止ワードであるいう縛りと考えるべきものだと思うんだよね。


 さて・・・

 面目にしりとりのプログラムを作るなら、これらの色々のルールに対応できるべく作っていった方が良いのだろうと思いますが、の最大の問題は、単語リストつくんの面倒! ってところなんで(爆)

 少ない単語で長く続けられるよう、

1,濁音半濁音は清音化。

2,長音は無視。

3,拗音促音は大文字化。

4,「を」などで終わる単語なんか登録しない!(爆)

 ・・・とゆう方針でやっていきたい。

 こんな感じ?

#しりとりテスト
#-----------------------------------------------------------
除去音=「ー-~・‥….。,、?!」。
変換音=「がぎぐげござじずぜぞだぢづでどばびぶべぼぱぴぷぺぽぁぃぅぇぉゃゅょゎっをゐゑ」
変換後=「かきくけこさしすせたちつてとはひふへほはひふへほあいうえおやゆよわつおいえ」
#-----------------------------------------------------------
*先頭語取得(Sから)
  先頭語はSの1文字左部分の変換音変換。

*末尾語取得(Sから)
  S=Sから除去音除去。
  末尾語はSの1文字右部分の変換音変換。
#-----------------------------------------------------------
*除去音除去(Sから)
  (除去音を文字列分解)を反復
    S=Sの対象置換。
  Sで戻る。

*変換音変換(Sの)
  変換文字=変換後を文字列分解。
  (変換音を文字列分解)を反復
    もし、S=対象ならば、S=変換文字¥(回数-1)
  Sで戻る。
#-----------------------------------------------------------

#-----テスト------------------------------------------------
ルール=「【ルール説明】
・小さい文字(拗促音)は大きくするよ(カボチャ→やさい)
・濁音半濁音は清音と同様に繋げられるよ(りんご→こまつな)
・長音は無視できるよ(チーター→たぬき)」
ルールと言う。
ルールと表示。

開始語=「しりとり」
先頭語=。
末尾語=開始語から先頭語取得。

開始語でシリトリする。

*シリトリ(Sで)
  先頭語はSから先頭語取得。
  もし、先頭語=末尾語でなければ、「負け!」と言う終わる。
  末尾語はSから末尾語取得。
  もし、末尾語=「ん」ならば、「負け!」と言う終わる。
  ダイアログIME=「IMEオン」
  「{カッコ}{S}{カッコ閉じ}{改行}{改行}全角ひらがなで続く単語を入力してね。」と尋ねる。
  もしそれならば、「負け!」と言う終わる。
  違えばそれでシリトリする。
#-----------------------------------------------------------

 一人で延々しりとりが続けられますw

 除去音と変換音を、もう少し丁寧に分けて登録して、フラグによって処理を振り分ければ、様々なパターンのルールに対応できるんだろうけど。

 登録しない!なんて言い張らなくても、濁音半濁音や拗促音同様に変換音に突っ込めば、「を」「ゐ」「ゑ」もふつーに変換できたなあwww

 促音を拗音同様大きな文字に変換とゆう取り扱いで良いのか、長音同様除去してしまうかは、悩むところ。

 いや、んな単語は登録しないっ!(爆)

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20170702

2017/06/20 (火)

お休み中・・・

| 23:58 | お休み中・・・ - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - お休み中・・・ - 雪乃☆雫のなでしこ日和 お休み中・・・ - 雪乃☆雫のなでしこ日和 のブックマークコメント

 訳あって、しばらく平行して遊んでいた、カメラとJuliusは、お休み中となっています。

 わっ訳ですか?! それを聞きますか?!?!(誰も聞いてないよ!)

 まあ・・・話せば長い深い深い事情があって(嘘)・・・・パソコンが変わったんですけど・・・・・のノートにはカメラもマイクも内蔵されてないからなんですよ~。しくしくしく。

 もともと、んな物があるいう認識も無く、長年一度も使ったことの無かった機能だったんだけどさぁ~。

 んなわけで、一旦保留にして、しようがないから純粋にしりとりとかオセロとかについて考えていきましょうかねえ。

 できてしまえばJuliusで音声入力に対応させるの自体は別に難しいことじゃないんで。


 さて・・・

 しりとりはまあ、すぐ出来るだろうとは思うんだよね。

 単語リスト作んのがめんどーになってただけで;;;

 でも、いちおう辞書ユーティリティは、だいたいできていた気がする実際にしりとりしながら学習させれるようにしたらいいんじゃ? ・・・みたいなw


 オセロ(リバーシ)は、昔々の大昔に一度作ったことがあります

 N88-日本語Basicで!(爆)

 してコレも、本のとうりにやったら動いたよ! というだけのことですが;

 しかも、の思考ルーチンたるや、ちょっと評価表で角や辺、星の辺りに重みをつけて、あとは、とにかく石が沢山取れるところを選択というものだったので、何しろ信じられないほど弱かったです。

 だいたい、ものの本によれば石を沢山取っていくとゆうのは最悪の戦法で、序盤なんかは取れる石の少ないところを選んでいった方がまだマシという感じらしいんですよ。

 まあ、当時はパソコン自体遅かったので、強いオセロのプログラムはモノスゴク遅かった;

 人の長考は平気でも、こんぴゅーたーのそれは待てないっていうのは、一体なぜなんだろう・・・

 ともかくーゆうわけなので、こはまったく一から考え直さなければなりません。

 でも、ワタシ自体が弱すぎなんで、どうかなあ?

 しかも、結局いまだに、ミニもマックスもアルファもベータもよくわからなんだ;;;


 それにしても、んなムカシからプログラムっぽいコトして遊んでいたのに、本のとうりじゃないプログラムができるようになったのは、なでしこが初なんだよね!

 して、そうしたら、以前に本のとうりに作ったプログラムの意味も、分かるようになった。

 まさに神だね!!(≧▽≦)

めだかめだか2017/06/26 08:01お久しぶりですぅぅぅ

パソコンかえましたかーwいいですねw

とか言ってますが、実は自分もかえました(笑
後は、自分でジャンクを漁ってきたりして組み立てとかしてます(笑


なので、全く同じ状況となります。カメラないです(泣
前のノートがないわけではないですが、今はディスクトップのみ使っている状態ですねー...悲しい←


でですが、壁紙に動画を設定できたら面白そうと思って調べるとめんどくさそうなのばっかだったんで、自分で作ろう!となったわけですが、プログラムの流れとしては...

動画再生

画面内キャプチャ

そのイメージを壁紙として設定


という、流れです。

やはり、キャプチャの部分でかなりのラグが出来てしまいますかね...?
枠なしウィンドウでどうにかして再生するっていう方法しか思いつきませんですた\(^o^)/

違和感なく動画を壁紙にするいい方法はないでしょうかね...w

雪乃☆雫雪乃☆雫2017/06/27 04:21 お久しぶりでした~。
 いやいや、パソコン変えたと言っても、事件あるいは事故なので、ちっともいいことありません。しくしく。

 それはそうと、パソコン起動中ずっと窓内側キャプチャ→壁紙設定を延々ループし続けるってことですかΣ(゜д゜;
 キャプチャの部分でラグとかいう問題以前に、モノスゴク負荷が掛かりませんかね(涙)
 それと、こうゆう用途に、窓内側キャプチャはまったく使えないと思いますよ。
 遅いとか以前に、この命令って文字通り、目的の窓の内側をそのままキャプチャするヤツなんで、動画を再生しているウィンドウを小さくしたら、その分しかキャプチャされないし、そのウィンドウの上に、別のウィンドウやタスクバーなんかがかぶると、それも一緒にキャプチャされてしまうので。
 カメラの時に窓内側キャプチャを見捨てたのは、ワタシ個人のことで言えば、主にそっちの問題でした;

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20170620

2017/05/09 (火)

Julius用辞書ユーティリティ

| 01:54 | Julius用辞書ユーティリティ - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - Julius用辞書ユーティリティ - 雪乃☆雫のなでしこ日和 Julius用辞書ユーティリティ - 雪乃☆雫のなでしこ日和 のブックマークコメント

 さて、長らく放置していたナコ様。

 しりとりは、プログラム自体は難しいことは無いんだけど、単語リストを作るのが、なかなか大変な作業じゃないですか?

 それがなんかもうめんどーでめんどーで・・・;;;

 しかも、Julius用のリストの他に、同じ内容でしりとり用のリストを作らなきゃならない

 しりとり用の読みと、Julius用の音素列に変換する用の読みは、ほとんど同じだけどちょっと違うしさー。(「さくらそう」と「さくらー」みたいな)

 AquesTalk用の音声記号列なんかに至っては、アクセント記号を入れてはいちいち聞いてみなくちゃぁ、どんなもんだか分かんないしさー。(しかも、田舎者だから、ようく調整して「よし、コレだ!」と思った発音が、実は訛ってるんじゃないかってゆう不安(爆))


 とにかくまー、最初エクセルで作ってたんだけど、なでしこで辞書ユーティリティでもつくってみようかということになった。

 読みを入れてボタンを押したらの場で音素列に変換してくれたり、音声記号列を入れてボタンを押したら喋ってくれたりで確認しながら作業を進めたい。

 して、Julius用としりとりようの二つのファイルとして保存できる的な?(Julius用の単語リストは、余計なモノが入ってるとJuliusさんが起動すらしなくなるので、どうしてもファイルを分けなければならないんだけど、万一齟齬があるとしりとりにならなくなっちゃうんで、一つのファイルから自動的に二つにして保存したい)

 何かと評判のイマイチな(?)なでしこのグリッドですけど、実はIMEATOKの辞書ユーティリティが、同じような仕様なんです。

 おらく、エクセルなどのようなののグリッドとは、用途の異なるグリッドなんだろうね。辞書ユーティリティなんかには最適・・・なのかもしない(どうだろ;)


 んなこんなでとりあえず、前に作った変換辞書を使い、Julius用単語リスト入力が出来るところまで作って、またまたひらめき脇道へ逸れました(^▽^;

 カテゴリの項目を作って、vocaファイルとしても出力できるようにしてみたらどうだろう(って、やってみたことも無いのに無謀;)

 でも、なんとなくこんな感じかなあ?とゆうのができました☆

 しか~し、の機能を自分で使う日が来るのかは不明!(爆)

 Perlをインストールしてないからコンパイルできないんで(入れろよ!)、出力したvocaファイルが使えるかどうかは未確認です(えっ;)

 あああ、誰か使ってみてくれないかなあ・・・www

#-----------------------------------------------------------------------
# Julius用辞書ユーティリティ
#
# 「大語彙連続音声認識エンジン Julius」http://julius.osdn.jp/index.php
# で使用する、単語リスト及びVOCAファイルを作成できます。
#-----------------------------------------------------------------------

#-----宣言--------------------------------------------------
ファイル形式とは文字列=「タブ区切り(*.tsv;*.yomi)|*.tsv;*.yomi|テキストファイル(*.txt)|*.txt|すべて(*.*)|*.*」
列見出しとは文字列=「単語        ,読み(ひらがな)  ,Julius音素列    ,vocaカテゴリ 」
ファイル名とは文字列。
辞書データとは文字列保存データとは文字列。
カテゴリデータとは配列。
編集行とは整数=0
新規フラグとは整数オフ。
変換辞書とは配列。変換辞書設定。
無音用エントリとは配列=「## 無音用エントリ
% NS_B	# 文頭無音
 	silB
% NS_E	# 文末無音
。	silE
% NOISE	# 文中ショートポーズ
、	sp」

列_単語とは整数=0。
列_読みとは整数=1。
列_音素列とは整数=2。
列_カテゴリとは整数=3。
#-----------------------------------------------------------

#-----母艦設計-----------------------------------------------
!母艦設計=「母艦の可視はオフ」

#---メニュー----
『#親部品名,部品名,テキスト,ショートカット,オプション,イベント
なし,ファイルメニュー,ファイル(&F),,,
 -,新規メニュー,新規作成(&N),Ctrl+N,,新規作成。
 -,開くメニュー,開く(&O),Ctrl+O,,ファイル開く。
 -,-,,,,
 -,JDICメニュー,Julius用単語リスト出力(&D),,,JDIC出力。
 -,VOCAメニュー,Julius用vocaファイル出力(&V),,,VOCA出力。
 -,-,,,,
 -,閉じるメニュー,閉じる(&X),Ctrl+X,,終わる
なし,編集メニュー,編集(&E),,,
 -,単語登録メニュー,新規単語登録(&N),,,(辞書データの要素数)で登録編集開始。
 -,単語編集メニュー,編集(&E),,,(辞書グリッドの値-1)で登録編集開始。
 -,-,,,,
 -,読みソートメニュー,読みでソート(&S),,,読みソート。
 -,カテゴリソートメニュー,カテゴリでソート(&C),,,カテゴリソート。
 -,-,,,,
 -,単語削除メニュー,削除(&D),Ctrl+D,,単語削除。
 -,-,,,,
 -,一括メニュー,読み→音素列一括変換(&A),,,音素列一括変換。
なし,ヘルプメニュー,ヘルプ(&H),,,
 -,操作説明メニュー,操作説明(&H),Ctrl+H,,操作説明
 -,-,,,,
 -,バージョンメニュー,バージョン情報(&A),Ctrl+A,,バージョン
』をメニュー一括作成。

#---母艦----
母艦について
  タイトルは「Julius用辞書ユーティリティ」
  クライアント幅は640。
  クライアント高さは480。
#------------------------------------------------------------

#-----GUI-------------------------------------------------
#---グリッド-----
辞書グリッドとはグリッド
これについて
  レイアウトは全体
  文字サイズは10。
  アイテムは「{列見出し}{改行}{辞書データ}」
  自動ソートはオフ。
  ダブルクリックした時は~(辞書グリッドの値-1)で登録編集開始。

#---単語登録/編集フォーム-----
編集フォームとはフォームこれについて
  可視はオフ。タイトルは「単語登録/編集」
  クライアント幅は400。クライアント高さは250。
  オフに最大化ボタン有効変更。
  オフに最小化ボタン有効変更。
  キー押した時は~
    もし、(シフトキー=CTRL)かつ(押された仮想キー=83)ならば、次単語。  #CTRL+S
編集フォームウィンドウ背景色画面クリア。

#編集用
部品間隔は20
カテゴリラベルとはラベルこれについて
  親部品は編集フォーム。
  テキストは「カテゴリ:」
  位置は「15,15」

単語ラベルとはラベルこれについて
  親部品は編集フォーム。
  テキストは「単 語:」
  位置はカテゴリラベルの下側。

読みラベルとはラベルこれについて
  親部品は編集フォーム。
  テキストは「読 み:」
  位置は単語ラベルの下側。

音素列ラベルとはラベルこれについて
  親部品は編集フォーム。
  テキストは「音素列:」
  位置は読みラベルの下側。

部品間隔は0
カテゴリコンボとはコンボこれについて
  親部品は編集フォーム。幅は180。
  位置はカテゴリラベルの右側。
  アイテムはカテゴリデータ。値は0。

単語エディタとはエディタこれについて
  親部品は編集フォームIMEIMEオン。
  位置は単語ラベルの右側。幅は300。

読みエディタとはエディタこれについて
  親部品は編集フォームIMEIMEオン。
  位置は読みラベルの右側。幅は300。

音素列エディタとはエディタこれについて
  親部品は編集フォームIMEIMEオフ。
  位置は音素列ラベルの右側。幅は300。
  有効はオフ。背景色はウィンドウ背景色部品間隔は5
カテゴリ追加ボタンとはボタン
これについて
  親部品は編集フォーム。
  位置はカテゴリコンボの右側。幅は100。
  クリックした時は~
    カテゴリコンボを注目。
    ダイアログタイトルは「カテゴリ追加」
    ダイアログIMEは「IMEオフ」
    「追加するカテゴリを入力して下さい。{改行}(%は自動的に付与されます)」と尋ねる。
    もしそれでなければ、
      カテゴリデータは「{カテゴリデータ}{改行}%{それ}」
      カテゴリコンボのアイテムはカテゴリデータ。
      カテゴリコンボの値は(カテゴリデータの要素数-1)

#変換設定
音素列入力フラグとはチェック
これについて
  親部品は編集フォーム。
  位置は音素列エディタの下側。幅は250。
  テキストは「音素列を手入力する」
  値はオフ。
  クリックした時は~
    もし、音素列入力フラグの値がオンならば、
      音素列エディタの有効はオン。
      音素列エディタの背景色は白色。
      音素列自動変換ボタンの有効はオフ。
    違えば、
      音素列エディタの有効はオフ。
      音素列エディタの背景色はウィンドウ背景色。
      音素列自動変換ボタンの有効はオン。

音素列自動変換ボタンとはボタン
これについて
  親部品は編集フォーム。
  位置は「70,165」。幅は250。
  テキストは「読み→音素列自動変換」
  クリックした時は~音素列自動変換。

自動変換注意ラベルとはラベル
これについて
  親部品は編集フォーム。
  位置は音素列自動変換ボタンの下側
  テキストは「(自動変換すると手入力の内容は上書きされます)」

#ボタン
次単語ボタンとはボタンこれについて
  親部品は編集フォーム。
  位置は「10,220」。テキストは「次へ(S)」
  クリックした時は~次単語。
*次単語
  もし、単語エディタのテキスト=ならば、登録キャンセル。
  違えば、
    「次」で登録編集結果反映。
    辞書グリッドの値=辞書グリッドの値+1。
    (辞書グリッドの値-1)で登録編集開始。

OKボタンとはボタンこれについて
  親部品は編集フォーム。
  位置は「230,220」
  クリックした時は~
    もし、単語エディタのテキスト=ならば、登録キャンセル。
    違えば、
      「OK」で登録編集結果反映。

部品間隔は10。
キャンセルボタンとはボタン。。
これについて
  親部品は編集フォーム。
  位置はOKボタンの右側。
  クリックした時は~登録キャンセル。
*登録キャンセル
  もし、新規フラグ=オンならば、辞書データの(辞書グリッドの値-1)を配列削除。
  編集フォームを閉じる。
#-----------------------------------------------------------

#-----メイン------------------------------------------------
母艦の可視はオン。
ファイル開くもし、ファイル名がならば、
  「新規作成しますか?」で二択。
  もしそれはいならば、新規作成。
  違えば終わるもし、ファイル名がならば終わる。
#-----------------------------------------------------------
*新規作成
  「無題.tsv」でファイル形式の保存ファイル選択。
  ファイル名はそれ。
  もしそれでなければ、をファイル名に保存。
  違えば戻る。
  辞書データは。
  母艦のタイトルは「{ファイル名からファイル名抽出} - Julius用辞書ユーティリティ」
  辞書グリッドのアイテムは「{列見出し}{改行}{辞書データ}」

*ファイル開く
  ファイル名はファイル形式のファイル選択。
  もしそれでなければ、それ開く。
  違えば抜ける。
//  辞書データはそれの「{タブ}+」を「{タブ}」に正規表現置換。
//  辞書データはそれの「  +」を「{タブ}」に正規表現置換。
  辞書データはそれTSV取得。
  母艦のタイトルは「{ファイル名からファイル名抽出} - Julius用辞書ユーティリティ」
  辞書グリッドのアイテムは「{列見出し}{改行}{辞書データ}」
  カテゴリデータは「{改行}{辞書データの列_カテゴリを表列取得}」
  カテゴリデータはカテゴリデータの0で表重複削除。
  カテゴリデータ¥0=「(なし)」
  カテゴリコンボのアイテムはカテゴリデータ。

#-----------------------------------------------------------
*登録編集開始(Aで)
  もし(辞書グリッドの値)>(辞書データの要素数ならば、新規フラグ=オン。
  違えば、新規フラグ=オフ。
  編集行=A。
  単語エディタのテキストは辞書データ¥編集行,列_単語。
  読みエディタのテキストは辞書データ¥編集行,列_読み。
  音素列エディタのテキストは辞書データ¥編集行,列_音素列。
  もし、(辞書データ¥編集行,3)=ならば、カテゴリコンボの値は0
  違えば、カテゴリコンボの値はカテゴリデータの1から(辞書データ¥編集行,列_カテゴリ)を配列検索。
  単語エディタを注目。
  もし、編集フォームの可視=オフならば、編集フォームをモーダル表示。

*登録編集結果反映(Fで)
  辞書データ¥編集行,列_単語は単語エディタのテキスト。
  辞書データ¥編集行,列_読みは読みエディタのテキスト。
  辞書データ¥編集行,列_音素列は音素列エディタのテキスト。
  もし、カテゴリコンボの値≦0ならば、
    辞書データ¥編集行,列_カテゴリ=
  違えば、
    辞書データ¥編集行,列_カテゴリはカテゴリデータ¥(カテゴリコンボの値)
  編集結果保存。
  もし、F=「OK」ならば、編集フォームを閉じる。
#-----------------------------------------------------------
*編集結果保存
  辞書グリッドのアイテムは「{列見出し}{改行}{辞書データ}」
  保存データは辞書データを表TSV変換。
  保存データは保存データの「"」を置換。
  保存データをファイル名に保存。
#-----------------------------------------------------------
*単語削除
  ダイアログタイトルは「削除」
  「単語:{辞書データ¥(辞書グリッドの値-1),列_単語}{改行}読み:{辞書データ¥(辞書グリッドの値-1),1}{改行}{改行} を削除します。よろしいですか?」で二択。
  もしそれはいならば、
    辞書データの(辞書グリッドの値-1)を配列削除。
    編集結果保存。
#-----------------------------------------------------------
*音素列自動変換
  一時は読みエディタのテキスト。
  変換辞書で反復
    一時は一時の(対象¥0)を(対象¥1)へ正規表現置換。
  音素列エディタのテキストは一時。

*音素列一括変換
  ダイアログタイトルは「一括変換」
  「一括変換を行うと、手入力した音素列データも{改行}全て上書きされます。よろしいですか?」で二択。
  もしそれはいならば、
    辞書データで反復。
      一時は対象¥1。
      変換辞書で反復
        一時は一時の(対象¥0)を(対象¥1)へ正規表現置換。
      辞書データ¥(回数-1),列_音素列は一時
    編集結果保存。
#-----------------------------------------------------------
*読みソート
  辞書データの列_読みを表ソート。
  編集結果保存。

*カテゴリソート
  もし、辞書データの列_カテゴリで「%*」を0から表曖昧検索=-1でなければ、
    辞書データの列_カテゴリを表ソート。
    編集結果保存。
#-----------------------------------------------------------
*JDIC出力
  JDICファイル名はファイル名を「.jdic」に拡張子変更。
  もし、JDICファイル名の存在はいならば、
    「{JDICファイル名からファイル名抽出}は既に存在します。{改行}上書きしますか?」で二択。
    もしそれいいえならば戻る。
  JDICデータ¥0は辞書データの列_単語を表列取得。
  JDICデータ¥1は辞書データの列_音素列を表列取得。
  JDICデータはJDICデータを表行列交換。
  JDICデータはJDICデータを表TSV変換。
  JDICデータはJDICデータの「"」を置換。
  JDICデータをJDICファイル名に保存。
  「{JDICファイル名からファイル名抽出}を作成しました。」と言う。

*VOCA出力
  VOCAファイル名はファイル名を「.voca」に拡張子変更。
  もし、VOCAファイル名の存在はいならば、
    「{VOCAファイル名からファイル名抽出}は既に存在します。{改行}上書きしますか?」で二択。
    もしそれいいえならば戻る。
  カテゴリ整理。
  一時データ¥0は辞書データの列_単語を表列取得。
  一時データ¥1は辞書データの列_音素列を表列取得。
  一時データ¥2は辞書データの列_カテゴリを表列取得。
  一時データは一時データを表行列交換。
  一時データは一時データの列_カテゴリを表ソート。

  VOCAデータは。
  カテゴリデータで反復。
    もし対象=「(なし)」ならば続ける。
    VOCAデータは「{VOCAデータ}{対象}{改行}」。
    VOCAデータは「{VOCAデータ}{一時データの2から対象表完全一致ピックアップ}{改行}{改行}」
  VOCAデータは「{VOCAデータ}{無音用エントリ}」
  VOCAデータはVOCAデータの2を表列削除。

  VOCAデータはVOCAデータを表TSV変換
  VOCAデータはVOCAデータの「"」を置換。
  VOCAデータをVOCAファイル名に保存。
  「{VOCAファイル名からファイル名抽出}を作成しました。」と言う。

*カテゴリ整理
  一時データはカテゴリデータ。
  一時データで反復。
    もし対象=「(なし)」ならば続ける
    もし、辞書データの列_カテゴリで対象を0から表検索=-1ならば、
      カテゴリデータの(回数-1)を配列削除。
  カテゴリコンボのアイテムはカテゴリデータ。

#-----------------------------------------------------------------------
*操作説明
  ダイアログタイトルは「せつめい」
  「・起動すると、{カッコ}開く{カッコ閉じ}から始まるので、編集したいファイルを選択。
 {カッコ}キャンセル{カッコ閉じ}すると、ファイルの新規作成になります。
 ファイルの形式はTSVで、拡張子は{カッコ}*.tsv{カッコ閉じ}{カッコ}*.txt{カッコ閉じ}{カッコ}*.yomi{カッコ閉じ}など。{改行}
・項目をダブルクリックすると、単語登録/編集フォーム開くので、
 {カッコ}単語{カッコ閉じ}と{カッコ}読み{カッコ閉じ}を入力して、{カッコ}音素列自動変換{カッコ閉じ}するだけ。
 (音素列は編集メニューから、まとめて一括変換もできます)
 [CTRL+S]で、次の単語の編集に移れます。
 セーブは都度自動的に行われますが{カッコ}単語{カッコ閉じ}は必須でだと保存されません。{改行}
・入力が完了したら、ファイルメニューから{カッコ}Julius用単語リスト出力{カッコ閉じ}
 拡張子は{カッコ}*.jdic{カッコ閉じ}としています。{改行}
・{カッコ}カテゴリ{カッコ閉じ}の項目を追加し、VOCAファイル作成にも対応しました。
 ファイルメニューから{カッコ}Julius用vocaファイル出力{カッコ閉じ}
 無音用エントリは自動挿入されます。不要の場合は削除して下さい。
 (vocaの中にgrammarで使用してない項目があるとコンパイルが失敗するらしい)
」と言うバージョン
  ダイアログタイトルは「バージョン情報」
  「{二重カッコ}Julius用{改行} 辞書ユーティリティ{二重カッコ閉じ}{改行}    Version 1.11{改行}{改行}   by 雪乃☆雫」と言う。
#-----------------------------------------------------------------------
*変換辞書設定
  # ひらがな -> Julius 標準モデル用変換辞書(yomi2voca.plより抽出)
  変換辞書=「う゛ぁ," b a"{~}う゛ぃ," b i"{~}う゛ぇ," b e"{~}う゛ぉ," b o"{~}う゛ゅ," by u"
ぅ゛," b u"{~}あぁ," a a"{~}いぃ," i i"{~}いぇ," i e"{~}いゃ," y a"{~}うぅ," u:"{~}えぇ," e e"{~}おぉ," o:"
かぁ," k a:"{~}きぃ," k i:"{~}くぅ," k u:"{~}くゃ," ky a"{~}くゅ," ky u"{~}くょ," ky o"{~}けぇ," k e:"{~}こぉ," k o:"
がぁ," g a:"{~}ぎぃ," g i:"{~}ぐぅ," g u:"{~}ぐゃ," gy a"{~}ぐゅ," gy u"{~}ぐょ," gy o"{~}げぇ," g e:"{~}ごぉ," g o:"
さぁ," s a:"{~}しぃ," sh i:"{~}すぅ," s u:"{~}すゃ," sh a"{~}すゅ," sh u"{~}すょ," sh o"{~}せぇ," s e:"{~}ぉ," s o:"
ざぁ," z a:"{~}じぃ," j i:"{~}ずぅ," z u:"{~}ずゃ," zy a"{~}ずゅ," zy u"{~}ずょ," zy o"{~}ぜぇ," z e:"{~}ぞぉ," z o:"
たぁ," t a:"{~}ちぃ," ch i:"{~}つぁ," ts a"{~}つぃ," ts i"{~}つぅ," ts u:"{~}つゃ," ch a"{~}つゅ," ch u"{~}つょ," ch o"
つぇ," ts e"{~}つぉ," ts o"{~}てぇ," t e:"{~}とぉ," t o:"
だぁ," d a:"{~}ぢぃ," j i:"{~}づぅ," d u:"{~}づゃ," zy a"{~}づゅ," zy u"{~}づょ," zy o"{~}でぇ," d e:"{~}どぉ," d o:"
なぁ," n a:"{~}にぃ," n i:"{~}ぬぅ," n u:"{~}ぬゃ," ny a"{~}ぬゅ," ny u"{~}ぬょ," ny o"{~}ねぇ," n e:"{~}のぉ," n o:"
はぁ," h a:"{~}ひぃ," h i:"{~}ふぅ," f u:"{~}ふゃ," hy a"{~}ふゅ," hy u"{~}ふょ," hy o"{~}へぇ," h e:"{~}ほぉ," h o:"
ばぁ," b a:"{~}びぃ," b i:"{~}ぶぅ," b u:"{~}ふゃ," hy a"{~}ぶゅ," by u"{~}ふょ," hy o"{~}べぇ," b e:"{~}ぼぉ," b o:"
ぱぁ," p a:"{~}ぴぃ," p i:"{~}ぷぅ," p u:"{~}ぷゃ," py a"{~}ぷゅ," py u"{~}ぷょ," py o"{~}ぺぇ," p e:"{~}ぽぉ," p o:"
まぁ," m a:"{~}みぃ," m i:"{~}むぅ," m u:"{~}むゃ," my a"{~}むゅ," my u"{~}むょ," my o"{~}めぇ," m e:"{~}もぉ," m o:"
やぁ," y a:"{~}ゆぅ," y u:"{~}ゆゃ," y a:"{~}ゆゅ," y u:"{~}ゆょ," y o:"{~}よぉ," y o:"
らぁ," r a:"{~}りぃ," r i:"{~}るぅ," r u:"{~}るゃ," ry a"{~}るゅ," ry u"{~}るょ," ry o"{~}れぇ," r e:"{~}ろぉ," r o:"
わぁ," w a:"{~}をぉ," o:"{~}う゛," b u"{~}でぃ," d i"{~}でぇ," d e:"{~}でゃ," dy a"{~}でゅ," dy u"{~}でょ," dy o"
てぃ," t i"{~}てぇ," t e:"{~}てゃ," ty a"{~}てゅ," ty u"{~}てょ," ty o"{~}すぃ," s i"
ずぁ," z u a"{~}ずぃ," z i"{~}ずぅ," z u"{~}ずゃ," zy a"{~}ずゅ," zy u"{~}ずょ," zy o"{~}ずぇ," z e"{~}ずぉ," z o"
きゃ," ky a"{~}きゅ," ky u"{~}きょ," ky o"{~}しゃ," sh a"{~}しゅ," sh u"{~}しぇ," sh e"{~}しょ," sh o"
ちゃ," ch a"{~}ちゅ," ch u"{~}ちぇ," ch e"{~}ちょ," ch o"{~}とぅ," t u"{~}とゃ," ty a"{~}とゅ," ty u"{~}とょ," ty o"
どぁ," d o a"{~}どぅ," d u"{~}どゃ," dy a"{~}どゅ," dy u"{~}どょ," dy o"{~}どぉ," d o:"
にゃ," ny a"{~}にゅ," ny u"{~}にょ," ny o"{~}ひゃ," hy a"{~}ひゅ," hy u"{~}ひょ," hy o"
みゃ," my a"{~}みゅ," my u"{~}みょ," my o"{~}りゃ," ry a"{~}りゅ," ry u"{~}りょ," ry o"
ぎゃ," gy a"{~}ぎゅ," gy u"{~}ぎょ," gy o"{~}ぢぇ," j e"{~}ぢゃ," j a"{~}ぢゅ," j u"{~}ぢょ," j o"
じぇ," j e"{~}じゃ," j a"{~}じゅ," j u"{~}じょ," j o"{~}びゃ," by a"{~}びゅ," by u"{~}びょ," by o"
ぴゃ," py a"{~}ぴゅ," py u"{~}ぴょ," py o"{~}うぁ," u a"{~}うぃ," w i"{~}うぇ," w e"{~}うぉ," w o"
ふぁ," f a"{~}ふぃ," f i"{~}ふぅ," f u"{~}ふゃ," hy a"{~}ふゅ," hy u"{~}ふょ," hy o"{~}ふぇ," f e"{~}ふぉ," f o"
あ," a"{~}い," i"{~}う," u"{~}え," e"{~}お," o"{~}か," k a"{~}き," k i"{~}く," k u"{~}け," k e"{~}こ," k o"
さ," s a"{~}し," sh i"{~}す," s u"{~}せ," s e"{~}," s o"{~}た," t a"{~}ち," ch i"{~}つ," ts u"{~}て," t e"{~}と," t o"
な," n a"{~}に," n i"{~}ぬ," n u"{~}ね," n e"{~}の," n o"{~}は," h a"{~}ひ," h i"{~}ふ," f u"{~}へ," h e"{~}ほ," h o"
ま," m a"{~}み," m i"{~}む," m u"{~}め," m e"{~}も," m o"{~}ら," r a"{~}り," r i"{~}る," r u"{~}れ," r e"{~}ろ," r o"
が," g a"{~}ぎ," g i"{~}ぐ," g u"{~}げ," g e"{~}ご," g o"{~}ざ," z a"{~}じ," j i"{~}ず," z u"{~}ぜ," z e"{~}ぞ," z o"
だ," d a"{~}ぢ," j i"{~}づ," z u"{~}で," d e"{~}ど," d o"{~}ば," b a"{~}び," b i"{~}ぶ," b u"{~}べ," b e"{~}ぼ," b o"
ぱ," p a"{~}ぴ," p i"{~}ぷ," p u"{~}ぺ," p e"{~}ぽ," p o"{~}や," y a"{~}ゆ," y u"{~}よ," y o"
わ," w a"{~}ゐ," i"{~}ゑ," e"{~}を," o"{~}ん," N"{~}っ," q"{~}ー,":"
ぁ," a"{~}ぃ," i"{~}ぅ," u"{~}ぇ," e"{~}ぉ," o"{~}ゎ," w a"{~}ぉ," o"{~}"^ ([a-z])","$1"{~}"\:+",":"」をCSV取得。
#-----------------------------------------------------------------------

 そうそう、またまたナゾが発生し、それは一応解決できたんだけど、これまで知らなかった事実が発覚したので記しておきます。

 編集フォームを開いた時、単語エディタを注目させるようにしたら、それまでは問題なかったカテゴリ追加時の、ダイアログIME=「IMEオフ」が効かなくなってしまったんです。

 どうやら、エディタに設定しているIMEオンが優先されてしまうらしいです。

 ダイアログを開く前に、IMEの設定をしていないカテゴリコンボにフォーカスを合わせるようにしたらうまく行きました。

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20170509

2017/04/21 (金)

フルスクリーンにしたい!2

| 16:35 | フルスクリーンにしたい!2 - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - フルスクリーンにしたい!2 - 雪乃☆雫のなでしこ日和 フルスクリーンにしたい!2 - 雪乃☆雫のなでしこ日和 のブックマークコメント

 以前、出来そうな気はしてたけど、着手しなかった、APIによるフルスクリーン。

 「SetWindowLong」とゆうので、ウィンドウスタイルの設定が出来るようなので、やってみます。

#-----------------------------------------------------------
#https://msdn.microsoft.com/ja-jp/library/cc411203.aspx
●SetWindowLong(hWnd,nIndex,dwNewLong) =DLL("user32.dll",
"LONG SetWindowLongA(
  HWND hWnd,       // ウィンドウのハンドル
  int nIndex,      // 設定する値のオフセット
  LONG dwNewLong   // 新しい値
)")
#-----------------------------------------------------------

 設定する値の・・・おふせっとってなんすか;;;

 ・・・どんなデータを書き換えるかを、まずここで指定するってコトらしい。

 どんなデータが書き換えられんのかとゆうと・・・MSDNに色々書いてあっても、何のことやらさっぱりわからない;・・・けど、とりあえずウィンドウスタイルを設定するには「GWL_STYLE」を指定すればよさそう

 GWL_STYLE=-16のようです。

 相変わらず、英語版にだけ値が載ってるとかヤメテ><

https://msdn.microsoft.com/ja-jp/library/windows/desktop/ms633591(v=vs.85).aspx


 そうして、最後の「新しい値」の部分に、「WS_VISIBLE」的なフラグを設定していく。

 論理和でねwww

https://msdn.microsoft.com/ja-jp/library/czada357.aspx

https://msdn.microsoft.com/ja-jp/library/windows/desktop/ms632600(v=vs.85).aspx


#-----------------------------------------------------------
!GWL_STYLEとは整数=-16     # ウィンドウスタイル
●窓ハンドルスタイル設定(ハンドルをスタイルに)
  SetWindowLong(ハンドル,GWL_STYLE,スタイル)

母艦のハンドルをWS_VISIBLEに窓ハンドルスタイル設定。
#-----------------------------------------------------------

 これで行けるかと思ったら、行かなかった。

 MSDNをようく読むと・・・

ウィンドウデータの中には、キャッシュされており、SetWindowLong 関数を使って
変更しても SetWindowPos 関数を呼び出すまでは有効にならないものもあります。
特に、フレームスタイルを変更した場合は、SWP_FRAMECHANGED フラグをセットして
 SetWindowPos 関数を呼び出すさなければ、キャッシュが正しく更新されません。

 ・・・なんて?ヽ(;´Д`)ノ

 ようするに、SetWindowLongでウィンドウの属性を変更しても、SetWindowPos関数を呼んで反映させるまでは、変更されない・・・的な。

 ここで、前フルスクリーンをやった時に、なんだか分かんないから取りあえず無視した「ウィンドウ位置のオプション」が発生。ここに「SWP_FRAMECHANGED」を指定するとゆうことのようです。

 どうやら、SWP_FRAMECHANGED=$20のようです。

https://msdn.microsoft.com/ja-jp/library/windows/desktop/ms633545(v=vs.85).aspx

#-----------------------------------------------------------
!GWL_STYLEとは整数=-16     # ウィンドウスタイル
!SWP_FRAMECHANGEDとは整数=$20  # SetWindowLong関数を使用後に新しいフレームスタイルの設定を適用
●窓ハンドルスタイル設定(ハンドルを{数値=0}X,{数値=0}Y,{数値=0}W,{数値=0}Hでスタイルに)
  SetWindowLong(ハンドル,GWL_STYLE,スタイル)
  SetWindowPos(ハンドル,0,X,Y,W,H,SWP_FRAMECHANGED)
  # SetWindowLongによるウィンドウの属性変更を反映させるには、SetWindowPosでSWP_FRAMECHANGEDを指定して反映させる必要ある。
#-----------------------------------------------------------

 できた!

 でもこれは、なでしこ標準のスタイル設定とは併用出来ないもよう。

 なんで、「枠固定」のウィンドウも、SetWindowLongを使って設定してやらなければならない

 何も無いウィンドウにフラグを追加して、足していくイメージ

 最大化ボタンや最小化ボタンはわざわざ外していたくらいだから、このくらいで行けそう

!WS_VISIBLEとは整数=$10000000  # 初期状態(枠なし)で表示。
!WS_CAPTIONとは整数=$C00000   # タイトルバーを持つ。
!WS_SYSMENUとは整数=$80000   # システムメニューボタン母艦のハンドルを0,0,640,480でWS_VISIBLE||WS_CAPTION||WS_SYSMENUに窓ハンドルスタイル設定。

 できた♪

#窓ハンドルスタイル設定
#-----------------------------------------------------------
!母艦設計=「母艦の可視はオフ母艦黒色画面クリア母艦枠固定中央表示。
2秒待つ母艦枠無全画面表示。
2秒待つ母艦枠固定中央表示。
#-----------------------------------------------------------
!WS_VISIBLEとは整数=$10000000  # 初期状態(枠なし)で表示。
!WS_DISABLEDとは整数=$8000000    # 初期状態で非表示。
!WS_CAPTIONとは整数=$C00000   # タイトルバーを持つ
!WS_SYSMENUとは整数=$80000   # システムメニューボタン母艦枠固定中央表示
  母艦の可視はオフ。
  母艦ハンドルをWS_DISABLED||WS_CAPTION||WS_SYSMENUに窓ハンドルスタイル設定。
  母艦のクライアント幅は640。母艦のクライアント高さは480。
    母艦ハンドルを(デスクトップW-母艦の幅)/2,(デスクトップH-母艦の高さ)/2,母艦の幅,母艦の高さでWS_VISIBLE||WS_CAPTION||WS_SYSMENUに窓ハンドルスタイル設定。
  母艦の可視はオン。  #オンにしなくてもウィンドウは表示されるけど、タスクバー表示されなくなる!

*母艦枠無全画面表示
  母艦の可視はオフ。
  母艦ハンドルを0,0,デスクトップW,デスクトップHでWS_VISIBLEに窓ハンドルスタイル設定。
  母艦の可視はオン。
#-----------------------------------------------------------
#https://msdn.microsoft.com/ja-jp/library/cc411203.aspx
●SetWindowLong(hWnd,nIndex,dwNewLong) =DLL("user32.dll",
"LONG SetWindowLongA(
  HWND hWnd,       // ウィンドウのハンドル
  int nIndex,      // 設定する値のオフセット
  LONG dwNewLong   // 新しい値
)")

!GWL_STYLEとは整数=-16     # ウィンドウスタイル
!SWP_FRAMECHANGEDとは整数=$20  # SetWindowLong関数を使用後に新しいフレームスタイルの設定を適用
●窓ハンドルスタイル設定(ハンドルを{数値=0}X,{数値=0}Y,{数値=0}W,{数値=0}Hでスタイルに)
  SetWindowLong(ハンドル,GWL_STYLE,スタイル)
  SetWindowPos(ハンドル,0,X,Y,W,H,SWP_FRAMECHANGED)
    # SetWindowLongでウィンドウスタイルを変更した後は、SetWindowPosでSWP_FRAMECHANGEDを指定して反映させる必要ある。
#-----------------------------------------------------------
#https://msdn.microsoft.com/ja-jp/library/cc411206.aspx
●SetWindowPos(hWnd,hWndInsertAfter,X,Y,cx,cy,uFlags) =DLL("user32.dll",
"BOOL SetWindowPos(
HWND hWnd,             // ウィンドウのハンドル
HWND hWndInsertAfter,  // 配置順序のハンドル…?
int X,                 // 横方向の位置
int Y,                 // 縦方向の位置
int cx,                // 幅
int cy,                // 高さ
UINT uFlags            // ウィンドウ位置のオプション
)")

●窓ハンドル位置サイズ設定(ハンドルをX,Y,W,Hに)
  SetWindowPos(ハンドル,0,X,Y,W,H,0)
#-----------------------------------------------------------

※重要!(ワタシ的にw)

 クライアント幅、クライアント高さでウィンドウのサイズを設定したい場合、まずウィンドウスタイルを変更してから設定しないと、枠幅やタイトルバー分サイズがずれてしまう。

母艦枠固定中央表示
  母艦のクライアント幅は640。母艦のクライアント高さは480。
  母艦ハンドルを(デスクトップW-母艦の幅)/2,(デスクトップH-母艦の高さ)/2,母艦の幅,母艦の高さでWS_VISIBLE||WS_CAPTION||WS_SYSMENUに窓ハンドルスタイル設定。
  母艦の可視はオン

 コレじゃダメだったんです。

 API的には、SetWindowLongでスタイル設定後にSetWindowPosでサイズを設定しているんだけど、やっぱりSWP_FRAMECHANGEDするまでは見た目だけじゃ無く反映されてないようで、母艦の幅と高さは元のウィンドウのサイズのままなので、このあとクライアント幅、クライアント高さを言わせると、サイズが変わってしまっている。

 (枠なしからの場合、タイトルバー分があるから顕著だけど、枠可変から枠固定の場合も、枠の幅がちょこっと違うんだよね、コレが;)

 さらに、最初からVISIBLEに設定すると、クライアント幅と高さを設定した時に、違う位置にチラッと見えてしまうため、なんだかムダっぽいけど一旦非表示でスタイルだけ設定した後、再び位置サイズとともにVISIBLEにしてみている。

 の場合、母艦の可視はオフを入れないと、全画面からウィンドウ表示戻る時、全画面の表示が残って(?)おかしなことになるみたい。

(なんでのようにしたんだったか、後からすぐ忘れるので、このように記しておく(爆))

 何か、もっと、無駄の無い手立てがあるかなあ・・・?

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20170421

2017/04/18 (火)

監視カメラ的な?

| 16:55 | 監視カメラ的な? - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - 監視カメラ的な? - 雪乃☆雫のなでしこ日和 監視カメラ的な? - 雪乃☆雫のなでしこ日和 のブックマークコメント

 昨日の続きです。

 とりあえずコレもお試しだけど、なんかこんな感じ?

 感度値は、値が大きい方が感度が高そうな気がしてしまうけど、実際はが少ない方が感度が良いというわけで、知恵の足りないワタシはいちいちコンランしまくり(バカ;)・・・のため、0~100で設定できるよーにした(爆)


 んなコトはさておき、精度は10でも5でも、侵入者wを発見して撮影することはできた。

 でも結局、いちいち静止画保存されるのも実際のところはめーわくなので、BEEPにしてあるwww

 こんな精度だと、侵入者は発見できても、まばたきなんかは全く検出しないと思ってたんだけど、日中だと太陽光効果か(屋内だけど)結構検出できるみたい。

 自然って素晴らしい!(違;)


 ちなみにこれまで、静止画保存ようの画像を取得するイメージ部品を「処理用」としてましたが、「保存用」に変更。

 処理用は、動いたピクセルを点描画するために使用することに。

#監視カメラ的な?

#-----宣言--------------------------------------------------
CW幅とは整数=640。CW高さとは整数=480。
CWハンドルとは整数=-1  #キャプチャーウィンドウのハンドル。
#---ウィンドウスタイル定数-----
!WS_VISIBLEとは整数=$10000000  #(初期状態)
!WS_CHILDとは整数=$40000000   #(子ウィンドウ)
CWスタイルとは整数=WS_VISIBLE||WS_CHILD  #キャプチャーウィンドウのスタイル

カメラ接続状態とは整数オフ。
フレームレートとは整数=60      #ミリ秒単位

精度=10
精度=精度/100
感度値=80
感度値=(255/100*(100-感度値))を切り下げ
閾値=50
閾値=(CW幅*精度*CW高さ*精度)/1000*閾値を切り下げ

#---GUI-----
保存用とはイメージの可視はオフ。

Tとはタイマーの値はフレームレート。
の時満ちた時は~画像比較。

動体検知モニターとはフォームこれについて
  可視はオン。
  スタイルは「枠固定」
  オフに最大化ボタン有効変更。
  タイトルは「動体検知的な?」
  クライアント幅はCW幅。
  クライアント高さはCW高さ。

処理用とはイメージこれについて
  可視はオフ。
  幅はCW幅*精度。
  高さはCW高さ*精度。

裏画面とはイメージこれについて
  可視はオフ。
  幅はCW幅。
  高さはCW高さ。

表示用とはイメージこれについて
  可視はオン。
  親部品は動体検知モニター。
  幅はCW幅。
  高さはCW高さ。
  位置は「0,0」
表示用を黒色画面クリア。

2
  比較用[回数-1]をイメージとして作成。
  比較用[回数-1]→可視はオフ。
  比較用[回数-1]→位置は「0,0」
  比較用[回数-1]→幅はCW幅。
  比較用[回数-1]→高さはCW高さ。

#---母艦-----
母艦について
  スタイルは「枠固定」
  オフに最大化ボタン有効変更。
  タイトルは「PCカメラキャプチャー」
  位置は「10,10」
  クライアント幅はCW幅。
  クライアント高さはCW高さ。
  閉じた時は~
    終了処理。
  キー押した時は~
    もし、押された仮想キー=13ならば、動体検知モニターの可視はオン。  # Enter
母艦黒色画面クリア。
動体検知モニターの位置は母艦の右側。
#-----------------------------------------------------------

#-----メイン------------------------------------------------
カメラ起動。
C=-1。Tを開始。
#-----------------------------------------------------------
*カメラ起動
  キャプチャーウィンドウ作成("",CWスタイル,0,0,CW幅,CW高さ,母艦のハンドル,0)
  CWハンドルはそれ。1秒待つ。
  5
    CWハンドルにカメラ接続。
    1秒待つ。
    もしそれはいならば、カメラ接続状態はオン抜ける。
  もし、カメラ接続状態がオフならば、
    CWハンドルをウィンドウ破棄。
    「カメラに接続出来ませんでした」と言う。
    終わる。
  CWハンドルをフレームレートにプレビューレート設定。
  CWハンドルをオンにプレビューモード設定。

*静止画保存
  ファイル名は「{今日} {}」を「yyyymmdd_hhnnss」に日時形式変換。
  ファイル名は「{デスクトップ}{ファイル名}.png」
  CWハンドルをクリップボードコピー。
  保存用の画像は「クリップボード」
  保存用をファイル名へ画像保存。

*終了処理
  CWハンドルからカメラ切断。
  CWハンドルをウィンドウ破棄。
  終わる。
#-----------------------------------------------------------
*画像比較
  C=C+1。D=0。I=0。
  CWハンドルをクリップボードコピー。
  比較用[C%2]→画像は「クリップボード」。
  比較用[C%2]を画像グレイスケール。
  比較用[C%2]をCW幅*精度,CW高さ*精度へ画像高速リサイズ。
  yで0からCW高さ*精度-1まで繰り返す。
    xで0からCW幅*精度-1まで繰り返す。
      比較用[C%2]のx,yから画像色取得。
      P¥(C%2),D=それ/$10000を切り下げ。
      もし、C=0でなければ、
        もし、((P\0,D)-(P\1,D))の絶対値>感度値ならば、
          I=I+1。
          処理用のx,yへ赤色点描画。
      D=D+1。
  もし、I>閾値ならばBEEP。//静止画保存。
  もし、動体検知モニターの可視=オンならば、モニター表示。

*モニター表示
  裏画面の画像は「クリップボード」
  処理用をCW幅,CW高さへ画像高速リサイズ。
  処理用を裏画面の0,0へ画像合成。
  表示用の画像は「裏画面」
  処理用をCW幅*精度,CW高さ*精度へ画像高速リサイズ。
  処理用を黒色画面クリア。
#-----------------------------------------------------------

#-----ビデオキャプチャー------------------------------------
#https://msdn.microsoft.com/en-us/library/windows/desktop/dd757696(v=vs.85).aspx
#---VFW定数-----
!WM_CAP_DRIVER_CONNECTとは整数=$400+10           # キャプチャウィンドウをキャプチャドライバに接続します。
!WM_CAP_DRIVER_DISCONNECTとは整数=$400+11        # キャプチャウィンドウからキャプチャドライバを切断します。
!WM_CAP_SET_PREVIEWとは整数=$400+50              # プレビューモード(オンオフ)
!WM_CAP_SET_PREVIEWRATEとは整数=$400+52          # プレビューモードのフレーム表示レート(ミリ秒)
!WM_CAP_SET_SCALEとは整数=$400+53                # 画像をキャプチャーウィンドウに合わせて拡縮(オンオフ)
!WM_CAP_SEQUENCEとは整数=$400+62                 # ストリーミングビデオおよびオーディオキャプチャをファイルに開始します。
!WM_CAP_FILE_SET_CAPTURE_FILEとは整数=$400+20    # ビデオキャプチャに使用されるファイルの名前を指定します。
!WM_CAP_EDIT_COPY=$400+30                        # 画面をクリップボードコピー。
#-----------------------------------------------------------
●カメラ接続(ハンドルに{数値=0}Noの)
  メッセージ送信(ハンドル,WM_CAP_DRIVER_CONNECT,No,0)  # カメラが1台ならNoは0でOK

●カメラ切断(ハンドルから)
  メッセージ送信(ハンドル,WM_CAP_DRIVER_DISCONNECT,0,0)

●プレビューレート設定(ハンドルをmsに)
  メッセージ送信(ハンドル,WM_CAP_SET_PREVIEWRATE,ms,0)  # ms=ミリ秒単位

●プレビューモード設定(ハンドルをfに)
  メッセージ送信(ハンドル,WM_CAP_SET_PREVIEW,f,0)     # f=オンオフ

●キャプチャ開始(ハンドルを)
  メッセージ送信(ハンドル,WM_CAP_SEQUENCE,0,0)

●キャプチャファイル設定(ハンドルをaviファイル名に)
  メッセージ送信(ハンドル,WM_CAP_FILE_SET_CAPTURE_FILE,0,aviファイル名)

●スケーリングフラグ設定(ハンドルをfに)
  メッセージ送信(ハンドル,WM_CAP_SET_SCALE,f,0)      # f=オンオフクリップボードコピー(ハンドルを)
  メッセージ送信(ハンドル,WM_CAP_EDIT_COPY,0,0)
#-----------------------------------------------------------

#-----API---------------------------------------------------
#https://msdn.microsoft.com/ja-jp/library/cc428606.aspx
●キャプチャーウィンドウ作成(lpszWindowName,dwStyle,x,y,nWidth,nHeight,hWnd,nID) =DLL("avicap32.dll",
"HWND capCreateCaptureWindowA(
LPCSTR lpszWindowName,  // ウィンドウ名
DWORD dwStyle,          // ウィンドウスタイル
int x,                  // X
int y,                  // Y
int nWidth,             // W
int nHeight,            // H
HWND hWnd,              // 親ウィンドウのハンドル
int nID                 // ウィンドウ識別子…ってなんすか;
)")
#-----------------------------------------------------------
#https://msdn.microsoft.com/ja-jp/library/cc411022.aspx
●メッセージ送信(hWnd,Msg,wParam,lParam) =DLL("user32.dll",
"LRESULT SendMessageA(
HWND hWnd,      // 送信先ウィンドウのハンドル
UINT Msg,       // メッセージ
SHORT wParam,  // メッセージの最初のパラメータ
LPCSTR lParam   // メッセージの 2 番目のパラメータ
)")
#-----------------------------------------------------------
#https://msdn.microsoft.com/ja-jp/library/cc410763.aspx
●ウィンドウ破棄(hWndを) =DLL("user32.dll",
"BOOL DestroyWindow(
HWND hWnd   // 破棄するウィンドウのハンドル
)")
#-----------------------------------------------------------

 うーん、この監視機能と、こないだのダイアログを加えて、あと、やっぱり現行のなでしこでもちゃんとフルスクリーンするようにAPIに直して、バージョン3かなぁ~♪

めだかめだか2017/04/24 01:17お久しゅう振りですw
なんか私より進んでません!?
私は、最近忙しすぎて出来てないんですよw


このプログラムを見る限り、私の野望の方が大きいです(笑
組んでるプログラム自体は、私の方がもっと簡単ですけどw

ところで、複数の検出は、速度やプログラム的にも可能だと思いますか?
複数の検出というのが、ただ、値以上を塗るではなく、ある程度の塊(背景誤差を検出しないものとする)での検出です。要は、両手を出して、両手とも上手いこと検出するかな?ですw
で、これなんですが、あまり深くは考えてないですが、ひょっとして不可能なのでは?と薄々思っています。

もし、可能でも、速度はとてもではないですが、実用的なものにはならないなと思っています。
そもそも、なでしこはGUI関連に弱いため、なでしこの高速は他言語で言うところの普通ぐらいでしょう...

これはあくまで、現段階の私の組んでいるプログラムをもとに考えたことなので一概には言えませんが、どう思いますか?

雪乃☆雫雪乃☆雫2017/04/24 17:01 めだかさん、こんにちは☆
 いや、まったく進んでません!w
 一番当初のお話しが顔認識・・・とゆうことだったので、こんなこっちゃぁないんだろうなってのは端から分かっていたのですが、なにぶんワタシの知恵ではこの程度;
 前に、画像はどの程度縮小して出来るか・・・というお話をしたので、速度的にはどんなもんだかを、実際お試ししてみようと思いついてちょっとやってみた結果、なんとかかんとかこーなったのですが・・・こりゃー予想通りとゆーかなんとゆーか、なかなか厳しくて参ったね>< と言う結果となりました。

 というわけで(?)現状ワタシの理解がまずここまでのレベルなもんで、どのようにも考えようがないんですけれどもねー;;;
 しかし、複数の検出とゆうのは、たとえば顔認識で言えば、複数人物がいた場合には、当然人数分検出しなけりゃならん、というようなことですよね・・??
 世の中にそのようなプログラムがある以上、速度のことは取りあえず置くとすれば、なでしこでも不可能ってことはあるまいと思ったり思わなかったりするところなのですが・・・何しろその方法が分かりませぬ~(@_@)

 しかし、とにかく最大の問題は速度なんですよね。
 他言語の普通というのがどのくらいなもんなのかも、ワタシにはちょっと分かりません。
 がっ・・・これは、なでしこのGUIが・・・とかいう以前の問題のように思います。
 なんにもせよ、画像色取得では、どうにも・・・ヽ(;´Д`)ノ

めだかめだか2017/04/24 21:26こにゃにゃちわ~

今日!久々にPC起動ですw

ほんとですよねぇ・・・やはり「速度」が問題ですね・・・それに、PC自体もスペックはいい方ではないので、そこからつまずきです・・・
とは、言えど、プログラムの可能性は無限大ですので、何かしらの解決策があるはず・・・!だと、思っていますw

そですね。
http://nonbiri-tereka.hatenablog.com/entry/2015/05/13/063713
「顔 検出 複数」での検索結果で1番上に来たやつが思っている奴が具現化されたものだったので、URLを載せておきます。こんな感じです。

他言語では、0.5秒以下の実行速度だったかな?そんぐらいは出しておかないと普通とは言えないとかいう話です・・・恐ろしい・・・

何か画像色取得以外の命令はないものか考え中です・・・

雪乃☆雫雪乃☆雫2017/04/25 00:23そうそうOpenCVですねー。
顔認識とかで検索すると、大体これ系ばかりヒットしてくるので、OpenCV自体がよくわからんもので、どうにもこうにも・・・(+_+)
画像の色を高速に取得するについては、ワタシが愚考するに、APIで直接ビットマップをどうにかしなきゃないと思うんだよね。
調べてないし、深くも考えてないし、可能かどうかすらよく分からんけど、やるとしたらおそらく、こーぞーたいで、ぽいんたぁで・・・うきゃぁぁヽ(;´Д`)ノ
・・・て感じかと思われます;;;

めだかめだか2017/04/25 21:08画像関連だと、OpenCVが一番有名というか、無難という感じですね(笑

私も他言語についてはさっぱりなので、もうやめて~状態ですTT

これ以上複雑なものはやだーって思ったのが一番です。てへへw

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20170418

2017/04/17 (月)

画像色取得が遅いよー(ToT)・・・とゆう話し(?)

| 09:32 | 画像色取得が遅いよー(ToT)・・・とゆう話し(?) - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - 画像色取得が遅いよー(ToT)・・・とゆう話し(?) - 雪乃☆雫のなでしこ日和 画像色取得が遅いよー(ToT)・・・とゆう話し(?) - 雪乃☆雫のなでしこ日和 のブックマークコメント

 何気に触発されて、動体検知的なことを調べてみたのだけれど・・・

 ・・・なんだかさっぱり分からないヽ(;´Д`)ノ

 それでも、画素値分検出ってゆうのは、なんとかワタシの知恵でもできそうだ。

http://www2.wisnet.ne.jp/~daddy/LC3/CaptureAlgorithm.html

 定期的に静止画を取得して、の画像からピクセルごと色を取得して、前後の画像を比較。色が違っていたら、のピクセルは動いたよってことだね。

 出来そうだけど、画像色取得点取得)や点描画が遅すぎて、死にたくなる予感。

 以前、ノベルを作ってた時に、記事にはなってないけど、アルファ値付きのマスクでの合成が出来ないかと思って試作したんだけども、あまりの遅さに挫折したんだよね。

 なにしろ640*480の画像で、20~30秒もかかるんだもん!

 この問題と、セーブデータの仕様を考えるのがめんどーってゆうのが、ノベルに飽きちゃった原因ですかね;;;

(いやむしろ、完成させたところで、絵も描けなけりゃ文章も書けんだろ! って事実に気付いちゃった・・・w)


 それはさておき、動体検知です。

 方針としては、

1,タイマーして、クリップボードコピーでフレームを取得。

2,それを、イメージ0とイメージ1に、交互に振り分ける。

3,イメージからピクセルごと画像色取得して、値を配列に保持。

4,イメージ0とイメージ1の値を比較。

 ・・・的な?

 して、

5,感度値とゆうのを設定して、それよりが大きければ、のピクセルを検知と認定するらしい。

 動いていない背景も、ようく見たら結構ちらつきがあって、全く色が変化してないわけじゃないから、幅を持たすんだね。

6,閾値を設定して、検知となったピクセル数が閾値をえたら、の画像は動いたよと判断する。

 コレでちょこっと、監視カメラっぽい機能を搭載してみようと思う。

 よくある、動くモノが映ったらシャッターを切ったり、メールで送ったり、録画を保存したりする的なコトだね。とりあえず簡単に、静止画保存を呼び出す感じで。


 さらに・・・加えて、動いたところをモニターしたい(?)とゆう野望なのです。

 それをリアルタイムでやろうとすると、コレがまた予想どうりなかなかキビシイ。

 たぶんだけど、なでしこの点取得画像色取得)と点描画は、WindowsAPIのGetPixelとSetPixelが元になってると思われ、コレ自体が遅いとゆう評判なので、もはやどうしようもないっぽいんですよね~(--;

 何か、他に手立ては無いのかなあ・・・

 とりあえず、画像色取得でやるとすると、高速化するには画像を縮小してピクセル数を減らすしかない

 3の前にイメージを縮小するとして、縮小すると精度が下がる。速度を取るか、精度を取るかの二択・・・でもないけど、妥協点を見いださなきゃならいって話になる。

 これは、縮小率を色々変えて、お試ししてみるしかないね。

#-----------------------------------------------------------
精度=20
精度=精度/100

動体検知モニターとはフォームこれについて
  可視はオン。
  スタイルは「枠固定」
  オフに最大化ボタン有効変更。
  タイトルは「動体検知的な?」
  クライアント幅はCW幅。
  クライアント高さはCW高さ。

表示用とはイメージこれについて
  可視はオン。
  親部品は動体検知モニター。
  幅はCW幅。
  高さはCW高さ。
  位置は「0,0」
表示用を黒色画面クリア。

2
  比較用[回数-1]をイメージとして作成。
  比較用[回数-1]→可視はオフ。
  比較用[回数-1]→位置は「0,0」
  比較用[回数-1]→幅はCW幅。
  比較用[回数-1]→高さはCW高さ。

Tとはタイマーの値はフレームレート。
の時満ちた時は~
  C=C+1。D=0。
  CWハンドルをクリップボードコピー。
  比較用[C%2]→画像は「クリップボード」。
  比較用[C%2]を画像グレイスケール。
  比較用[C%2]をCW幅*精度,CW高さ*精度へ画像高速リサイズ。
  yで0からCW高さ*精度-1まで繰り返す。
    xで0からCW幅*精度-1まで繰り返す。
      比較用[C%2]のx,yから画像色取得。
      P¥(C%2),D=それ/$10000を切り下げ。
      D=D+1。
  表示用の画像は「クリップボード」。
#-----------------------------------------------------------

 精度は、何パーセントまで画像を縮小するかの値となってます。

 うーん、画像色取得を終えて、単にクリップボードの画像を表に転送しているだけなんだけどね~。

 ストレス無く動くと言ったらせいぜい20%・・・(´д`;

 リアルタイム感を出そうと思ったら、10%とか・・・Σ(゜д゜;

 の上、動いたピクセルに点描画かなんかすることを考えたら・・・あああ(ToT)

 点描画より四角の方が早いなんてオチはないよね?(汗)

 いや、どっちにしても、画像色取得が最大のネックなんだから、しようがない


 しかしまー、動いたよ→静止画保存・・・くらいなら、出来そう感があるんで、とりあえずはそれかな;;;

 この場合は、細かい動きは無視して、大きく動くものを侵入者(?!)としてとらえるわけだから、ちっちゃこい画像からの検出でもいけそう(たぶん)

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20170417

2017/04/15 (土)

ステータスをゲットしてみる

| 14:37 | ステータスをゲットしてみる - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - ステータスをゲットしてみる - 雪乃☆雫のなでしこ日和 ステータスをゲットしてみる - 雪乃☆雫のなでしこ日和 のブックマークコメント

 実際に、キャプチャーウィンドウのステータスをゲットしてみる。

 同じようにやれば出来るハズ~・・・なんだけど、なかなかそうは問屋が卸さなかった><;


 さて、CAPSTATUS構造体は、何だかわからんものが多いけど、とりあえず幅と高さしか使う予定無いから、他の部分はコピペしただけ~;

 でもたぶんここは問題ないはず。

#https://msdn.microsoft.com/en-us/library/windows/desktop/dd756939(v=vs.85).aspx
■CAPSTATUS
 ・幅
 ・高さ
 ・fLiveWindow
 ・fOverlayWindow
 ・fScale
 ・ptScroll
 ・fUsingDefaultPalette
 ・fAudioHardware
 ・fCapFileExists
 ・dwCurrentVideoFrame
 ・dwCurrentVideoFramesDropped
 ・dwCurrentWaveSamples
 ・dwCurrentTimeElapsedMS
 ・hPalCurrent
 ・fCapturingNow
 ・dwReturn
 ・wNumVideoAllocated
 ・wNumAudioAllocated

 しかし、まずは早くもPACKエラー発生(´д`;

PACK(CAPSTATUS,S,"UINT,UINT,BOOL,BOOL,BOOL,POINT,BOOL,BOOL,BOOL,DWORD,DWORD,DWORD,DWORD,HPALETTE,BOOL,DWORD,UINT,UINT")

 エラーの内容としては、こんな感じ。

[エラー] 6,ステータスをゲットしてみる.nako.bak(233): 関数UNPACK』の
実行中にエラーが起きました。PACK規則の設定に失敗。構造体の定義エラー
「POINT」は未定義(関数)

 これまた意味も分からずコピペしてきただけだもんね~。

 でも、UINTやらBOOLなどもなでしこで使える型に単純置換してくれるらしいコトだったので、このままで行けるかと思ったのにぃ~。

https://nadesi.com/doc/system/sys-1-DLL-WindowsAPI.htm#head1

 PナントカはPOINTERにとゆうことだったので、

PACK(CAPSTATUS,S,"UINT,UINT,BOOL,BOOL,BOOL,POINTER,BOOL,BOOL,BOOL,DWORD,DWORD,DWORD,DWORD,HPALETTE,BOOL,DWORD,UINT,UINT")

 としてみたら、通ったっぽい。

 次にいよいよ「WM_CAP_GET_STATUS」のメッセージを送信しようとしたところ、またまた、GetWindowRectの時にはなかった問題が発生。

#https://msdn.microsoft.com/en-us/library/windows/desktop/dd743906
!WM_CAP_GET_STATUS=$400+54         # キャプチャウィンドウのステータスを取得します。

 二つ目のパラメーターは、同様に「POINTER(S)」でいいとして・・・

 一つ目のパラメーター「sで参照される構造体のサイズ(バイト単位)」・・・ってなんすかヽ(;´Д`)ノ

 C(?)とかだと「sizeof」なる関数があって取得出来るらしいんだけど・・・ああ、マジックナンバーってそうゆうことか・・・

(だんだんナゾな独り合点が多くなっていきますが、気にしないで!www)

 コレはどうやら、SHORTが2バイトであったり、DWORDやLONGが4バイトであったり、LONGLONGが8バイト・・・的なコトの合計らしい。

 とりあえず・・・大は小を兼ねるのかどうかすら分からんけど、仮に144とか入れてみる。

メッセージ送信(ハンドル,WM_CAP_GET_STATUS,144,POINTER(S))    # Size=バイト単位。S=CAPSTATUS構造体へのポインタ。

 ところが度は、UNPACKのところでエラーが出てしまう。

[エラー] 6,ステータスをゲットしてみる.nako.bak(233): 関数UNPACK』の
実行中にエラーが起きました。PACK変数代入失敗。モジュール 'dnako.dll'
 のアドレス 0228B034 でアドレス 00000000 に対する読み込み違反がおきました。(関数)

 読込違反とか、マジでキライさ! 何言ってんのか分かんないんだもんヽ(;´Д`)ノ

 しかし、「PACK変数代入失敗」とか言ってるので・・・またまた型の指定とかなのか。PACKでは通ったのに、まだダメなんすか。

 だいたい、もの型の意味がわかんないから、9種類のうちのどれに置換されてんのかも分からん;

 もー半ばヤケで、

UNPACK(S,CAPSTATUS,"long,long,long,long,long,long,long,long,long,long,long,long,long,long,long,long,long")

 こんなことしてみたら、なんと動いた! えー;;;

 動いたことだし、このままでもいいかと思ったんだけど(こら;)、いちおういっこいっこ、どれが良くないのか確認してみたら、またもや6番目のPOINTERだった。えええ~??

 やっぱ、ぽいんたぁはキモンなのか。

 鬼門には近づきたくないので、深く追求せず、このようにしておく(爆)

UNPACK(S,CAPSTATUS,"UINT,UINT,BOOL,BOOL,BOOL,long,BOOL,BOOL,BOOL,DWORD,DWORD,DWORD,DWORD,HPALETTE,BOOL,DWORD,UINT,UINT")

 まあ・・・いちおうコレでステータスは取得でき、キャプチャーウィンドウの幅と高さが分かるようになりました。

 ところで、全部LONGで行けるのなら、マジックナンバーは18*4=72で良いのではないかと思ったんだけどダメで、ステータスが0になってしまった。むむむ~;

 地道に1づつ手動で(爆)増やしていってみたところ、76で行けました。

 でっ、とりあえずこんな感じ。

#-----------------------------------------------------------
CWとはCAPSTATUS。
CWハンドルのステータス取得。
#-----------------------------------------------------------
!WM_CAP_GET_STATUS=$400+54         # キャプチャウィンドウのステータスを取得します。
●ステータス取得(ハンドルの)
  PACK(CW,S,"UINT,UINT,BOOL,BOOL,BOOL,POINTER,BOOL,BOOL,BOOL,DWORD,DWORD,DWORD,DWORD,HPALETTE,BOOL,DWORD,UINT,UINT")
  メッセージ送信(ハンドル,WM_CAP_GET_STATUS,76,POINTER(S))    # Size=バイト単位。S=CAPSTATUS構造体へのポインタ。
  UNPACK(S,CW,"UINT,UINT,BOOL,BOOL,BOOL,long,BOOL,BOOL,BOOL,DWORD,DWORD,DWORD,DWORD,HPALETTE,BOOL,DWORD,UINT,UINT")
#-----------------------------------------------------------

 ここまでくれば、あとはそれ母艦に反映してやるだけ。

#-----------------------------------------------------------
*ウィンドウサイズ設定
  CWハンドルのステータス取得。
  母艦のクライアント幅はCWの幅
  母艦のクライアント高さはCWの高さ
  母艦中央移動。
#-----------------------------------------------------------

 起動時と、ビデオ形式のダイアログを開いた後に、ウィンドウサイズ設定してやればOK。

#-----------------------------------------------------------
!WM_CAP_DLG_VIDEOFORMAT=$400+41    # ビデオ形式を選択できるダイアログボックスが表示されます。
●ビデオ形式ダイアログ
  メッセージ送信(CWハンドル,WM_CAP_DLG_VIDEOFORMAT,0,0)
  ウィンドウサイズ設定。
  CWハンドルに0,0,母艦のクライアント幅,母艦のクライアント高さを窓ハンドル位置サイズ設定。
#-----------------------------------------------------------

 ・・・なんかまたまた大事なことを棚上げした気がするけど、ここまで><;

うぇいくうぇいく2017/04/15 21:18念のため。

https://msdn.microsoft.com/ja-jp/library/8kk2sy33.aspx
(型名まで日本語に訳されてしまっているのは誤訳。)

POINTは、構造体を用いた型で、2つのlongにより座標を折らわすのに使われます。
(RECTが四角を表す構造体を用いた型)

ポインターなら、LPRECTや、LPPOINTのように、元の型名の前にLPを付けた型名になっているはずです。
(LPはlong pointerの略。たぶん。)

雪乃☆雫雪乃☆雫2017/04/16 00:21うぇいくさま、ありがとうございます~!!
POINTとPOINTERは違ったんですね(^▽^;
おおぉ、そして、おかげさまでナゾが一つ解明しました。
なんで72じゃなく76になるのかさっぱり分からんと思っていたのですが、longが二つ分だったのですね!
それにしても、構造体の中にまたこーぞーたい・・・あああ(@_@)

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20170415