Hatena::Groupnadesiko

雪乃☆雫のなでしこ日和

2009-04-04

サイコロといえばギャンブルだよ?!

| 14:44

 昨日はとうとう日付が変わってしまって、に合わなかった・・・

 って思っていたら、なんとはてなは日付変更時刻が自分で設定できて、の初期値はAM6:00になってたらしい。すばらしい!

 というわけで、毎日連載継続中~。


 さて、サイコロです。

 とりあえず、マニュアルの文体模写風味で。

 自分が行き詰ってきたら、たちどころに崩れると思いますが;


【せんせい】

 当たり外れの判定だけじゃ、ちょっとつまらないよね?

 以下のように改良してみましたよ。

 どこが変わったか、分かるかな?

#-------------------------------------------------------------
#数当てゲーム
所持金とは整数。所持金=5
賭け金とは整数。賭け金=0
配当とは整数。配当=2
所持金>0の
  R=6の乱数+1
  「いくら賭ける?(1~{所持金})」と尋ねる。
    賭け金=それ
    「1~6のど~れだ?」と尋ねるもし(R=それならば
      所持金=所持金+賭け金*配当
    「当たり!{改行}所持金が{所持金}に増えました」と言う
    違えば
      所持金=所持金-賭け金
    「ハズレ。答えは{R}でした。{改行}所持金が{所持金}に減りました」と言う
    ここまで
「破産しました」と言う。
終わり。
#-------------------------------------------------------------

【でし】

 えっと・・・掛け金とか、配当とか、めちゃくちゃギャンブルっぽいんですけど。

【せんせい】

 のとおり! これは『ちょぼいち』という古典的なサイコロ賭博の基本形です。もちろん、実際にお金をやり取りするわけじゃないから、つかまる心配はありませんよ。

 「」命令で、所持金が残っている中ゲームを続け、当たれば賭けたお金が二に! もちろん外れれば没収です。賭け事となると、燃えてきませんか?

【でし】

 所持金が0になったら破産してゲームオーバーなんですね。ていうか、ゲームオーバーするまでこのゲーム、やめられないんですけど。

【せんせい】

 それは、仕様ですので、スルーしてください(汗)

 のために、所持金も配当も低くしてあります(笑)

 所持金全額をかけ続ければ、わりとすぐに終われると思いますが、どうしてもという場合はエディタから強制終了して。

 実はこのゲーム、ゲーム的にもっと大きな問題がありました。

 実は、所持金外の金額も賭けることができちゃうんですよ。

 たとえば、いくら賭ける?に100と答えて当てれば、なんとあっというに所持金が205に!

【でし】

 おぉ!

【せんせい】

 もちろん外せば、借金95ですけど、借金があってもなくても破産して終了に変わりないですからね。

 というわけで、以下のようにさらに改良してみましたよ。

#-------------------------------------------------------------
#数当てゲーム
所持金とは整数。所持金=5
賭け金とは整数。賭け金=0
配当とは整数。配当=2
所持金>0の
  R=6の乱数+1
  賭ける


*賭ける
  「いくら賭ける?(1~{所持金})」と尋ねる。
  賭け金=それ
  もし、(それ<1)または(それ)または(それ>所持金)ならば
    賭ける。
  違えば
    答える
*答える
    「1~6のど~れだ?」と尋ねるもし、(それ<1)または(それ)または(それ>6)ならば
      答える
    もし(R=それならば
      所持金=所持金+賭け金*配当
    「当たり!{改行}所持金が{所持金}に増えました」と言う
    違えば
      所持金=所持金-賭け金
    「ハズレ。答えは{R}でした。{改行}所持金が{所持金}に減りました」と言う
  ここまで
「破産しました」と言う。
終わり。
#-------------------------------------------------------------

【でし】

 ユーザー定義関数ですね!

【せんせい】

 サブルーチンのラベルとしてしか使ったことが無いですけれどね(汗)

 とにかくこれで、賭け金は1~所持金の範囲内、当てるときもサイコロの1~6の範囲内しか受け付けなくなりました。よかったよかった。

【でし】でも、やっぱり文字だけじゃ物足りない。ゲームであるからには、かっこいい絵を表示しなくては!!(笑)


【せんせい】

 というわけで次は、サイコロを画面に表示させることに挑戦です。

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090404