Hatena::Groupnadesiko

雪乃☆雫のなでしこ日和

2009-04-25

○×を表示するよ!

| 21:07

【せんせい】

 昨日、さりげなくスルーした、まで何問正解して何問不正解なのかを表示する部分です。

 同じ書式で「正解何問、不正解何問」と文字表示するのはたやすいのですが、ちょっと趣向を変えて○×で表示していくことにしてみましょう。

#------------------------------------------------------------
*マウス判定
  もし、マウス待ち=「オンならば
    母艦のマウス押した時は
      数を0から3まで繰り返す
        もし、(母艦のマウスX>選択板x)かつ
        (母艦のマウスY>選択板y+(選択板高さ+選択板隔)*数)かつ
        (母艦のマウスX<選択板x+選択板幅)かつ
        (母艦のマウスY<選択板y+選択板高さ+(選択板高さ+選択板隔)*数)ならば
          もし、選択肢¥数が答えならば
            得点=得点+残り。
            総合得点=総合得点+残り。
            タイマー停止。
            ノルマ=ノルマ-1
            得点描画
            正解数=正解数+1
            当たりで正誤表示。
            「当たり」と言う。
            問題設定
          違えば
            タイマー停止。
            外れで正誤表示。
            「ハズレ。答えは{答え}」と言う。
            問題設定

  違えば
    母艦のマウス押した時は
      戻る
#-----正誤表示-----------------------------------------------
*正誤表示(sで)
  x=440+35*((番号-1)%5)。y=135+35*((番号-1)/5を切り下げ)
  もし、s=当たりならば
    文字書体は「MS ゴシック」。文字サイズは18。文字色は$FF0000。
    表画面のx,yへ「○」を文字描画。
  違えばもし、s=外れならば
    文字書体は「MS ゴシック」。文字サイズは24。文字色は$0000FF。
    表画面のx-5,y-5へ「×」を文字描画。
  違えばもし、s=消去ならば
    塗り色は$FFFFEE。線色は$FFFFEE。線太さは0。
    表画面の435,130から615,130+35*(問題数/5を切り下げ)へ四角。
  表画面の435,130,180,70を母艦の435,130へ画像部分コピー。
  描画処理反映

#------------------------------------------------------------

【でし】

 おぉ~、ぱちぱちぱち~。

 しかし、これで1科目10問以内という縛りが出来てしまいました(笑)

【せんせい】

 そうなんです;

 でもどうせ、んな山ほど問題考えるつもりもないし。

 さて、関数引数についてのおさらいです。

 以前、文字遅延描画の対策用の命令を作ったときには、さりげなく文字遅延描画引数をコピペして対応する変数を合わせたら動いたので、大体は分かった気でいたわけですが、最近ようやく引数ってものについてひらめいた気がするので、早速使ってみましたよ!

【でし】

 引数とは(sで)てヤツですね。

【せんせい】

 正確には「s」が引数で、「で」は引数関数に指定してやるための助詞ですね。関数の後ろに()で括って指定してやります。・・・なんてあたりはまあ、大体分かっていたのですが、実際自分で使ってみると、おぉ!っていう感じですね(笑)

 別にフラグを立てても大ないような内容ですが、ちょっとレベルアップした気分~♪

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090425