Hatena::Groupnadesiko

雪乃☆雫のなでしこ日和

2016/02/27 (土)

ちょぼいち2016

| 23:07 | ちょぼいち2016 - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - ちょぼいち2016 - 雪乃☆雫のなでしこ日和 ちょぼいち2016 - 雪乃☆雫のなでしこ日和 のブックマークコメント

 サイコロはまあ、こんなもんでしょ。

 これだけ色々やっても、ゲーム内容自体は、マニュアルの「数当てゲーム」と全く変わらないっていうね(爆)

 でも、これが意外と何度も遊んでしまうんだよ~www

#-----------------------------------------------------------------------
#   ちょぼいち2016
#-----------------------------------------------------------------------

#-----母艦設計-----------------------------------------------
!母艦設計=「母艦の可視はオフ母艦のタイトルは「ちょぼいち」
母艦のクライアント幅は640。母艦のクライアント高さは480。
母艦を$FFDDAAで画面クリア母艦のスタイルは「枠固定」
母艦オフに最大化ボタン有効変更。
母艦中央移動

『#親部品名,部品名,テキスト,ショートカット,オプション,イベント
なし,ファイルメニュー,ファイル(&F),,,
 -,新規メニュー,新しいゲーム(&N),Ctrl+N,,新規ゲーム
 -,-,,,,
 -,メッセージメニュー,メッセージ速度(&S),Ctrl+S,,
 --,速度1,早い(&1),,,メッセージ早い。
 --,速度2,普通(&2),,,メッセージ普通。
 --,速度3,遅い(&3),,,メッセージ遅い。
 -,-,,,,
 -,閉じるメニュー,閉じる(&X),Ctrl+X,,終わる
なし,ヘルプメニュー,ヘルプ(&H),,,
 -,ルールメニュー,ちょぼいちについて(&R),Ctrl+R,,遊び方
 -,-,,,,
 -,バージョンメニュー,バージョン情報(&A),Ctrl+A,,バージョン
』をメニュー一括作成。

*メッセージ早い
	メッセージ速度=0
	速度1のチェックオン。速度2のチェックオフ。速度3のチェックオフ。

*メッセージ普通
	メッセージ速度=30
	速度1のチェックオフ。速度2のチェックオン。速度3のチェックオフ。

*メッセージ遅い
	メッセージ速度=100
	速度1のチェックオフ。速度2のチェックオフ。速度3のチェックオン。
#------------------------------------------------------------

#-----宣言---------------------------------------------------
ダイスサイズとは整数=100
半径とは整数=10

元手とは整数=1000
標準賭け金=100
一口とは整数=10
所持金とは整数=元手
賭け金とは整数=0
配当とは整数=5
予想とは整数。

賭場サイズとは整数=300
板サイズとは整数=70
左マージンとは整数=15
上マージンとは整数=15
テキストウィンドウ幅=500
テキストウィンドウ高さ=120
メッセージ速度=30。
速度2のチェックオンボタンフラグとは整数=0	#0=賭ける/待った 1=やる/やめる	2=再戦/終了
マウス待ちとは整数オン
出目とは整数。

裏画面とはイメージの可視はオフのWはダイスサイズ*6。のHはダイスサイズ+板サイズ*2。

処理用とはイメージの可視はオフ。

#---サイコロ振るところ----
賭場とはイメージの可視はオフのWは賭場サイズ。のHは賭場サイズ。
賭場を$775533で画面クリア。

#---胴元がしゃべるところ----
テキストウィンドウとはイメージの可視はオフのWはテキストウィンドウ幅。のHはテキストウィンドウ高さ。
テキストウィンドウを$222222で画面クリア。

#---所持金表示----
文字書体は「MS 明朝|24|標準」。
母艦の左マージン+賭場サイズ+40,上マージン+50+板サイズ*2へ「所持金:」を文字描画母艦の左マージン+賭場サイズ+160,上マージン+50+板サイズ*2,80,33へ「{所持金}」を右,下で枠内文字描画母艦の左マージン+賭場サイズ+250,上マージン+50+板サイズ*2へ「文」を文字描画。

#---賭け金表示----
文字書体は「MS 明朝|24|標準」。
母艦の左マージン+賭場サイズ+40,上マージン+100+板サイズ*2へ「賭け金:」を文字描画母艦の左マージン+賭場サイズ+160,上マージン+100+板サイズ*2,80,33へ「{賭け金}」を右,下で枠内文字描画母艦の左マージン+賭場サイズ+250,上マージン+100+板サイズ*2へ「文」を文字描画。

#---勝負ボタン----
勝負ボタンとはボタンのテキストは「勝負!」
のXは左マージン*2+テキストウィンドウ幅。のYは上マージン*2+賭場サイズ+テキストウィンドウ高さ-80。
のWは100。のHは35。
文字書体は「MS 明朝|18|標準」。
の有効はオフ。

#---待ったボタン----
待ったボタンとはボタンのテキストは「待った」
のXは左マージン*2+テキストウィンドウ幅。のYは上マージン*2+賭場サイズ+テキストウィンドウ高さ-35。
のWは100。のHは35。
文字書体は「MS 明朝|18|標準」。
の有効はオフ。

#---お金を賭けるところ----
賭け板とはイメージの可視はオフのWは板サイズ*2。のHは板サイズ*6

賭け板設定とは配列。 #0ボタン表示位置X、1ボタン表示位置Y、2ボタン幅、ボタン高さ
6
  賭け板設定¥回数,0は左マージン+賭場サイズ+60+(板サイズ*((回数-1)%3))。
  賭け板設定¥回数,1は上マージン+20+(板サイズ*((回数-1)/3を切り下げ))
  賭け板設定¥回数,2は板サイズ
  賭け板設定¥回数,3は板サイズ

#---お金を賭ける窓----
賭け窓とはフォーム。賭け窓をウィンドウ背景色画面クリアの幅は240。の高さは180。
のXは母艦のX+(母艦の幅-賭け窓の幅)/2。のYは母艦のY+(母艦の高さ-賭け窓の高さ)/2。
のスタイルは「枠固定」
賭け窓はオフにシステムメニューボタン有効変更。

金額スピンとはエディタの親部品は賭け窓。
のXは50。のYは60。の幅は120。の高さは30。
文字サイズは22。
金額スピンの変更した時は~
	もし、金額スピンのテキスト>所持金ならば
		金額スピンのテキスト=所持金
	違えばもし、金額スピンのテキスト<1ならば
		金額スピンのテキスト=1
	違えば
		金額スピンのテキスト=金額スピンのテキスト
		
プラスボタンとはボタンの親部品は金額スピン。
のXは103。プラスボタンのYは0。の幅は13。の高さは17。
文字書体は「MS 明朝|6|標準」。のテキストは「▲」
プラスボタンのマウス押した時は~
	もし、プラスボタンの押されたボタン=左ならば
		m=0。n=0。
		金額プラス
プラスボタンのマウス離した時は~
	m=1

*金額プラス
	もしm=0ならば
		金額スピンのテキスト=金額スピンのテキスト+一口
		もし、n=0ならば
			0.5秒待つ。n=1。
		0.1秒待つ
		金額プラス

マイナスボタンとはボタンの親部品は金額スピン。
のXは103。のYは16。の幅は13。の高さは17。
文字書体は「MS 明朝|6|標準」。のテキストは「▼」
マイナスボタンのマウス押した時は~
	もし、マイナスボタンの押されたボタン=左ならば
		m=0。n=0。
		金額マイナス
マイナスボタンのマウス離した時は~
	m=1

*金額マイナス
	もしm=0ならば
		金額スピンのテキスト=金額スピンのテキスト-一口
		もし、n=0ならば
			0.5秒待つ。n=1。
		0.1秒待つ
		金額マイナス

OKボタンとはボタンの親部品は賭け窓。
のXは30。のYは120。
文字書体は「MS 明朝|10|標準」。のテキストは「OK」
OKボタンのクリックした時は~
  掛け金=金額スピンのテキスト。
  所持金=所持金-掛け金。
  塗り色は$FFDDAA。線色は$FFDDAA。線太さは0。
  賭け窓をウィンドウ背景色画面クリア。
  賭け窓の可視はオフ。賭け窓を閉じる。
  所持金表示。
  「2」で胴元セリフ。

キャンセルボタンとはボタンの親部品は賭け窓。
のXは130。のYは120。
文字書体は「MS 明朝|10|標準」。のテキストは「キャンセルキャンセルボタンのクリックした時は~
  賭け窓をウィンドウ背景色画面クリア。
  賭け窓を閉じる
  「0」で胴元セリフ。
#------------------------------------------------------------

#-----マウス入力待ち-------------------------------------------
母艦マウス移動した時は~
  もし、マウス待ち=オンならば
    賭け板の賭け板設定を母艦へマウスインアウト反映。
  違えば
    戻る母艦のマウス押した時は~
  もし、マウス待ち=オンならば
    もし母艦の押されたボタン=左ならば
      もし、前選択ボタン=0でなければ
        もし、前選択ボタン=1ならば
          予想=3
        違えばもし、前選択ボタン=3ならば
          予想=1
        違えば、
          予想=前選択ボタン
        賭ける
    違えば
      戻る
  違えば
    戻る

勝負ボタンのクリックした時は~
  マウス待ち=オフ。
 	勝負ボタンの有効はオフ。
 	待ったボタンの有効はオフもしボタンフラグ=0ならば
  	サイコロ振る。
  	勝ち負け判定。
  違えばもしボタンフラグ=1ならば
   	賭場を母艦の左マージン,上マージンへ画像コピー。
   	賭け板の賭け板設定を母艦へマウスインアウト反映。
   	もし、所持金≦0ならば
			「破産」で胴元セリフ。
			文字色白色文字書体は「MS 明朝|20|太字」。
  		母艦の左マージン,上マージン,左マージン+賭場サイズ,賭場サイズへ「{元手-所持金}文すりました」を中央,中央で枠内文字描画
			ボタンフラグ=2
			勝負ボタンのテキストは「再戦」
			待ったボタンのテキストは「終了違えば
	  	「1」で胴元セリフ。 
	  	ボタンフラグ=0	
			勝負ボタンのテキストは「勝負!」
			待ったボタンのテキストは「待った」
  違えばもしボタンフラグ=2ならば
		新規ゲーム。

待ったボタンのクリックした時は~
	もしボタンフラグ=0ならば
	  所持金=所持金+掛け金。
  	掛け金=0。
  	所持金表示。
	 	勝負ボタンの有効はオフ。
 		待ったボタンの有効はオフ。
  	「1」で胴元セリフ。
  違えばもしボタンフラグ=1ならば
   	賭場を母艦の左マージン,上マージンへ画像コピー。
   	賭け板の賭け板設定を母艦へマウスインアウト反映。
		文字色白色文字書体は「MS 明朝|20|太字」。
  	もし、所持金>元手ならば
  		母艦の左マージン,上マージン,左マージン+賭場サイズ,賭場サイズへ「{所持金-元手}文もうかった!」を中央,中央で枠内文字描画
			「勝ち逃げ」で胴元セリフ。
		違えばもし、所持金=元手ならば
  		母艦の左マージン,上マージン,左マージン+賭場サイズ,賭場サイズへ「勝ち負け無しです」を中央,中央で枠内文字描画
			「賢明」で胴元セリフ。		
		違えば
  		母艦の左マージン,上マージン,左マージン+賭場サイズ,賭場サイズへ「{元手-所持金}文損しました」を中央,中央で枠内文字描画
			「賢明」で胴元セリフ。
		勝負ボタンの可視はオフ。
		待ったボタンのテキストは「終了ボタンフラグ=2
  違えばもしボタンフラグ=2ならば
		終わる。
#------------------------------------------------------------

#-----メインルーチン-----------------------------------------
母艦の可視はオン。

サイコロ準備
ゲーム画面準備
新規ゲーム
#------------------------------------------------------------
*新規ゲーム
	乱数初期化。
	所持金=元手。
	掛け金=0。
	所持金表示ボタンフラグ=0
 	賭場を母艦の左マージン,上マージンへ画像コピー。
 	賭け板の賭け板設定を母艦へマウスインアウト反映。
 	勝負ボタンの可視はオン。
 	勝負ボタンの有効はオフ。
	待ったボタンの有効はオフ。
	勝負ボタンのテキストは「勝負!」
	待ったボタンのテキストは「待った」
  「1」で胴元セリフ。
#------------------------------------------------------------
*賭ける
  金額スピンのテキストは標準賭け金。
  文字色ウィンドウ文字色文字書体は「MS 明朝|16|標準」
  賭け窓の30,20へ「{予想} の目に賭けるよ!」を文字描画。
  賭け窓をモーダル表示。
#------------------------------------------------------------
*所持金表示
  文字書体は「MS 明朝|24|標準」。文字色は黒。塗り色は$FFDDAA。線色は$FFDDAA。
  母艦の左マージン+賭場サイズ+160,上マージン+50+板サイズ*2から左マージン+賭場サイズ+160+80,上マージン+50+板サイズ*2+33へ四角。
  母艦の左マージン+賭場サイズ+160,上マージン+50+板サイズ*2,80,33へ「{所持金}」を右,下で枠内文字描画。

  母艦の左マージン+賭場サイズ+160,上マージン+100+板サイズ*2から左マージン+賭場サイズ+160+80,上マージン+100+板サイズ*2+33へ四角。
  母艦の左マージン+賭場サイズ+160,上マージン+100+板サイズ*2,80,33へ「{掛け金}」を右,下で枠内文字描画。
#------------------------------------------------------------
*サイコロ振る
    r=6の乱数。出目=r+1。
    x=r*ダイスサイズ。y=0。
    
    処理用をダイスサイズ,ダイスサイズへ画像高速リサイズ。
    裏画面のx,y,ダイスサイズ,ダイスサイズを処理用の0,0へ画像部分コピー。
    処理用を母艦の左マージン+(賭場サイズ/2-ダイスサイズ/2),上マージン+(賭場サイズ/2-ダイスサイズ/2)へ画像合成改。
#------------------------------------------------------------
*勝ち負け判定
  もし、出目=予想ならば
		ボタンフラグ=1
		文字色白色文字書体は「MS 明朝|32|太字」。
		母艦の101,51へ「当たり」を文字描画文字色赤色母艦の100,50へ「当たり」を文字描画。
		「当たり」で胴元セリフ。
    所持金=所持金+掛け金*配当。

  違えば
		ボタンフラグ=1
		文字色白色文字書体は「MS 明朝|32|太字」。
		母艦の101,51へ「はずれ」を文字描画文字色青色母艦の100,50へ「はずれ」を文字描画。

		「外れ」で胴元セリフ。
	勝負ボタンのテキストは「やる」
	待ったボタンのテキストは「やめる」
 	掛け金=0。
  所持金表示。
#------------------------------------------------------------
*胴元セリフ(Sで)
  テキストウィンドウを母艦の左マージン,上マージン+賭場サイズ+10へ画像コピー。
  文字色白色文字書体は「MS 明朝|16|標準」。
  母艦の左マージン+10,上マージン+賭場サイズ+20へ「【胴元】」を文字描画。
  もし、S=「0」ならば
    母艦の左マージン+30,上マージン+賭場サイズ+50へ「さあ、張った張った!」をメッセージ速度で文字遅延描画

  もし、S=「1」ならば
    母艦の左マージン+30,上マージン+賭場サイズ+50へ「どの目にいくら張るんだい?」をメッセージ速度で文字遅延描画
    マウス待ち=オン。

  もし、S=「2」ならば
    母艦の左マージン+30,上マージン+賭場サイズ+50へ「{予想}に{掛け金}文だな?」をメッセージ速度で文字遅延描画
    母艦の左マージン+30,上マージン+賭場サイズ+75へ「良ければ勝負だ!」をメッセージ速度で文字遅延描画
    勝負ボタンの有効はオン。
    待ったボタンの有効はオン。
    マウス待ち=オフ。
  
  もし、S=「外れ」ならば
    母艦の左マージン+30,上マージン+賭場サイズ+50へ「外れだな。」をメッセージ速度で文字遅延描画 
    母艦の左マージン+30,上マージン+賭場サイズ+75へ「掛け金は没収だ。」をメッセージ速度で文字遅延描画
    母艦の左マージン+30,上マージン+賭場サイズ+100へ「まだ続けるかい?」をメッセージ速度で文字遅延描画
		勝負ボタンの有効はオン
		待ったボタンの有効はオン
    マウス待ち=オフ。
  
  もし、S=「当たり」ならば
    母艦の左マージン+30,上マージン+賭場サイズ+50へ「おめでとう。大当たりだ。」をメッセージ速度で文字遅延描画 
    母艦の左マージン+30,上マージン+賭場サイズ+75へ「配当を払うぜ。」をメッセージ速度で文字遅延描画
    母艦の左マージン+30,上マージン+賭場サイズ+100へ「まだ続けるかい?」をメッセージ速度で文字遅延描画
		勝負ボタンの有効はオン
		待ったボタンの有効はオン
    マウス待ち=オフ。
  
  もし、S=「破産」ならば
    母艦の左マージン+30,上マージン+賭場サイズ+50へ「おやおや、すってんてんじゃねえか。」をメッセージ速度で文字遅延描画 
    母艦の左マージン+30,上マージン+賭場サイズ+75へ「いいカモっぷりだったぜ。」をメッセージ速度で文字遅延描画
    母艦の左マージン+30,上マージン+賭場サイズ+100へ「懲りずにまた遊んでくれよ?」をメッセージ速度で文字遅延描画
		勝負ボタンの有効はオン
		待ったボタンの有効はオン

	もし、S=「勝ち逃げ」ならば
    母艦の左マージン+30,上マージン+賭場サイズ+50へ「おいおい、勝ち逃げかよ。」をメッセージ速度で文字遅延描画 

	もし、S=「賢明」ならば
    母艦の左マージン+30,上マージン+賭場サイズ+50へ「まあ、賢明だな。」をメッセージ速度で文字遅延描画 
    母艦の左マージン+30,上マージン+賭場サイズ+75へ「のうち、また遊んでくれ。」をメッセージ速度で文字遅延描画
#------------------------------------------------------------
*ゲーム画面準備

  #---お金を賭けるところ----
  処理用を板サイズ,板サイズ*6へ画像高速リサイズ。
  数を0から5まで繰り返す
    塗り色は$DDAA00。線太さは0。
    x=0
    y=数*板サイズ
    処理用のx,yからx+板サイズ,y+板サイズへ四角
    数で条件分岐
      0ならば
        板数=「三」
      1ならば
        板数=「二」
      2ならば
        板数=「一」
      3ならば
        板数=「四」
      4ならば
        板数=「五」
      5ならば
        板数=「六」
    文字サイズは42。文字色は$000000。文字書体は「MS 明朝」
    処理用のx+5,y+5へ板数を文字描画。

  処理用を賭け板の0,0へ画像コピー。
  処理用を画像ネガポジ。
  処理用を賭け板の板サイズ,0へ画像コピー。
  
  賭場を母艦の左マージン,上マージンへ画像コピー。
  テキストウィンドウを母艦の左マージン,上マージン*2+賭場サイズへ画像コピー。
  賭け板の0,0を賭け板設定で母艦へマウスオーバーボタン表示。
#------------------------------------------------------------
*サイコロ準備
  裏画面を$000000で画面クリア。
    数を0から5まで繰り返す。
    もし、数=0ならば                #1のサイコロ
      線色は$000001。塗り色は$FFFFFF        #地の色は白
      外枠。                    #ダイスの外枠
      線色は$FF0000。塗り色は$FF0000        #目の色は赤
      半径=15。                 #大き目
      中点。
    
    もし、数=1ならば                #2のサイコロ
      線色は$000001。塗り色は$FFFFFF
      外枠。
      線色は$000001。塗り色は$000001
      半径=10。
      左上点。右下点。
    
    もし、数=2ならば                #3のサイコロ
      線色は$000001。塗り色は$FFFFFF
      外枠。
      線色は$000001。塗り色は$000001
      半径=10。
      中点。左上点。右下点。
    
    もし、数=3ならば                #4のサイコロ
      線色は$000001。塗り色は$FFFFFF
      外枠。
      線色は$000001。塗り色は$000001
      半径=10。
      左上点。左下点。右上点。右下点。
    
    もし、数=4ならば                #5のサイコロ
      線色は$000001。塗り色は$FFFFFF
      外枠。
      線色は$000001。塗り色は$000001
      半径=10。
      中点。左上点。左下点。右上点。右下点。
    
    もし、数=5ならば                #6のサイコロ
      線色は$000001。塗り色は$FFFFFF
      外枠。
      線色は$000001。塗り色は$000001
      半径=9。
      左上点。左下点。右上点。右下点。左中点。右中点。

*外枠
  x=数*ダイスサイズ。y=0。
  x2=x+ダイスサイズ。y2=ダイスサイズ。
  裏画面のx,yからx2,y2へ30,30で角丸四角。

*中点
  xx=(x+ダイスサイズ/2)-半径。yy=ダイスサイズ/2-半径
  xx2=(x+ダイスサイズ/2)+半径。yy2=ダイスサイズ/2+半径。
  裏画面のxx,yyからxx2,yy2へ。

*左上点
  xx=(x+ダイスサイズ/4)-半径。yy=ダイスサイズ/4-半径
  xx2=(x+ダイスサイズ/4)+半径。yy2=ダイスサイズ/4+半径。
  裏画面のxx,yyからxx2,yy2へ。

*左下点
  xx=(x+ダイスサイズ/4)-半径。yy=(ダイスサイズ/4)*3-半径
  xx2=(x+ダイスサイズ/4)+半径。yy2=(ダイスサイズ/4)*3+半径。
  裏画面のxx,yyからxx2,yy2へ。

*右上点
  xx=(x+ダイスサイズ/4*3)-半径。yy=ダイスサイズ/4-半径
  xx2=(x+ダイスサイズ/4*3)+半径。yy2=ダイスサイズ/4+半径。
  裏画面のxx,yyからxx2,yy2へ。

*右下点
  xx=(x+ダイスサイズ/4*3)-半径。yy=(ダイスサイズ/4)*3-半径
  xx2=(x+ダイスサイズ/4*3)+半径。yy2=(ダイスサイズ/4)*3+半径。
  裏画面のxx,yyからxx2,yy2へ。

*左中点
  xx=(x+ダイスサイズ/4)-半径。yy=ダイスサイズ/2-半径
  xx2=(x+ダイスサイズ/4)+半径。yy2=ダイスサイズ/2+半径。
  裏画面のxx,yyからxx2,yy2へ。

*右中点
  xx=(x+ダイスサイズ/4*3)-半径。yy=ダイスサイズ/2-半径
  xx2=(x+ダイスサイズ/4*3)+半径。yy2=ダイスサイズ/2+半径。
  裏画面のxx,yyからxx2,yy2へ。
#------------------------------------------------------------
*遊び方
	ダイアログタイトルは「ちょぼいちについて」
	「【ちょぼいちのルール】
	さいころ1個を振り、出目に賭ける賭博。
	賭け者は1から6の好きな目に賭け、
	当たれば4~5の配当が払われるが、
	外れれば親に賭け金全額没収される。」を言う。
#------------------------------------------------------------
*バージョン
  ダイアログタイトルは「バージョン情報」
  「{二重カッコ}ちょぼいち{二重カッコ閉じ}{改行} Version 1.91{改行}{改行} by 雪乃☆雫」と言う。
#------------------------------------------------------------

#------------------------------------------------------------
●枠内文字描画({グループ=?}OBJのX,Y,W,HへSをA,Vで)
  xxとは整数。yyとは整数。
  もし、A=左ならば
    xx=X
  違えばもし、A=中央ならば
    xx=X+(W-(Sの文字幅取得))/2
  違えばもし、A=右ならば
    xx=(X+W)-(Sの文字幅取得)
  もし、V=上ならば
    yy=Y
  違えばもし、V=中央ならば
    yy=Y+(H-(Sの文字高さ取得))/2
  違えばもし、V=下ならば
    yy=(Y+H)-(Sの文字高さ取得)
  OBJのxx,yyへSを文字描画。
#------------------------------------------------------------
●画像合成改({グループ}Sを{グループ}DのX,Yへ)
 Cとは整数
//マスク画像はSの透過色を黒色それ以外を白色にしたもの
 マスク画像をイメージとして作成
 マスク画像→可視はオフ
 マスク画像→画像はS→名前
 マスク画像の0,0を画像色取得してCに代入
 マスク画像をCで画像マスク作成
//ソース画像はSの透明色を黒色に変換したもの
 ソース画像をイメージとして作成
 ソース画像→可視はオフ
 ソース画像→画像はS→名前
 マスク画像を画像ネガポジ
 マスク画像をソース画像の0,0へ画像ANDコピー
 マスク画像を画像ネガポジ
//合成実行
 マスク画像をDのX,Yへ画像ANDコピー
 ソース画像をDのX,Yへ画像ORコピー
 VCL_FREE(マスク画像)
 VCL_FREE(ソース画像)
// マスク画像→壊す
// ソース画像→壊す
#------------------------------------------------------------
●マウスオーバーボタン表示({グループ=?}OBJ1のX,YをAで{グループ=?}OBJ2へ)
  A\0,0=X。A\0,1=Y
  (Aの要素数-1)
    OBJ1のX,Y+(回数-1)*(A¥回数,3),(A¥回数,2),(A¥回数,3)をOBJ2の(A¥回数,0),(A¥回数,1)へ画像部分コピー。

●マウスインアウト反映({グループ=?}OBJ1のAを{グループ=?}OBJ2へ)
  (Aの要素数-1)
    もし、((OBJ2→マウスX)>(A¥回数,0))かつ
      ((OBJ2→マウスX)<(A¥回数,0)+(A¥回数,2))かつ
      ((OBJ2→マウスY)>(A¥回数,1))かつ
      ((OBJ2→マウスY)<(A¥回数,1)+(A¥回数,3))ならば
        選択ボタン回数。
    違えばもし、(回数=Aの要素数)かつ(選択ボタン=0)ならば
      選択ボタンは0。
    ここまで

  もし、前選択ボタン<>選択ボタンならば
    もし、前選択ボタン>0ならば
      OBJ1の(A\0,0),(A\0,1)+(前選択ボタン-1)*(A¥(前選択ボタン),3),(A¥(前選択ボタン),2),(A¥(前選択ボタン),3)をOBJ2の(A¥(前選択ボタン),0),(A¥(前選択ボタン),1)へ画像部分コピー。
    もし、選択ボタン>0ならば
      OBJ1の(A\0,0)+(A¥(選択ボタン),2),(A\0,1)+(選択ボタン-1)*(A¥(選択ボタン),3),(A¥(選択ボタン),2),(A¥(選択ボタン),3)をOBJ2の(A¥(選択ボタン),0),(A¥(選択ボタン),1)へ画像部分コピー。
  前選択ボタン=選択ボタン
  選択ボタン=0
  描画処理反映
#------------------------------------------------------------

chocochoco2016/02/29 22:47こんにちは、すげー長いプログラム、気合いですね。
でも、これだけのプログラム書けるってうらやましいです。
仕事ではバッチ的に良く使ってますが、趣味では最近書けなくなって来ました( ̄ー ̄)

雫さんに負けないように頑張ろう。
雫さんのわかりやすいコード、いろいろと参考にさせて頂きます。

仕事帰りで、全然まとまりの無い文章ですが。。。

雪乃☆雫雪乃☆雫2016/03/01 12:26>chocoさま、こんにちは☆
 長い長い間放置で、ものすごくさりげなくこっそりと再開したというのに、また見て下さっていたなんて感激です!

 コード、わかりやすいかな?(恥)
 だったらうれしいけど、自分的にはぐちゃぐちゃな気分で、それはもう、ナデシコさまのおかげ~♪
 プログラムも、長いっていっても、サイコロの絵を描くのや胴元がしゃべるのに、無駄に行数使ってるだけで、内容的には全然大したヤツじゃないです(汗)

 以前のような気合いはないので、時間を掛けてゆるゆる遊んでますけど、またよろしくおつきあいくださいませ☆

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20160227