Hatena::Groupnadesiko

雪乃☆雫のなでしこ日和

2016-05-30

石をキーボードで左右に移動

| 18:06

 石を固定するところまでと思っていたけど・・・あれれ~?! なんだか上手くいかなくなっちゃった~(?_?)

 固定した石を表画面に反映するのにも、画像合成通を使っていたんだった。

 画像コピーでなんとかしようと書き換えてみたら、石が固定された途端、メイン画面が大変なことにΣ(゜д゜;


 とゆーわけで、途中経過。

 とりあえず左右に移動転、落下まで。

 一応、左右キーは押し続けた時には一気に動くけど、連打した時には一マスずつ動くようにウェイトをかけたり、落下ボタンは離せば落下が止まったり、ボタンは押し続けてもぐるぐる転し続けないようにしているのがこだわりポイントです。

 ・・・てゆうかキーボードなのかよ。

 ジョイパッドはどうしたw


 移動判定は、壁と床だけ;;;

 壁と床はマス目で判定。

 他の石は、固定石配列の内容を参照して判定・・・出来る予定だけど、石の固定ができるようになるまでコメントアウトしておく。

 20とゆうのは仮の数値だけど、キー処理がスムーズに動くようにするためのもの。

#-----------------------------------------------------------------------
*落下処理
  20
    キー処理
    落下用をメイン合成用の落下X,落下Yへ画像コピー。
    メイン合成用を表画面のメインX,メインYへ画像コピー
    メイン画面をメイン合成用の0,0へ画像コピー。
    # 落下キーを押していない時のウェイト
    もし、落下フラグがオンでなければ、
      0.05秒待つ。
    # 左右キーは押し続けた時は一気に動くが、連打した時は一マスごと動くようにする。
    もし、(左移動中=オン)かつ(左キー押下状態=オフならば、
      左キー押下状態=オン。
      0.1秒待つ。
    もし、(右移動中=オン)かつ(右キー押下状態=オフならば、
      右キー押下状態=オン。
      0.1秒待つ。

  落下Y=落下Y+マス目
  移動判定
#-----------------------------------------------------------------------
*キー処理
  # 左移動。
  もし(左移動キーのキー状態=オン)ならば
    移動判定
    もし、左移動フラグ=オンならば
      落下X=落下X-マス目。
      左移動中=オン。
  違えば、
    左キー押下状態=オフ。
    左移動中=オフ。

  # 右移動。
  もし(右移動キーのキー状態=オン)ならば
    移動判定
    もし、右移動フラグ=オンならば
      落下X=落下X+マス目。
      右移動中=オン。
  違えば、
    右キー押下状態=オフ。
    右移動中=オフ。

  # 石を落とす
  もし、(落下キーのキー状態=オン)ならば
    落下フラグ=オン
  違えば
    落下フラグ=オフ

  # 石を転
  もし、(転キーのキー状態=オンならば
    もし転キー押下状態=オフならば  # 押しっぱなしでは転し続けない
     転キー押下状態=オン。
     A=落下石¥0。B=落下石¥1。C=落下石¥2。
     落下石¥0=C。
     落下石¥1=A。
     落下石¥2=B。
     3
       x=落下石¥(回数-1)*マス目。y=0。
       石用のx,y,マス目,マス目を石転用の0,(回数-1)*マス目へ画像部分コピー。
       落下用クリア。
       石転用を落下用の0,0へ画像コピー。
  違えば転キー押下状態=オフ移動判定
  # はみ出しの処理。
  # 石が壁、床、他の石にぶつからずに動けるかどうかを判定。
  落下マスXとは整数=落下X/マス目
  落下マスYとは整数=落下Y/マス目+2  # 一番下の石があるマス目

 # 縦方向
  # 床
  もし、落下Y>=マス目*11ならば、縦移動フラグ=オフ。
  # 他の石
//  違えばもし、固定石¥(落下マスX),(落下マスY)=-1ならば、縦移動フラグ=オン。
//  違えば、縦移動フラグ=オフ。

 # 横方向
  # 左の壁
  もし、(落下X-マス目<0)ならば、
    左移動フラグ=オフ。
    左移動中=オン。
  # 他の石
//  違えばもし、固定石¥(落下マスX-1),(落下マスY)=-1でなければ、
//    左移動フラグ=オフ。
//    左移動中=オン。
  違えば、左移動フラグ=オン。
  # 右のカベ
  もし、(落下X+マス目>=マス目*6)ならば、
    右移動フラグ=オフ。
    右移動中=オン。
  # 他の石
//  違えばもし、固定石¥(落下マスX+1),(落下マスY)=-1でなければ、
//    右移動フラグ=オフ。
//    右移動中=オン。
  違えば、右移動フラグ=オン。
#-----------------------------------------------------------------------
トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20160530

2016-05-22

とりあえず石を落とすところまで・・・

| 05:24

 は別に、はまったからサイコロに逃げていたとゆーわけではないんだけど・・・(本当!)

 またまたナゾ現象が発生していたのも事実!(ToT)

 関数の中で動的作成したイメージを壊す件は、「壊す」をやめて「VCL_FREE」にしたら、正常動作するようになったと思ってたんだけど、やっぱりダメかもしない

 サイコロくらいならいいんだろうけど、落下する石の合成を何十、何百と繰り返しているうちに、突然エラーも出さずに落ちたりしてね;

 ちなみに、関数内部でイメージ部品を動的作成して壊す(VCL_FREE)のをやめて、普通に外部で静的に作ったイメージ部品を使って画像合成通を動かしたら正常動作している風味なんで、やっぱりここら辺の問題なんだろうとおもう。


 のうちやる気が出たら色々試してみることにして(一発で出る問題と違って、再現にものすご~く時が掛かる上にエラーすら出ないから、もうヤダ><)とりあえずは、画像合成ないで、コピーで済ます方針に変更(爆)

 まあ、石用の裏画面にメイン画面と同じ格子を描いとくってだけのことですw

 ・・・と、ゆうわけでこうなった。

#とりあえず石を落とす。(画像合成不使用版)

#-----母艦設計----------------------------------------------------------
!母艦設計=「母艦の可視はオフ」

#---メニュー----
『#親部品名,部品名,テキスト,ショートカット,オプション,イベント
なし,ファイルメニュー,ファイル(&F),,,
 -,新規メニュー,新しいゲーム(&N),Ctrl+N,,新規ゲーム
 -,-,,,,
 -,成績表メニュー,成績表(&S),Ctrl+S,,成績表表示
 -,成績リセットメニュー,成績リセット(&D),Ctrl+D,,成績リセット
 -,-,,,,
 -,閉じるメニュー,閉じる(&X),Ctrl+X,,終わる
なし,設定メニュー,設定(&O),,,
 -,選択メニュー,コントローラー選択(&C),,,
 --,キーボード選択メニュー,キーボード(&K),,チェック,
 --,ジョイパッド選択メニュー,ジョイパッド(&J),,,
 -,-,,,,
 -,キーボード設定メニュー,キーボードのキー設定(&K),,,
 -,ジョイパッド設定メニュー,ジョイパッドのキー設定(&J),,,
なし,ヘルプメニュー,ヘルプ(&H),,,
 -,ルールメニュー,遊び方(&R),Ctrl+R,,遊び方
 -,-,,,,
 -,バージョンメニュー,バージョン情報(&A),Ctrl+A,,バージョン
』をメニュー一括作成。

#---母艦----
母艦のタイトルは「なでこら」
母艦を$FFBBAAで画面クリア母艦のスタイルは「枠固定」
母艦オフに最大化ボタン有効変更。
母艦のクライアント幅は330。母艦のクライアント高さは480。
母艦中央移動
#-----------------------------------------------------------------------

#-----宣言--------------------------------------------------------------
マス目とは整数=32。

石落下位置Xとは整数=マス目*3。
石落下位置Yとは整数=0-マス目*2。
落下Xとは整数=石落下位置X
落下Yとは整数=石落下位置Y

メインXとは整数=30。
メインYとは整数=50。
スコアXとは整数=メインX/2
スコアYとは整数=メインY/3
右辺ラベルXとは整数=メインX+マス目*6+25
ネクストXとは整数=メインX+マス目*6+40
ネクストYとは整数=メインY+30
レベルYとは整数=メインY+マス目*3+80

石とは配列    #石の種類(形状,色)
石=「●,$DD0000
◆,$FF7700
■,$0077FF
★,$EEEE00
▲,$EE00EE
▼,$00DD00」
#-----------------------------------------------------------
次石とは配列   #次に落下する石
落下石とは配列  #落下中の石

#---裏画面----
石用とはイメージ。
石用について。
  可視はオフ。
  幅はマス目*6。高さはマス目

マス目用とはイメージ
マス目用について
  可視はオフ
  幅はマス目。高さはマス目。
  $332211で画面クリア。

石転用とはイメージ。
石転用について。
  可視はオフ。
  幅はマス目。高さはマス目*3。

メイン合成用とはイメージ
メイン合成用について
  可視はオフ。
  幅はマス目*6。高さはマス目*13。

#---画面----
表画面とはイメージ
表画面について
  Xは0。Yは0。
  幅は母艦のクライアント幅。高さは母艦のクライアント高さ。
  $FFBBAAで画面クリア。

メイン画面とはイメージ
メイン画面について
  可視はオフ。
  幅はマス目*6。高さはマス目*13。

次石表示用とはイメージ
次石表示用について。
  可視はオフ。
  幅はマス目。高さはマス目*3。

落下用とはイメージ
落下用について。
  可視はオフ。
  幅はマス目。高さはマス目*3。
#-----------------------------------------------------------

#-----メインルーチン----------------------------------------------------
画面準備
母艦の可視はオン。

次石決定
次石落下
落下処理
メインループ
#-----------------------------------------------------------------------
*メインループ
  オン
    0.01秒待つ
    落下処理。
#-----------------------------------------------------------------------
*次石決定
  3
    r=6の乱数。次石¥(回数-1)=r。
    x=r*マス目。y=0。
    石用のx,y,マス目,マス目を次石表示用の0,(回数-1)*マス目へ画像部分コピー。
    次石表示用を表画面のネクストX,ネクストYへ画像コピー。

*次石落下
  次石表示用を落下用の0,0へ画像コピー
  落下石=次石。
  次石決定
  落下X=石落下位置X。落下Y=石落下位置Y

*落下処理
  落下用をメイン合成用の落下X,落下Yへ画像コピー。
  メイン合成用を表画面のメインX,メインYへ画像コピー
  メイン画面をメイン合成用の0,0へ画像コピー。
  0.5秒待つ。

  落下Y=落下Y+マス目
#-----------------------------------------------------------------------
*画面準備
  # マス目を描く
  線太さは0。線色は$443322。塗り色は$443322。
  マス目用の0,0から2,マス目-4へ四角。
  マス目用の0,0からマス目-4,2へ四角。
  線太さは0。線色は$221100。塗り色は$221100。
  マス目用のマス目-2,4からマス目,マス目へ四角。
  マス目用の4,マス目-2からマス目,マス目へ四角。

  #マス目をコピー。
  3
    C=回数-1
    マス目用を次石表示用の0,C*マス目へ画像コピー。

  メイン画面初期化
  メイン画面をメイン合成用の0,0へ画像コピー。

  # 表画面
  文字書体は「MS Pゴシック|14|太字」。文字色は$FFFFFF。
  表画面のスコアX+1,スコアY+2へ「すこあ」を文字描画。
  表画面の右辺ラベルX+1,ネクストY-25+2へ「ねくすと」を文字描画。
  表画面の右辺ラベルX+1,レベルY-25+2へ「れべる」を文字描画。
  文字色は$CC3322。
  表画面のスコアX,スコアYへ「すこあ」を文字描画。
  表画面の右辺ラベルX,ネクストY-25へ「ねくすと」を文字描画。
  表画面の右辺ラベルX,レベルY-25へ「れべる」を文字描画。

  メイン画面を表画面のメインX,メインYへ画像コピー。
  次石表示用を表画面のネクストX,ネクストYへ画像コピー。
  スコア表示。
  レベル表示。

  # 石用に石を描く
  6
    C=回数-1
    マス目用を石用のC*マス目,0へ画像コピー。
    文字書体は「MS ゴシック|23|太字」。文字色は石¥C,1。
    石用のC*マス目,0へ石¥C,0を文字表示。

*スコア表示
  文字書体は「MS Pゴシック|14|太字」
  XXとは整数=「すこあ」の文字幅取得+スコアX+2
  線色は$FFDDCC。塗り色は$FFDDCC。文字書体は「MS Pゴシック|18|太字」。文字色は$882211。
  表画面のXX,スコアY-5からメインX+マス目*6,スコアY+23へ四角。

*レベル表示
  レベル=消去数/50を切り下げ
  線色は$FFDDCC。塗り色は$FFDDCC。文字書体は「MS Pゴシック|18|太字」。文字色は$882211。
  表画面の右辺ラベルX,レベルYから右辺ラベルX+65,レベルY+30へ四角。

*メイン画面初期化
  6
    マス目用をメイン画面のマス目*(回数-1),0へ画像コピー。
  13
    メイン画面の0,0,マス目*6,マス目をメイン画面の0,マス目*(回数-1)へ画像部分コピー。
#-----------------------------------------------------------------------

 本当にタダ石を出して落としているだけだけどねぇ~www

(だって、石の固定をせずに、とりあえず移動部分を作って実験していたら、上記の問題が発生したんだもん!)

 だから、石を転させたりキーボードで左右に移動したりの部分はもう出来ているようなもんだけど、画像合成ない版に合わせて書き換えた上で、石を固定して、の石との当たり判定を付けてから、UPするよてい~。

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20160522

2016-05-20

完成かな?

| 22:17

 ダイスはサイコロキャラメルにし替えて、得点表示部分が白だと、白のサイコロが何だか見づらいから、ちょこっとだけ色替えをして(でもんなに見やすくなったわけでもない;)、勝敗判定の表示と、メッセージ表示を付け加えて・・・

 このメッセージの数々に一番、無駄っぽく行数と時を食っていたり;;;

 ついでに、なこ様を表示させてみたりして、いちおう完成、完成~☆

#-----------------------------------------------------------------------
# 36(Thirty-six)
#-----------------------------------------------------------------------

#-----母艦設計-----------------------------------------------
!母艦設計=「母艦の可視はオフ」

#---メニュー----
『#親部品名,部品名,テキスト,ショートカット,オプション,イベント
なし,ファイルメニュー,ファイル(&F),,,
 -,新規メニュー,新しいゲーム(&N),Ctrl+N,,新規ゲーム
 -,-,,,,
 -,メッセージメニュー,メッセージ速度(&S),Ctrl+S,,
 --,速度1,早い(&1),,,「早い」にメッセージ速度変更。
 --,速度2,普通(&2),,,「普通」にメッセージ速度変更。
 --,速度3,遅い(&3),,,「遅い」にメッセージ速度変更。
 -,-,,,,
 -,閉じるメニュー,閉じる(&X),Ctrl+X,,終わる
なし,ヘルプメニュー,ヘルプ(&H),,,
 -,ルールメニュー,遊び方(&R),Ctrl+R,,遊び方
 -,-,,,,
 -,バージョンメニュー,バージョン情報(&A),Ctrl+A,,バージョン
』をメニュー一括作成。

*メッセージ速度変更(Sに)
  もし、S=「早い」ならば、
    メッセージ速度=0
    速度1のチェックオン。速度2のチェックオフ。速度3のチェックオフ。

  違えばもし、S=「普通」ならば、
    メッセージ速度=30
    速度1のチェックオフ。速度2のチェックオン。速度3のチェックオフ。

  違えばもし、S=「遅い」ならば、
    メッセージ速度=60
    速度1のチェックオフ。速度2のチェックオフ。速度3のチェックオン。
#------------------------------------------------------------

#---母艦----
母艦のタイトルは「36(Thirty-six)」
母艦のクライアント幅は640。母艦のクライアント高さは480。
母艦を$EEAA88で画面クリア母艦のスタイルは「枠固定」
母艦オフに最大化ボタン有効変更。
母艦中央移動。
#------------------------------------------------------------

#-----宣言---------------------------------------------------
プレイヤー名とは文字列=「プレイヤー」
コンピューター名とは文字列=「なこ様」
ナコ様画像とは文字列=「{ランタイムパス}\lib\nako.png」

出目とは配列。
得点とは整数=0
プレイヤー得点とは整数=0
コンピューター得点とは整数=0
プレイヤー罰点とは整数=0
コンピューター罰点とは整数=0

手番とは整数=0
プレイヤーとは整数=0
コンピューターとは整数=1
カウントとは整数=0
ゾロ目とは整数オフ
六ゾロとは整数オフ

マージンとは整数=15
メッセージ速度とは整数=30
速度2のチェックオン。

#---サイコロ設定----
ダイスサイズとは整数=80
ミニダイスとは整数=20

サイコロ赤とは配列。
サイコロ赤=「{ダイスサイズ}
{黒色},{赤色},{白色}
{黒色},{赤色},{白色}
{黒色},{赤色},{白色}
{黒色},{赤色},{白色}
{黒色},{赤色},{白色}
{黒色},{赤色},{白色}」

サイコロ白とは配列。
サイコロ白=「{ダイスサイズ}
{黒色},{白色},{赤色}
{黒色},{白色},{赤色}
{黒色},{白色},{赤色}
{黒色},{白色},{赤色}
{黒色},{白色},{赤色}
{黒色},{白色},{赤色}」

#---サイコロ用イメージ----
線太さ=1
ダイス用¥1にサイコロ赤でサイコロ準備
ダイス用¥2にサイコロ白でサイコロ準備

処理用とはイメージの可視はオフ。

#---サイコロ振るところ----
トレイ幅とは整数=350
トレイ高さとは整数=310
トレイxとは整数。トレイx=(母艦のクライアント幅/2)-(トレイ幅/2)
トレイyとは整数。トレイy=30

ダイストレイとはイメージの可視はオフの幅はトレイ幅。の高さはトレイ高さ。
ダイストレイを$006600で画面クリア。
ダイストレイを母艦のトレイx,トレイyへ画像コピー。

#---メッセージ出すところ----
テキストウィンドウ幅とは整数=610
テキストウィンドウ高さとは整数=115
テキストウィンドウxとは整数=マージン
テキストウィンドウyとは整数。テキストウィンドウy=トレイ高さ+トレイy+マージン

テキストウィンドウとはイメージの可視はオフの幅はテキストウィンドウ幅。の高さはテキストウィンドウ高さ。
テキストウィンドウを$222222で画面クリア。
テキストウィンドウを母艦のテキストウィンドウx,テキストウィンドウyへ画像コピー

#---得点計算するところ----
得点表示幅とは整数=110
得点表示高さとは整数=310
プレイヤーxとは整数=マージン
コンピューターxとは整数母艦のクライアント幅-(マージン+得点表示幅)
得点表示xとは整数。
得点表示yとは整数=マージン

得点表示用とはイメージの可視はオフの幅は得点表示幅。の高さは得点表示高さ。
得点表示用を$FFDDAAで画面クリア。

得点表示用を母艦のプレイヤーx,得点表示y*2へ画像コピー。
得点表示用を母艦のコンピューターx,得点表示y*2へ画像コピー文字書体は「MS ゴシック|12|太字」
母艦のプレイヤーx,0,得点表示幅,得点表示y*2-1へ「{プレイヤー名}」を中央,下で枠内文字描画母艦のコンピューターx,0,得点表示幅,得点表示y*2-1へ「{コンピューター名}」を中央,下で枠内文字描画。

#---サイコロ振るボタン----
ボタンフラグとは整数。  #0=OK、1=ゲーム開始、2=サイコロ振る、3=勝敗判定、4=新規ゲーム

ボタンAとはボタンの可視はオフの幅は100。の高さは30。
のXはトレイx+(トレイ幅/2-ボタンAの幅/2)。のYはトレイ高さ+トレイy-ボタンAの高さ。
ボタンAをクリックした時は~
  ナコ様の可視はオフ。
  もしボタンフラグ=0ならば
    ボタンフラグ=2
    もし、手番=プレイヤーならば、プレイヤー手番。
    違えば、コンピューター手番。
  違えばもしボタンフラグ=1ならば
    ボタンAの有効はオフ。
    「プレイヤーの手番」でメッセージ表示。
    ボタンAのテキストは「ダイスを振る」
    の有効はオン。
    ボタンフラグ=2
  違えばもしボタンフラグ=2ならば
    ボタンAの有効はオフ。
    サイコロ振る。得点計算。得点加算。
  違えばもしボタンフラグ=3ならば
    勝敗判定。
  違えばもしボタンフラグ=4ならば
    ボタンAの有効はオフ
    新規ゲーム。

#---なこ様----
ナコ様とはフォームの可視はオフの親部品は母艦
の画像はナコ様画像。
ナコ様を画像通り変形。
のドラッグ移動オフ。
#------------------------------------------------------------

#-----メインルーチン-----------------------------------------
母艦の可視はオンダイアログIMEIMEオンダイアログタイトルは「名前入力」
「あなたの名前は?(全角7文字以内で教えてね)」と尋ねるもしそれならば、
  プレイヤー名は「プレイヤー」
違えば
  プレイヤー名はそれの14バイト左部分。
  線色は$EEAA88。塗り色は$EEAA88。
  母艦のプレイヤーx,0からプレイヤーx+得点表示幅,得点表示y*2-1へ四角。
  母艦のプレイヤーx,0,得点表示幅,得点表示y*2-1へ「{プレイヤー名}」を中央,下で枠内文字描画。

「挨拶」でメッセージ表示ボタンAのテキストは「よろしく」
の可視はオンボタンフラグ=4
#------------------------------------------------------------
*新規ゲーム
  乱数初期化。
  プレイヤー得点=0
  コンピューター得点=0
  プレイヤー罰点=0
  コンピューター罰点=0
  カウント=0

  得点表示y=マージン。
  得点表示用を母艦のプレイヤーx,得点表示y*2へ画像コピー。
  得点表示用を母艦のコンピューターx,得点表示y*2へ画像コピー。
  ダイストレイを母艦のトレイx,トレイyへ画像コピー。
  描画処理反映。
  手番はプレイヤー。
  「ゲーム開始」でメッセージ表示。
  ボタンAの有効はオン
  ボタンAのテキストは「準備OK!」
  ボタンフラグは1

#-----2Dを振る---------------------------------------------
*サイコロ振る
  2
    処理用をダイスサイズ,ダイスサイズへ画像高速リサイズ。
    r=6の乱数。出目¥(回数-1)=r+1。
    x=r*ダイスサイズ。y=0。
    ダイス用¥回数のx,y,ダイスサイズ,ダイスサイズを処理用の0,0へ画像部分コピー。
    処理用を母艦のトレイx+((トレイ幅/3)*回数-ダイスサイズ/2),トレイy+(トレイ高さ/2-ダイスサイズ/2)へ画像コピー。

    処理用をミニダイス,ミニダイスへ画像リサイズ。
    もし、手番=プレイヤーならば
      得点表示x=プレイヤーx+10+(ミニダイス+10)*(回数-1)
      得点表示y=マージン*2+10+(ミニダイス+10)*(カウント/2)
      処理用を母艦の得点表示x,得点表示yへ画像コピー。
    違えば
      得点表示x=コンピューターx+10+(ミニダイス+10)*(回数-1)
      得点表示y=マージン*2+10+(ミニダイス+10)*((カウント-1)/2)
      処理用を母艦の得点表示x,得点表示yへ画像コピー。
#------------------------------------------------------------
*得点計算
  もし、(出目¥0)=(出目¥1)ならば
    もし、(出目¥0)=6ならば
      得点=36。
      文字色赤色。
    違えばもし、(出目¥0)=1ならば
      得点=0。
      文字色青色。
    違えば
      得点=出目¥0*出目¥1。
      ゾロ目=オン
      文字色黒色。
  違えば
    得点=出目¥0+出目¥1。
    文字色黒色。

*得点加算
  もし、手番=プレイヤーならば
    もし、得点=36ならば
      プレイヤー得点=36
      得点表示。
      「プレイヤー6ゾロ」でメッセージ表示。
      六ゾロ=1
    違えばもし、得点=0ならば
      プレイヤー得点=0
      得点表示。
      「プレイヤー1ゾロ」でメッセージ表示。
    違えば
      プレイヤー得点=プレイヤー得点+得点
      もし、プレイヤー得点>=36ならば
        文字色赤色。
        プレイヤー罰点=プレイヤー得点-36
      得点表示。
      もし、ゾロ目=オンならば
        「プレイヤーゾロ目」でメッセージ表示。
        ゾロ目=オフ
      違えば
        「プレイヤー出目」でメッセージ表示。
    手番=コンピューター。
    ボタンAのテキストは「OK」
    の有効はオン。
    ボタンフラグ=0
    
  違えば
    もし、得点=36ならば
      コンピューター得点=36
      得点表示。
      「コンピューター6ゾロ」でメッセージ表示。
      六ゾロ=六ゾロ+2
    違えばもし、得点=0ならば
      コンピューター得点=0
      得点表示。
      「コンピューター1ゾロ」でメッセージ表示。
    違えば
      コンピューター得点=コンピューター得点+得点
      もし、コンピューター得点>=36ならば
        文字色赤色。
        コンピューター罰点=コンピューター得点-36
      得点表示。
      もし、ゾロ目=オンならば
        「コンピューターゾロ目」でメッセージ表示。
        ゾロ目=オフ
      違えば
        「コンピューター出目」でメッセージ表示。

    もし、(プレイヤー得点>=36)または(コンピューター得点>=36)ならば
      ボタンAのテキストは「勝敗判定」
      の有効はオン。
      ボタンフラグ=3
    違えばもし、カウント=19ならば
      ボタンAのテキストは「無効試合」
      の有効はオン。
      ボタンフラグ=3
    違えば
      手番=プレイヤー。
      ボタンAのテキストは「OK」
      の有効はオン。
      ボタンフラグ=0

*得点表示
  文字書体は「MS ゴシック|16|太字」。
  もし、手番=プレイヤーならば
    得点表示x=プレイヤーx+20+(ミニダイス+10)*2
    得点表示y=マージン*2+10+(ミニダイス+10)*(カウント/2)
    母艦の得点表示x,得点表示y,ミニダイス,ミニダイスへ右,中央でプレイヤー得点を枠内文字描画。

  違えば
    得点表示x=コンピューターx+20+(ミニダイス+10)*2
    得点表示y=マージン*2+10+(ミニダイス+10)*((カウント-1)/2)
    母艦の得点表示x,得点表示y,ミニダイス,ミニダイスへ右,中央でコンピューター得点を枠内文字描画。
#------------------------------------------------------------
*勝敗判定
  #6ゾロでの上がりは累計での上がりに優先する
  もし、六ゾロ=1ならば        #プレイヤーが6ゾロ
    「勝ち」で勝敗表示。「プレイヤー6ゾロ勝利」で勝敗メッセージ表示。
  違えばもし、六ゾロ=2ならば    #コンピューターが6ゾロ
    「負け」で勝敗表示。「コンピューター6ゾロ勝利」で勝敗メッセージ表示。
  違えばもし、六ゾロ=3ならば    #プレイヤーもコンピューターも6ゾロ
    「引き分け」で勝敗表示。「双方6ゾロ」で勝敗メッセージ表示。

  #プレイヤーもコンピューターも6ゾロではない
  違えば
    もし、(プレイヤー得点>=36)ならば        #プレイヤーの点数が36かそれ以上で
      もし、(コンピューター得点<36)ならば        #コンピューターがそれ以下ならば
        「勝ち」で勝敗表示。「プレイヤー勝利」で勝敗メッセージ表示。
      違えばもし、(コンピューター得点>=36)ならば   #コンピューターの点数も36かそれ以上なら
        もし、(プレイヤー罰点<コンピューター罰点)ならば    #罰点のより少ない方が勝ちとなり
          「勝ち」で勝敗表示。「プレイヤー勝利2」で勝敗メッセージ表示。
        違えばもし、(プレイヤー罰点>コンピューター罰点)ならば
          「負け」で勝敗表示。「コンピューター勝利2」で勝敗メッセージ表示。
        違えば                          #それも同じならば引き分け
          「引き分け」で勝敗表示。「引き分け」で勝敗メッセージ表示。
    違えばもし、(コンピューター得点>=36)ならば  #プレイヤーの点数が36に満たずコンピューターの点数が36かそれ以上
      「負け」で勝敗表示。「コンピューター勝利」で勝敗メッセージ表示。
    違えば                        #10でどちらも36を越えなかった場合
      「引き分け」で勝敗表示。「無効試合」で勝敗メッセージ表示。

  六ゾロ=0
  ボタンAのテキストは「もう一度?」
  ボタンフラグ=4

*勝敗表示(Sで)
  ダイストレイを母艦のトレイx,トレイyへ画像コピー。
  文字書体は「MS ゴシック|32|太字」。
  勝敗表示x=(トレイ幅/2)-(Sの文字幅取得/2)+トレイx
  勝敗表示y=トレイy+10
  もし、S=「勝ち」ならば、
    文字色白色母艦の勝敗表示x+2,勝敗表示y+2へ「勝ち」を文字描画。
    文字色赤色母艦の勝敗表示x,勝敗表示yへ「勝ち」を文字描画。
  違えばもし、S=「負け」ならば、
    文字色白色母艦の勝敗表示x+2,勝敗表示y+2へ「負け」を文字描画。
    文字色青色母艦の勝敗表示x,勝敗表示yへ「負け」を文字描画。
  違えばもし、S=「引き分け」ならば、
    文字色白色母艦の勝敗表示x+2,勝敗表示y+2へ「引き分け」を文字描画。
    文字色は$777777。母艦の勝敗表示x,勝敗表示yへ「引き分け」を文字描画。

*勝敗メッセージ表示(Sで)
  文字色白色文字書体は「MS ゴシック|18|太字」。#12文字表示できる
  勝敗表示x=トレイx+30
  勝敗表示y=トレイy+80
  もし、S=「プレイヤー6ゾロ勝利」ならば
    母艦の勝敗表示x,勝敗表示yへ「おめでとう!{改行}6ゾロで{プレイヤー名}の{改行}完全勝利!!」を文字描画。
  もし、S=「コンピューター6ゾロ勝利」ならば
    母艦の勝敗表示x,勝敗表示yへ「残念!!{改行}6ゾロで{コンピューター名}の{改行}完全勝利!」を文字描画。
  もし、S=「双方6ゾロ」ならば
    母艦の勝敗表示x,勝敗表示yへ「双方6ゾロで引き分けです」を文字描画。
  もし、S=「プレイヤー勝利」ならば
    母艦の勝敗表示x,勝敗表示yへ「おめでとう!{改行}{プレイヤー名}の勝ち!!」を文字描画。
  もし、S=「プレイヤー勝利2」ならば
    母艦の勝敗表示x,勝敗表示yへ「{プレイヤー名}の罰点{プレイヤー罰点}点{改行}{コンピューター名}の罰点{コンピューター罰点}点で{改行}{プレイヤー名}の勝ち!」を文字描画。
  もし、S=「コンピューター勝利」ならば
    母艦の勝敗表示x,勝敗表示yへ「残念!!{改行}{コンピューター名}の勝ち!」を文字描画。
  もし、S=「コンピューター勝利2」ならば
    母艦の勝敗表示x,勝敗表示yへ「{プレイヤー名}の罰点{プレイヤー罰点}点{改行}{コンピューター名}の罰点{コンピューター罰点}点で{改行}{コンピューター名}の勝ち!」を文字描画。
  もし、S=「引き分け」ならば
    母艦の勝敗表示x,勝敗表示yへ「引き分けです」を文字描画。
  もし、S=「無効試合」ならば
    母艦の勝敗表示x,勝敗表示yへ「残念でした。{改行}10で決着がつかず{改行}無効試合となります。」を文字描画。
  Sでメッセージ表示。
#------------------------------------------------------------
*プレイヤー手番
  カウント=カウント+1
  ボタンAの有効はオフ。
  ボタンAのテキストは「ダイスを振る」  
  ダイストレイを母艦のトレイx,トレイyへ画像コピー。
  「プレイヤーの手番」でメッセージ表示。
  ボタンAの有効はオン。

*コンピューター手番
  カウント=カウント+1
  ボタンAの有効はオフ。
  ダイストレイを母艦のトレイx,トレイyへ画像コピー。
  「コンピューターの手番」でメッセージ表示。
  サイコロ振る。得点計算。得点加算。
#------------------------------------------------------------
*メッセージ表示(Sで)
  テキストウィンドウを母艦のテキストウィンドウx,テキストウィンドウyへ画像コピー。
  文字色白色文字書体は「MS ゴシック|18|太字」。
  メッセージx=マージン+30。一行目=テキストウィンドウy+30。二行目=テキストウィンドウy+60。
  名前x=マージン。名前y=テキストウィンドウy+5。
  セリフ一行目=テキストウィンドウy+40。セリフ二行目=テキストウィンドウy+70。
  もし、S=「挨拶」ならば
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    ナコ様表示。
    母艦のメッセージx,セリフ一行目へ「こんにちは、{プレイヤー名}!」をメッセージ速度で文字遅延描画。
    母艦のメッセージx,セリフ二行目へ「よろしくね☆」をメッセージ速度で文字遅延描画。
  もし、S=「ゲーム開始」ならば
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「それでは始めよう!」をメッセージ速度で文字遅延描画。
    母艦のメッセージx,セリフ二行目へ「準備はいいかな?」をメッセージ速度で文字遅延描画。 
  もし、S=「プレイヤーの手番」ならば、
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「{プレイヤー名}の番だよ。」をメッセージ速度で文字遅延描画。
    母艦のメッセージx,セリフ二行目へ「ダイスを振ってね。」をメッセージ速度で文字遅延描画。
  もし、S=「コンピューターの手番」ならば、
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「僕の番だね。」をメッセージ速度で文字遅延描画。
    0.5秒待つ。
    母艦のメッセージx,セリフ二行目へ「………… ………… ………… …………」をメッセージ速度で文字遅延描画。
    0.5秒待つ。
    ナコ様の可視はオフ。

  もし、S=「プレイヤー出目」ならば、
    母艦のメッセージx,一行目へ「出目は{得点}です。」をメッセージ速度で文字遅延描画。
    母艦のメッセージx,二行目へ「{プレイヤー名}の点数は{プレイヤー得点}点になりました。」をメッセージ速度で文字遅延描画。
  もし、S=「プレイヤーゾロ目」ならば、
    母艦のメッセージx,一行目へ「{出目¥0}ゾロです。得点は{得点}点。」をメッセージ速度で文字遅延描画。
    母艦のメッセージx,二行目へ「{プレイヤー名}の点数は{プレイヤー得点}点になりました。」をメッセージ速度で文字遅延描画。
  もし、S=「プレイヤー6ゾロ」ならば、
    母艦のメッセージx,一行目へ「6ゾロです!!」をメッセージ速度で文字遅延描画。
    母艦のメッセージx,二行目へ「{コンピューター名}が6ゾロ以外なら{プレイヤー名}の勝ち!」をメッセージ速度で文字遅延描画。
  もし、S=「プレイヤー1ゾロ」ならば、
    母艦のメッセージx,一行目へ「残念!1ゾロです!!」をメッセージ速度で文字遅延描画。
    母艦のメッセージx,二行目へ「{プレイヤー名}の点数が0点になりました。」をメッセージ速度で文字遅延描画。
  もし、S=「コンピューター出目」ならば、
    母艦のメッセージx,一行目へ「出目は{得点}です。」をメッセージ速度で文字遅延描画。
    母艦のメッセージx,二行目へ「{コンピューター名}の点数は{コンピューター得点}点になりました。」をメッセージ速度で文字遅延描画。
  もし、S=「コンピューターゾロ目」ならば、
    母艦のメッセージx,一行目へ「{出目¥0}ゾロです。得点は{得点}点。」をメッセージ速度で文字遅延描画。
    母艦のメッセージx,二行目へ「{コンピューター名}の点数は{コンピューター得点}点になりました。」をメッセージ速度で文字遅延描画。
  もし、S=「コンピューター6ゾロ」ならば、
    母艦のメッセージx,一行目へ「{コンピューター名}が、6ゾロを出しました!!」をメッセージ速度で文字遅延描画。
  もし、S=「コンピューター1ゾロ」ならば、
    母艦のメッセージx,一行目へ「1ゾロです!!」をメッセージ速度で文字遅延描画。
    母艦のメッセージx,二行目へ「{コンピューター名}の点数が0点になりました。」をメッセージ速度で文字遅延描画。

  もし、S=「プレイヤー6ゾロ勝利」ならば
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「ま、負けました・・・」をメッセージ速度で文字遅延描画。
  もし、S=「コンピューター6ゾロ勝利」ならば
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「圧勝だね」をメッセージ速度で文字遅延描画。
  もし、S=「双方6ゾロ」ならば
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「惜しい!」をメッセージ速度で文字遅延描画。
  もし、S=「プレイヤー勝利」ならば
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「ちくしょ~」をメッセージ速度で文字遅延描画。
  もし、S=「プレイヤー勝利2」ならば
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「悔しい~」をメッセージ速度で文字遅延描画。
  もし、S=「コンピューター勝利」ならば
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「ひゃっほう!」をメッセージ速度で文字遅延描画。
  もし、S=「コンピューター勝利2」ならば
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「やったね!」をメッセージ速度で文字遅延描画。
  もし、S=「引き分け」ならば
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「引き分けか・・・」をメッセージ速度で文字遅延描画。
  もし、S=「無効試合」ならば
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「なんと?!」をメッセージ速度で文字遅延描画。
#------------------------------------------------------------
*ナコ様表示
  ナコ様のX=母艦のクライアント幅-ナコ様の幅。
  ナコ様のY=母艦のクライアント高さ-ナコ様の高さ。
  ナコ様の可視はオン。ナコ様を最前面表示。
#------------------------------------------------------------
*サイコロ準備({グループ}imgにSで)
  imgをイメージとして作成。
  img→可視はオフ。
  img→幅はS\0*6
  img→高さはS\0
  imgを$00FF00で画面クリア。    #透過色
  目サイズ=S\0/8。
  6
    色設定とは配列。色設定=S\回数。
    線色は色設定¥0。塗り色は色設定¥1。
    外枠(img,S\0)
    線色は色設定¥2。塗り色は色設定¥2。
    もし回数=1ならば
      半径=目サイズ+S\0/40。
      中点(img,S\0)。
    もし回数=2ならば
      半径=目サイズ。
      左上点(img,S\0)。右下点(img,S\0)。
    もし回数=3ならば
      半径=目サイズ。
      中点(img,S\0)。左上点(img,S\0)。右下点(img,S\0)。
    もし回数=4ならば
      半径=目サイズ。
      左上点(img,S\0)。左下点(img,S\0)。右上点(img,S\0)。右下点(img,S\0)。
    もし回数=5ならば
      半径=目サイズ。
      中点(img,S\0)。左上点(img,S\0)。左下点(img,S\0)。右上点(img,S\0)。右下点(img,S\0)。
    もし回数=6ならば
      半径=目サイズ-S\0/80。
      左上点(img,S\0)。左下点(img,S\0)。右上点(img,S\0)。右下点(img,S\0)。左中点(img,S\0)。右中点(img,S\0)。

*外枠({グループ}img,S)
  x=(回数-1)*S。y=0。
  x2=x+S。y2=S。
  imgのx,yからx2,y2へ四角。

*中点({グループ}img,S)
  xx=(x+S/2)-半径。yy=S/2-半径
  xx2=(x+S/2)+半径。yy2=S/2+半径。
  imgのxx,yyからxx2,yy2へ。

*左上点({グループ}img,S)
  xx=(x+S/4)-半径。yy=S/4-半径
  xx2=(x+S/4)+半径。yy2=S/4+半径。
  imgのxx,yyからxx2,yy2へ。

*左下点({グループ}img,S)
  xx=(x+S/4)-半径。yy=(S/4)*3-半径
  xx2=(x+S/4)+半径。yy2=(S/4)*3+半径。
  imgのxx,yyからxx2,yy2へ。

*右上点({グループ}img,S)
  xx=(x+S/4*3)-半径。yy=S/4-半径
  xx2=(x+S/4*3)+半径。yy2=S/4+半径。
  imgのxx,yyからxx2,yy2へ。

*右下点({グループ}img,S)
  xx=(x+S/4*3)-半径。yy=(S/4)*3-半径
  xx2=(x+S/4*3)+半径。yy2=(S/4)*3+半径。
  imgのxx,yyからxx2,yy2へ。

*左中点({グループ}img,S)
  xx=(x+S/4)-半径。yy=S/2-半径
  xx2=(x+S/4)+半径。yy2=S/2+半径。
  imgのxx,yyからxx2,yy2へ。

*右中点({グループ}img,S)
  xx=(x+S/4*3)-半径。yy=S/2-半径
  xx2=(x+S/4*3)+半径。yy2=S/2+半径。
  imgのxx,yyからxx2,yy2へ。
#------------------------------------------------------------
*遊び方
  ダイアログタイトルは「36(Thirty-six)について」
  「【36(Thirty-six)のルール】
   二人で交互に六面ダイス二個を振り合い、点数を累計してゆきます。
   二個の目の和が、のまま点数になり、ゾロ目の場合は二個の目のが点数と
  なりますが、1ゾロの場合はそれまでの点数の累計がクリアされ0点になります。
   早く36点に達した方が勝ちとなりますが、先攻後攻はなく両者同じ回数だけ
  ダイスを振ることが出来るため、双方同時に上がった場合は、36を越えた分が
  罰点となり、より罰点の少ない方が勝ちとなります。
   なお、6ゾロで上がった場合は、36点ぴったりでの上がりとなり罰点はなく、
  また、通常の累計での上がりに優先します。
   罰点も同数の場合や両者ともに6ゾロで上がった場合は、引き分けとなります。」と言う
#------------------------------------------------------------
*バージョン
  ダイアログタイトルは「バージョン情報」
  「{二重カッコ}36(Thirty-six){二重カッコ閉じ}{改行}  Version 1.03{改行}{改行} by 雪乃☆雫」と言う。
#------------------------------------------------------------
●枠内文字描画({グループ=?}OBJのX,Y,W,HへSをA,Vで)
  xxとは整数。yyとは整数。
  もし、A=左ならば
    xx=X
  違えばもし、A=中央ならば
    xx=X+(W-(Sの文字幅取得))/2
  違えばもし、A=右ならば
    xx=(X+W)-(Sの文字幅取得)
  もし、V=上ならば
    yy=Y
  違えばもし、V=中央ならば
    yy=Y+(H-(Sの文字高さ取得))/2
  違えばもし、V=下ならば
    yy=(Y+H)-(Sの文字高さ取得)
  OBJのxx,yyへSを文字描画。
#------------------------------------------------------------

 やっぱり、こうゆう単純なゲームは、自分でサイコロを振ってこ、相手が人であってこって部分があるよねぇ。

 しかし、の時代は各々スマホのアプリって感じで、みんなでこういった埒もない暇つぶしの遊びをしたりはもうしないんだろうね・・・

 なこ様がもう少し、出目に対して一喜一憂した方が、少しは人っぽくて面白いかとも思ったけど、所詮は焼け石に水っていうか、色々メッセージを考えるのがもうさすがに面倒になったていうか、場合によっちゃむしろ腹立つっていうかなので、やめた~www

 画像合成を使わず、画面の書き換えもしなくて済むように、画像通り変形したフォームを重ねてみたんだけど、このなこ様で、デスクトップマスコットを作ってみたらどうだろう。

 またまたひらめいてしまったw(だから、なでコラはどうした;)

 次は、なでコラです(予定)

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20160520

2016-05-16

勝敗判定

| 08:57

 昨日買い物に行った時、ついでに探してみたら、なるほどサイコロキャラメルはどこにも無かった。

 ってか、ついこないだまでは、ふつーにあったような気がするから、やっぱりYahoo!ニュースに載ったがために、みんな買いに走ったのだろうか。

 人って愚かだな・・・(自分のことでしょ!)



 ・・・さて、実際にやればんな難しいことは無いんだけど、単に、累計点数が先に上ったら勝ちという場合と比べて、勝敗のパターンが結構多いです。

 ざっと書き出してみます。

●6ゾロは全てに優先します
・プレイヤーが6ゾロ=プレイヤーの勝ち
・コンピューターが6ゾロ=コンピューターの勝ち
・双方6ゾロ=引き分け

●ふつーに累計で勝負がつく場合
・プレイヤーが36をえ、コンピューターは36未満=プレイヤーの勝ち
・コンピューターが36をえ、プレイヤーは36未満=コンピューターの勝ち

●プレイヤーもコンピューターも、ともに36をえた場合
◎罰点(累計得点-36)の少ない方が勝ち
・プレイヤーの罰点<コンピューターの罰点=プレイヤーの勝ち
・プレイヤーの罰点>コンピューターの罰点=コンピューターの勝ち
・罰点まで同じ=引き分け

●無効試合
 ふつーにサイコロで遊んでいた時にはの制度はなかったのですが、、
得点表示するスペースの都合により、10で勝負が決まらなければ無効試合
とします。
 滅多にんなことないけど、絶妙なタイミングで双方1ゾロしたりすると、
起こりえます。

 して、これをプログラムにすると、こんな感じ。

#------------------------------------------------------------
*勝敗判定
  ダイアログタイトルは「勝敗判定」
  #6ゾロでの上がりは累計での上がりに優先する
  もし、六ゾロ=1ならば        #プレイヤーが6ゾロ
    「おめでとう!{改行}6ゾロで{プレイヤー名}の勝ち!!」を言う。

  違えばもし、六ゾロ=2ならば    #コンピューターが6ゾロ
    「残念!!{改行}6ゾロで{コンピューター名}の勝ち!」を言う。

  違えばもし、六ゾロ=3ならば    #プレイヤーもコンピューターも6ゾロ
    「双方6ゾロで引き分けです」を言う。

  #プレイヤーもコンピューターも6ゾロではない
  違えば
    もし、(プレイヤー得点>=36)ならば          #プレイヤーの点数が36かそれ以上で
      もし、(コンピューター得点<36)ならば          #コンピューターがそれ以下ならば
        「おめでとう!{改行}{プレイヤー名}の勝ち!!」を言う。
      
      違えばもし、(コンピューター得点>=36)ならば      #コンピューターの点数も36かそれ以上なら
        もし、(プレイヤー罰点<コンピューター罰点)ならば    #罰点のより少ない方が勝ちとなり
          「{プレイヤー名}の罰点{プレイヤー罰点}点{改行}{コンピューター名}の罰点{コンピューター罰点}点で{改行}{プレイヤー名}の勝ち!」を言う。

        違えばもし、(プレイヤー罰点>コンピューター罰点)ならば
          「{プレイヤー名}の罰点{プレイヤー罰点}点{改行}{コンピューター名}の罰点{コンピューター罰点}点で{改行}{コンピューター名}の勝ち!」を言う。

        違えば                          #それも同じならば引き分け
          「引き分けです」を言う。

    違えばもし、(コンピューター得点>=36)ならば    #プレイヤーの点数が36に満たずコンピューターの点数が36かそれ以上
      「残念!!{改行}{コンピューター名}の勝ち!」を言う。

    違えば                          #10でどちらも36を越えなかった場合
      「残念でした。{改行}10で決着がつかず{改行}無効試合となります。」を言う。

  ボタンAのテキストは「もう一度?」
#------------------------------------------------------------

 これで、いちおう遊べて、勝ち負けも判定して言ってもらえるようになったけど、未だ活用されていないテキストウィンドウに、は言わせているメッセージを表示したり、ちょぼいちの時みたく、相手のコンピューターに何かしゃべらせたりする予定。

 あと、コンピューターがサイコロを振る時も、自分でダイスを振るボタンを押してやらなければならないってのは、いかがなものか。

 この辺を手直しすれば、とりあえずは完成と言えるかな?

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20160516

2016-05-13

サイコロキャラメルを振るよ!

| 21:29

 ある意味本題(爆)の、サイコロキャラメルが振れるようになりましたw

 別に、んなに再現性は高くないし、もちろん明治のロゴとか入ってるわけじゃなく、単なる赤白のサイコロってだけなんですけれどねぇ~www

 結局、全部の色設定を配列にして引数にすることにした~。

 サイコロキャラメルは、全部の面の色が同じカラーリングなんだから、こんな必要ないじゃんとか、角丸じゃないから画像合成通の必要ないじゃんとかゆう野暮なツッコミは不可です!

 おもちゃみたいな、全面色違いのサイコロとかも作りたいんだよ~ん。


 そうそう、普通の一般的なサイコロの、1の目が赤いのは、日の丸に見立てたものなんだって!

 日本だけだったんだね・・・

 まめちしきぃ~。

 ちなみに、そうなったのは大正時代のことらしいから、もし時代劇の丁半博打の場で、目の赤いサイコロが使われていたら、早速テレビ局に電話しなきゃ!(爆)

#サイコロキャラメル

#-----母艦設計-----------------------------------------------
!母艦設計=「母艦の可視はオフ母艦のタイトルは「2Dを振る」
母艦のクライアント幅は640。母艦のクライアント高さは480。
母艦を$006600で画面クリア母艦のスタイルは「枠固定」
母艦オフに最大化ボタン有効変更。
母艦中央移動。
#------------------------------------------------------------

#-----宣言---------------------------------------------------
ダイスサイズとは整数=80

サイコロ一般とは配列。 #サイズ{~}線色,地色,点色{~}...
サイコロ一般=「{ダイスサイズ}
{黒色},{白色},{赤色}
{黒色},{白色},{黒色}
{黒色},{白色},{黒色}
{黒色},{白色},{黒色}
{黒色},{白色},{黒色}
{黒色},{白色},{黒色}」

サイコロ赤とは配列。
サイコロ赤=「{ダイスサイズ}
{黒色},{赤色},{白色}
{黒色},{赤色},{白色}
{黒色},{赤色},{白色}
{黒色},{赤色},{白色}
{黒色},{赤色},{白色}
{黒色},{赤色},{白色}」

サイコロ白とは配列。
サイコロ白=「{ダイスサイズ}
{黒色},{白色},{赤色}
{黒色},{白色},{赤色}
{黒色},{白色},{赤色}
{黒色},{白色},{赤色}
{黒色},{白色},{赤色}
{黒色},{白色},{赤色}」

サイコロ虹とは配列。
サイコロ虹=「{ダイスサイズ}
{$330000},{$FFBBBB},{$CC3333}
{$003300},{$BBFFBB},{$33CC33}
{$000033},{$BBBBFF},{$3333CC}
{$330033},{$FFBBFF},{$CC33CC}
{$333300},{$FFFFBB},{$CCCC33}
{$003333},{$BBFFFF},{$33CCCC}」

#---サイコロ用イメージ----
線太さ=1
ダイス用¥1にサイコロ赤でサイコロ準備
ダイス用¥2にサイコロ白でサイコロ準備

処理用とはイメージの可視はオフ。

#---サイコロ振るボタン----
ボタンAとはボタンの可視はオンの幅は110。の高さは35。
のXは母艦のクライアント幅/2-ボタンAの幅/2。のYは母艦の高さ-100。
のテキストは「サイコロを振る」

ボタンAをクリックした時は~
  サイコロ振る。
#------------------------------------------------------------

#-----メインルーチン-----------------------------------------
母艦の可視はオン乱数初期化。

サイコロ振る
#------------------------------------------------------------

#------------------------------------------------------------
*サイコロ振る
  処理用をダイスサイズ,ダイスサイズへ画像高速リサイズ。
  2
    r=6の乱数。出目¥(回数-1)=r+1。
    x=r*ダイスサイズ。y=0。
    ダイス用¥回数のx,y,ダイスサイズ,ダイスサイズを処理用の0,0へ画像部分コピー。
    処理用を母艦の((母艦のクライアント幅/4)*(回数))-(ダイスサイズ/2)+(母艦のクライアント幅/8),(母艦のクライアント高さ/2)-(ダイスサイズ/2)へ画像合成通。
#------------------------------------------------------------
*サイコロ準備({グループ}imgにSで)
  imgをイメージとして作成。
  img→可視はオフ。
  img→幅はS\0*6
  img→高さはS\0
  imgを$00FF00で画面クリア。    #透過色
  目サイズ=S\0/8。
  6
    色設定とは配列。色設定=S\回数。
    線色は色設定¥0。塗り色は色設定¥1。
    外枠(img,S\0)
    線色は色設定¥2。塗り色は色設定¥2。
    もし回数=1ならば
      半径=目サイズ+S\0/40。
      中点(img,S\0)。
    もし回数=2ならば
      半径=目サイズ。
      左上点(img,S\0)。右下点(img,S\0)。
    もし回数=3ならば
      半径=目サイズ。
      中点(img,S\0)。左上点(img,S\0)。右下点(img,S\0)。
    もし回数=4ならば
      半径=目サイズ。
      左上点(img,S\0)。左下点(img,S\0)。右上点(img,S\0)。右下点(img,S\0)。
    もし回数=5ならば
      半径=目サイズ。
      中点(img,S\0)。左上点(img,S\0)。左下点(img,S\0)。右上点(img,S\0)。右下点(img,S\0)。
    もし回数=6ならば
      半径=目サイズ-S\0/80。
      左上点(img,S\0)。左下点(img,S\0)。右上点(img,S\0)。右下点(img,S\0)。左中点(img,S\0)。右中点(img,S\0)。

*外枠({グループ}img,S)
  x=(回数-1)*S。y=0。
  x2=x+S。y2=S。
//  imgのx,yからx2,y2へS/3,S/3で角丸四角。
  imgのx,yからx2,y2へ四角。

*中点({グループ}img,S)
  xx=(x+S/2)-半径。yy=S/2-半径
  xx2=(x+S/2)+半径。yy2=S/2+半径。
  imgのxx,yyからxx2,yy2へ。

*左上点({グループ}img,S)
  xx=(x+S/4)-半径。yy=S/4-半径
  xx2=(x+S/4)+半径。yy2=S/4+半径。
  imgのxx,yyからxx2,yy2へ。

*左下点({グループ}img,S)
  xx=(x+S/4)-半径。yy=(S/4)*3-半径
  xx2=(x+S/4)+半径。yy2=(S/4)*3+半径。
  imgのxx,yyからxx2,yy2へ。

*右上点({グループ}img,S)
  xx=(x+S/4*3)-半径。yy=S/4-半径
  xx2=(x+S/4*3)+半径。yy2=S/4+半径。
  imgのxx,yyからxx2,yy2へ。

*右下点({グループ}img,S)
  xx=(x+S/4*3)-半径。yy=(S/4)*3-半径
  xx2=(x+S/4*3)+半径。yy2=(S/4)*3+半径。
  imgのxx,yyからxx2,yy2へ。

*左中点({グループ}img,S)
  xx=(x+S/4)-半径。yy=S/2-半径
  xx2=(x+S/4)+半径。yy2=S/2+半径。
  imgのxx,yyからxx2,yy2へ。

*右中点({グループ}img,S)
  xx=(x+S/4*3)-半径。yy=S/2-半径
  xx2=(x+S/4*3)+半径。yy2=S/2+半径。
  imgのxx,yyからxx2,yy2へ。
#------------------------------------------------------------
●画像合成通({グループ}コピー元を{数値=$00FF00}透過色で{グループ}コピー先のX,Yへ)
  # マスクの作成(キャラの透過部分が白、表示部分が黒の画像)
  マスク画像をイメージとして作成。マスク画像の可視はオフ。
  マスク画像→画像はコピー元→名前
  マスク画像を透過色で画像マスク作成

  # キャラの透過色部分を黒に変換
  # はじめからキャラの透過色を黒にすると髪や目や文字に黒が使用出来なくなる
  キャラ画像をイメージとして作成。キャラ画像の可視はオフ
  キャラ画像→画像はコピー元→名前
  マスク画像を画像ネガポジ
  マスク画像をキャラ画像の0,0へ画像ANDコピー
  マスク画像を画像ネガポジ

  # 合成実行
  マスク画像をコピー先のX,Yへ画像ANDコピー
  キャラ画像をコピー先のX,Yへ画像ORコピー
 
  VCL_FREE(マスク画像)
  VCL_FREE(キャラ画像)
#------------------------------------------------------------

 なにがでるかな? なにがでるかな? .... .... ....

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20160513

2016-05-12

基本的な機能は完成

| 19:24

 前に作った、2Dを振るプログラムと合体させるだけで、実際にボタンAを押したら、サイコロが振れるようになります。

 前、実はこまで出来てはいたんだけど、ダイスの見た目をサイコロキャラメルに合わせたらどうかしらとか、しょーもないことを考えていたんだよね。

 サイコロ準備の線色塗り色を変えれば、ダイスの色は簡単に変更出来るのだけれど、2Dを別々の色で表示することまでは考えていなかった。

 2Dを赤白にするためには、サイコロ用の裏画面を2つ用意しなくちゃならないし、サイコロ準備の色指定はのところ決め打ちなので・・・もちろん、サイコロ準備をコピペして赤白2色分作れば簡単にできるんだけど、それをやったら負けでしょ(?)

 かといって、全部の色設定を引数にするってのもねぇ~。一体いくつ引数がつくことになるんだよ・・・(--;

 なにか、スマートな良い方法はないもんか・・・と考えていたんだけど、よく考えたらもサイコロ準備自体が全くスマートじゃないんだから、ダメだこりゃ;・・・とゆうことに気が付いたので、とりあえず一旦保留にして、元のふつーのダイスのままで先に進むことにした(爆)


 さて、得点計算は、前書いた通り、6ゾロならぴったり36点、1ゾロなら0点。それ以外のゾロ目は、二つの目の、普通の出目なら二つの目の和。

 得点加算で、この計算結果を、プレイヤー得点と、コンピューター得点に、っくり同じ手順で代入しているのは、いかにも無駄っぽいけれど、気にしないで!;;;

 得点表示では、この加算結果をタダ表示するだけだとつまらないので、小さく縮小したサイコロの画像で、実際の出目を一緒に表示することにした。

#・手番交代、得点計算、得点とミニダイスの表示

#-----2Dを振る---------------------------------------------
*サイコロ振る
  カウント=カウント+1
  2
    処理用をダイスサイズ,ダイスサイズへ画像高速リサイズ。
    r=6の乱数。出目¥(回数-1)=r+1。
    x=r*ダイスサイズ。y=0。
    裏画面のx,y,ダイスサイズ,ダイスサイズを処理用の0,0へ画像部分コピー。
    処理用を母艦のトレイx+((トレイ幅/3)*回数-ダイスサイズ/2),トレイy+(トレイ高さ/2-ダイスサイズ/2)へ画像合成通。

    # 得点表示用にミニダイスを表示
    処理用をミニダイス,ミニダイスへ画像リサイズ。
    もし、手番=プレイヤーならば
      得点表示x=プレイヤーx+10+(ミニダイス+10)*(回数-1)
      得点表示y=マージン*2+10+(ミニダイス+10)*(カウント/2)
      処理用を母艦の得点表示x,得点表示yへ画像合成通。
    違えば
      得点表示x=コンピューターx+10+(ミニダイス+10)*(回数-1)
      得点表示y=マージン*2+10+(ミニダイス+10)*((カウント-1)/2)
      処理用を母艦の得点表示x,得点表示yへ画像合成通。
#------------------------------------------------------------
*得点計算
  もし、(出目¥0)=(出目¥1)ならば   # ゾロ目
    もし、(出目¥0)=6ならば      # 6ゾロ
      得点=36。
      文字色赤色。
    違えばもし、(出目¥0)=1ならば  # 1ゾロ
      得点=0。
      文字色青色。
    違えば                 # の他のゾロ目
      得点=出目¥0*出目¥1。
      文字色黒色。
  違えば                   # 平目
    得点=出目¥0+出目¥1。
    文字色黒色。

*得点加算
  もし、手番=プレイヤーならば
    もし、得点=36または得点=0ならば
      プレイヤー得点=得点
      得点表示。
    違えば
      プレイヤー得点=プレイヤー得点+得点
      もし、プレイヤー得点>=36ならば
        文字色赤色。
        プレイヤー罰点=プレイヤー得点-36
      得点表示。
    手番=コンピューター。

  違えば
    もし、得点=36または得点=0ならば
      コンピューター得点=得点
      得点表示。
    違えば
      コンピューター得点=コンピューター得点+得点
      もし、コンピューター得点>=36ならば
        文字色赤色。
        コンピューター罰点=コンピューター得点-36
      得点表示。
    
    # 勝負がついたかどうかを確認
    もし、(プレイヤー得点>=36)または(コンピューター得点>=36)ならば
      ボタンAのテキストは「勝敗判定」
      の有効はオフ。
    違えばもし、カウント=19ならば  # 得点表示用に表示出来る上限が10なので
      ボタンAのテキストは「無効試合」
      の有効はオフ。
    違えば
      手番=プレイヤー。

*得点表示
  文字書体は「MS ゴシック|16|太字」。
  もし、手番=プレイヤーならば
    得点表示x=プレイヤーx+20+(ミニダイス+10)*2
    得点表示y=マージン*2+10+(ミニダイス+10)*(カウント/2)
    母艦の得点表示x,得点表示y,ミニダイス,ミニダイスへ右,中央でプレイヤー得点を枠内文字描画。

  違えば
    得点表示x=コンピューターx+20+(ミニダイス+10)*2
    得点表示y=マージン*2+10+(ミニダイス+10)*((カウント-1)/2)
    母艦の得点表示x,得点表示y,ミニダイス,ミニダイスへ右,中央でコンピューター得点を枠内文字描画。

#------------------------------------------------------------

 とりあえず、今日ここまで。

 一応、もう一通りは遊べるようになりました。

 得点表示の部分を見れば、別に一目で勝ち負けも分かるけど、やはりちゃんとプログラムのほうで判定して、言って欲しいところ。

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20160512

2016-05-10

新幹線とサイコロキャラメルと

| 14:38

 連休中に北海道新幹見てきた!(乗ったわけではない;)

 東京まで、4時2分なんだってさ。在来の札幌函館とほとんど変わらんね(驚)

 でも、札幌まで延伸されるまでは、もう見る機会ないかも~;;;

f:id:snowdrops89:20160510143447j:image


 それはさておき、明治のサイコロキャラメルが販売終了ってマヂか?!

 水曜どうでしょうのサイコロの旅は、一体どうなるんだ?!

 ・・・じゃなくて、長い汽車旅のの、心の友じゃないか~!!

 (ワタシのサイコロ好きは、TRPG以前に、ここから始まっている)


 ・・・とゆうわけで、当時汽車の中でサイコロキャラメルを使って盛り上がったゲームを作るよ!(なでこらはどうした?!)

 前に2Dを振ってみたのを利用して、折角だから2Dを使ったサイコロゲームにしてみようと思う。

 2Dを使うといえば、当然っ先に思い浮かぶのが時代劇でおなじみの丁半博打ですが、ゲームとして考えると、ちょぼいちと同じ、数当て遊びなんだよね。

 しかもちょぼいちでは、1~6の出目を当てるのに対して、丁半は結局、当てるのは偶数か奇数の二択なんで、実際の博打となればまた違うかも知れないけど、コンピューターゲームとしては単調でたいして面白くもないだろう。

 2Dを使った遊びは他にも色々ありますが、は「36(Thirty-six)」の予定。

 とりあえずこれは、簡単に言えば、二人で2Dを振り合い、点数を累計していき、早く36になった方が勝ちというゲーム。

 同様の、得点累計型のダイスゲームに、「21(Twenty-one)」と「50(Fifty)」ってのがあり、どうもこの2つのほうが有名みたいだ。

 しかも、うちのは何かローカルルールなのか、検索してみると色々うちのとは違うことが書いてあったりもするんだけど、いいんだい!

 ちょっとユキノ家ルールを整理してみる。

【21(Twenty-one)】
 二人で交互に六面ダイス二個を振り合い、二合計が21に近い方が勝ち。
 ただし、21を越えたらバスト(アウト)という、ダイス版ブラックジャック。
 双方二振り終えた段階で、どちらもバストしていなければ、出目の少ない側が、
ヒットする(もう一振る)かどうか選択できます。
 ヒットされた場合、もう一方は、の出目が17以上ならスタンドする(振らない)
こともできますが、17未満なら必ず振らねばなりません。
 ヒットした側は、最大3までヒットし続けることができ、もう一方は、自分が17
を越えたらスタンドするかどうか選択できるようになります。
 ただし一度スタンドしたらそれ以降は、相手が何ヒットしても、もう振れません。
【36(Thirty-six)】
 二人で交互に六面ダイス二個を振り合い、点数を累計してゆきます。
 2個の目の和が、のまま点数になり、ゾロ目の場合は2個の目のが点数と
なりますが、1ゾロの場合はそれまでの点数の累計がクリアされ0点になります。
 早く36点に達した方が勝ちとなりますが、先攻後攻はなく両者同じ回数だけ
ダイスを振ることが出来るため、双方同時に上がった場合は、36を越えた分が
罰点となり、より罰点の少ない方が勝ちとなります。
 なお、6ゾロで上がった場合は、それまでの累計に関わらず、36点ぴったり
での上がりとなり罰点はなく、また、通常の累計での上がりに優先します。
 罰点も同数の場合や両者ともに6ゾロで上がった場合は、引き分けとなります。
【50(Fifty)】
 数人で順番に六面ダイス二個を振り、ゾロ目を出すと点数がもらえます。
 点数を累計してゆき、早く50点に達した人が勝ち。
 6ゾロがボーナスで25点、それ以外のゾロ目は5点。ただし、3ゾロの場合は、
それまでの点数の累計がクリアされ0点。ゾロ目以外の目は無得点です。
  1-1…5点、2-2…5点、3-3…それまでの点数の累計がクリアされ0点になる
  4-4…5点、5-5…5点、6-6…25点
 これは36とは違い、先に振る人が有利になるゲームなので、最初にはじめる時は
ダイスの目の大小などで順番決めを行い、それ以降は勝った人の次の人からスタート
(勝った人が順番の一番最後になる)します。

 全て、サイコロを振っては得点を累計し、定められた数を目指すという意味では、同様の遊びで、出目によって得られる点数の付け方と、目指すべき数をオーバーした場合の処遇が異なるだけなんだよね。

 ゲームとして一番面白いのは、「21」なんだけど、これはトランプのブラックジャックをサイコロでやる的な遊びだから、コンピューターもちょっとは考えなくちゃいけない

 相手があんまりバカすぎると、面白くない

 ・・・というわけで、たいしたことを考える訳じゃ無いんだけど、コンピューターが何か考えるゲームはまだ作ったことがないから、これは後の課題として、とりあえずは、単に点数を累計していくやつを作るよ!

 「50」は一番単純で、しかも、得点なんて計算する必要もなく駅弁の包装紙に正の字でも書いていけばいいんで、汽車の中なんかで暇つぶしするには丁度いい遊びだったんだけど、ゾロ目の時しか得点がもらえないから結構時がかかっちゃって、暇つぶしにしても、対コンピューターの場合、飽きてしまうだろう。

 だいたい、計算はなでしこさんがやってくれるからね。

 ・・・能書きが長くなったけど、いうわけでは「36」w


 今日はとりあえず、画面設計だけ。

 無駄にこの見た目にこだわるから、なんか、こんなことに一番時がかかったりするんだよね~www

 しかし、のわりには、しょぼいけどねぇ~;;;

#-----------------------------------------------------------------------
# 36(Thirty-six)
#-----------------------------------------------------------------------

#-----母艦設計-----------------------------------------------
!母艦設計=「母艦の可視はオフ」

#---メニュー----
『#親部品名,部品名,テキスト,ショートカット,オプション,イベント
なし,ファイルメニュー,ファイル(&F),,,
 -,新規メニュー,新しいゲーム(&N),Ctrl+N,,新規ゲーム
 -,-,,,,
 -,閉じるメニュー,閉じる(&X),Ctrl+X,,終わる
なし,ヘルプメニュー,ヘルプ(&H),,,
 -,ルールメニュー,遊び方(&R),Ctrl+R,,遊び方
 -,-,,,,
 -,バージョンメニュー,バージョン情報(&A),Ctrl+A,,バージョン
』をメニュー一括作成。

#---母艦----
母艦のタイトルは「36(Thirty-six)」
母艦のクライアント幅は640。母艦のクライアント高さは480。
母艦を$FFDDAAで画面クリア母艦のスタイルは「枠固定」
母艦オフに最大化ボタン有効変更。
母艦中央移動。
#------------------------------------------------------------

#-----宣言---------------------------------------------------
マージンとは整数=15

#---サイコロ振るところ----
トレイ幅とは整数=350
トレイ高さとは整数=310
トレイxとは整数。トレイx=(母艦のクライアント幅/2)-(トレイ幅/2)
トレイyとは整数。トレイy=30

ダイストレイとはイメージの可視はオフの幅はトレイ幅。の高さはトレイ高さ。
ダイストレイを$006600で画面クリア。
ダイストレイを母艦のトレイx,トレイyへ画像コピー。

#---メッセージ出すところ----
テキストウィンドウ幅とは整数=610
テキストウィンドウ高さとは整数=115
テキストウィンドウxとは整数=マージン
テキストウィンドウyとは整数。テキストウィンドウy=トレイ高さ+トレイy+マージン

テキストウィンドウとはイメージの可視はオフの幅はテキストウィンドウ幅。の高さはテキストウィンドウ高さ。
テキストウィンドウを$222222で画面クリア。
テキストウィンドウを母艦のテキストウィンドウx,テキストウィンドウyへ画像コピー

#---得点計算するところ----
得点表示幅とは整数=110
得点表示高さとは整数=310
プレイヤーxとは整数=マージン
コンピューターxとは整数母艦のクライアント幅-(マージン+得点表示幅)
得点表示xとは整数。
得点表示yとは整数=マージン

得点表示用とはイメージの可視はオフの幅は得点表示幅。の高さは得点表示高さ。
得点表示用を白色画面クリア。

得点表示用を母艦のプレイヤーx,得点表示y*2へ画像コピー。
得点表示用を母艦のコンピューターx,得点表示y*2へ画像コピー文字書体は「MS ゴシック|12|太字」
母艦のプレイヤーx,0,得点表示幅,得点表示y*2-1へ「プレイヤー」を中央,下で枠内文字描画母艦のコンピューターx,0,得点表示幅,得点表示y*2-1へ「コンピューター」を中央,下で枠内文字描画。

#---サイコロ振るボタン----
ボタンAとはボタン。#の可視はオフの幅は100。の高さは30。
のXはトレイx+(トレイ幅/2-ボタンAの幅/2)。のYはトレイ高さ+トレイy-ボタンAの高さ。
#------------------------------------------------------------

#-----メインルーチン-----------------------------------------
母艦の可視はオン。

#------------------------------------------------------------
●枠内文字描画({グループ=?}OBJのX,Y,W,HへSをA,Vで)
  xxとは整数。yyとは整数。
  もし、A=左ならば
    xx=X
  違えばもし、A=中央ならば
    xx=X+(W-(Sの文字幅取得))/2
  違えばもし、A=右ならば
    xx=(X+W)-(Sの文字幅取得)
  もし、V=上ならば
    yy=Y
  違えばもし、V=中央ならば
    yy=Y+(H-(Sの文字高さ取得))/2
  違えばもし、V=下ならば
    yy=(Y+H)-(Sの文字高さ取得)
  OBJのxx,yyへSを文字描画。
#------------------------------------------------------------

 サイコロを振るダイストレイと、テキストウィンドウ、して、得点計算用紙です。

 単なるべた塗りなのに無駄にイメージ部品なのは、これ母艦コピーしてやると楽に表示をクリア出来るからでもあり、本当はかっこいいグラフィックを用意して、らしい画面にしたいという虚しい希望の表れでもあります

 ボタンAは、サイコロを振るボタンですが、状況によって違う機能も持たせるつもりです。

 ちょぼいちの時は、当初んな構想ではなく名前を決めてしまい、なんだか妙な感じになったので、は素っ気ない名前にしました。

 これと、先日の2Dを振るプログラムをくっつければ、簡単に交互にサイコロを振るプログラムはできるから、後は得点を計算して表示することと、勝ち負けを判定するだけだね。

 うん、すぐ出来そう

 さくっと作って、なでこらに戻・・・れるかな?(爆)


 そうそう、ちょぼいちの時から、なんか変だなと思いつつスルーしてたんですが、「母艦のクライアント高さ」は、メニュー作成した後に設定しないと、実際に使える高さは、「母艦のクライアント高さ-メニューの高さ」となってしまうようです。

 ・・・なんて、い、さら過ぎる(--;;;

 なでこらの画面作成時に気づいたんだけど、書くの忘れてたから、一応書いとく。

通り道通り道2016/05/10 20:32さいころではないけれど、6面体つながりで。
$GREED(専用の6面体6個使う。多人数向き)とか結構好きですが、さいころは手で振ってこそというところもあるので、難しいところです。

雪乃☆雫雪乃☆雫2016/05/10 20:52通り道さん、こんにちは☆
グリードも広義のダイスゲームとゆうことになるでしょうね。
ダイスは必ずしも1~6の数が刻まれているものだけじゃないし、6面とも限らないですもんね~。
手で振ってこそと言うのは全くその通りで、タダ手の中で転がしてるだけで楽しいシロモノが、コンピューターに振らすと途端につまらなくなるってゆうか(汗)

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20160510