Hatena::Groupnadesiko

雪乃☆雫のなでしこ日和

2016/09/22 (木)

INIファイルで成績表

| 04:16 | INIファイルで成績表 - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - INIファイルで成績表 - 雪乃☆雫のなでしこ日和 INIファイルで成績表 - 雪乃☆雫のなでしこ日和 のブックマークコメント

 久々の、新しい学習・・・かもしない

 なでしこで、一番最初に作ったプログラム、『15パズル』を作った時には、まだINIファイルってものを、よく知らなかった。

 の命令があるのは見ていても、何するもんだか分かってなかった。

 だから、ハイスコアの表示を作った時も、うだうだ考えた挙げ句、手数やタイムの数値を単にテキストファイルに保存して、配列として扱っていたんだけど、あの頃よりはワタシも色々とひらめいて、だいぶ賢くなったんだからね!

 ハイスコアだけじゃなくて、ゆくゆくはキーコンフィグなどの設定情報なども、INIファイルに保存しておけるようにしたいとゆう希望なんだケド、まあとにかく手始めに、ハイスコアの表示をINIファイルでやってみる。

#-----------------------------------------------------------
# INI
設定ファイル名とは文字列=「{母艦パス}なでこら.ini」
ハイスコア表示件数とは整数=10
成績とは整数。
#-----------------------------------------------------------

#-----成績表------------------------------------------------------------
*成績記録
  設定ファイル名のINI開いてコンフィグに代入。
  Cとは整数。記録とは整数。順位とは整数=0
  Cをハイスコア表示件数から1まで繰り返す。
    記録=(成績[C-1,1])を整数変換。
    もし、記録<スコアならば、順位=C。
  Cをハイスコア表示件数から1まで繰り返す。
    もし、順位=0でなければ、
      もし、順位=Cならば、
        コンフィグで「ハイスコア」の「Date_{C-1}」に今日INI書く。
        コンフィグで「ハイスコア」の「Score_{C-1}」にスコアをINI書く。
        コンフィグで「ハイスコア」の「Level_{C-1}」にレベルをINI書く。
      違えばもし、順位<Cならば、
        コンフィグで「ハイスコア」の「Date_{C-1}」に成績[C-2,0]をINI書く。
        コンフィグで「ハイスコア」の「Score_{C-1}」に成績[C-2,1]をINI書く。
        コンフィグで「ハイスコア」の「Level_{C-1}」に成績[C-2,2]をINI書く。
  コンフィグのINI閉じる。
  成績読み込み。
  もし、順位=0でなければ、
    ダイアログタイトルは「新記録!」
    「おめでとうございます。{改行}ハイスコアが出ました☆{改行}{改行}歴代{順位を2で文字列右寄せ}位のスコアです。」と言う。
    成績表表示。

*成績読み込み
  もし、設定ファイル名が存在するならば
    設定ファイル名のINI開いてコンフィグに代入。
    (ハイスコア表示件数)
      Cとは整数。C=回数-1
      コンフィグで「ハイスコア」の「Date_{C}」をINI読んで成績[C,0]に代入。
      コンフィグで「ハイスコア」の「Score_{C}」をINI読んで成績[C,1]に代入。
      コンフィグで「ハイスコア」の「Level_{C}」をINI読んで成績[C,2]に代入。
    コンフィグのINI閉じる。
  違えば
    成績クリア
#-----------------------------------------------------------
*成績表表示
  文字書体は「MS ゴシック」
  HSとは文字列=「   ★☆★ ハイスコア ★☆★」&改行&改行
  (ハイスコア表示件数)
    Cとは整数回数-1。
    Dとは文字列。D=(成績[C,0])を文字列変換もし、D=0ならば、D=「----/--/--」
    Sとは文字列。S=(成績[C,1])を文字列変換もし、S=0ならば、S=「-------」
    Lとは文字列。L=(成績[C,2])を文字列変換もし、L=0ならば、L=「--」
    HS=HS&「{回数を2で文字列右寄せ}位 {Sを7で文字列右寄せ}点 {Lを2で文字列右寄せ}レベル {D}」&改行
  ダイアログタイトルは「成績表」
  HSを言う。

*成績リセット
  ダイアログタイトルは「成績表リセット」
  「リセットしてもいい?」と二択。
    もしそれはいならば、成績クリア

*成績クリア
    設定ファイル名のINI開いてコンフィグに代入。
    (ハイスコア表示件数)
      Cとは整数。C=回数-1
      コンフィグで「ハイスコア」の「Date_{C}」に0をINI書く。
      コンフィグで「ハイスコア」の「Score_{C}」に0をINI書く。
      コンフィグで「ハイスコア」の「Level_{C}」に0をINI書く。
      コンフィグで「ハイスコア」の「Date_{C}」をINI読んで成績[C,0]に代入。
      コンフィグで「ハイスコア」の「Score_{C}」をINI読んで成績[C,1]に代入。
      コンフィグで「ハイスコア」の「Level_{C}」をINI読んで成績[C,2]に代入。
    コンフィグのINI閉じる
#-----------------------------------------------------------------------

 成績読み込みは、起動時に行い、成績記録は、ゲームオーバー時に行う。

 表示のものは、相変わらずの「言う」であるwww


 あと、さらですけど、これまでは起動するといきなりゲームが始まってて、メニューの新規ゲームはダミーで、ゲームオーバーするごといちいち再起動必要だったんだけど、ようやくちゃんとしました;

#-----------------------------------------------------------------------
*新規ゲーム
  固定石初期化。
  メイン画面初期化。
  消去数=0。レベル=0。スコア=0

  次石決定。
  次石落下。
  落下処理。
  メインループ。
#-----------------------------------------------------------------------
トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20160922