Hatena::Groupnadesiko

雪乃☆雫のなでしこ日和

2016-10-29

ジョイパッドを使うよ!

| 05:32

 ファイターズが10年ぶりの日本一!

 いや~、めでたいね、こりゃ\(^▽^)/



 さて・・・

 とりあえず、なでコラをジョイパッドで遊べるようにすること自体は、簡単でした。

 まえに、サンプルのなでりすでやってみたように、「キー処理」のサブルーチンをコピペして、「JOYキー処理」とでもして、「キー状態」を「JOYキー状態」に書き換えてやったらふつーに動きます。

 でもなあ、んなことでいいのか、本当に?!?!(汗)

 ・・・だけど、「または」で、一つにまとめようとすると、ジョイパッドがつながってる時はいいんだけど、つながっていない時のキーボードでの動きが、異常に悪くなるんだよね。

 なんでーなるのか、よく分からん(--;;;

 ・・・とゆうわけで、ものすごく無駄っぽく、ほとんど同じ風味なコードで行数を使ってしまうけど・・・取りあえず動けばOK!

 ・・・ってことにしておく。むむむ。



 さて、の、前のなでりすを試しに改造してみた時には、知恵が足りなくて、十字キーの状態をお手軽に別関数にしてしまっていたんだけど・・・

 ・・・「ほんっとバカだよなー、こいつ(爆)」・・・みたいな感じで、一つにまとめたwww

 文字列「U,R,D,L」の代わりに数値「$1000,$2000,$4000,$8000」を与えることにしただけです。

 ついでに、単にジョイパッドが接続されてるかどうかを返す関数と、JOYキー状態とは逆に、押されているジョイパッドのボタンのキーを返す関数追加して、のワタシの知恵ではこれが限度だけど、とりあえずキーコンフィグようの準備は整った・・・かもしない

 取りあえず、こんな感じ。

#-----------------------------------------------------------------------
# ジョイパッドの使用
#-----------------------------------------------------------------------
#『JOYパッド接続状態』
#・ジョイパッドが接続されてるかどうかをオン(1)かオフ(0)で返す。
#『JOYキー状態』
#・なでしこの「キー状態」と同じ感じで、ジョイパッドのボタン入力状態を調べ、オンオフを返す。
#『JOYキー取得』
#・押されているジョイパッドのボタンを返す。
#-----------------------------------------------------------------------
#※肝心のWindowsAPI部分は「なでしこ質問掲示板」の一般人さまの答による。
#http://nade.jp-pro.net/bbs/bbs/cbbs.cgi?mode=one&number=7435&type=7400&space=45&no=0
#-----------------------------------------------------------------------
!JOYERR_NOERROR = 0 //情報取得時にエラーがないときに返される値
!JOY_RETURNALL = 255 //Joystickの情報を全て取り込む値
//Joystickの情報を取り込む関数
●joyGetPosEx(uJoyID,{参照渡し}pji) =DLL("winmm.dll","UINT joyGetPosEx(UINT uJoyID,LPJOYINFOEX pji)")
//Joystickの最大サポート数(?)は未使用
●joyGetNumDevs =DLL("winmm.dll","UINT joyGetNumDevs(VOID)")

//JOYINFOEXの構造体をグループで構成
■JOYINFOEXとは
 ・dwSize
 ・dwFlags
 ・dwXpos
 ・dwYpos
 ・dwZpos
 ・dwRpos
 ・dwUpos
 ・dwVpos
 ・dwButtons
 ・dwButtonNumber
 ・dwPOV
 ・dwReserved1
 ・dwReserved2
#-----------------------------------------------------------------------
●JOYパッド接続状態
  もし、joyGetPosEx(0, POINTER(B))=JOYERR_NOERRORならばオン戻る。
  違えばオフ戻る。
#-----------------------------------------------------------------------
●JOYキー状態(Sで|Sの)
  AとはJOYINFOEX
  A.dwSize = 52 //Cで言うsizeof()がわからなかったためマジックナンバー
  A.dwFlags = JOY_RETURNALL
  Bとは文字列
  PACK(A,B,`DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD`)
  もし、joyGetPosEx(0, POINTER(B))=JOYERR_NOERRORならば
    UNPACK(B,A,`DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD`)
    もし、S=A.dwButtonsならばオン戻る。
    # $2777とか$D888とかの数値は暫定。アナログジョイスティックのための措置。
    違えばもし、S=$1000ならば、
      もし、(A.dwYpos<$2777)ならばオン戻る。  # UP (A.dwYpos=0)
      違えばオフ戻る。
    違えばもし、S=$2000ならば、
      もし、(A.dwXpos>$D888)ならばオン戻る。  # RIGHT (A.dwXpos=$FFFF)
      違えばオフ戻る。
    違えばもし、S=$4000ならば、
      もし、(A.dwYpos>$D888)ならばオン戻る。  # DOWN (A.dwYpos=$FFFF)
      違えばオフ戻る。
    違えばもし、S=$8000ならば、
      もし、(A.dwXpos<$2777)ならばオン戻る。  # LEFT (A.dwXpos=0)
      違えばオフ戻る。
    違えばオフ戻る。
  違えばキャンセル戻る。
#-----------------------------------------------------------------------
●JOYキー取得
  AとはJOYINFOEX
  A.dwSize = 52 //Cで言うsizeof()がわからなかったためマジックナンバー
  A.dwFlags = JOY_RETURNALL
  Bとは文字列
  PACK(A,B,`DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD`)
  もし、joyGetPosEx(0, POINTER(B))=JOYERR_NOERRORならば
    UNPACK(B,A,`DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD,DWORD`)
    JOY_KEY=A.dwButtons
    もし、(A.dwYpos<$2777)ならば、JOY_KEY=JOY_KEY+$1000      # UP (A.dwYpos=0)
    違えばもし、(A.dwYpos>$D888)ならば、JOY_KEY=JOY_KEY+$4000  # DOWN (A.dwYpos=$FFFF)
    もし、(A.dwXpos<$2777)ならば、JOY_KEY=JOY_KEY+$8000      # LEFT (A.dwXpos=0)
    違えばもし、(A.dwXpos>$D888)ならば、JOY_KEY=JOY_KEY+$2000  # RIGHT (A.dwXpos=$FFFF)
    もし、JOY_KEY=0ならばオフ戻る。
    違えば、JOY_KEYで戻る。
  違えばオフ戻る。
#-----------------------------------------------------------------------

#以下はテスト
#-----------------------------------------------------------------------
!母艦設計=「母艦の可視はオフ」
//!「ジョイパッドの使用.nako」を取り込む。

#---キー定義------------------
!JOY_UPとは整数=$1000
!JOY_RIGHTとは整数=$2000
!JOY_DOWNとは整数=$4000
!JOY_LEFTとは整数=$8000
!JOY_Aとは整数=$01
!JOY_Bとは整数=$02
#-----------------------------

#---母艦------------
母艦中央移動
母艦の可視はオン
#-----------------------------------------------------------------------

AとはエディタCX=母艦のクライアント幅/2-24/2
CY=母艦のクライアント高さ/2-24/2
文字書体は「MS ゴシック|24|太字」
母艦CX,CYへ「●」を文字表示。

#---動作テスト------------

# 『JOYパッド接続状態』
もし、JOYパッド接続状態=オンならば、「ジョイパッドを認識しました」を言う違えば、「ジョイパッドが接続されていません」を言う終わる。

# 『JOYキー状態オン
  もし(JOY_UPのJOYキー状態オン)ならば
    もし、(JOY_RIGHTのJOYキー状態オン)ならばCX=CX+3。CY=CY-3。
    違えばもし、(JOY_LEFTのJOYキー状態オン)ならばCX=CX-3。CY=CY-3。
    違えば、CY=CY-3。
  違えばもし(JOY_DOWNのJOYキー状態オン)ならば
    もし、(JOY_RIGHTのJOYキー状態オン)ならばCX=CX+3。CY=CY+3。
    違えばもし、(JOY_LEFTのJOYキー状態オン)ならばCX=CX-3。CY=CY+3。
    違えば、CY=CY+3。
  違えばもし(JOY_RIGHTのJOYキー状態オン)ならばCX=CX+3。
  違えばもし(JOY_LEFTのJOYキー状態オン)ならばCX=CX-3。

  もし、(JOY_AのJOYキー状態オン)ならば文字色赤色。
  違えばもし、(JOY_BのJOYキー状態オン)ならば文字色青色。
  違えば文字色黒色。
  母艦白色画面クリア
  母艦CX,CYへ「●」を文字表示。
//  0.01秒待つ

# 『JOYキー取得』
  もし、JOYキー取得=0でなければ、
    Aのテキストは、「${HEX(JOYキー取得)}」。
  0.01秒待つ
#-----------------------------------------------------------------------

 ジョイパッドがつながっていないと、接続されていませんと言って終わるだけだけどね;


※2017/01/29

 ちょっと修正しました。

 十字キーの割り当てですが、「U,L,R,D=$1000,$2000,$4000,$8000」としていましたが、パッドによっては、十字キーも「A.dwXpos」「A.dwYpos」を使わず、「A.dwButtons」を割り当てているヤツがあり、それ数値がどうやら、「U,R,D,L=$1000,$2000,$4000,$8000」となっているようだったので、のように。

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20161029

2016-10-25

別フォームの位置が・・・

| 16:16

 ちょっと、キーコンフィグ画面っぽいものを作って表示してみようとしただけなのにぃ~。しくしくしくしくしく。

 まだ、内容は無くて、表示用のフォームだけなんですよ。見た目から作る人だからさーw

 この、位置の設定が上手くいかないのさ~。

 どうしても、あらぬところに表示されてしまう。

#キーコンフィグ画面の実験
#-----------------------------------------------------------
!母艦設計=「母艦の可視はオフ」

#---母艦------------
母艦中央移動

#---キー設定画面--------------
設定窓とはフォーム。
設定窓をウィンドウ背景色画面クリアこれについて
  可視はオフ。幅は300。高さは310。
  スタイルは「枠固定」
  タイトルは「キーボードの設定」
//  位置は"{母艦のX},{母艦のY}"

タイトルラベルとはラベル
これについて
  親部品は設定窓。
  文字書体は「|11|太字」
  テキストは「キーボードの設定」

キー割当とはグループボックス。
これについて
  親部品は設定窓。位置は"10,40"。
  幅は(設定窓の幅-25)。高さは(設定窓の高さ-100)。

#---ボタン--------------------
OKボタンとはボタンこれについて
  親部品は設定窓。
  位置は"{設定窓の幅-180},{設定窓の高さ-55}"
  クリックした時は~
    設定窓を閉じる。

キャンセルボタンとはボタンこれについて
  親部品は設定窓。
  位置は"{設定窓の幅-90},{設定窓の高さ-55}"
  クリックした時は~
    設定窓を閉じる。

#---ラベルエディタを動的作成----
# ラベルのテキスト,X,Y,
配置とは配列=「上(転),100,20{~}左,40,60{~}右,160,60{~}下(落下),100,100{~}転,45,155{~}落下,155,155」
キー数とは整数=配置の要素数。

(キー数)
  Cとは整数。C=回数-1
  KEYラベル[C]をラベルとして作成。
  KEYラベル[C]→親部品はキー割当。
  KEYラベル[C]→文字位置は中央。
  KEYラベル[C]→テキストは配置[C,0]
  KEYラベル[C]→幅は80
  KEYラベル[C]→位置は"{配置[C,1]},{配置[C,2]}"

  KEYエディタ[C]をエディタとして作成。
  KEYエディタ[C]→親部品はキー割当。
  KEYエディタ[C]→幅は80
  KEYエディタ[C]→位置は"{配置[C,1]},{配置[C,2]+15}"
  KEYエディタ[C]→ポケットはC
#------------------------------------------------------------

母艦の可視はオン
キー設定開く

*キー設定開く
  設定窓の位置は"{母艦のX},{母艦のY}"
  設定窓をモーダル表示。
//  設定窓の可視はオン
#-----------------------------------------------------------

 色々試した結果、変になるのはスタイル指定のあるフォームだけで、可視をオンにした後設定すると、設定が正しく反映されるけど、オフのうちに設定したものは無視されちゃうっぽい。

 でも、可視をオンにした後に位置の設定をしたら、一瞬ちらっともとの位置にフォーム表示されるのが見えちゃうんだよね~。

 ーゆう、細かいことが気になっちゃうタイプなんだよね。別に、たいして誰かに見せるわけでも無いんだけどw

#スタイル指定のフォームの実験
#-----------------------------------------------------------
!母艦設計=「母艦の可視はオフ」
Fとはフォーム。
Fについて
  可視はオフ。
  スタイルは「枠固定」

//Fを中央移動     #A
//Fの位置は"10,10"   #A

Fの可視はオン

//Fを中央移動     #B
//Fの位置は"10,10"   #B
#-----------------------------------------------------------

 えー、んな感じだったかなあと、以前作った「ちょぼいち」を開いてみたところ・・・

https://nadesiko.g.hatena.ne.jp/snowdrops89/20160227/1456582078

 なんと、お金を賭けるフォームが、あらぬところに表示されるわ~;

 これを作った頃はまだ、だいぶ古いバージョンを使ってたんだよね。(2011年頃からしばらくナデシコちょしてなかったんだけど、丁度の頃使ってたバージョンが、や安定版と言われているらしいことが分かったので)

 っち(1.5332)使ったら、ちょぼいちはもとよりキーコンフィグの画面も、ちゃんと希望の場所に表示されました。

 最近治った、母艦中央移動が利かなかった件と同じような現象におもえるけど、やっぱり母艦とふつーのフォームは、違うんだねー。

 なんか、やっぱりまたバージョン戻すかなーw

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20161025

2016-10-21

脳トレ! 漢字まちがい探し

| 00:42

 取りあえず完成させたから載せとく。

 問題も増やしました。

 やってると、どんどんゲシュタルト崩壊してゆき、なんかもう脳トレどころじゃない~ヽ(;´Д`)ノ

#-----------------------------------------------------------------------
# まちがいさがし
#-----------------------------------------------------------------------

#-----母艦設計----------------------------------------------------------
!母艦設計=「母艦の可視はオフ」

#---メニュー----
『#親部品名,部品名,テキスト,ショートカット,オプション,イベント
なし,ファイルメニュー,ファイル(&F),,,
 -,新規メニュー,新しいゲーム(&N),Ctrl+N,,新規ゲーム
 -,-,,,,
 -,閉じるメニュー,閉じる(&X),Ctrl+X,,終わる
なし,ヘルプメニュー,ヘルプ(&H),,,
 -,ルールメニュー,遊び方(&R),Ctrl+R,,遊び方
 -,-,,,,
 -,バージョンメニュー,バージョン情報(&A),Ctrl+A,,バージョン
』をメニュー一括作成。

#---母艦----
母艦のタイトルは「まちがいさがし」
母艦白色画面クリア母艦のスタイルは「枠固定」
母艦オフに最大化ボタン有効変更。
母艦のクライアント幅は800。母艦のクライアント高さは600。
母艦中央移動
母艦のマウス押した時は~
  もし、(母艦のマウスX>正解x)かつ
  (母艦のマウスY>正解y)かつ
  (母艦のマウスX<正解x+文字幅)かつ
  (母艦のマウスY<正解y+文字高)ならば、
    ダイアログタイトルは「まちがいさがし」
    終了
    開始時から終了までの秒差で経過時計算。
    「正解!{改行}{改行}タイムは{改行}  {それ}です。」と言う。
    「もう一度?」で二択。
    もしそれはいならば、新規ゲーム。
    違えば終わる。
  違えばBEEP。
#-----------------------------------------------------------------------

#-----宣言--------------------------------------------------------------
問題とは配列=「大,犬,太{~}犬,尤{~}天,夭{~}千,干{~}人,入{~}日,曰{~}因,困
井,丼{~}王,玉,生,主{~}吉,舌,告{~}末,未,朱{~}矢,失,朱{~}己,巳,已{~}成,戌,戊
持,待,侍{~}内,肉{~}休,体{~}ぬ,め{~}ね,わ{~}る,ろ{~}る,ゐ
味,昧{~}裕,祐{~}崇,祟{~}栽,裁{~}微,徴{~}綱,網{~}輸,輪{~}輸,諭,愉{~}織,職,識
園,圓,圍{~}推,稚,椎{~}苦,苫{~}萩,荻{~}芽,茅{~}第,弟{~}季,李{~}杏,否,盃,杳
瓜,爪{~}晴,睛{~}到,致{~}斤,斥{~}酒,洒{~}治,冶{~}減,滅{~}釣,鈎,鉤」

出題とは配列
正解とは整数。
正解xとは整数。
正解yとは整数。

横とは整数=10。
縦とは整数=10。
総数とは整数=縦*横。

開始時とは整数終了とは整数。
カウントダウンとは配列=「③{~}{~}①」
CDとは整数文字書体は「|32|太字」
文字幅=「あ」の文字幅取得
文字高=「あ」の文字高さ取得

上マージンとは整数=20。
左マージンとは整数=20。
文字隔とは整数。文字隔=((母艦のクライアント高-上マージン*2)-(文字高*縦))/(縦-1)。
行隔とは整数。行隔=((母艦のクライアント幅-左マージン*2)-(文字幅*横))/(横-1)。
#-----------------------------------------------------------------------

#-----メインルーチン----------------------------------------------------
母艦の可視はオン乱数初期化。
遊び方。
新規ゲーム。

#-----新規ゲーム--------------------------------------------------------
*新規ゲーム
#---問題作成----
  r=問題の要素数乱数。
  問題¥rを配列シャッフル。
  出題は。
  (総数-1)
    出題に問題¥r,0を一行追加。
  出題に問題¥r,1を一行追加。
  出題を配列シャッフル。

#---正解の位置を記録----
  総数
    出題¥(回数-1)と問題¥r,1を文字列比較
    もしそれが0ならば、
      正解は(回数-1)
      抜ける
  正解x=(正解%横)*(文字幅+行隔)+左マージン。
  正解y=((正解/横)を切り下げ)*(文字高+文字隔)+上マージン。

#---カウントダウン----
  母艦白色画面クリア。
  文字書体は「|64|太字」
  x=(母艦のクライアント幅/2)-(「①」の文字幅取得/2)
  y=(母艦のクライアント高/2)-(「①」の文字幅取得/2)
  CD=3
  3
    もし、CD>0ならば、
     母艦のx,yへカウントダウン¥(回数-1)を文字表示。
     1秒待つ。CD=CD-1。
     母艦白色画面クリア。
    違えば抜ける。

#---画面表示----
  文字書体は「|32|太字」
  総数
    x=((回数-1)%横)*(文字幅+行隔)+左マージン。
    y=(((回数-1)/横)を切り下げ)*(文字高+文字隔)+上マージン。
    母艦のx,yへ出題¥(回数-1)を文字表示。

#---開始時----
  開始時

#------------------------------------------------------------
*遊び方
  ダイアログタイトルは「まちがいさがしについて」
  「【まちがいさがし】
   一個だけ、違う漢字が混じっています。
   出来るだけ早く見つけて、クリックして下さい。
   
   一つ一つ文字を追って、探すことに熱中するのではなく、
  なるべく視点を動かさずに、視野を広げて画面全体を見て、
  ぱっと見つけるようにするとよいそうです。
   漢字によって難易度が違うので、正解時に表示される
  秒数は目安ですが、一秒でも早く見つけるよう心がけます。」を言う。
#------------------------------------------------------------
*バージョン
  ダイアログタイトルは「バージョン情報」
  「{二重カッコ}まちがいさがし{二重カッコ閉じ}{改行} Version 1.00{改行}{改行} by 雪乃☆雫」と言う。
#------------------------------------------------------------

#------------------------------------------------------------
#秒差から00時00分00秒の形式で、経過時を返す。
●経過時計算(Aで)
  時=(A/3600)を切り下げ。
  分=((A-(時*3600))/60)を切り下げ。
  秒=(A)-(時*3600)-(分*60)
  時=時を2でゼロ埋め。分=分を2でゼロ埋め。秒=秒を2でゼロ埋め
  もし、(時=0)かつ(分=0)ならば、
    それは「{秒}秒」。
  違えばもし、時=0ならば
    それは「{分}分{秒}秒」。
  違えば、
    それは「{時}時{分}分{秒}秒」。
#------------------------------------------------------------
トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20161021

2016-10-12

早速ミスってるし!(--;

| 00:11

 でも、こっりなおしといた(爆)

 一遊んだ後、新規ゲームをしても、前のスコアやレベルの表示が画面に残ったままだった;

 数値自体はクリアしてるから、一石を消せば、ちゃんとなるんですが、画面に反映し忘れてた;;

 こはちゃんと見たつもりだったのに、全然見らさって無かったラシイ;;;

 まったく、しょーもないねえ┐( ̄ヘ ̄)┌

#-----------------------------------------------------------------------
*新規ゲーム
  固定石初期化。
  メイン画面初期化。
  消去数=0。レベル=0。スコア=0

  #↓↓↓
  スコア表示。
  レベル表示。
  消去数表示。
  レベルアップメータークリア。

  次石決定。
  次石落下。
  落下処理。
  メインループ。
#-----------------------------------------------------------------------

 

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20161012

2016-10-10

ひとまずの完成と、ダメらしい話し

| 09:08

 ・・・とゆうわけで(?)発覚した、問題点について。

 問題点は、天井近くまでみ上がっている時の挙動です。

 ワタシはね、んなんなったらもう、早々にあきらめですよw

 だから、考えもしなかったんだけど、石が消えた時点で、まだメイン画面に見えていない、天井より上の位置にも落下石があった場合に、それが消滅してしまう。

 また、石固定処理時に、石落下位置の天井に落下石の上端が達していると、こに消せる石があっても石を消去する前に、ゲームオーバーとなってしまう・・・など。

 後者は、なるほど確かに、石落下位置の上の方に同じ色が二個まさっていて、後一個同じ色が欲しい・・・というところへ望みの色の石が落ちてきたとしても、消えずに同色の石が3つくっついた物が表示された状態の画面でゲームオーバーになってしまうっていうのは、の分のスコアも当然入らないわけだから、ちょっともやもやしてしまうね。

 これは、たぶん連鎖まで終わらせた後にゲームオーバー判定を移動させれば、いいんだろう。

 しかし・・・

 天井より上の石が消滅してしまうっていうのは・・・なんかダメなの? むしろ、助かるような気が・・・と言ったら、「当たり前でしょ。こで、連鎖を起こして持ちこたえてこじゃん」っと言われてしまった。

 うえぇ~、マヂか?! 奥が深いな。ワタシには到底ムリだが;;;

 して、これを直すにはどうしたらいいんだ?

 固定石と消去石の配列を2段分大きくするとか・・・?



 ・・・なにげに直せそうではあるんだけど、なんかもう面倒だから、ひとまずこーいう仕様だと言い張る(えっ?!)

 天井の上にヨユウはなく、オーバーした石は消え失せるし、石落下位置があふれたら即アウトってことでっ;;;

 なぜなら、ちょっと忘れかけていたけど、ジョイパッドに対応したゲームでも作ってみようと思い立ったのがもの発端だったことを思い出したのです!(爆)

 っと言うわけで、気が向いたら、いずれこの問題は解決するかも知れないし、の際には、教えを頂いたことを元に、石消去の部分も全面的に見直すかも知れないけれど、とりあえずこのまま先に進みます~(ええぇっ;)



 でっ、取りあえずはこんな感じ~。

#-----------------------------------------------------------------------
# なでこらキーボード版 ダメっぽいけどver1.00
#-----------------------------------------------------------------------
# INI
設定ファイル名とは文字列=「{母艦パス}なでこら.ini」

#-----母艦設計----------------------------------------------------------
!母艦設計=「母艦の可視はオフ」

#---メニュー----
『#親部品名,部品名,テキスト,ショートカット,オプション,イベント
なし,ファイルメニュー,ファイル(&F),,,
 -,新規メニュー,新しいゲーム(&N),Ctrl+N,,新規ゲーム
 -,-,,,,
 -,成績表メニュー,成績表(&S),Ctrl+S,,成績表表示
 -,成績リセットメニュー,成績リセット(&D),Ctrl+D,,成績リセット
 -,-,,,,
 -,閉じるメニュー,閉じる(&X),Ctrl+X,,終わる
なし,設定メニュー,設定(&O),,,
 -,選択メニュー,コントローラー選択(&C),,,
 --,キーボード選択メニュー,キーボード(&K),,チェック,
 --,ジョイパッド選択メニュー,ジョイパッド(&J),,,
 -,-,,,,
 -,キーボード設定メニュー,キーボードのキー設定(&K),,,
 -,ジョイパッド設定メニュー,ジョイパッドのキー設定(&J),,,
なし,ヘルプメニュー,ヘルプ(&H),,,
 -,ルールメニュー,遊び方(&R),Ctrl+R,,遊び方
 -,-,,,,
 -,バージョンメニュー,バージョン情報(&A),Ctrl+A,,バージョン
』をメニュー一括作成。

設定メニューの有効はオフ。

#---母艦----
母艦のタイトルは「なでこら」
母艦を$FFBBAAで画面クリア母艦のスタイルは「枠固定」
母艦オフに最大化ボタン有効変更。
母艦のクライアント幅は330。母艦のクライアント高さは480。
母艦中央移動
#-----------------------------------------------------------------------

#-----宣言--------------------------------------------------------------
マス目とは整数=32。

石落下位置Xとは整数=マス目*3。
石落下位置Yとは整数=0-マス目*2。
落下Xとは整数=石落下位置X
落下Yとは整数=石落下位置Y

メインXとは整数=30。
メインYとは整数=50。
スコアXとは整数=メインX/2
スコアYとは整数=メインY/3
右辺ラベルXとは整数=メインX+マス目*6+25
ネクストXとは整数=メインX+マス目*6+40
ネクストYとは整数=メインY+30
レベルYとは整数=メインY+マス目*3+80
消去数Yとは整数=メインY+マス目*3+160
連鎖Yとは整数=メインY+マス目*12-50

石とは配列    #石の種類(形状,色)
石=「●,$DD0000
◆,$FF7700
■,$0077FF
★,$EEEE00
▲,$EE00EE
▼,$00DD00」
#-----------------------------------------------------------
次石とは配列   #次に落下する石
落下石とは配列  #落下中の石
固定石とは配列  #落下し終わり固定された石
消去石とは配列  #消去する予定の石
石消去フラグとは整数オフ。

# 移動可能かどうかを調べる
縦移動フラグとは整数オフ。
右移動フラグとは整数オフ。
左移動フラグとは整数オフ。

# 移動中かどうか
右移動中とは整数オフ。
左移動中とは整数オフ。

# 押しっぱなしかどうかを調べる
右キー押下状態とは整数オフ。
左キー押下状態とは整数オフ転キー押下状態とは整数オフ。

# キー設定
左移動キーとは整数=$25 #VK_LEFT
右移動キーとは整数=$27 #VK_RIGHT
落下キーとは整数=$28 #VK_DOWN
//転キーとは整数=$26 #VK_UP
転キーとは整数=$20 #VK_SPACE

# カウンター
消去数とは整数=0
連鎖数とは整数=1

# スコア・レベル表示
レベルとは整数=0
スコアとは整数=0

終了フラグとは整数オフ
#-----------------------------------------------------------
#---裏画面----
石用とはイメージ。
石用について。
  可視はオフ。
  幅はマス目*6。高さはマス目

マス目用とはイメージ
マス目用について
  可視はオフ。
  幅はマス目。高さはマス目。
  $332211で画面クリア。

石転用とはイメージ。
石転用について。
  可視はオフ。
  幅はマス目。高さはマス目*3。

メイン合成用とはイメージ
メイン合成用について
  可視はオフ。
  幅はマス目*6。高さはマス目*13。

#---画面----
表画面とはイメージ
表画面について
  Xは0。Yは0。
  幅は母艦のクライアント幅。高さは母艦のクライアント高さ。
  $FFBBAAで画面クリア。

メイン画面とはイメージ
メイン画面について
  可視はオフ。
  幅はマス目*6。高さはマス目*13。

次石表示用とはイメージ
次石表示用について。
  可視はオフ。
  幅はマス目。高さはマス目*3。

落下用とはイメージ
落下用について。
  可視はオフ。
  幅はマス目。高さはマス目*3。
#-----------------------------------------------------------
# 成績表
ハイスコア表示件数とは整数=10
成績とは整数。
成績読み込み
#-----------------------------------------------------------------------

#-----メインルーチン----------------------------------------------------
画面準備
母艦の可視はオン。

*新規ゲーム
  固定石初期化。
  メイン画面初期化。
  消去数=0。レベル=0。スコア=0
  スコア表示。
  レベル表示。
  消去数表示。
  レベルアップメータークリア。

  次石決定。
  次石落下。
  落下処理。
  メインループ。
#-----------------------------------------------------------------------
*メインループ
  終了フラグはオフ
  (終了フラグ=オフ)の
    0.01秒待つ
    もし、縦移動フラグ=オンならば
      落下処理。
    違えば
      石固定処理。
      次石落下。
#-----------------------------------------------------------------------
*次石決定
  3
    r=6の乱数。次石¥(回数-1)=r。
    x=r*マス目。y=0。
    石用のx,y,マス目,マス目を次石表示用の0,(回数-1)*マス目へ画像部分コピー。
    次石表示用を表画面のネクストX,ネクストYへ画像コピー。

*次石落下
  連鎖表示クリア。
  次石表示用を落下用の0,0へ画像コピー
  落下石=次石。
  次石決定
  落下X=石落下位置X。落下Y=石落下位置Y

  縦移動フラグ=オン

*落下処理
  LSとは整数=レベル*0.01   # 落下速度は「{(0.1-LS)*10}秒」
  10
    キー処理
    落下用をメイン合成用の落下X,落下Yへ画像コピー。
    メイン合成用を表画面のメインX,メインYへ画像コピー
    メイン画面をメイン合成用の0,0へ画像コピー。
    # 落下キーを押していない時のウェイト
    もし、落下フラグがオンでなければ、
      (0.1-LS)秒待つ。
    # 左右キーは押し続けた時は一気に動くが、連打した時は一マスごと動くようにする。
    もし、(左移動中=オン)かつ(左キー押下状態=オフならば、
      左キー押下状態=オン。
      0.1秒待つ。
    もし、(右移動中=オン)かつ(右キー押下状態=オフならば、
      右キー押下状態=オン。
      0.1秒待つ。

  落下Y=落下Y+マス目
  移動判定
#-----------------------------------------------------------------------
*キー処理
  # 左移動。
  もし(左移動キーのキー状態=オン)ならば
    移動判定
    もし、左移動フラグ=オンならば
      落下X=落下X-マス目。
      左移動中=オン。
  違えば、
    左キー押下状態=オフ。
    左移動中=オフ。

  # 右移動。
  もし(右移動キーのキー状態=オン)ならば
    移動判定
    もし、右移動フラグ=オンならば
      落下X=落下X+マス目。
      右移動中=オン。
  違えば、
    右キー押下状態=オフ。
    右移動中=オフ。

  # 石を落とす
  もし、(落下キーのキー状態=オン)ならば
    落下フラグ=オン
  違えば
    落下フラグ=オフ

  # 石を転
  もし、(転キーのキー状態=オンならば
    もし転キー押下状態=オフならば  # 押しっぱなしでは転し続けない
     転キー押下状態=オン。
     A=落下石¥0。B=落下石¥1。C=落下石¥2。
     落下石¥0=C。
     落下石¥1=A。
     落下石¥2=B。
     3
       x=落下石¥(回数-1)*マス目。y=0。
       石用のx,y,マス目,マス目を石転用の0,(回数-1)*マス目へ画像部分コピー。
       落下用クリア。
       石転用を落下用の0,0へ画像コピー。
  違えば転キー押下状態=オフ移動判定
  # はみ出しの処理。
  # 石が壁、床、他の石にぶつからずに動けるかどうかを判定。
  落下マスXとは整数=落下X/マス目
  落下マスYとは整数=落下Y/マス目+2  # 一番下の石があるマス目

 # 縦方向
  # 床
  もし、落下Y>=マス目*11ならば、縦移動フラグ=オフ。
  # 他の石
  違えばもし、固定石¥(落下マスX),(落下マスY)=-1ならば、縦移動フラグ=オン。
  違えば、縦移動フラグ=オフ。

 # 横方向
  # 左の壁
  もし、(落下X-マス目<0)ならば、
    左移動フラグ=オフ。
    左移動中=オン。
  # 他の石
  違えばもし、固定石¥(落下マスX-1),(落下マスY)=-1でなければ、
    左移動フラグ=オフ。
    左移動中=オン。
  違えば、左移動フラグ=オン。
  # 右のカベ
  もし、(落下X+マス目>=マス目*6)ならば、
    右移動フラグ=オフ。
    右移動中=オン。
  # 他の石
  違えばもし、固定石¥(落下マスX+1),(落下マスY)=-1でなければ、
    右移動フラグ=オフ。
    右移動中=オン。
  違えば、右移動フラグ=オン。
#-----------------------------------------------------------------------
*石固定処理
  # 落下しきった石をメイン画面に固定する。
  # 固定石配列の書き換えと、メイン画面への石画像表示。
  落下マスXとは整数=落下X/マス目
  落下マスYとは整数=落下Y/マス目-1  # 一番上の石があるマス目

  もし、((落下マスY)<0)かつ(落下マスX=3)ならば、ゲームオーバー。
  違えば、
    xxとは整数。yyとは整数。
    3
      xx=(落下マスX)。yy=(落下マスY)+(回数-1)
      もし、yy>=0ならば
        固定石¥xx,yy=落下石¥(回数-1)

    固定石描画。
    落下フラグ=オフ。
    0.3秒待つ

    消去石初期化
    3
      もし、落下マスY+(回数-1)<0でなければ、		#の石が画面外でなければ
        落下マスX,落下マスY+(回数-1)で消去判定
    もし、石消去フラグ=オンならば、石消去。隙埋め。連鎖

*固定石描画
    xxとは整数。yyとは整数。
    メイン画面初期化。
    メイン合成用の0,0へメイン画面を画像コピー。
    6
      xx=(回数-1)
      13
        yy=(回数-1)
        x=固定石¥xx,yy。y=0。
        石用のx*マス目,y,マス目,マス目をメイン合成用のxx*マス目,yy*マス目へ画像部分コピー。
    メイン画面の0,0へメイン合成用を画像コピー。
    メイン画面をメイン合成用の0,0へ画像コピー。
    メイン合成用を表画面のメインX,メインYへ画像コピー。
#-----------------------------------------------------------------------
*消去判定(x,yで)
  Cとは整数=1。
  f1とは整数オン。f2とは整数オン。
  # 左右
  5
    もしf1=オフでなければ
      もし、(x-回数<0)ならばf1オフ   # 左の壁
      違えばもし、(固定石¥(x-回数),y)=(固定石¥x,y)ならば、
        C=C+1。
        もし、消去石¥(x-回数),y=1でなければ、消去石¥(x-回数),y=0。
      違えばf1オフ。
    もし、f2=オフでなければ
      もし、(x+回数>5)ならば、f2=オフ   # 右の壁
      違えばもし、(固定石¥(x+回数),y)=(固定石¥x,y)ならば
        C=C+1。
        もし、消去石¥(x+回数),y=1でなければ、消去石¥(x+回数),y=0。
      違えば、f2=オフ。
    もし、(f1=オフ)かつ(f2=オフならば抜ける。
  もし、C>=3ならば、
    消去石¥x,y=0。オンに消去フラグ設定。石消去フラグ=オン。
  違えばオフに消去フラグ設定。

  C=1。f1=オン。f2=オン。
  # 上下
  12
    もしf1=オフでなければ
      もし、(y-回数<0)ならばf1オフ   # 上端
      違えばもし、(固定石¥x,(y-回数))=(固定石¥x,y)ならば、
        C=C+1。
        もし、消去石¥x,(y-回数)=1でなければ、消去石¥x,(y-回数)=0。
      違えばf1オフ。
    もし、f2=オフでなければ
      もし、(y+回数>12)ならば、f2=オフ   # 床
      違えばもし、(固定石¥x,(y+回数))=(固定石¥x,y)ならば
        C=C+1。
        もし、消去石¥x,(y+回数)=1でなければ、消去石¥x,(y+回数)=0。
      違えば、f2=オフ。
    もし、(f1=オフ)かつ(f2=オフならば抜ける。
  もし、C>=3ならば、
    消去石¥x,y=0。オンに消去フラグ設定。石消去フラグ=オン。
  違えばオフに消去フラグ設定。

  C=1。f1=オン。f2=オン。
  # 斜め\
  5
    もしf1=オフでなければ
      もし、(x-回数<0)または(y-回数<0)ならばf1オフ   # 左の壁 または 上端
      違えばもし、(固定石¥(x-回数),(y-回数))=(固定石¥x,y)ならば、
        C=C+1。
        もし、消去石¥(x-回数),(y-回数)=1でなければ、消去石¥(x-回数),(y-回数)=0。
      違えばf1オフ。
    もし、f2=オフでなければ
      もし、(x+回数>5)または(y+回数>12)ならば、f2=オフ   # 右の壁 または 床
      違えばもし、(固定石¥(x+回数),(y+回数))=(固定石¥x,y)ならば
        C=C+1。
        もし、消去石¥(x+回数),(y+回数)=1でなければ、消去石¥(x+回数),(y+回数)=0。
      違えば、f2=オフ。
    もし、(f1=オフ)かつ(f2=オフならば抜ける。
  もし、C>=3ならば、
    消去石¥x,y=0。オンに消去フラグ設定。石消去フラグ=オン。
  違えばオフに消去フラグ設定。

  C=1。f1=オン。f2=オン。
  # 斜め/
  5
    もしf1=オフでなければ
      もし、(x-回数<0)または(y+回数>12)ならばf1オフ   # 左の壁 または 床
      違えばもし、(固定石¥(x-回数),(y+回数))=(固定石¥x,y)ならば、
        C=C+1。
        もし、消去石¥(x-回数),(y+回数)=1でなければ、消去石¥(x-回数),(y+回数)=0。
      違えばf1オフ。
    もし、f2=オフでなければ
      もし、(x+回数>5)または(y-回数<0)ならば、f2=オフ   # 右の壁 または 上端
      違えばもし、固定石¥(x+回数),(y-回数)=固定石¥x,yならば
        C=C+1。
        もし、消去石¥(x+回数),(y-回数)=1でなければ、消去石¥(x+回数),(y-回数)=0。
      違えば、f2=オフ。
    もし、(f1=オフ)かつ(f2=オフならば抜ける。
  もし、C>=3ならば、
    消去石¥x,y=0。オンに消去フラグ設定。石消去フラグ=オン。
  違えばオフに消去フラグ設定。

*消去フラグ設定(Aに)
  xxとは整数。yyとは整数。
  6
    xx=(回数-1)
    13
      yy=(回数-1)
      もし、消去石¥xx,yy=0ならば、
        もし、A=オンならば、消去石¥xx,yy=1
        違えばもし、A=オフならば、消去石¥xx,yy=-1

*石消去
  xxとは整数。yyとは整数。
  6
    xx=(回数-1)
    13
      yy=(回数-1)
      もし、消去石¥xx,yy=1ならば、
        固定石¥xx,yy=-1。
        消去数=消去数+1
        スコア=スコア+10*(レベル+1)*(連鎖数^2)
        スコア表示。
        レベル表示。
        消去数表示。
        レベルアップメーター表示。
  固定石描画。0.3秒待つ。

*隙埋め
  xxとは整数。yyとは整数。Cとは整数。
  6
    xx=(回数-1)
    13
      yy=(回数-1)
      もし、消去石¥xx,yy=1ならば、
        Cでyyから0まで繰り返す
          もし、C=0ならば、
            固定石¥xx,C=-1
          違えば、
            固定石¥xx,C=固定石¥xx,(C-1)
  固定石描画。0.3秒待つ。

*連鎖
  消去石初期化。
  xxとは整数。yyとは整数。
  6
    xx=(回数-1)
    13
      yy=(回数-1)
      もし、固定石¥xx,yy<0でなければ
        xx,yyで消去判定。

  もし、石消去フラグ=オンならば、
    連鎖数=連鎖数+1
    連鎖表示。0.5秒待つ
    石消去。隙埋め。連鎖
  違えば、
    連鎖数=1
#-----------------------------------------------------------------------
*画面準備
  # マス目を描く
  線太さは0。線色は$443322。塗り色は$443322。
  マス目用の0,0から2,マス目-4へ四角。
  マス目用の0,0からマス目-4,2へ四角。
  線太さは0。線色は$221100。塗り色は$221100。
  マス目用のマス目-2,4からマス目,マス目へ四角。
  マス目用の4,マス目-2からマス目,マス目へ四角。

  #マス目をコピー。
  3
    C=回数-1
    マス目用を次石表示用の0,C*マス目へ画像コピー。

  メイン画面初期化
  メイン画面をメイン合成用の0,0へ画像コピー。

  # 表画面
  文字書体は「MS Pゴシック|14|太字」。文字色は$FFFFFF。
  表画面のスコアX+1,スコアY+2へ「すこあ」を文字描画。
  表画面の右辺ラベルX+1,ネクストY-25+2へ「ねくすと」を文字描画。
  表画面の右辺ラベルX+1,レベルY-25+2へ「れべる」を文字描画。
  表画面の右辺ラベルX+1,消去数Y-25+2へ「じゅえる」を文字描画。
  文字色は$CC3322。
  表画面のスコアX,スコアYへ「すこあ」を文字描画。
  表画面の右辺ラベルX,ネクストY-25へ「ねくすと」を文字描画。
  表画面の右辺ラベルX,レベルY-25へ「れべる」を文字描画。
  表画面の右辺ラベルX+1,消去数Y-25へ「じゅえる」を文字描画。

  メイン画面を表画面のメインX,メインYへ画像コピー。
  次石表示用を表画面のネクストX,ネクストYへ画像コピー。
  スコア表示。
  レベル表示。
  消去数表示。
  レベルアップメータークリア。

  # 石用に石を描く
  6
    C=回数-1
    マス目用を石用のC*マス目,0へ画像コピー。
    文字書体は「MS ゴシック|23|太字」。文字色は石¥C,1。
    石用のC*マス目,0へ石¥C,0を文字表示。

*メイン画面初期化
  6
    マス目用をメイン画面のマス目*(回数-1),0へ画像コピー。
  13
    メイン画面の0,0,マス目*6,マス目をメイン画面の0,マス目*(回数-1)へ画像部分コピー。

*スコア表示
  文字書体は「MS Pゴシック|14|太字」
  XXとは整数=「すこあ」の文字幅取得+スコアX+2
  線色は$FFDDCC。塗り色は$FFDDCC。文字書体は「MS Pゴシック|18|太字」。文字色は$882211。
  表画面のXX,スコアY-5からメインX+マス目*6,スコアY+23へ四角。
  表画面のXX,スコアY-5,145,28へスコアを右,中央で枠内文字描画。

*レベル表示
  レベル=消去数/10を切り下げ
  線色は$FFDDCC。塗り色は$FFDDCC。文字書体は「MS Pゴシック|18|太字」。文字色は$882211。
  表画面の右辺ラベルX,レベルYから右辺ラベルX+65,レベルY+30へ四角。
  表画面の右辺ラベルX,レベルY,65,30へレベルを中央,中央で枠内文字描画。

*消去数表示
  線色は$FFDDCC。塗り色は$FFDDCC。文字書体は「MS Pゴシック|18|太字」。文字色は$882211。
  表画面の右辺ラベルX,消去数Yから右辺ラベルX+65,消去数Y+30へ四角。
  表画面の右辺ラベルX,消去数Y,65,30へ消去数を中央,中央で枠内文字描画。

*連鎖表示
  線色は$FFDDCC。。塗り色は$FFDDCC。。
  表画面の右辺ラベルX,連鎖Yから右辺ラベルX+60,連鎖Y+60へ。

  文字書体は「MS Pゴシック|14|太字」。文字色は$FFFFFF。
  表画面の右辺ラベルX+5+1,連鎖Y+65+2へ「れんさ!」を文字描画。
  文字色は$CC3322。
  表画面の右辺ラベルX+5,連鎖Y+65へ「れんさ!」を文字描画。

  文字書体は「MS Pゴシック|28|太字」。文字色は$882211。
  表画面の右辺ラベルX,連鎖Y,60,60へ連鎖数を中央,中央で枠内文字描画。

*連鎖表示クリア
  線色は$FFBBAA。塗り色は$FFBBAA。
  表画面の右辺ラベルX,連鎖Yから母艦のクライアント幅,母艦のクライアント高さへ四角。

*レベルアップメーター表示
  レベルアップメータークリア。
  線色黄色塗り色黄色。
  表画面の右辺ラベルX+5,スコアY+5から右辺ラベルX+5+(消去数%10)*5,スコアY+20へ四角。

*レベルアップメータークリア
  線色は背景色。塗り色は背景色。
  表画面の右辺ラベルX+5,スコアY+5から右辺ラベルX+55,スコアY+20へ四角。

#-----------------------------------------------------------------------
*固定石初期化
  xxとは整数。yyとは整数。
  6
    xx=(回数-1)
    13
      yy=(回数-1)
      固定石¥xx,yy=-1

*消去石初期化
  石消去フラグ=オフ。
  xxとは整数。yyとは整数。
  6
    xx=(回数-1)
    13
      yy=(回数-1)
      消去石¥xx,yy=-1
#-----------------------------------------------------------------------
*ゲームオーバー
  「ゲームオーバー」と言う。
  終了フラグはオン。
  成績記録。
#-----------------------------------------------------------------------

#-----成績表------------------------------------------------------------
*成績記録
  設定ファイル名のINI開いてコンフィグに代入。
  Cとは整数。記録とは整数。順位とは整数=0
  Cをハイスコア表示件数から1まで繰り返す。
    記録=(成績[C-1,1])を整数変換。
    もし、記録<スコアならば、順位=C。
  Cをハイスコア表示件数から1まで繰り返す。
    もし、順位=0でなければ、
      もし、順位=Cならば、
        コンフィグで「ハイスコア」の「Date_{C-1}」に今日INI書く。
        コンフィグで「ハイスコア」の「Score_{C-1}」にスコアをINI書く。
        コンフィグで「ハイスコア」の「Level_{C-1}」にレベルをINI書く。
      違えばもし、順位<Cならば、
        コンフィグで「ハイスコア」の「Date_{C-1}」に成績[C-2,0]をINI書く。
        コンフィグで「ハイスコア」の「Score_{C-1}」に成績[C-2,1]をINI書く。
        コンフィグで「ハイスコア」の「Level_{C-1}」に成績[C-2,2]をINI書く。
  コンフィグのINI閉じる。
  成績読み込み。
  もし、順位=0でなければ、
    ダイアログタイトルは「新記録!」
    「おめでとうございます。{改行}ハイスコアが出ました☆{改行}{改行}歴代{順位を2で文字列右寄せ}位のスコアです。」と言う。
    成績表表示。

*成績読み込み
  もし、設定ファイル名が存在するならば
    設定ファイル名のINI開いてコンフィグに代入。
    (ハイスコア表示件数)
      Cとは整数。C=回数-1
      コンフィグで「ハイスコア」の「Date_{C}」をINI読んで成績[C,0]に代入。
      コンフィグで「ハイスコア」の「Score_{C}」をINI読んで成績[C,1]に代入。
      コンフィグで「ハイスコア」の「Level_{C}」をINI読んで成績[C,2]に代入。
    コンフィグのINI閉じる。
  違えば
    成績クリア
#-----------------------------------------------------------
*成績表表示
  文字書体は「MS ゴシック」
  HSとは文字列=「   ★☆★ ハイスコア ★☆★」&改行&改行
  (ハイスコア表示件数)
    Cとは整数回数-1。
    Dとは文字列。D=(成績[C,0])を文字列変換もし、D=0ならば、D=「----/--/--」
    Sとは文字列。S=(成績[C,1])を文字列変換もし、S=0ならば、S=「-------」
    Lとは文字列。L=(成績[C,2])を文字列変換もし、L=0ならば、L=「--」
    HS=HS&「{回数を2で文字列右寄せ}位 {Sを7で文字列右寄せ}点 {Lを2で文字列右寄せ}レベル {D}」&改行
  ダイアログタイトルは「成績表」
  HSを言う。

*成績リセット
  ダイアログタイトルは「成績表リセット」
  「リセットしてもいい?」と二択。
    もしそれはいならば、成績クリア

*成績クリア
    設定ファイル名のINI開いてコンフィグに代入。
    (ハイスコア表示件数)
      Cとは整数。C=回数-1
      コンフィグで「ハイスコア」の「Date_{C}」に0をINI書く。
      コンフィグで「ハイスコア」の「Score_{C}」に0をINI書く。
      コンフィグで「ハイスコア」の「Level_{C}」に0をINI書く。
      コンフィグで「ハイスコア」の「Date_{C}」をINI読んで成績[C,0]に代入。
      コンフィグで「ハイスコア」の「Score_{C}」をINI読んで成績[C,1]に代入。
      コンフィグで「ハイスコア」の「Level_{C}」をINI読んで成績[C,2]に代入。
    コンフィグのINI閉じる
#-----ヘルプメニュー----------------------------------------------------
*遊び方
  ダイアログタイトルは「なでこらについて」
  「【いわゆるコラ○スのルール】
  フィールドに上から縦1列3個1組で落ちてくるブロックを、
  左右に動かしたり転させたりしながら、同色同型のものを
  縦・横・斜めに3つ以上揃えるとのブロックが消えます。
  連鎖すると、得られる得点が高くなります。
  左から4列目の上端までブロックがみ上がってしまったら、
  ゲームオーバーです。
  なお、魔法石は出現しませんw

【キー設定】
  ←・→ で左右に動かす。
   ↓  で落下。
  スペースで転。」を言う。
#-----------------------------------------------------------
*バージョン
  ダイアログタイトルは「バージョン情報」
  「{二重カッコ}なでこら{二重カッコ閉じ}{改行} Version 1.00{改行}{改行} by 雪乃☆雫」と言う。
#-----------------------------------------------------------------------

#-----------------------------------------------------------------------
●枠内文字描画({グループ=?}OBJのX,Y,W,HへSをA,Vで)
  xxとは整数。yyとは整数。
  もし、A=左ならば
    xx=X
  違えばもし、A=中央ならば
    xx=X+(W-(Sの文字幅取得))/2
  違えばもし、A=右ならば
    xx=(X+W)-(Sの文字幅取得)
  もし、V=上ならば
    yy=Y
  違えばもし、V=中央ならば
    yy=Y+(H-(Sの文字高さ取得))/2
  違えばもし、V=下ならば
    yy=(Y+H)-(Sの文字高さ取得)
  OBJのxx,yyへSを文字描画。
#-----------------------------------------------------------------------

 どうかな? 一応それっぽく遊べはすると、思うんだけど・・・

hanatai001hanatai0012016/10/12 03:55すごいですね!!
ちゃんと遊べて楽しいです!!

雪乃☆雫雪乃☆雫2016/10/12 18:01>hanatai001さん
 ありがとうございます☆
 遊んで下さったんですね!
 うれし~(≧▽≦)
 もし記事にあげた問題点のほかに、バグってるとか、本家の動作はこうじゃないよ!とかあったら、教えて下さいね~(直すかどうかは不明デスがっ;;;;)

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20161010

2016-10-07

レベルとともにスピードアップ

| 22:44

 これまでは、落下ボタンを押してない時のウェイトを1秒(20*0.05秒)ってことにしてたけど、レベルが上がるごとそれを短くしていきたいって事で、ウェイトからレベルを引いて行くことにしただけ。

#-----------------------------------------------------------------------
*落下処理
  LSとは整数=レベル*0.01   # 落下速度は「{(0.1-LS)*10}秒」
  10
    キー処理
    落下用をメイン合成用の落下X,落下Yへ画像コピー。
    メイン合成用を表画面のメインX,メインYへ画像コピー
    メイン画面をメイン合成用の0,0へ画像コピー。
    # 落下キーを押していない時のウェイト
    もし、落下フラグがオンでなければ、
      (0.1-LS)秒待つ。
    # 左右キーは押し続けた時は一気に動くが、連打した時は一マスごと動くようにする。
    もし、(左移動中=オン)かつ(左キー押下状態=オフならば、
      左キー押下状態=オン。
      0.1秒待つ。
    もし、(右移動中=オン)かつ(右キー押下状態=オフならば、
      右キー押下状態=オン。
      0.1秒待つ。

  落下Y=落下Y+マス目
  移動判定
#-----------------------------------------------------------------------

 ちなみに、秒待つ命令は、0秒待つになってもウェイトがかかるんだけど、マイナスになると、ほぼかからなくなる感じで、特にエラーとかにはならないようなので、レベルが10えたときの処理は設けていません。

 ってわけで、11レベル以降は、ワタシにはムリな感じになっています;


 これで基本的な部分は完成で一段落~・・・っとおもったら、どうやら、ダメらしい。

 思わぬ落とし穴が発覚なのですよ?!

 どうするか、考え中・・・(@_@)

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20161007

2016-10-02

脳トレ?!

| 16:34

 突然ですが、脳トレ的な漢字の違い探しです。

 少しは鍛えたら、ワタシのバカも少しは治るかも知れんと思ったんだけど、本のヤツって一やったらもう、場所覚えますよね~。

 ・・・と、ゆうわけで、同じような問題を作るやつを作ってみた。


 一個だけ、違う漢字が混じっています。

 一つ一つ文字を追って、探すことに熱中するのではなく、なるべく視点を動かさずに、視野を広げて画面全体を見て、ぱっと見つけるようにすると良いそうです。

#-----------------------------------------------------------------------
# まちがいさがし
#-----------------------------------------------------------------------

#-----母艦設計----------------------------------------------------------
!母艦設計=「母艦の可視はオフ」

#---母艦----
母艦のタイトルは「まちがいさがし」
母艦白色画面クリア母艦のスタイルは「枠固定」
母艦オフに最大化ボタン有効変更。
母艦のクライアント幅は800。母艦のクライアント高さは600。
母艦中央移動
#-----------------------------------------------------------------------

#-----宣言--------------------------------------------------------------
問題とは配列=「大,犬,太
犬,尤
天,夭
千,干
人,入
日,曰
因,困
井,丼
王,玉,生,主
吉,舌,告
末,未,朱
矢,失,朱
己,巳,已
成,戌,戊
持,待,侍
内,肉
休,体
ぬ,め
ね,わ
る,ろ
る,ゐ」

出題とは配列

文字書体は「|32|太字」
文字幅=「あ」の文字幅取得
文字高=「あ」の文字高さ取得

上マージンとは整数=20。
左マージンとは整数=20。
文字隔とは整数。文字隔=((母艦のクライアント高-上マージン*2)-(文字高*10))/9。
行隔とは整数。行隔=((母艦のクライアント幅-左マージン*2)-(文字幅*10))/9。
#-----------------------------------------------------------------------

#-----メインルーチン----------------------------------------------------
母艦の可視はオン乱数初期化。
新規ゲーム

*新規ゲーム
#---問題作成----
  r=問題の要素数乱数。
  問題¥rを配列シャッフル。
  出題は。
  99
    出題に問題¥r,0を一行追加。
  出題に問題¥r,1を一行追加。
  出題を配列シャッフル。

#---画面表示----
  母艦白色画面クリア。
  100
    x=((回数-1)%10)*(文字幅+行隔)+左マージン。
    y=(((回数-1)/10)を切り下げ)*(文字高+文字隔)+上マージン。
    母艦のx,yへ出題¥(回数-1)を文字表示。
#------------------------------------------------------------

 取りあえず問題を作って表示するだけだけど、のうちマウスクリック答出来るようにする予定~。

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20161002