Hatena::Groupnadesiko

雪乃☆雫のなでしこ日和

2018/02/19 (月)

v3.0.31をダウンロードしたりバイオリズムを修正したり

| 13:15 | v3.0.31をダウンロードしたりバイオリズムを修正したり - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - v3.0.31をダウンロードしたりバイオリズムを修正したり - 雪乃☆雫のなでしこ日和 v3.0.31をダウンロードしたりバイオリズムを修正したり - 雪乃☆雫のなでしこ日和 のブックマークコメント

 近頃たいしたことはしてませんが、ちょこちょことなんだかんだした件を三件ほど。


 まずは、ぼやき記事に追記を入れただけで放置してましたケド、v3.0.21で新たに論理OR、論理AND、論理NOT追加され、ANDORは、なでしこ1同様のビット演算に戻りました☆

 おかげさまでこんな感じに♪

#数当て表作成
60
  数=回数。
  6
    もしAND(数,2^(回数-1))=0でなければ、数当表[回数-1]=数当表[回数-1]に数を一行追加。
  ここまで。
ここまで。

 あと、前密かに一行追加がどうもうまくいかないと思っていたら、v1非互換で、ちゃんと代入しなきゃならなかったみたい。

・数当てカード

http://www.geocities.jp/snowdrops890/wnako3_test/13_kazuate2.html

 いきなり始まるのもアレなんでボタンを押して開始するようにした。


・数当てカードを二進数で表示

http://www.geocities.jp/snowdrops890/wnako3_test/13_kazuatehyo.html

 テーブルで表示するようにしてみた。

 cellspacingに該当するCSSが分からん・・・;



 ところで、なでしこ3は、いつのにかさらにバージョンアップしてv3.0.31になってました。

 PC版の機能が大幅に拡張されてWebサーバを作成する機能が追加されたんだってさー。って・・・ナンカヨクワカンナイケド;

 これまでWeb版しかお試ししてこなかったからね。

 でもとりあえず、ちょこっとだうんろーどしてみたところ・・・解凍できませんでした。

 っからか。ワタシって・・・無能すぎる。

 しくしくしくしく。

 なんか、ファイル名または拡張子が長すぎて、フォルダが作成出来ませんとか言われてしまう~。えらく階層の深そうな、書き写すどころか見たくない感じのフォルダ名が表示されておる~。

 ・・・とゆうわけでしばし放置していたんだけど、急にひらめきました。

 書庫名でフォルダを作ってこに解凍する設定にしてたんだけど、どっちみちちゃんとフォルダを作った中に全部展開されるようになってるからなーと、の設定をオフにしたらできました。フォルダ一個分・・・?

 たぶん、てきとーにデスクトップ解凍しようとしたのもいけませんでした;

 ・・・でっ、解凍さえ出来ましたら、バッチファイルを実行であっさりと無事にエディタ起動しました☆

 だけど・・・保存したファイルをファイル一覧から見ようとしてもナゼか、問答無用で「こんにちは」と表示。になってしまうみたいなんだよね;むむむ(?_?)

 ↑ 3.0.32で解消されました!



 それはさておき、NADE APPに投稿していたバイオリズムの、前月表示や翌月表示が近頃ちゃんと動いてなかったことを発見。

 自前の日付加算がダメでした;

 12月の絡んだ計算がエラーになってしまう。

 v3.0.19頃から、UNIXTIME変換がシビアになったみたいなんですね。

 まえは、「2017/0/1」みたいな日付が通っていたんですよ~w

 それで計算もちゃんと合ってる風味だったんで、スルーしてたんですが、直しました。

日付加算(SにAを)
  記号=Aの1だけ文字左部分。
  A=Aの1から1だけ文字削除。
  A=Aを「/」で区切る。
  y=A@1/12を切捨。m=A@1%12。
  S=Sを「/」で区切る。
  もし、記号=「+」ならば、
    y=y+(S@1+m)/12を切捨。
    S@0=S@0+A@0+y。
    S@1=(S@1+m)%12。
  違えば、
    S@0=S@0-A@0-y。
    S@1=S@1-m。
  ここまで。
  もし、S@1=0ならば、
    S@1=12。S@0=S@0-1。
  ここまで。
  d=(A@2)*(24*60*60)。
  年=S@0。月=S@1。日=S@2。
  S=「{年}/{月}/{日}」をUNIXTIME変換。
  もし、記号=「+」ならば、S=S+d。
  違えば、S=S-d。
  S=Sを日時変換。
  S=Sの10だけ文字左部分。
  Sで戻るここまで。

http://www.eznavi.net/app/index2.php?pagetop=25&only=one

http://www.eznavi.net/app/index2.php?pagetop=27&only=one

 あっ、プラグインのは問題なく動くんですけどね。

 掲示板に投稿したのは制作エディタで動くように自前の日付加算を使ってたので。

miqibuzadmiqibuzad2018/07/24 00:33http://doxycycline-cheapbuy.site/ - doxycycline-cheapbuy.site.ankor <a href="http://onlinebuycytotec.site/">onlinebuycytotec.site.ankor</a>

iteqevoqositeqevoqos2018/07/24 00:53http://doxycycline-cheapbuy.site/ - doxycycline-cheapbuy.site.ankor <a href="http://onlinebuycytotec.site/">onlinebuycytotec.site.ankor</a>

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20180219