Hatena::Groupnadesiko

雪乃☆雫のなでしこ日和

2009/03/29 (日)

画像変更機能をつけよう!

| 17:53 | 画像変更機能をつけよう! - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - 画像変更機能をつけよう! - 雪乃☆雫のなでしこ日和 画像変更機能をつけよう! - 雪乃☆雫のなでしこ日和 のブックマークコメント

 こっちのほうが難しそうに思っていたけど、案外簡単に出来そうな気がしてきたので、ハイスコア表示はいったん休んで、こちらに着手。


 メニューに、画像変更を追加して、コードは以下のとおり

#-----画像変更-------------------------------------------------
*画像変更
  マイピクチャー作業フォルダ変更。
  「*.jpg;*.jpeg;*.png;*.bmp」のファイル選択。
  裏画面の画像はそれ。
  
  裏画面を盤サイズ,盤サイズで画像リサイズ。
  新規ゲーム
#--------------------------------------------------------------

 これで、とりあえずは動きました。

 でも、世の中の画像はたいてい正方形じゃないので、比率が変になってしまいます。

 かといって、比率変えずにリサイズでは、余白が出来てしまうので、15パズルができません(汗)


 好きなところを好きなサイズで正方形にトリミングしてリサイズできるのが一番よさそうだけど、何気に難しそうな上、必要ないときにはいちいちんなの手だから、短いほうの辺にあわせて、長いほうの辺の両端を切って、盤サイズにリサイズするようにしようと思う。

#-----画像変更-------------------------------------------------
*画像変更
  マイピクチャー作業フォルダ変更。
  「*.jpg;*.jpeg;*.png;*.bmp」のファイル選択。
  作業用の画像はそれ。
  
  もし、作業用のW>作業用のHならば
    x=(作業用のW-作業用のH)/2。y=0。
    x2=作業用のH+x。y2=作業用のH。
  違えば
    x=0。y=(作業用のH-作業用のW)/2。
    x2=作業用のW。y2=作業用のW+y

  作業用のx,y,x2,y2を裏画面の0,0へ画像部分コピー

  裏画面を盤サイズ,盤サイズで画像リサイズ。
  裏画面を母艦の15,15へ画像コピー。
  新規ゲーム
#--------------------------------------------------------------

 これでいけるか? とおもったら、あれれ~?

 大きな画像の端っこが切り取られて表示されてる。

 一度400*400の画像が入った裏画面には、大きな画像をコピーしても、大きくならないらしい。むむむ。

 ーくるなら、裏画像を先に大きくしておくしかないね!

 裏では、15パズルの画像がおっきく引き伸ばされているだろうけど、見えないから問題なし!

 して、キャンセル押した時にっ白くなってしまう問題を解決する処理を追加

 折角だから「」を使う!

 「でなければ」何気に書いてみたら、使えた!!

 で、こんな感じ。

#-----画像変更-------------------------------------------------
*画像変更
  マイピクチャー作業フォルダ変更。
  「*.jpg;*.jpeg;*.png;*.bmp」のファイル選択。
  もしそれでなければ	#キャンセルした時は処理しない
    作業用の画像はそれ。

    もし、作業用のW>作業用のHならば	#横長の画像
      x=(作業用のW-作業用のH)/2。y=0。
      x2=作業用のH+x。y2=作業用のH。
      裏画面をy2,y2で画像リサイズ。	 #短いほうの辺に長さあわせて正方形
    違えば
      x=0。y=(作業用のH-作業用のW)/2。
      x2=作業用のW。y2=作業用のW+y
      裏画面をx2,x2で画像リサイズ。

    作業用のx,y,x2,y2を裏画面の0,0へ画像部分コピー。
    裏画面を盤サイズ,盤サイズで画像リサイズ。
    裏画面を母艦の15,15へ画像コピー。
    新規ゲーム
#--------------------------------------------------------------

 できた~♪

 ・・・だけど、難易度高すぎ(--;

 選んだ画像のせいもあるけど、ワタシには解けない・・onz

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090329

2009/03/28 (土)

ハイスコア表示機能をつけよう!

| 23:41 | ハイスコア表示機能をつけよう! - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - ハイスコア表示機能をつけよう! - 雪乃☆雫のなでしこ日和 ハイスコア表示機能をつけよう! - 雪乃☆雫のなでしこ日和 のブックマークコメント

 文字列の操作とか、ファイルの読み書きとか、よくわかんにゃい(*_*)

 とりあえず成績の記録よりは、単にデータを読んで表示するのほうが圧倒的に楽そうな気がするので、まずっちをやってみる。

 メニューに「成績表」の項目を追加し、これを選択したら、ハイスコアが表示されるようにしよう。

 データがなければ話になんないので、「成績表.txt」というファイルを、メモ帳で作った。以下のような単純なものです。

#---------------
手数
98手
115手
159手
#---------------

 して、コードはこんな感じ。

#-----成績表表示----------------------------------------------
*成績表表示
  「成績表.txt」を毎行読んで反復
    成績¥回数対象。
  成績を改行配列結合していう。
#-------------------------------------------------------------

 なんか、反復で一行づつ読んだ意味なし(汗)

 見た目はともかく、ファイルの内容を言ってくれることはくれました。

 でも、なんでダイアログの背景白くなっちゃうんだ? わけわからん;


 見た目については置いといて(え;)

 度は記録の保存について考える。


 成績を記録させるのは、おめでとう!て出た時に出している手数とタイムの数値を、ファイルに書き込んでいけばいいんだろうけど、ただ追記していくんじゃなくて、過去の記録と比較して上っていた時だけ書き換える。

 しかも、ただ書き換えるんじゃなくて、過去の記録が一個づつ下がって、一番低い記録がトコロテン式に消える、みたいな?

 これはなんとなく、配列でなんとかなるかな?

 目的の状態になった配列を、一気にファイルに保存ってすれば、んなに難しくないかも??


 と思ったら、甘かった。

 毎行読んで反復回数は、1からスタートらしい。

 して、0には配列名が入ってるようで、単に「成績を保存」としたら、さっきのデータがこーなってしまう。

#---------------
成績
手数
98手
115手
159手
#---------------


 とゆーわけで、こうなった。

 ファイルの中には純粋に手数だけを保存し、表示するときに「手数」だの「**手」の「手」だのは追加すればいいかな。のほうが断然楽っぽい。

#---------------
98
115
159
#---------------
#-----成績表記録----------------------------------------------
*成績表記録
  s=「」
  数を1から3まで繰り返す
    s=「{s}{成績¥数}{改行}」

  sを「成績表.txt」へ保存。
#-------------------------------------------------------------

 あと、成績表.txtを読み込むのは、ゲーム起動時に行うことにする。

 成績の配列を参照すればいいんだから、成績表を見るたびにファイルを読む必要なんてないね?


 単に、ある成績を保存するのはいいけど、実際にはハイスコアが出たかを判定し、出ていたら、の順位の行は手数に書き換え、それ以下の順位の行は、いっこづつ下がっていくという処理が必要

 やりたいことは、以下のとおり

#-------------------------------------------------------------
  もし、成績¥3>手数ならば
    もし、成績¥2>手数ならば
      もし、成績¥1>手数ならば
        成績¥3=成績¥2
        成績¥2=成績¥1
        成績¥1=手数
      違えば
        成績¥3=成績¥2
        成績¥2=手数。
    違えば
      成績¥3=手数
#-------------------------------------------------------------

 これで、正常に動きます。OKですね!

 ・・・って、んなわけねー;

 ダメダメなプログラムの権化みたいなもんですねー。

 3位くらいまでだからいいけど、5位までとか、まかり違って10位くらいまで表示させたいなんて思ったときにはどーしたらいいんですかっ?!


 ひらめかないので、表示のほうでも手直ししてよう(汗)

#-----成績表表示-----------------------------------------------
*成績表表示
  s=「★☆★成績表★☆★{改行}{改行}◎手数のハイスコア{改行}」
  数を1から3まで繰り返す
    もし、成績¥数がならば
      s=「{s} {数}位  ---手{改行}」
    違えば
      s=「{s} {数}位  {成績¥数}手{改行}」
  s=「{s}{改行}◎タイムのハイスコア{改行}」
  数を4から6まで繰り返す
    分=成績¥数/60を切り下げ。
    秒=成績¥数%60。
    分=分を2でゼロ埋め。秒=秒を2でゼロ埋め
    もし、成績¥数がならば
      s=「{s} {数-3}位  --分--秒{改行}」
    違えば
      s=「{s} {数-3}位  {分}分{秒}秒{改行}」
  ダイアログタイトルは「成績表」
  sを言う。
#--------------------------------------------------------------

 タイムのほうも表示できるようになりました(笑)

 タイムの記録も、「経過」の数(つまり総秒数)のみ保存して、ここで分秒表示に直すのがいいね。

 あと、ダイアログが白くなるナゾは、プログラム上の問題ではなく「言う」と「いう」の違いによるものと判明(汗)

 にしても、「言う」で、全部表示させようって言うのがも無謀?

 別フォームをだしたほうがいいのかな。

 「言う」にすると、右クリックで、メモ画面が開く機能は消せないのかな?

 「いう」にしたら出なくなるけど、なんかダイアログボックスの背景が白くなっちゃうのが、気に入らない~。


 あと、完成したときに、ハイスコアが出ていたら、当然教えて欲しい。

 「手数順位」と「タイム順位」を記録時に取得させることにして、結局「言う」で無理矢理表示

#--------------------------------------------------------------
    成績表記録。
    
    #表示させる文字の設定
    もし、手数順位=0ならば
      手数成績=「{改行} 手数{手数}手です」
    違えば
      手数成績=「{改行} 手数{手数}手は{改行}   歴代{手数順位}位の成績です」
    
    もし、タイム順位=0ならば
      タイム成績=「{改行} タイム{分}分{秒}秒です」
    違えば
      タイム順位=タイム順位-3
      タイム成績=「{改行} タイム{分}分{秒}秒は{改行}   歴代{タイム順位}位の成績です」    

    #表示させる
    もし、(手数順位=0 かつ タイム順位=0)ならば
      ダイアログタイトルは「完成!」
      「おめでとう。完成です!{改行}{手数成績}{タイム成績}」と言う。
    違えば
      ダイアログタイトルは「ハイスコアが出ました!」
      「おめでとう。新記録です!{改行}{手数成績}{タイム成績}」と言う。
      成績表表示。
#--------------------------------------------------------------

 バカだから、表示を確認する為に、何度も15パズルやっちゃった(汗)

 無理やりの割には、まあまあの見た目になったかな?

 自分の環境意外では、崩れるのかな?

 ま、とりあえずいいけど。


 それにしても、また課題が持ち越しとなってしまった・・・

 U D U D 2009/03/29 00:42着々とLVUpしてますねー

\0に配列名が入るわけではなくて、きちんと宣言しなかった変数は初期値として変数名(文字列)がセットされます。
で、「回数」は1から始まるのに、配列のインデックスは0から始まるんですよね。
だからうっかり変数宣言せずに配列を使ってしかも反復とか~回で代入すると、
上手い具合に0番目に変数名が入るわけですf(^^;

テストとは配列
3回、テスト[回数]=回数
テストを『,』で配列結合して言う
5回、テスト[回数-1]=回数
テストを『,』で配列結合して言う

雪乃☆雫雪乃☆雫2009/03/29 12:05UDさま、ありがとうございます☆
しかも、見本のコードまで!

なるほど~。
宣言時に値を与えないでいると、空ではなくて変数名が代入されているわけなのですね。

・・・て、あれ?
「テストとは配列」と宣言するだけでよいのですか?
宣言・・・してなかったかな(汗)

雪乃☆雫雪乃☆雫2009/03/29 12:12UDさまへのレスの続き

 分かりました!
 宣言は、上のほうにまとめてしているのですが、一番初めのコードを書いた時には、とりあえず書いてみたせいで、ちゃんと宣言していなかった為に発生した現象のようです。

 いま確認してみたら、宣言してあったので、試しに言わせて見たら、成績¥0は空になっていました!
 おかげさまでだんだん知識が深まっていきますです。

 ありがとうございました。

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090328

2009/03/27 (金)

タイムトライアル機能をつけよう!

| 18:23 | タイムトライアル機能をつけよう! - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - タイムトライアル機能をつけよう! - 雪乃☆雫のなでしこ日和 タイムトライアル機能をつけよう! - 雪乃☆雫のなでしこ日和 のブックマークコメント

 いよいよタイマー

 普通に、何秒で出来たかを計るタイマーにします。


 まず、「トライアルタイマーとはタイマー隔は1。」でタイマー作成

 隔は秒数なので、1秒ごとにイベントが発生するようなイメージ

 あと、手数のときと同じように、表示用のラベルを配置。


 コードはこんな感じ。

 時満ちた時は~って、なんかとても素敵だ♪

 とりあえず、1秒ごとにここが実行され、ラベルの秒数を書き換えていく。

#-----タイムトライアル----------------------------------------
*タイムトライアル
  トライアルタイマーの時満ちた時は~
    経過=経過+1。
    分=経過/60を切り下げ。
    秒=経過%60。
    分=分を2でゼロ埋め。秒=秒を2でゼロ埋め。 #時を00:00で表示させる。
    タイムラベルのテキストは「{分}:{秒}」。のXは440。のYは140。のWは180。のHは50。
#-------------------------------------------------------------

 までずっと、「分=経過/60。分=分を切り下げ。」のように書いていたけど、「分=経過/60を切り下げ。」って書くことが出来るってわかった。このほうが日本語らしいし、みやすいね!


 あと、開始時からいきなり時計が動き出しているというのは、心理的によろしくないので、最初に盤の中をクリックした時をゲーム開始と判断して、タイマーを動かし始めることにする。

 というわけで、マウス判定の下に、タイマーを開始させるコードを入れる。

#-------------------------------------------------------------

      もし、手数=0ならば       #はじめに盤をクリックした時から
        トライアルタイマーを開始。  #タイマーを動かす
        タイムトライアル。
#-------------------------------------------------------------

 完成の判定が出来たら、っ先にタイマーを止める。

 おめでとうの時に、の手数と秒数も言ってもらうことにする。

 あと、手数カウントのときと同じく、新規ゲームとやり直しの時ラベルをクリアする。

 これでOK?と思ったら、完成させずにやり直しや新規ゲームを選択したら、タイマーが動き続けてるよ!

 というわけで、新規ゲームとやり直しのはじめに、「トライアルタイマー停止」を追加

 タイマーを開始する前に停止、と言ってもいいのかな? と思いましたが、特に問題ないみたいだったので、タイマーが動いてるかどうかの判断はしてません。

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090327

2009/03/26 (木)

「このゲームをやり直す」機能をつけよう!

| 18:37 | 「このゲームをやり直す」機能をつけよう! - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - 「このゲームをやり直す」機能をつけよう! - 雪乃☆雫のなでしこ日和 「このゲームをやり直す」機能をつけよう! - 雪乃☆雫のなでしこ日和 のブックマークコメント

 予定には無かった機能ですが、手数カウント機能をつけて遊んでいたら、思いつきました。

 問題によって、解くための必要最小手数は異なるかも知れず、同じ問題何度も出来たら、より効率的に解けるようになったかどうかがちゃんと分かるってもんです。


 メニューに「このゲームをやり直す」を追加

 問題作成直後の、駒配列と、アキを、記憶配列とアキ記憶に覚えさせる。

 それで、やり直すが選択されたら、以下のとおり全部元に戻してやればOK。

#-----このゲームをやりなおす-----------------------------------
*やり直し
  手数は0。手数ラベルのテキストは「0」。のXは500。のYは30。のWは100。のHは30。        #手数も0に初期化。
  数を0から15まで繰り返す。
    駒¥数=記憶¥数。
  アキはアキ記憶。         #アキ位置を初期化。
  ゲーム画面描画。
  マウス判定。
#-------------------------------------------------------------

 意外と簡単だった☆


 あと、突然気づく。

 「手数」て表示するだけのラベル、何ゆえラベル

 VBは、ペタペタ貼るのが楽だったので、ちょっとした文字を書くのに何でもラベルを使っていたような気がするんですが、こんな座標指定するなら、表示でも別に良かった・・・

 ていうか、文字描画にしたら、アンチエイリアスされた文字が書けるので、こっちがいいかも!

 というわけで修正。

 なお、実際の手数を表示してくところは、ラベルのまま。

 書き換えの際に、消す処理が要らないからです。

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090326

2009/03/25 (水)

手数カウント機能をつけよう!

| 22:02 | 手数カウント機能をつけよう! - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - 手数カウント機能をつけよう! - 雪乃☆雫のなでしこ日和 手数カウント機能をつけよう! - 雪乃☆雫のなでしこ日和 のブックマークコメント

 というわけで、手数のカウント機能について考える。

 手数と言うのは、何駒を動かしたかと言うことだから、何駒入れ替えが発生したかを数えればいい。

 駒入れ替え_描画と完成判定は、見やすいように別ルーチンにしてるけどセット品なので、完成判定の中に入れてしまえ。

 手数は折角なので(?)ラベル表示することにした。

 ごちゃっとしてますけど、こんな感じね;

 いまさらながら、はてなのソースの表示の仕方を学んだ。

#-------------------------------------------------------------

#手数カウント機能ようラベル
ラベル1とはラベルのテキストは「手数」。
のXは440。のYは33。のWは50。のHは30。
文字書体は「MSPゴシック」。文字サイズは18。文字色は$AA0000。

手数ラベルとはラベルのテキストは「0」
のXは500。のYは30。のWは100。のHは35。
文字書体は「MSPゴシック」。文字サイズは24。の文字位置は右。文字色は$550000。
の背景色は$FFDDDD。の透明はオフ。
#-------------------------------------------------------------

 こういうことだけは、VBのが楽だったねえ。

 新規ゲームで「手数」を0にして、完成判定の中で、手数=手数+1して、ラベル表示、でOKなはず!


 ・・・と思って実行したら、うえぇ~、手数が書き換わった途端にラベルのサイズが文字にあわせて変更されちゃった~。んなの頼んでないよ~!(汗)

 ラベルの背景色を使って、表示位置を作っていたので、これはよろしくありません。っていうか、こーいう使い方自体がよろしくない?(汗)


 とりあえず、手数表示のコードはこーなりました。

#-----手数表示------------------------------------------------
  手数=手数+1。手数ラベルのテキストは手数。のXは500。のYは30。のWは100。のHは35。
#-------------------------------------------------------------

 美しくないけど、いいんだい!

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090325

2009/03/24 (火)

バージョンアップするよ!

| 21:07 | バージョンアップするよ! - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - バージョンアップするよ! - 雪乃☆雫のなでしこ日和 バージョンアップするよ! - 雪乃☆雫のなでしこ日和 のブックマークコメント

 昨日ので、普通に15パズルが遊べるようになりました☆

 あと他に、追加していきたい機能について。

 後の目標と言うか、抱負と言うか?


①手数のカウント

 やっぱり、ただ完成させるだけじゃ、だんだん飽きてきますからねー。

 何か目標がないと。

 これは、なんとなくすぐにでも実装できそうな気が。


②タイムトライアル

 タイマーについて学ぶのが目的です。

 ワタシの勝手な思い込みによれば、ゲームには乱数の次にタイマー必要(笑)

 何秒で出来たか計測するのと、時内に完成しないとアウトにするのと、どっちがいいかな?

 ちなみに、子どものころにアナログの15パズルで遊んでたときは前者で、誰が一番早くできるか競争。慌てるあまりに駒を飛び散らかしてアウトになってたりしてましたね(汗)


③成績表

 よい成績があれば、残したくなるのが人情。

 ハイスコア表示って、どうやんだ?

 ファイルにデータを残しておいて読み書きする、みたいな?

 ファイル入出力みたいなことを学べばいいのかな?


④好きな画像を使う

 数字の駒は、プログラムするときも考えやすくて楽でしたが、パズルを完成させるのも割りと簡単です。画像になると、難易度がUPします。

 画像のリサイズとか、ダイアログボックスとか? いろいろ学べそうな気が。


 このくらいできたら、十分かな?

 いろいろ違うことが勉強できそうな予感ですね☆

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090324

2009/03/23 (月)

『15パズル』 Ver.1 だよ!

| 20:40 | 『15パズル』 Ver.1 だよ! - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - 『15パズル』 Ver.1 だよ! - 雪乃☆雫のなでしこ日和 『15パズル』 Ver.1 だよ! - 雪乃☆雫のなでしこ日和 のブックマークコメント

 一応、課題? を解決して、バージョン1になったよ!

 DLしてから2週経たないのに、これだけ出来たよ!

 なでしこ、すごい!!

 というわけで、ここまでのソースの全文を公開。

 ついでに、この画像も拾っていってくれたら、15パズルで暇つぶしが出来ます(笑)

 それはさておき、何か突っ込みどころがあったら、教えてくれたらうれしいかな? かな?

 あと、あんまりいい内容でもないけど、いつか誰かの役にちょっとでも立ったらうれしいかな・・・なんて。


f:id:snowdrops89:20090323203902j:image

#-------------------------------------------------------------
#  15パズル   ver.1.00
#-------------------------------------------------------------

#-----母艦設計------------------------------------------------
!母艦設計=「母艦の可視はオフ母艦のタイトルは「15パズル」
母艦のWは440。母艦のHは480。
母艦を$FFBBBBで画面クリア母艦のスタイルは「枠固定」
母艦オフに最大化ボタン有効変更。

#--メニュー設定----
『#親部品名,部品名,テキスト,ショートカット,オプション,イベント
なし,ファイルメニュー,ファイル(&F),,,
 -,新規メニュー,新しいゲーム(&N),Ctrl+N,,新規ゲーム
 -,-,,,,
 -,閉じるメニュー,閉じる(&X),Ctrl+X,,終わる
なし,ヘルプメニュー,バージョン(&A),,,
 -,バージョンメニュー,バージョン情報(&A),Ctrl+A,,「{二重カッコ}15パズル{二重カッコ閉じ}{改行} Version 1.00{改行}{改行} by 雪乃☆雫」と言う。
』をメニュー一括作成母艦の可視はオン。
#-------------------------------------------------------------

#-----宣言----------------------------------------------------
パズル画像は「15パズル.jpg」。
裏画面とはイメージの可視はオフ。
アキとは整数。
駒とは配列。
新規ゲーム待ちとは文字列。
問題作成中とは文字列。

#--定数----
盤サイズとは整数。盤サイズは400。
駒サイズとは整数。駒サイズは100。
左マージンとは整数。左マージンは15。
上マージンとは整数。上マージンは15。
#-------------------------------------------------------------

#-----メインルーチン------------------------------------------
裏画面の画像はパズル画像。
新規ゲーム。
マウス判定。
#-------------------------------------------------------------

#-----新規ゲーム----------------------------------------------
*新規ゲーム
  #---初期化------
  アキは15。            #アキ位置を初期化。
  数を0から15まで繰り返す。                      #駒位置を初期化
    駒¥数は数。

  #---問題作成------
  問題作成中は「オン」
  乱数初期化。
  1000
    rは4の乱数
    もし、rが0ならば
      駒入れ替え_上。

    もし、rが1ならば
      駒入れ替え_下。

    もし、rが2ならば
      駒入れ替え_左。

    もし、rが3ならば
      駒入れ替え_右。

  #---画面描画------
  線色は$AAAAAA。線太さは5。塗り色は$DDDDDD。  #画面のクリア
  母艦の10,10から420,420へ四角。

  数を0から15まで繰り返す。         #ゲーム画面描画
    x=駒¥数%4。y=駒¥数/4。y=yを切り下げ。
    x=x*駒サイズ。y=y*駒サイズ。

    x2=数%4。y2=数/4。y2=y2を切り下げ。
    x2=左マージン+x2*駒サイズ。y2=上マージン+y2*駒サイズ

    もし、駒¥数<15ならば
      裏画面のx,y,駒サイズ,駒サイズを母艦のx2,y2へ画像部分コピー。

  新規ゲーム待ちは「オフ」
  問題作成中は「オフ」
#-------------------------------------------------------------

#-----マウス判定----------------------------------------------
*マウス判定
  母艦のマウス押した時は
    もし、(新規ゲーム待ち=「オフ」)かつ
    (母艦のマウスX>左マージン)かつ  #マウスが盤の中で
    (母艦のマウスY>上マージン)かつ  #押されたか確認
    (母艦のマウスX<左マージン+盤サイズ)かつ
    (母艦のマウスY<上マージン+盤サイズ)ならば

      mx=(母艦のマウスX-左マージン)/駒サイズ。my=(母艦のマウスY-上マージン)/駒サイズ。
      mx=mxを切り下げ。my=myを切り下げ。
      m=mx+my*4。       #どの駒を押したか?

      x=駒¥m%4。y=駒¥m/4。y=yを切り下げ。
      x=x*駒サイズ。y=y*駒サイズ。  #クリックした駒が裏画面に実際にある位置
      
      x2=アキ%4。y2=アキ/4。y2=y2を切り下げ。
      x2=左マージン+x2*駒サイズ。y2=上マージン+y2*駒サイズ   #のときのアキの座標→クリックした駒と入れ替わる
      
      mx=左マージン+mx*駒サイズ。my=上マージン+my*駒サイズ。  #マウスで押した駒の座標→アキに入れ替わる。

      もし、駒¥m<15ならば
        もし、m+4=アキならば
          駒入れ替え_上。

        もし、m-4=アキならば
          駒入れ替え_下。

        もし、m+1=アキならば
          駒入れ替え_左。

        もし、m-1=アキならば
          駒入れ替え_右。
#-------------------------------------------------------------

#-----駒入れ替え----------------------------------------------
*駒入れ替え_上
  もし、(アキ/4≧1)ならば      #アキが一番上でなければ
    駒のアキと(アキ-4)を配列入れ替え。#上の駒と入れ替え
    アキ=アキ-4。駒入れ替え_描画。

*駒入れ替え_下
  もし、(アキ/4<3)ならば      #アキが一番下でなければ
    駒のアキと(アキ+4)を配列入れ替え。#下の駒と入れ替え
    アキ=アキ+4。駒入れ替え_描画。

*駒入れ替え_左
  もし、(アキ%4>0)ならば     #アキが左端でなければ
    駒のアキと(アキ-1)を配列入れ替え。#左の駒と入れ替え
    アキ=アキ-1。駒入れ替え_描画。

*駒入れ替え_右
  もし、(アキ%4<3)ならば     #アキが右端でなければ
    駒のアキと(アキ+1)を配列入れ替え。#右の駒と入れ替え
    アキ=アキ+1。駒入れ替え_描画。

*駒入れ替え_描画
  もし、問題作成中が「オフならば   #問題作成はいちいち描画しない
    裏画面のx,y,駒サイズ,駒サイズを母艦のx2,y2へ画像部分コピー。
    線色は$DDDDDD。線太さは0。塗り色は$DDDDDD。
    母艦のmx,myから(mx)+駒サイズ,(my)+駒サイズへ四角。
    完成判定。
#-------------------------------------------------------------

#-----完成判定------------------------------------------------
*完成判定
  完成は整数。完成は0。
  数を0から15まで繰り返す。
    もし、駒¥数が数ならば
      完成は完成+1
  もし、完成=16ならば
    「おめでとう!」と言う。
    裏画面を母艦の15,15へ画像コピー。 #16コマ目表示

    新規ゲーム待ちは「オン」      #完成したら新規ゲーム開始までマウスで駒を動かさない。
#-------------------------------------------------------------

上下左右の駒配列入れ替え部分が、問題作成時と、ゲーム中のマウスクリック時と、処理がかぶっていたのを、別ルーチンにしただけです。

 もっとスマートに書けるのかも知れないけど・・・


 あと、母艦設計の頭に、「!母艦設計=「母艦の可視はオフ」」てのを追加

 起動時に、母艦がチラッとちらつくのを防ぐまじないのようです。

 単に、「母艦の可視はオフ」にしても、の前に一瞬ちらっと母艦表示されちゃうんですけど、こうするとOK。

 意味はわかんないけど、後も役に立ちそうなおまじないです。

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090323

2009/03/22 (日)

いよいよ完成! ・・・かな?

| 20:19 | いよいよ完成! ・・・かな? - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - いよいよ完成! ・・・かな? - 雪乃☆雫のなでしこ日和 いよいよ完成! ・・・かな? - 雪乃☆雫のなでしこ日和 のブックマークコメント

 いよいよ、完成近だよ!

 前バグったところは、忘れていたはみ出しのチェックを加えて、あっさり解決したけど、これって・・・問題作成のコードとほとんど同じじゃん~(汗)

 ワタシ的には動けば全然問題ないですが、ありとあらゆる本(ってほど知ってるわけじゃないけどね)に、こーいうプログラムはイカーン! と書いてあるのでした。む~。

 ・・・ま、それはとりあえず置いといて(コラ)


 「き」は「アキ」に変えてみました(笑)

 あと、初期化~問題作成~画面描画までを「*新規ゲーム」というサブルーチンにして、メニューの「新規ゲーム」から呼び出せるようになりました♪

 それ以外で追加したのが、完成のチェック

 まあ、15パズルが完成したかどうかくらい、自分で見た目に分かりますけど、完成したよ~って言う達成感が欲しいっていうか?

#-----完成判定----------------------------------------------------------

  完成は整数。完成は0。

  数を0から15まで繰り返す

    もし、駒¥数が数ならば

      完成は完成+1

  もし、完成=16ならば

    「おめでとう!」と言う

    裏画面を母艦の15,15へ画像コピー。      #16コマ目表示

    新規ゲーム待ちは「オン」          #完成したら新規ゲーム開始までマウスで駒を動かさない

#-----------------------------------------------------------------------

 駒入れ替えのあとに、駒の配列が順番どおりになったかをチェックするようにしました。

 これで、15パズルが遊べて、完成したら「おめでとう!」って言ってもらえます。

 完成! 完成! やた~♪


 調子に乗って、メニューバージョン情報を表示するようにしました(爆)

 若干の課題が残ったので、とりあえず0.9ってことにしときますか。

 これからも、なでしこ勉強しながら機能を追加していくつもりです!

 ・・・って、あれ? 課題が残ったのでVer.0.9ってことは、やっぱそれ解決しない限り、バージョンアップできないんじゃ?!(汗)

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090322

2009/03/21 (土)

ゴトとゴスブだよ?!

| 19:57 | ゴトとゴスブだよ?! - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - ゴトとゴスブだよ?! - 雪乃☆雫のなでしこ日和 ゴトとゴスブだよ?! - 雪乃☆雫のなでしこ日和 のブックマークコメント

 マウスの位置を取得できたら、後の話は意外と簡単。

 クリックした駒の上下左右にきがあるかどうかを調べて、あればこと入れ替えるだけです。

#-----マウス判定--------------------------------------------------------

母艦のマウス押した時は

  もし、(新規ゲーム待ち=「オフ」)かつ

  (母艦のマウスX>左マージン)かつ      #マウスが盤の中で

  (母艦のマウスY>上マージン)かつ      #押されたか確認

  (母艦のマウスX<左マージン+盤サイズ)かつ

  (母艦のマウスY<上マージン+盤サイズ)ならば

    mx=(母艦のマウスX-左マージン)/駒サイズ。my=(母艦のマウスY-上マージン)/駒サイズ。

    mx=mxを切り下げ。my=myを切り下げ

    m=mx+my*4。               #どの駒を押したか?

    x=駒¥m%4。y=駒¥m/4。y=yを切り下げ

    x=x*駒サイズ。y=y*駒サイズ。       #のときのきの座標

    x2=き%4。y2=き/4。y2=y2を切り下げ

    x2=左マージン+x2*駒サイズ。y2=上マージン+y2*駒サイズ  #マウスで押した駒の座標

    mx=左マージン+mx*駒サイズ。my=上マージン+my*駒サイズ。 #マウスで押した駒の座標→きに入れ替わる。

    もし、駒¥m<15ならば

      もし、m+4=ならば

        駒のきと(き-4)を配列入れ替え。

        き=き-4。

      もし、m-4=ならば

        駒のきと(き+4)を配列入れ替え。

        き=き+4。

      もし、m+1=ならば

        駒のきと(き-1)を配列入れ替え。

        き=き-1。

      もし、m-1=ならば

        駒のきと(き+1)を配列入れ替え。

        き=き+1。

      #---画面描画------

      裏画面のx,y,駒サイズ,駒サイズを母艦のx2,y2へ画像部分コピー

      線色は$DDDDDD。線太さは0。塗り色は$DDDDDD。

      母艦のmx,myから(mx)+駒サイズ,(my)+駒サイズへ四角

#-----------------------------------------------------------------------

 これでいけるかと思ったら、いかなかった。

 やっぱり、画面描画のコードは、もしもしの下に、それぞれ入らないとダメっぽい。

 同じコードを4つ貼るのはあれなんで、この部分をサブルーチン化したいですね。

 っていうか、までもよく分からないからスルーしていただけで、問題作成のところもそうないと、メニューから呼び出せないんじゃ? みたいな。

 発見したのは「飛ぶ」という命令と、「ユーザー定義関数」っていうのがあるいうこと。

 「飛ぶ」は「ジャンプポイントへ処理を移す」という説明を見ると、たぶん「goto」と同じで、飛んだらそれっきり戻ってこないと思われ。

 ユーザー定義関数は、調べ方も足りてませんけど、あんまりよく分かる解説が無い。っていうか、関数のものが理解できてないのが問題?

 別に、関数じゃなくっていいんだよね~。「gosub」みたいに、行って処理して、帰ってきてくれさえすれば!

 とりあえず、行頭に「●」か「*」付けるらしいのは分かったので、以下のようにしたら動きました。

#-----------------------------------------------------------------------

   :

   :

      もし、m-1=ならば

        駒のきと(き+1)を配列入れ替え。

        き=き+1。

        駒入れ替え。

*駒入れ替え

  #---画面描画------

  裏画面のx,y,駒サイズ,駒サイズを母艦のx2,y2へ画像部分コピー

  線色は$DDDDDD。線太さは0。塗り色は$DDDDDD。

  母艦のmx,myから(mx)+駒サイズ,(my)+駒サイズへ四角

#-----------------------------------------------------------------------

 とりあえず、「*」のほうが打ちやすいのでこっち使いましたが、マニュアルのユーザー定義命令のとこには「●」で説明されていて「*」についての言及が見られないけど、「●」がほんとなのかな?

 それとも、VBのプロシージャの「Sub」と「Function」みたいな使い分けが?

 でも、とりあえず動いたからOK!

 これで、いちおう完成~☆

 ……と思ったら、はみ出しのチェックをしていなかったため、バグっていることが判明。

 右端から左端(の逆も)へ、駒が飛んでしまうのでした(汗)

 U D 4 U D 42009/03/21 22:35むしろ後で追加された「飛ぶ」命令の方がリファレンスが少ない気がしますが…f(^^; なでしこではプロシージャという概念がありません。ユーザ定義命令でプロシージャも関数も表現します。

●と*と*は同じ意味で、どれもユーザ定義命令を定義するのに使います。なので、●を使うか*を使うかは好みですね。ひまわりから移ってきた人は見慣れている*を使う傾向にあるみたいですし、半角文字の方がよくて*を使う人もいます。そういえば不思議なことに、掲示板やマニュアル、サンプルでは割と●に統一されているようです。

あと、「空き」「空」は別の変数のように見えますが、実は全く同じ変数です。

空きは3
空を言う

なでしこは平仮名を無視するという名前規則が存在するため、これらは同じものとして扱われます。まぁ、粗茶さんが仰ったように、「空」を空文字列として利用しないなら、問題は起きませんがね。

着々と進んでいるようなので、頑張って完成させてください!ではでは

 U D U D 2009/03/21 22:36どうでもいいけどなぜ名前に4がついたしorz

雪乃☆雫雪乃☆雫2009/03/21 23:14UDさま、ありがとうございます♪
「飛ぶ」のほうも、命令検索で出る「ジャンプポイントへ処理を移す。ジャンプポイントは文字列で指定する」ってことしか分かってないです;
そもそも、関数とかプロシージャとか手続きとか、よく分かってないダメダメっぷりなので、ユーザ定義命令の理解できる道のりは遠そうですが、いくつか記載されてるところは見つけているので、ゆっくり学んでみますです。

●と*と*は同じ意味なんですね。
「●」は「まる」って打って変換しないとならないので、「*」のほうが楽なのでこっちをつかいましたが、掛けるの「*」とかぶるのでちょっと心配でした。
疑問がひとつ氷解です。ありがとうございました☆

っていうか、「空」と「空き」は同じなんですか?!
じゃじゃじゃあ、何にしよー(汗)

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090321

2009/03/20 (金)

もしもしもしもしぃ~~;

| 22:43 | もしもしもしもしぃ~~; - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - もしもしもしもしぃ~~; - 雪乃☆雫のなでしこ日和 もしもしもしもしぃ~~; - 雪乃☆雫のなでしこ日和 のブックマークコメント

 昨日ので、マウスの座標を取得して、どの駒をクリックしたかが分かるようになりました。

 でも、パズルの盤の外をクリックしても、座標が入ってしまうのは、よろしくありません。盤の中をクリックした時だけ取得するように変更。

#-----マウス判定--------------------------------------------------------

母艦のマウス押した時は                 #マウス位置が

  もし母艦のマウスX>左マージンならば        #盤の中にあるかを確認

    もし母艦のマウスY>上マージンならば

      もし母艦のマウスX<左マージン+盤サイズならば

        もし母艦のマウスY<上マージン+盤サイズならば

          x=(母艦のマウスX-左マージン)/駒サイズ。y=(母艦のマウスY-上マージン)/駒サイズ。

          x=xを切り下げ。y=yを切り下げ

#-----------------------------------------------------------------------

 もしもしもしもしぃ~~~~~~~~(汗)

 条件分岐のなかで、論理式?を使う方法がよく分からなかったので、てきとーに「かつ」とか「and」とか入れてみたけどうまくいかず。

 しょうがないからとりあえず書いたらこんなことに…;

 でも、一応これで動きますけどね。

 というわけで、とりあえずスルーして先に進もうかとも思いましたが、んなわけねーだろ?! と、学んだ結果以下のとおりに書き換え。

#-----マウス判定--------------------------------------------------------

母艦のマウス押した時は

  もし、(新規ゲーム待ち=「オフ」)かつ

  (母艦のマウスX>左マージン)かつ         #マウスが盤の中で

  (母艦のマウスY>上マージン)かつ         #押されたか確認

  (母艦のマウスX<左マージン+盤サイズ)かつ

  (母艦のマウスY<上マージン+盤サイズ)ならば

    x=(母艦のマウスX-左マージン)/駒サイズ。y=(母艦のマウスY-上マージン)/駒サイズ。

    x=xを切り下げ。y=yを切り下げ

#-----------------------------------------------------------------------

 これは、一行に書いても大丈夫のようです。

 わかったのは、もしならばだけのときは特に必要ありませんでしたが、条件の式を()で囲まないとダメらしい。これは、「かつ」が白い文字なので、式の中の変数とはつながってしまうからだと思われます。

 あと、なぜか改行は「かつ」の後ろで入れなくてはならず、「かつ」を行頭に持ってくるような書き方は出来ないらしいです。

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090320