Hatena::Groupnadesiko

雪乃☆雫のなでしこ日和

2011/01/13 (木)

15パズルのバグを直すよ!

| 21:29 | 15パズルのバグを直すよ! - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - 15パズルのバグを直すよ! - 雪乃☆雫のなでしこ日和 15パズルのバグを直すよ! - 雪乃☆雫のなでしこ日和 のブックマークコメント

 突然ですけど、以前作った15パズルに、バグを発見したので、直しておきます。


 この部分です。

#-----成績リセット---------------------------------------------
*成績リセット
  ダイアログタイトルは「成績表リセット」
  「リセットしてもいい?」と二択。
    もしそれはいならば
      (表示順位数*2)
      成績¥回数
      を「成績表.txt」へ保存。
#-------------------------------------------------------------

> テキストをクリアするだけなら、保存すればいいだけだけど、それだと現在の成績表表示は変わらないので、成績配列の中身もにしないとね。


 なんて書いていながら、それが正常に機能してなかったことが判明なのです;

 ちゃんとテストもしてたつもりだったのに、なんでだ・・・(涙)


 というわけで、↓のように直しました。

#-----成績リセット---------------------------------------------
*成績リセット
  ダイアログタイトルは「成績表リセット」
  「リセットしてもいい?」と二択。
    もしそれはいならば
      (表示順位数*2)
        成績¥回数    #←ここです
      を「{母艦パス}成績表.txt」へ保存。
#-------------------------------------------------------------

 繰り返しの「」の中身がちゃんとインデントされていなかったのが問題でした。

 途中で、変にしてしまったのかも・・・




 さてさて、問題の15パズルのソースの全文は、こちら。

http://nadesiko.g.hatena.ne.jp/snowdrops89/20090401/1238587801

 該当の関数し替えたら、ばっちり動きます☆

chocochoco2011/01/28 20:45いつの間にか復帰してたのですね^^;
今日初めて気が付きました(笑)

また素敵な物語が続くのかと思うと、とても楽しみです。
これからも頑張って下さい。

私も自分のページ頑張らないと・・・。

雪乃☆雫雪乃☆雫2011/01/29 17:12>choco さま
そうなんです、いつの間にか・・・w
でも、ぼちぼちですけれどね。
復帰そうそう、こちらは大雪で雪かきに追われてぐったり(>_<)
プログラムどころじゃ、ありません;;;
ともあれ、素敵な物語?!?!と言えるかどうか分かりませんけれども、またゆるゆるとお付き合いくださいませ。

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20110113

2009/05/04 (月)

大事件だよ!

| 01:11 | 大事件だよ! - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - 大事件だよ! - 雪乃☆雫のなでしこ日和 大事件だよ! - 雪乃☆雫のなでしこ日和 のブックマークコメント

 GWで遊び呆けているに、大変なことが!!!

 ノリで(参加賞目当てで;)応募した、なでしこコミュニティーコンテストの発表が、5/1だったわけで。

 んなことも忘れ去り、GWを満喫し、遊び歩いていたわけで(汗)

 ふと、久々にパソコンを起動してみたら、メールが届いていたわけで。(しかも、さりげなく迷惑メールフォルダに落ちていたりして、大ぴんち!(滝汗))


 とにかく!

 なぜか、最優秀賞のところに、ワタシのつくった15パズルがさりげなく載っているのであった。

 なんで?! Why?!

 あんなので、良かったのデスか~~?!?!?!

 何かの違いじゃないかと、こはかとなく不安だ・・(爆)

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090504

2009/04/01 (水)

『15パズル』 Ver.2 完成だよ!!

| 21:10 | 『15パズル』 Ver.2 完成だよ!! - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - 『15パズル』 Ver.2 完成だよ!! - 雪乃☆雫のなでしこ日和 『15パズル』 Ver.2 完成だよ!! - 雪乃☆雫のなでしこ日和 のブックマークコメント

 15パズルでやりたいこと、出来ることといったら、このくらいかなあ?

 あと思いつくのは、駒の数を増やしてみるくらいですけど、大体のやり方が見えているので、学習としては効果が薄そうなのに加えて、それを解きたい気持ちが湧き上がってこない(汗)しかも、当初は全然んなつもりじゃなかったから、の辺りの数値は全部数字で決め打ちしてるから、直すのがえらくめんどー(--; などの問題により、パス!(だから何でも変数にしておいたほうがいいよ、っていう好例?;)


 ・・・ってわけで、バージョン2の完成! としました☆

 に合いそうだったので、うれしがってコンテストにも応募してみました! 参加賞って何かな? かな?(それがめあてか;)

 NAKOちゃんストラップとか?(笑)

#-------------------------------------------------------------
#  15パズル   ver.2.00
#-------------------------------------------------------------

#-----母艦設計------------------------------------------------
!母艦設計=「母艦の可視はオフ母艦のタイトルは「15パズル」
母艦のWは640。母艦のHは480。
母艦を$FFBBBBで画面クリア母艦のスタイルは「枠固定」
母艦オフに最大化ボタン有効変更。
母艦中央移動

#--メニュー設定----
『#親部品名,部品名,テキスト,ショートカット,オプション,イベント
なし,ファイルメニュー,ファイル(&F),,,
 -,新規メニュー,新しいゲーム(&N),Ctrl+N,,新規ゲーム
 -,やり直しメニュー,このゲームをやり直す(&R),Ctrl+R,,やり直し
 -,-,,,,
 -,画像変更メニュー,画像変更(&C),Ctrl+C,,画像変更
 -,-,,,,
 -,成績表メニュー,成績表(&S),Ctrl+S,,成績表表示
 -,成績リセットメニュー,成績リセット(&D),Ctrl+D,,成績リセット
 -,-,,,,
 -,閉じるメニュー,閉じる(&X),Ctrl+X,,終わる

なし,ヘルプメニュー,ヘルプ(&H),,,
 -,リードミーメニュー,よんでね(&R),Ctrl+R,,りーどみー
 -,-,,,,
 -,ヒントメニュー,ヒントを見る(&H),F1,,ヒント表示
 -,ギブアップメニュー,ギブアップする(&G),F5,,ギブアップ
 -,-,,,,
 -,バージョンメニュー,バージョン情報(&A),Ctrl+A,,バージョン
』をメニュー一括作成。

#手数カウント機能用
文字書体は「MSPゴシック」。文字サイズは18。文字色は$AA0000。
母艦の440,33へ「手数」を文字描画。

手数ラベルとはラベルのテキストは「0」
のXは500。のYは30。のWは100。のHは35。
文字書体は「MSPゴシック」。文字サイズは24。の文字位置は右。文字色は$550000。
の背景色は$FFDDDD。の透明はオフ。

#タイムトライアル用
トライアルタイマーとはタイマー隔は1。

母艦の440,110へ「タイムトライアル!」を文字描画。

タイムラベルとはラベルのテキストは「00:00」
のXは440。のYは140。のWは180。のHは50。の文字位置は中央。
文字書体は「MSPゴシック」。文字サイズは36。文字色は$550000。
の背景色は$FFDDDD。の透明はオフ。

#ヒント表示用
ヒントメニューチェックオフ母艦の可視はオン。
#-------------------------------------------------------------

#-----宣言----------------------------------------------------
パズル画像は「15パズル.jpg」。
裏画面とはイメージの可視はオフ。
アキとは整数。
駒とは配列。
新規ゲーム待ち文字位置とは文字列。
問題作成中とは文字列。
手数順位とは整数。手数順位=0
タイム順位とは整数。タイム順位=0
表示順位数とは整数表示順位数=5

記憶とは配列。
アキ記憶とは整数。

成績とは配列。
作業用とはイメージの可視はオフ。

#--定数----
盤サイズとは整数。盤サイズは400。
駒サイズとは整数。駒サイズは100。
左マージンとは整数。左マージンは15。
上マージンとは整数。上マージンは15。
裏画面のWは盤サイズ。裏画面のHは盤サイズ。
#-------------------------------------------------------------

#-----データ読み込み------------------------------------------
もし、「成績表.txt」が存在するならば
  「成績表.txt」を毎行読んで反復
    成績¥回数対象違えば
  「成績表.txt」に保存。												#成績表が無かったら作成する

もし、パズル画像の存在が1ならば
  作業用の画像はパズル画像。
  もし、作業用のW=盤サイズ かつ 作業用のH=盤サイズでなければ     #画像ファイルがデフォルトの物と違う場合
    リサイズし変更
  違えば
    作業用を裏画面の0,0へ画像コピー違えば
  十五																	#画像ファイルが無かった場合	
#-------------------------------------------------------------

#-----メインルーチン------------------------------------------
新規ゲーム。
マウス判定。
#-------------------------------------------------------------


#-----初期化処理----------------------------------------------
*初期化
  トライアルタイマー停止。
  手数は0。手数ラベルのテキストは「0」。のXは500。のYは30。のWは100。のHは35。		#手数も0に初期化。
  経過は0。タイムラベルのテキストは「00:00」。のXは440。のYは140。のWは180。のHは50。	#タイムも初期化。
#-------------------------------------------------------------

#-----新規ゲーム----------------------------------------------
*新規ゲーム
  #---初期化------
  アキは15。															#アキ位置を初期化。
  数を0から15まで繰り返す。											#駒位置を初期化
    駒¥数は数。
  初期化。

  #---問題作成------
  問題作成中は「オン」
  乱数初期化。
  1000
    rは4の乱数
    もし、rが0ならば
      駒入れ替え_上。

    もし、rが1ならば	
      駒入れ替え_下。

    もし、rが2ならば
      駒入れ替え_左。

    もし、rが3ならば
      駒入れ替え_右。

  ゲーム画面描画。

#-----ゲーム画面描画------------------------------------------
*ゲーム画面描画
  線色は$AAAAAA。線太さは5。塗り色は$DDDDDD。		#画面のクリア
  母艦の10,10から420,420へ四角。
  アキ記憶=アキ。											 			#アキの初期値を記憶

  数を0から15まで繰り返す。
    記憶¥数=駒¥数													#現在の配列を記憶

    x=駒¥数%4。y=駒¥数/4。y=yを切り下げ。
    x=x*駒サイズ。y=y*駒サイズ。

    x2=数%4。y2=数/4。y2=y2を切り下げ。
    x2=左マージン+x2*駒サイズ。y2=上マージン+y2*駒サイズ

    もし、駒¥数<15ならば
      裏画面のx,y,駒サイズ,駒サイズを母艦のx2,y2へ画像部分コピー。	#ゲーム画面描画

  新規ゲーム待ちは「オフ」
  問題作成中は「オフ」
#-------------------------------------------------------------

#-----マウス判定----------------------------------------------
*マウス判定
  母艦のマウス押した時は
    もし、(新規ゲーム待ち=「オフ」)かつ
    (母艦のマウスX>左マージン)かつ									#マウスが盤の中で
    (母艦のマウスY>上マージン)かつ									#押されたか確認
    (母艦のマウスX<左マージン+盤サイズ)かつ
    (母艦のマウスY<上マージン+盤サイズ)ならば
    
      もし、手数=0ならば											#はじめに盤をクリックした時から
        トライアルタイマーを開始。									#タイマーを動かす
        タイムトライアル。
        
      mx=(母艦のマウスX-左マージン)/駒サイズ。my=(母艦のマウスY-上マージン)/駒サイズ。
      mx=mxを切り下げ。my=myを切り下げ。
      m=mx+my*4。											#どの駒を押したか?

      x=駒¥m%4。y=駒¥m/4。y=yを切り下げ。
      x=x*駒サイズ。y=y*駒サイズ。							#クリックした駒が裏画面に実際にある位置
      
      x2=アキ%4。y2=アキ/4。y2=y2を切り下げ。
      x2=左マージン+x2*駒サイズ。y2=上マージン+y2*駒サイズ		#のときのアキの座標→クリックした駒と入れ替わる
      
      mx=左マージン+mx*駒サイズ。my=上マージン+my*駒サイズ。	#マウスで押した駒の座標→アキに入れ替わる。

      もし、駒¥m<15ならば
        もし、m+4=アキならば
          駒入れ替え_上。

        もし、m-4=アキならば
          駒入れ替え_下。

        もし、m+1=アキならば
          駒入れ替え_左。

        もし、m-1=アキならば
          駒入れ替え_右。

#-------------------------------------------------------------

#-----駒入れ替え----------------------------------------------
*駒入れ替え_上
  もし、(アキ/4≧1)ならば										#アキが一番上でなければ
    駒のアキと(アキ-4)を配列入れ替え。							#上の駒と入れ替え
    アキ=アキ-4。駒入れ替え_描画。

*駒入れ替え_下
  もし、(アキ/4<3)ならば										#アキが一番下でなければ
    駒のアキと(アキ+4)を配列入れ替え。							#下の駒と入れ替え
    アキ=アキ+4。駒入れ替え_描画。

*駒入れ替え_左
  もし、(アキ%4>0)ならば									#アキが左端でなければ
    駒のアキと(アキ-1)を配列入れ替え。							#左の駒と入れ替え
    アキ=アキ-1。駒入れ替え_描画。

*駒入れ替え_右
  もし、(アキ%4<3)ならば									#アキが右端でなければ
    駒のアキと(アキ+1)を配列入れ替え。							#右の駒と入れ替え
    アキ=アキ+1。駒入れ替え_描画。

*駒入れ替え_描画
  もし、問題作成中が「オフならば								#問題作成はいちいち描画しない
    裏画面のx,y,駒サイズ,駒サイズを母艦のx2,y2へ画像部分コピー。
    線色は$DDDDDD。線太さは0。塗り色は$DDDDDD。
    母艦のmx,myから(mx)+駒サイズ,(my)+駒サイズへ四角。
    完成判定。
#-------------------------------------------------------------

#-----完成判定------------------------------------------------
*完成判定
  #---手数表示------
  手数=手数+1。手数ラベルのテキストは手数。のXは500。のYは30。のWは100。のHは35。

  完成は整数。完成は0。
  数を0から15まで繰り返す。
    もし、駒¥数が数ならば
      完成は完成+1
  もし、完成=16ならば
    トライアルタイマー停止。												#タイマー停止

    成績表記録。
    
    #表示させる文字の設定
    もし、手数順位=0ならば
      手数成績=「{改行} 手数{手数}手です」
    違えば
      手数成績=「{改行} 手数{手数}手は{改行}   歴代{手数順位}位の成績です」
    
    もし、タイム順位=0ならば
      タイム成績=「{改行} タイム{分}分{秒}秒です」
    違えば
      タイム順位=タイム順位-表示順位数
      タイム成績=「{改行} タイム{分}分{秒}秒は{改行}   歴代{タイム順位}位の成績です」    

    #表示させる
    もし、(手数順位=0 かつ タイム順位=0)ならば
      ダイアログタイトルは「完成!」
      「おめでとう。完成です!{改行}{手数成績}{タイム成績}」と言う。
    違えば
      ダイアログタイトルは「ハイスコアが出ました!」
      「おめでとう。新記録です!!{改行}{手数成績}{タイム成績}」と言う。
      成績表表示。

    裏画面を母艦の左マージン,上マージンへ画像コピー。						#16コマ目表示

    新記録は0
    新規ゲーム待ちは「オン」												#完成したら新規ゲーム開始までマウスで駒を動かさない。
#-------------------------------------------------------------

#-----バージョン表示------------------------------------------
*バージョン
  ダイアログタイトルは「バージョン情報」
  「{二重カッコ}15パズル{二重カッコ閉じ}{改行} Version 2.00{改行}{改行} by 雪乃☆雫」と言う。

#-------------------------------------------------------------

#-----このゲームをやりなおす----------------------------------
*やり直し
  初期化。
  数を0から15まで繰り返す。
    駒¥数=記憶¥数。
  アキはアキ記憶。															#アキ位置を初期化。
  ゲーム画面描画。
  マウス判定。
#-------------------------------------------------------------

#-----タイムトライアル----------------------------------------
*タイムトライアル
  トライアルタイマーの時満ちた時は~
    経過=経過+1。
    分=経過/60を切り下げ。
    秒=経過%60。
    分=分を2でゼロ埋め。秒=秒を2でゼロ埋め。							#時を00:00で表示させる。
    タイムラベルのテキストは「{分}:{秒}」。のXは440。のYは140。のWは180。のHは50。
#-------------------------------------------------------------

#-----成績表表示----------------------------------------------
*成績表表示
  s=「★☆★成績表★☆★{改行}{改行}◎手数のハイスコア{改行}」
  数を1から表示順位数まで繰り返す
    もし、成績¥数がならば
      s=「{s} {数}位  ---手{改行}」
    違えば
      s=「{s} {数}位  {成績¥数}手{改行}」
  s=「{s}{改行}◎タイムのハイスコア{改行}」
  数を(表示順位数+1)から(表示順位数*2)まで繰り返す
    分=成績¥数/60を切り下げ。
    秒=成績¥数%60。
    分=分を2でゼロ埋め。秒=秒を2でゼロ埋め
    もし、成績¥数がならば
      s=「{s} {数-表示順位数}位  --分--秒{改行}」
    違えば
      s=「{s} {数-表示順位数}位  {分}分{秒}秒{改行}」
  ダイアログタイトルは「成績表」
  sを言う。

#-------------------------------------------------------------

#-----成績表記録----------------------------------------------
*成績表記録
  #手数のハイスコア
  手数順位=0
  数を表示順位数から1まで繰り返す。
    もし、(成績¥数>手数 または 成績¥数=ならば
      手数順位=数
  数を表示順位数から1まで繰り返す。
    もし、手数順位=0でなければ
      もし、手数順位=数ならば
        成績¥数=手数
      もし、手数順位<数ならば
        成績¥数=成績¥(数-1)

      
  #タイムのハイスコア
  タイム順位=0
  数を(表示順位数*2)から(表示順位数+1)まで繰り返す。
    もし、(成績¥数>経過 または 成績¥数=ならば
      タイム順位=数
  数を(表示順位数*2)から(表示順位数+1)まで繰り返す。
    もし、タイム順位=0でなければ
      もし、タイム順位=数ならば
        成績¥数=経過
      もし、タイム順位<数ならば
        成績¥数=成績¥(数-1)

  s=「」
  数を1から表示順位数まで繰り返す
    s=「{s}{成績¥数}{改行}」
  数を(表示順位数+1)から(表示順位数*2)まで繰り返す
    s=「{s}{成績¥数}{改行}」

  sを「{母艦パス}成績表.txt」へ保存。
#-------------------------------------------------------------

#-----画像変更------------------------------------------------
*画像変更
  マイピクチャー作業フォルダ変更。
  「*.jpg;*.jpeg;*.png;*.bmp」のファイル選択。
  もしそれでなければ												#キャンセルした時は処理しない
    作業用の画像はそれ。
    リサイズし変更

*リサイズし変更
  もし、作業用のW>作業用のHならば									#横長の画像
    x=(作業用のW-作業用のH)/2。y=0。
    x2=作業用のH+x。y2=作業用のH。
    裏画面をy2,y2で画像リサイズ。								#短いほうの辺に長さあわせて正方形
  違えば
    x=0。y=(作業用のH-作業用のW)/2。
    x2=作業用のW。y2=作業用のW+y
    裏画面をx2,x2で画像リサイズ。

  作業用のx,y,x2,y2を裏画面の0,0へ画像部分コピー。
  裏画面を盤サイズ,盤サイズで画像リサイズ。
  裏画面を母艦の左マージン,上マージンへ画像コピー。
  ヒントメニューチェックオン。ヒント表示。            #画像を変更したら、ヒントはいったん消す
  新規ゲーム
#-------------------------------------------------------------

#-----ヒント表示----------------------------------------------
*ヒント表示
  もし、(ヒントメニューチェックオフ)ならば
    ヒントメニューチェックオン。
    作業用を盤サイズ,盤サイズで画像リサイズ。
    裏画面を作業用の0,0へ画像コピー。
    作業用を150,150で画像リサイズ。
    作業用を母艦の455,260へ画像コピー。
    文字サイズは18。文字色は$AA0000。
    母艦の478,230へ「☆ヒント☆」を文字描画。
    描画処理反映。
  違えば
    ヒントメニューチェックオフ。
    線色は$FFBBBB。塗り色は$FFBBBB。
    母艦の455,230から610,410へ四角。
    ラベル3の可視はオフ。
    描画処理反映。
#-------------------------------------------------------------

#-----ぎぶあっぷ----------------------------------------------
*ギブアップ
  ダイアログタイトルは「ギブアップする?」
  「本当に?」と二択。
    もしそれはいならば
      裏画面を母艦の左マージン,上マージンへ画像コピー。
      描画処理反映。
      新規ゲーム待ちは「オン」
      初期化。
#-------------------------------------------------------------

#-----しょぼい15パズル画面作成------------------------------
*十五
  裏画面のWは盤サイズ。裏画面のHは盤サイズ。
  裏画面を$FFFFAAで画面クリア
  線色は$AAAAAA。線太さは0。
  数を0から15まで繰り返す
    x=数%4。
    y=数/4を切り下げ。
    yで条件分岐
      0ならば
        塗り色は$AAAAFF
      1ならば
        塗り色は$FFAAAA
      2ならば
        塗り色は$FFDDAA
      3ならば
        塗り色は$AAFFAA

    裏画面のx*駒サイズ,y*駒サイズからx*駒サイズ+駒サイズ,y*駒サイズ+駒サイズへ四角。
    文字サイズは42。文字色は$006600
    もし、(数>8)ならば
      x=20+(数%4)*駒サイズ。
    違えば
      x=35+(数%4)*駒サイズ。
    y=数/4を切り下げ。y=20+y*駒サイズ。
    もし、数=15ならば
      裏画面のx,yへ「★」を文字描画
    違えば
      裏画面のx,yへ(数+1)を文字描画
  
  裏画面を母艦の左マージン,上マージンへ画像コピー。
#-------------------------------------------------------------

#-----成績リセット--------------------------------------------
*成績リセット
  ダイアログタイトルは「成績表リセット」
  「リセットしてもいい?」と二択。
    もしそれはいならば
      (表示順位数*2)
      成績¥回数
      を「{母艦パス}成績表.txt」へ保存。
#-------------------------------------------------------------

#-----よんでね------------------------------------------------
*りーどみー
  もし、「よんでね.txt」が存在するならば
    「よんでね.txt」を起動。
  違えば
    ダイアログタイトルは「よんでね」
    「【15パズルのルール】
  知らない人はあまりいないと思いますが…
  16枚ある駒の16番目の駒を抜いてばらばらにしたものを動かしていって、
 1から15まで数字を連続させて並べたらクリアです(画像の場合はもちろん
 右下の一マスを除いて、の画像を完成させればクリアです)
  いているマス目の上下左右の駒ををクリックすると、の駒を動かす
 ことができます。
  当然のことながら、きマスに隣接していない駒は(斜めも不可)動か
 すことが出来ません」を言う。
#-------------------------------------------------------------

 違う画像を選択で別のフォルダの画像を選んだとき、のフォルダに成績表が記録されてしまうことがわかったので、成績表.txtの保存先を母艦パスにするように変更しました。

mr-80bmr-80b2009/04/01 23:08プレイしてみました。
楽しいです!

雪乃☆雫雪乃☆雫2009/04/02 19:44mr-80bさま
ありがとうございます!!
遊んでいただけたんですね!うれしー♪
おかげさまでここまでこぎつけました。
これからも、頑張ります☆

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090401

2009/03/31 (火)

いよいよ完成! かな?

| 21:01 | いよいよ完成! かな? - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - いよいよ完成! かな? - 雪乃☆雫のなでしこ日和 いよいよ完成! かな? - 雪乃☆雫のなでしこ日和 のブックマークコメント

 まずは課題の解決から。

 表示順位数を先に宣言しておくことで、何位まで表示するかを後から容易に変更できるようになりました!

 「言う」では8位以上表示しきれずに、詳細ってボタン表示されてしまいますけどね(汗)

 調子に乗って5位まで表示させるようにしました。

#-----成績表表示-----------------------------------------------
*成績表表示
  s=「★☆★成績表★☆★{改行}{改行}◎手数のハイスコア{改行}」
  数を1から表示順位数まで繰り返す
    もし、成績¥数がならば
      s=「{s} {数}位  ---手{改行}」
    違えば
      s=「{s} {数}位  {成績¥数}手{改行}」
  s=「{s}{改行}◎タイムのハイスコア{改行}」
  数を(表示順位数+1)から(表示順位数*2)まで繰り返す
    分=成績¥数/60を切り下げ。
    秒=成績¥数%60。
    分=分を2でゼロ埋め。秒=秒を2でゼロ埋め
    もし、成績¥数がならば
      s=「{s} {数-表示順位数}位  --分--秒{改行}」
    違えば
      s=「{s} {数-表示順位数}位  {分}分{秒}秒{改行}」
  ダイアログタイトルは「成績表」
  sを言う。

#--------------------------------------------------------------
#-----成績表記録-----------------------------------------------
*成績表記録
  #手数のハイスコア
  手数順位=0
  数を表示順位数から1まで繰り返す。
    もし、(成績¥数>手数 または 成績¥数=ならば
      手数順位=数
  数を表示順位数から1まで繰り返す。
    もし、手数順位=0でなければ
      もし、手数順位=数ならば
        成績¥数=手数
      もし、手数順位<数ならば
        成績¥数=成績¥(数-1)


  #タイムのハイスコア
  タイム順位=0
  数を(表示順位数*2)から(表示順位数+1)まで繰り返す。
    もし、(成績¥数>経過 または 成績¥数=ならば
      タイム順位=数
  数を(表示順位数*2)から(表示順位数+1)まで繰り返す。
    もし、タイム順位=0でなければ
      もし、タイム順位=数ならば
        成績¥数=経過
      もし、タイム順位<数ならば
        成績¥数=成績¥(数-1)

  s=「」
  数を1から表示順位数まで繰り返す
    s=「{s}{成績¥数}{改行}」
  数を(表示順位数+1)から(表示順位数*2)まで繰り返す
    s=「{s}{成績¥数}{改行}」

  sを「成績表.txt」へ保存。
#--------------------------------------------------------------

 前のUD様にいただいたコメントから、「成績表.txt」を毎行読んで反復する時に、回数を-1すれば成績¥0から値が入っていくことを学びましたが、順位のところをまた全部+1しないとならないのが面倒で、のままになってます(汗)


 成績表読み書きの部分を作るにあたって、何度も成績表のテキストを手動でにした(笑)

 それはさておいても、成績表はリセットできたほうがいいと思うので、成績リセットをメニュー追加することに。

#-----成績リセット---------------------------------------------
*成績リセット
  ダイアログタイトルは「成績表リセット」
  「リセットしてもいい?」と二択。
    もしそれはいならば
      (表示順位数*2)
      成績¥回数
      を「成績表.txt」へ保存。
#--------------------------------------------------------------

 違いでいきなりリセットされるとショックなので、2択で確認メッセージを表示

 テキストをクリアするだけなら、保存すればいいだけだけど、それだと現在の成績表表示は変わらないので、成績配列の中身もにしないとね。


 あと追加で、前「15パズル.jpg」が存在しなかった場合の処理を追加しましたが、じゃあもし「15パズル.jpg」が違う画像にし変わってた場合は?

 もしかしたら毎自分の好きな画像でやりたいと思って、「15パズル.jpg」自体を違う画像にする場合があるもしない

 自分はわかってるからいいけど、人にあげた場合とか、400*400の画像にしてくれるとは思えないんだよね。


 実際に試してみると、予想通り大きな画像の端っこだけが表示される上、ギブアップしたら母艦が大変なことに!(滝汗)

 これ避するには、画像変更の時と同様、もし400*400の画像じゃなかったら、違う「15パズル.jpg」をリサイズして表示させられるようにしないとね。

#--------------------------------------------------------------
もし、パズル画像の存在が1ならば
  作業用の画像はパズル画像。
  もし、作業用のW=盤サイズ かつ 作業用のH=盤サイズでなければ  #画像ファイルがデフォルトの物と違う場合
    リサイズし変更
  違えば
    作業用を裏画面の0,0へ画像コピー。
    
違えば
  十五																	#画像ファイルが無かった場合	
#--------------------------------------------------------------

 「*画像変更」は、フォルダ選択から始まってしまうので、ルーチンを二つに分割して「*リサイズし変更」をつくり、ここへ飛ばすようにした。


 15パズル的には、このくらいでもう十分かなあ?

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090331

2009/03/30 (月)

ギブアップとヒント表示をつけよう!

| 21:44 | ギブアップとヒント表示をつけよう! - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - ギブアップとヒント表示をつけよう! - 雪乃☆雫のなでしこ日和 ギブアップとヒント表示をつけよう! - 雪乃☆雫のなでしこ日和 のブックマークコメント

 昨日は妹が遊びに来ていたので、成績表表示の確認を兼ねて15パズル大会を開催しました! 妹とはいえ、人にやらせるのは初めてだから、嬉しいね☆

 ちなみに、なかなか盛り上がっていた。

 ・・・なんと暇でバカで微笑ましい姉妹であろうか(汗)


 さて、昨日ので好きな画像で15パズルが遊べるようになったのはいいけど、難しすぎて解けない!という大問題が!!(汗)

 折角選んだ画像の完成形が見れないのは、悲しい・・・

 あと、完成図が見えていれば、パズルの難易度もぐっと下がるはず。


 というわけで、ヒントを見る機能と、ギブアップする機能を追加しようと思う。

 ギブアップは簡単。裏画面のを母艦コピーしてやればOKじゃん?

 メニューにギブアップの項目を追加する。

 バージョン情報のメニューをヘルプに変えて、の下にヒントとギブアップとバージョン情報をいれるよ。世の中の一般的なアプリケーションはこんな感じになってるはず!(ヘルプやヒントの意味が若干違うけどね;)

 折角だから(?)二択のダイアログでも使ってみよー。

 ギブアップを選択したら、「本当に?」とたずねて、はいのときだけ処理をする。

 もっと嫌味なことを言うと面白いかと思ったけど、使うのはどうせ自分なのに、なんかムカツクからやめた(爆)


 で、こんな感じ。

#-----ぎぶあっぷ-----------------------------------------------
*ギブアップ
  「本当に?」と二択。
    もしそれはいならば
      裏画面を母艦の15,15へ画像コピー。
      新規ゲーム待ちは「オン」
      初期化。
#--------------------------------------------------------------

 あれれ~? 書き換わらない

 マウスをクリックしたら変わるんだけど、おっかしいなあ。

 完成のときに同じように裏画面を母艦コピーしたときには問題なかったよ?

 意味わかんなーい!

 この機能を、実にスゥィ~トに考えていただけに、ドはまりしてしまってショック!!

 とりあえず、命令一覧をずっと眺めて「描画処理反映」を追加したら、正常動作しました。ちなみに、母艦再描画は、なぜかラベルが消えてしまってダメっぽい。

 問題は解決したけど、意はわからず・・・


 次に、ヒント機能です。

 これは、小さいサイズにリサイズした完成画像を、表示させる機能。

 手数とタイムの下が、無駄っぽく開いているから、こに表示させる。

 の学習内容は、メニューチェックオンオフで、ヒントの表示、非表示をトグルさせるよ!

#-----ヒント表示-----------------------------------------------
*ヒント表示
  もし、(ヒントメニューチェックオフ)ならば
    ヒントメニューチェックオン。
    作業用を盤サイズ,盤サイズで画像リサイズ。
    裏画面を作業用の0,0へ画像コピー。
    作業用を150,150で画像リサイズ。
    作業用を母艦の455,260へ画像コピー。
    文字サイズは18。文字色は$AA0000。
    母艦の478,230へ「☆ヒント☆」を文字描画。
    描画処理反映。
  違えば
    ヒントメニューチェックオフ。
    線色は$FFBBBB。塗り色は$FFBBBB。
    母艦の455,230から610,410へ四角。
    ラベル3の可視はオフ。
    描画処理反映。
#--------------------------------------------------------------

 これは、比較的簡単に出来たよ! 描画処理反映も忘れず!!

 最初「もし、(ヒントメニューチェックオフ)ならば」の行の書き方が、どこか悪かったのか、ちゃんと動作しなくてしばらく悩んだのは内緒(汗)

 いろいろ違うコト書いたりしてもダメで、も一度書いてみたらあっさり動いたという・・・


 前、画像変更機能を付けたときに、ファイル選択のときに「いいえ」を押したら、っ白になってしまう現象が発生し、避する処理を加えた。

 ーいえば、しょっぱなに「15パズル.jpg」を読み込んでますけど、これが万一なかったらどーなるんだ? と思い、ためしに消してみたら案の定エラー出て止まった;

 これ避するには、もし無かったら、画像変更機能へ飛ばして、任意の画像を選ぶようにするのが簡単そうだとおもったんだけど、やっぱりやめて以下のようにしてみた。

#-----しょぼい15パズル画面作成-------------------------------
*十五
  裏画面のWは盤サイズ。裏画面のHは盤サイズ。
  裏画面を$FFFFAAで画面クリア
  線色は$AAAAAA。線太さは0。
  数を0から15まで繰り返す
    x=数%4。
    y=数/4を切り下げ。
    yで条件分岐
      0ならば
        塗り色は$AAAAFF
      1ならば
        塗り色は$FFAAAA
      2ならば
        塗り色は$FFDDAA
      3ならば
        塗り色は$AAFFAA

    裏画面のx*駒サイズ,y*駒サイズからx*駒サイズ+駒サイズ,y*駒サイズ+駒サイズへ四角。
    文字サイズは42。文字色は$006600
    もし、(数>8)ならば
      x=20+(数%4)*駒サイズ。
    違えば
      x=35+(数%4)*駒サイズ。
    y=数/4を切り下げ。y=20+y*駒サイズ。
    もし、数=15ならば
      裏画面のx,yへ「★」を文字描画
    違えば
      裏画面のx,yへ(数+1)を文字描画
  
  裏画面を母艦の15,15へ画像コピー。
#--------------------------------------------------------------

 これで、何の画像も無くても、15パズルの画面が出ます。

 意外と簡単で、はまりどころも無くすぐできちゃったよ!

 ていうか、最初にしょぼい画像に半日かけたワタシって一体・・・?(哀)

 成績表のテキストも、無いときは自動生成出来るようにしないとダメだね。

#--------------------------------------------------------------
もし、「成績表.txt」が存在するならば
  「成績表.txt」を毎行読んで反復
    成績¥回数対象違えば
  「成績表.txt」に保存。     #成績表が無かったら作成する
#--------------------------------------------------------------

 今日ここまで。

 課題も大体解決してきてるけど、それは明日UPするよ!

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090330

2009/03/29 (日)

画像変更機能をつけよう!

| 17:53 | 画像変更機能をつけよう! - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - 画像変更機能をつけよう! - 雪乃☆雫のなでしこ日和 画像変更機能をつけよう! - 雪乃☆雫のなでしこ日和 のブックマークコメント

 こっちのほうが難しそうに思っていたけど、案外簡単に出来そうな気がしてきたので、ハイスコア表示はいったん休んで、こちらに着手。


 メニューに、画像変更を追加して、コードは以下のとおり

#-----画像変更-------------------------------------------------
*画像変更
  マイピクチャー作業フォルダ変更。
  「*.jpg;*.jpeg;*.png;*.bmp」のファイル選択。
  裏画面の画像はそれ。
  
  裏画面を盤サイズ,盤サイズで画像リサイズ。
  新規ゲーム
#--------------------------------------------------------------

 これで、とりあえずは動きました。

 でも、世の中の画像はたいてい正方形じゃないので、比率が変になってしまいます。

 かといって、比率変えずにリサイズでは、余白が出来てしまうので、15パズルができません(汗)


 好きなところを好きなサイズで正方形にトリミングしてリサイズできるのが一番よさそうだけど、何気に難しそうな上、必要ないときにはいちいちんなの手だから、短いほうの辺にあわせて、長いほうの辺の両端を切って、盤サイズにリサイズするようにしようと思う。

#-----画像変更-------------------------------------------------
*画像変更
  マイピクチャー作業フォルダ変更。
  「*.jpg;*.jpeg;*.png;*.bmp」のファイル選択。
  作業用の画像はそれ。
  
  もし、作業用のW>作業用のHならば
    x=(作業用のW-作業用のH)/2。y=0。
    x2=作業用のH+x。y2=作業用のH。
  違えば
    x=0。y=(作業用のH-作業用のW)/2。
    x2=作業用のW。y2=作業用のW+y

  作業用のx,y,x2,y2を裏画面の0,0へ画像部分コピー

  裏画面を盤サイズ,盤サイズで画像リサイズ。
  裏画面を母艦の15,15へ画像コピー。
  新規ゲーム
#--------------------------------------------------------------

 これでいけるか? とおもったら、あれれ~?

 大きな画像の端っこが切り取られて表示されてる。

 一度400*400の画像が入った裏画面には、大きな画像をコピーしても、大きくならないらしい。むむむ。

 ーくるなら、裏画像を先に大きくしておくしかないね!

 裏では、15パズルの画像がおっきく引き伸ばされているだろうけど、見えないから問題なし!

 して、キャンセル押した時にっ白くなってしまう問題を解決する処理を追加

 折角だから「」を使う!

 「でなければ」何気に書いてみたら、使えた!!

 で、こんな感じ。

#-----画像変更-------------------------------------------------
*画像変更
  マイピクチャー作業フォルダ変更。
  「*.jpg;*.jpeg;*.png;*.bmp」のファイル選択。
  もしそれでなければ	#キャンセルした時は処理しない
    作業用の画像はそれ。

    もし、作業用のW>作業用のHならば	#横長の画像
      x=(作業用のW-作業用のH)/2。y=0。
      x2=作業用のH+x。y2=作業用のH。
      裏画面をy2,y2で画像リサイズ。	 #短いほうの辺に長さあわせて正方形
    違えば
      x=0。y=(作業用のH-作業用のW)/2。
      x2=作業用のW。y2=作業用のW+y
      裏画面をx2,x2で画像リサイズ。

    作業用のx,y,x2,y2を裏画面の0,0へ画像部分コピー。
    裏画面を盤サイズ,盤サイズで画像リサイズ。
    裏画面を母艦の15,15へ画像コピー。
    新規ゲーム
#--------------------------------------------------------------

 できた~♪

 ・・・だけど、難易度高すぎ(--;

 選んだ画像のせいもあるけど、ワタシには解けない・・onz

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090329

2009/03/28 (土)

ハイスコア表示機能をつけよう!

| 23:41 | ハイスコア表示機能をつけよう! - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - ハイスコア表示機能をつけよう! - 雪乃☆雫のなでしこ日和 ハイスコア表示機能をつけよう! - 雪乃☆雫のなでしこ日和 のブックマークコメント

 文字列の操作とか、ファイルの読み書きとか、よくわかんにゃい(*_*)

 とりあえず成績の記録よりは、単にデータを読んで表示するのほうが圧倒的に楽そうな気がするので、まずっちをやってみる。

 メニューに「成績表」の項目を追加し、これを選択したら、ハイスコアが表示されるようにしよう。

 データがなければ話になんないので、「成績表.txt」というファイルを、メモ帳で作った。以下のような単純なものです。

#---------------
手数
98手
115手
159手
#---------------

 して、コードはこんな感じ。

#-----成績表表示----------------------------------------------
*成績表表示
  「成績表.txt」を毎行読んで反復
    成績¥回数対象。
  成績を改行配列結合していう。
#-------------------------------------------------------------

 なんか、反復で一行づつ読んだ意味なし(汗)

 見た目はともかく、ファイルの内容を言ってくれることはくれました。

 でも、なんでダイアログの背景白くなっちゃうんだ? わけわからん;


 見た目については置いといて(え;)

 度は記録の保存について考える。


 成績を記録させるのは、おめでとう!て出た時に出している手数とタイムの数値を、ファイルに書き込んでいけばいいんだろうけど、ただ追記していくんじゃなくて、過去の記録と比較して上っていた時だけ書き換える。

 しかも、ただ書き換えるんじゃなくて、過去の記録が一個づつ下がって、一番低い記録がトコロテン式に消える、みたいな?

 これはなんとなく、配列でなんとかなるかな?

 目的の状態になった配列を、一気にファイルに保存ってすれば、んなに難しくないかも??


 と思ったら、甘かった。

 毎行読んで反復回数は、1からスタートらしい。

 して、0には配列名が入ってるようで、単に「成績を保存」としたら、さっきのデータがこーなってしまう。

#---------------
成績
手数
98手
115手
159手
#---------------


 とゆーわけで、こうなった。

 ファイルの中には純粋に手数だけを保存し、表示するときに「手数」だの「**手」の「手」だのは追加すればいいかな。のほうが断然楽っぽい。

#---------------
98
115
159
#---------------
#-----成績表記録----------------------------------------------
*成績表記録
  s=「」
  数を1から3まで繰り返す
    s=「{s}{成績¥数}{改行}」

  sを「成績表.txt」へ保存。
#-------------------------------------------------------------

 あと、成績表.txtを読み込むのは、ゲーム起動時に行うことにする。

 成績の配列を参照すればいいんだから、成績表を見るたびにファイルを読む必要なんてないね?


 単に、ある成績を保存するのはいいけど、実際にはハイスコアが出たかを判定し、出ていたら、の順位の行は手数に書き換え、それ以下の順位の行は、いっこづつ下がっていくという処理が必要

 やりたいことは、以下のとおり

#-------------------------------------------------------------
  もし、成績¥3>手数ならば
    もし、成績¥2>手数ならば
      もし、成績¥1>手数ならば
        成績¥3=成績¥2
        成績¥2=成績¥1
        成績¥1=手数
      違えば
        成績¥3=成績¥2
        成績¥2=手数。
    違えば
      成績¥3=手数
#-------------------------------------------------------------

 これで、正常に動きます。OKですね!

 ・・・って、んなわけねー;

 ダメダメなプログラムの権化みたいなもんですねー。

 3位くらいまでだからいいけど、5位までとか、まかり違って10位くらいまで表示させたいなんて思ったときにはどーしたらいいんですかっ?!


 ひらめかないので、表示のほうでも手直ししてよう(汗)

#-----成績表表示-----------------------------------------------
*成績表表示
  s=「★☆★成績表★☆★{改行}{改行}◎手数のハイスコア{改行}」
  数を1から3まで繰り返す
    もし、成績¥数がならば
      s=「{s} {数}位  ---手{改行}」
    違えば
      s=「{s} {数}位  {成績¥数}手{改行}」
  s=「{s}{改行}◎タイムのハイスコア{改行}」
  数を4から6まで繰り返す
    分=成績¥数/60を切り下げ。
    秒=成績¥数%60。
    分=分を2でゼロ埋め。秒=秒を2でゼロ埋め
    もし、成績¥数がならば
      s=「{s} {数-3}位  --分--秒{改行}」
    違えば
      s=「{s} {数-3}位  {分}分{秒}秒{改行}」
  ダイアログタイトルは「成績表」
  sを言う。
#--------------------------------------------------------------

 タイムのほうも表示できるようになりました(笑)

 タイムの記録も、「経過」の数(つまり総秒数)のみ保存して、ここで分秒表示に直すのがいいね。

 あと、ダイアログが白くなるナゾは、プログラム上の問題ではなく「言う」と「いう」の違いによるものと判明(汗)

 にしても、「言う」で、全部表示させようって言うのがも無謀?

 別フォームをだしたほうがいいのかな。

 「言う」にすると、右クリックで、メモ画面が開く機能は消せないのかな?

 「いう」にしたら出なくなるけど、なんかダイアログボックスの背景が白くなっちゃうのが、気に入らない~。


 あと、完成したときに、ハイスコアが出ていたら、当然教えて欲しい。

 「手数順位」と「タイム順位」を記録時に取得させることにして、結局「言う」で無理矢理表示

#--------------------------------------------------------------
    成績表記録。
    
    #表示させる文字の設定
    もし、手数順位=0ならば
      手数成績=「{改行} 手数{手数}手です」
    違えば
      手数成績=「{改行} 手数{手数}手は{改行}   歴代{手数順位}位の成績です」
    
    もし、タイム順位=0ならば
      タイム成績=「{改行} タイム{分}分{秒}秒です」
    違えば
      タイム順位=タイム順位-3
      タイム成績=「{改行} タイム{分}分{秒}秒は{改行}   歴代{タイム順位}位の成績です」    

    #表示させる
    もし、(手数順位=0 かつ タイム順位=0)ならば
      ダイアログタイトルは「完成!」
      「おめでとう。完成です!{改行}{手数成績}{タイム成績}」と言う。
    違えば
      ダイアログタイトルは「ハイスコアが出ました!」
      「おめでとう。新記録です!{改行}{手数成績}{タイム成績}」と言う。
      成績表表示。
#--------------------------------------------------------------

 バカだから、表示を確認する為に、何度も15パズルやっちゃった(汗)

 無理やりの割には、まあまあの見た目になったかな?

 自分の環境意外では、崩れるのかな?

 ま、とりあえずいいけど。


 それにしても、また課題が持ち越しとなってしまった・・・

 U D U D 2009/03/29 00:42着々とLVUpしてますねー

\0に配列名が入るわけではなくて、きちんと宣言しなかった変数は初期値として変数名(文字列)がセットされます。
で、「回数」は1から始まるのに、配列のインデックスは0から始まるんですよね。
だからうっかり変数宣言せずに配列を使ってしかも反復とか~回で代入すると、
上手い具合に0番目に変数名が入るわけですf(^^;

テストとは配列
3回、テスト[回数]=回数
テストを『,』で配列結合して言う
5回、テスト[回数-1]=回数
テストを『,』で配列結合して言う

雪乃☆雫雪乃☆雫2009/03/29 12:05UDさま、ありがとうございます☆
しかも、見本のコードまで!

なるほど~。
宣言時に値を与えないでいると、空ではなくて変数名が代入されているわけなのですね。

・・・て、あれ?
「テストとは配列」と宣言するだけでよいのですか?
宣言・・・してなかったかな(汗)

雪乃☆雫雪乃☆雫2009/03/29 12:12UDさまへのレスの続き

 分かりました!
 宣言は、上のほうにまとめてしているのですが、一番初めのコードを書いた時には、とりあえず書いてみたせいで、ちゃんと宣言していなかった為に発生した現象のようです。

 いま確認してみたら、宣言してあったので、試しに言わせて見たら、成績¥0は空になっていました!
 おかげさまでだんだん知識が深まっていきますです。

 ありがとうございました。

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090328

2009/03/27 (金)

タイムトライアル機能をつけよう!

| 18:23 | タイムトライアル機能をつけよう! - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - タイムトライアル機能をつけよう! - 雪乃☆雫のなでしこ日和 タイムトライアル機能をつけよう! - 雪乃☆雫のなでしこ日和 のブックマークコメント

 いよいよタイマー

 普通に、何秒で出来たかを計るタイマーにします。


 まず、「トライアルタイマーとはタイマー隔は1。」でタイマー作成

 隔は秒数なので、1秒ごとにイベントが発生するようなイメージ

 あと、手数のときと同じように、表示用のラベルを配置。


 コードはこんな感じ。

 時満ちた時は~って、なんかとても素敵だ♪

 とりあえず、1秒ごとにここが実行され、ラベルの秒数を書き換えていく。

#-----タイムトライアル----------------------------------------
*タイムトライアル
  トライアルタイマーの時満ちた時は~
    経過=経過+1。
    分=経過/60を切り下げ。
    秒=経過%60。
    分=分を2でゼロ埋め。秒=秒を2でゼロ埋め。 #時を00:00で表示させる。
    タイムラベルのテキストは「{分}:{秒}」。のXは440。のYは140。のWは180。のHは50。
#-------------------------------------------------------------

 までずっと、「分=経過/60。分=分を切り下げ。」のように書いていたけど、「分=経過/60を切り下げ。」って書くことが出来るってわかった。このほうが日本語らしいし、みやすいね!


 あと、開始時からいきなり時計が動き出しているというのは、心理的によろしくないので、最初に盤の中をクリックした時をゲーム開始と判断して、タイマーを動かし始めることにする。

 というわけで、マウス判定の下に、タイマーを開始させるコードを入れる。

#-------------------------------------------------------------

      もし、手数=0ならば       #はじめに盤をクリックした時から
        トライアルタイマーを開始。  #タイマーを動かす
        タイムトライアル。
#-------------------------------------------------------------

 完成の判定が出来たら、っ先にタイマーを止める。

 おめでとうの時に、の手数と秒数も言ってもらうことにする。

 あと、手数カウントのときと同じく、新規ゲームとやり直しの時ラベルをクリアする。

 これでOK?と思ったら、完成させずにやり直しや新規ゲームを選択したら、タイマーが動き続けてるよ!

 というわけで、新規ゲームとやり直しのはじめに、「トライアルタイマー停止」を追加

 タイマーを開始する前に停止、と言ってもいいのかな? と思いましたが、特に問題ないみたいだったので、タイマーが動いてるかどうかの判断はしてません。

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090327

2009/03/26 (木)

「このゲームをやり直す」機能をつけよう!

| 18:37 | 「このゲームをやり直す」機能をつけよう! - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - 「このゲームをやり直す」機能をつけよう! - 雪乃☆雫のなでしこ日和 「このゲームをやり直す」機能をつけよう! - 雪乃☆雫のなでしこ日和 のブックマークコメント

 予定には無かった機能ですが、手数カウント機能をつけて遊んでいたら、思いつきました。

 問題によって、解くための必要最小手数は異なるかも知れず、同じ問題何度も出来たら、より効率的に解けるようになったかどうかがちゃんと分かるってもんです。


 メニューに「このゲームをやり直す」を追加

 問題作成直後の、駒配列と、アキを、記憶配列とアキ記憶に覚えさせる。

 それで、やり直すが選択されたら、以下のとおり全部元に戻してやればOK。

#-----このゲームをやりなおす-----------------------------------
*やり直し
  手数は0。手数ラベルのテキストは「0」。のXは500。のYは30。のWは100。のHは30。        #手数も0に初期化。
  数を0から15まで繰り返す。
    駒¥数=記憶¥数。
  アキはアキ記憶。         #アキ位置を初期化。
  ゲーム画面描画。
  マウス判定。
#-------------------------------------------------------------

 意外と簡単だった☆


 あと、突然気づく。

 「手数」て表示するだけのラベル、何ゆえラベル

 VBは、ペタペタ貼るのが楽だったので、ちょっとした文字を書くのに何でもラベルを使っていたような気がするんですが、こんな座標指定するなら、表示でも別に良かった・・・

 ていうか、文字描画にしたら、アンチエイリアスされた文字が書けるので、こっちがいいかも!

 というわけで修正。

 なお、実際の手数を表示してくところは、ラベルのまま。

 書き換えの際に、消す処理が要らないからです。

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090326

2009/03/25 (水)

手数カウント機能をつけよう!

| 22:02 | 手数カウント機能をつけよう! - 雪乃☆雫のなでしこ日和 を含むブックマーク はてなブックマーク - 手数カウント機能をつけよう! - 雪乃☆雫のなでしこ日和 手数カウント機能をつけよう! - 雪乃☆雫のなでしこ日和 のブックマークコメント

 というわけで、手数のカウント機能について考える。

 手数と言うのは、何駒を動かしたかと言うことだから、何駒入れ替えが発生したかを数えればいい。

 駒入れ替え_描画と完成判定は、見やすいように別ルーチンにしてるけどセット品なので、完成判定の中に入れてしまえ。

 手数は折角なので(?)ラベル表示することにした。

 ごちゃっとしてますけど、こんな感じね;

 いまさらながら、はてなのソースの表示の仕方を学んだ。

#-------------------------------------------------------------

#手数カウント機能ようラベル
ラベル1とはラベルのテキストは「手数」。
のXは440。のYは33。のWは50。のHは30。
文字書体は「MSPゴシック」。文字サイズは18。文字色は$AA0000。

手数ラベルとはラベルのテキストは「0」
のXは500。のYは30。のWは100。のHは35。
文字書体は「MSPゴシック」。文字サイズは24。の文字位置は右。文字色は$550000。
の背景色は$FFDDDD。の透明はオフ。
#-------------------------------------------------------------

 こういうことだけは、VBのが楽だったねえ。

 新規ゲームで「手数」を0にして、完成判定の中で、手数=手数+1して、ラベル表示、でOKなはず!


 ・・・と思って実行したら、うえぇ~、手数が書き換わった途端にラベルのサイズが文字にあわせて変更されちゃった~。んなの頼んでないよ~!(汗)

 ラベルの背景色を使って、表示位置を作っていたので、これはよろしくありません。っていうか、こーいう使い方自体がよろしくない?(汗)


 とりあえず、手数表示のコードはこーなりました。

#-----手数表示------------------------------------------------
  手数=手数+1。手数ラベルのテキストは手数。のXは500。のYは30。のWは100。のHは35。
#-------------------------------------------------------------

 美しくないけど、いいんだい!

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090325