Hatena::Groupnadesiko

雪乃☆雫のなでしこ日和

2009-03-28

ハイスコア表示機能をつけよう!

| 23:41

 文字列の操作とか、ファイルの読み書きとか、よくわかんにゃい(*_*)

 とりあえず成績の記録よりは、単にデータを読んで表示するのほうが圧倒的に楽そうな気がするので、まずっちをやってみる。

 メニューに「成績表」の項目を追加し、これを選択したら、ハイスコアが表示されるようにしよう。

 データがなければ話になんないので、「成績表.txt」というファイルを、メモ帳で作った。以下のような単純なものです。

#---------------
手数
98手
115手
159手
#---------------

 して、コードはこんな感じ。

#-----成績表表示----------------------------------------------
*成績表表示
  「成績表.txt」を毎行読んで反復
    成績¥回数対象。
  成績を改行配列結合していう。
#-------------------------------------------------------------

 なんか、反復で一行づつ読んだ意味なし(汗)

 見た目はともかく、ファイルの内容を言ってくれることはくれました。

 でも、なんでダイアログの背景白くなっちゃうんだ? わけわからん;


 見た目については置いといて(え;)

 度は記録の保存について考える。


 成績を記録させるのは、おめでとう!て出た時に出している手数とタイムの数値を、ファイルに書き込んでいけばいいんだろうけど、ただ追記していくんじゃなくて、過去の記録と比較して上っていた時だけ書き換える。

 しかも、ただ書き換えるんじゃなくて、過去の記録が一個づつ下がって、一番低い記録がトコロテン式に消える、みたいな?

 これはなんとなく、配列でなんとかなるかな?

 目的の状態になった配列を、一気にファイルに保存ってすれば、んなに難しくないかも??


 と思ったら、甘かった。

 毎行読んで反復回数は、1からスタートらしい。

 して、0には配列名が入ってるようで、単に「成績を保存」としたら、さっきのデータがこーなってしまう。

#---------------
成績
手数
98手
115手
159手
#---------------


 とゆーわけで、こうなった。

 ファイルの中には純粋に手数だけを保存し、表示するときに「手数」だの「**手」の「手」だのは追加すればいいかな。のほうが断然楽っぽい。

#---------------
98
115
159
#---------------
#-----成績表記録----------------------------------------------
*成績表記録
  s=「」
  数を1から3まで繰り返す
    s=「{s}{成績¥数}{改行}」

  sを「成績表.txt」へ保存。
#-------------------------------------------------------------

 あと、成績表.txtを読み込むのは、ゲーム起動時に行うことにする。

 成績の配列を参照すればいいんだから、成績表を見るたびにファイルを読む必要なんてないね?


 単に、ある成績を保存するのはいいけど、実際にはハイスコアが出たかを判定し、出ていたら、の順位の行は手数に書き換え、それ以下の順位の行は、いっこづつ下がっていくという処理が必要

 やりたいことは、以下のとおり

#-------------------------------------------------------------
  もし、成績¥3>手数ならば
    もし、成績¥2>手数ならば
      もし、成績¥1>手数ならば
        成績¥3=成績¥2
        成績¥2=成績¥1
        成績¥1=手数
      違えば
        成績¥3=成績¥2
        成績¥2=手数。
    違えば
      成績¥3=手数
#-------------------------------------------------------------

 これで、正常に動きます。OKですね!

 ・・・って、んなわけねー;

 ダメダメなプログラムの権化みたいなもんですねー。

 3位くらいまでだからいいけど、5位までとか、まかり違って10位くらいまで表示させたいなんて思ったときにはどーしたらいいんですかっ?!


 ひらめかないので、表示のほうでも手直ししてよう(汗)

#-----成績表表示-----------------------------------------------
*成績表表示
  s=「★☆★成績表★☆★{改行}{改行}◎手数のハイスコア{改行}」
  数を1から3まで繰り返す
    もし、成績¥数がならば
      s=「{s} {数}位  ---手{改行}」
    違えば
      s=「{s} {数}位  {成績¥数}手{改行}」
  s=「{s}{改行}◎タイムのハイスコア{改行}」
  数を4から6まで繰り返す
    分=成績¥数/60を切り下げ。
    秒=成績¥数%60。
    分=分を2でゼロ埋め。秒=秒を2でゼロ埋め
    もし、成績¥数がならば
      s=「{s} {数-3}位  --分--秒{改行}」
    違えば
      s=「{s} {数-3}位  {分}分{秒}秒{改行}」
  ダイアログタイトルは「成績表」
  sを言う。
#--------------------------------------------------------------

 タイムのほうも表示できるようになりました(笑)

 タイムの記録も、「経過」の数(つまり総秒数)のみ保存して、ここで分秒表示に直すのがいいね。

 あと、ダイアログが白くなるナゾは、プログラム上の問題ではなく「言う」と「いう」の違いによるものと判明(汗)

 にしても、「言う」で、全部表示させようって言うのがも無謀?

 別フォームをだしたほうがいいのかな。

 「言う」にすると、右クリックで、メモ画面が開く機能は消せないのかな?

 「いう」にしたら出なくなるけど、なんかダイアログボックスの背景が白くなっちゃうのが、気に入らない~。


 あと、完成したときに、ハイスコアが出ていたら、当然教えて欲しい。

 「手数順位」と「タイム順位」を記録時に取得させることにして、結局「言う」で無理矢理表示

#--------------------------------------------------------------
    成績表記録。
    
    #表示させる文字の設定
    もし、手数順位=0ならば
      手数成績=「{改行} 手数{手数}手です」
    違えば
      手数成績=「{改行} 手数{手数}手は{改行}   歴代{手数順位}位の成績です」
    
    もし、タイム順位=0ならば
      タイム成績=「{改行} タイム{分}分{秒}秒です」
    違えば
      タイム順位=タイム順位-3
      タイム成績=「{改行} タイム{分}分{秒}秒は{改行}   歴代{タイム順位}位の成績です」    

    #表示させる
    もし、(手数順位=0 かつ タイム順位=0)ならば
      ダイアログタイトルは「完成!」
      「おめでとう。完成です!{改行}{手数成績}{タイム成績}」と言う。
    違えば
      ダイアログタイトルは「ハイスコアが出ました!」
      「おめでとう。新記録です!{改行}{手数成績}{タイム成績}」と言う。
      成績表表示。
#--------------------------------------------------------------

 バカだから、表示を確認する為に、何度も15パズルやっちゃった(汗)

 無理やりの割には、まあまあの見た目になったかな?

 自分の環境意外では、崩れるのかな?

 ま、とりあえずいいけど。


 それにしても、また課題が持ち越しとなってしまった・・・

 U D U D 2009/03/29 00:42 着々とLVUpしてますねー

\0に配列名が入るわけではなくて、きちんと宣言しなかった変数は初期値として変数名(文字列)がセットされます。
で、「回数」は1から始まるのに、配列のインデックスは0から始まるんですよね。
だからうっかり変数宣言せずに配列を使ってしかも反復とか~回で代入すると、
上手い具合に0番目に変数名が入るわけですf(^^;

テストとは配列
3回、テスト[回数]=回数
テストを『,』で配列結合して言う
5回、テスト[回数-1]=回数
テストを『,』で配列結合して言う

雪乃☆雫雪乃☆雫 2009/03/29 12:05 UDさま、ありがとうございます☆
しかも、見本のコードまで!

なるほど~。
宣言時に値を与えないでいると、空ではなくて変数名が代入されているわけなのですね。

・・・て、あれ?
「テストとは配列」と宣言するだけでよいのですか?
宣言・・・してなかったかな(汗)

雪乃☆雫雪乃☆雫 2009/03/29 12:12 UDさまへのレスの続き

 分かりました!
 宣言は、上のほうにまとめてしているのですが、一番初めのコードを書いた時には、とりあえず書いてみたせいで、ちゃんと宣言していなかった為に発生した現象のようです。

 いま確認してみたら、宣言してあったので、試しに言わせて見たら、成績¥0は空になっていました!
 おかげさまでだんだん知識が深まっていきますです。

 ありがとうございました。

ゲスト



トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090328