Hatena::Groupnadesiko

雪乃☆雫のなでしこ日和

2009-04-12

ようやくクイズだよ!

| 13:45

【せんせい】

 さあさあさあ! よーやくクイズですよ!!

【でし】

 苦労されてましたね(汗)

【せんせい】

 現在進行形です(哀) 毎日更新は、ろ厳しくなってきました(涙)

 それはさておき、まずは以下のデータを「問題集.csv」って名前で保存してください。

 本家公式マニュアルのクイズを踏襲して、古典日本史な内容ですよ。

#-------------------------------------------------------------
古典『源氏物語』の作者は?,紫式部,清少納言,光源氏,紫の上
鎌倉幕府を開いたのは?,源頼朝,織田信長,弁慶,源義経
平安京が作られたのは何年?,794年,1192年,710年,1333年
清少納言が書いたのはどれ?,枕草子,古事記,更級日記,竹取物語
関が原の戦いは何年?,1600年,1700年,1500年,1800年
古典『徒然草』の作者は?,吉田兼好,紀貫之,紫式部,在原業平
紀貫之が書いたのはどれ?,土佐日記,和泉式部日記,更級日記,蜻蛉日記
ペリー来航は何年?,1853年,1583年,1543年,1793年
江戸幕府を開いたのは?,徳川家康,徳川吉宗,豊臣秀吉,織田信長
#-------------------------------------------------------------

【でし】

 うわっ、問題数が増えてる。なでしこのコード見るより頭が痛くなりそうです。

 ところで、書式が少し変わってる?

【せんせい】

 4択にしました(笑)

 それから、答えのための欄は廃止して、正答は「データ¥番号,1」に固定。問題の次の選択肢が答えってことです。

 選択肢もシャッフルして、毎違う並びで出題されるように改造したから、これでOKなわけです。

【でし】

 それに成績発表も付いて、最初言ってた基本部分の課題はクリアですね!

#-----母艦設計------------------------------------------------
!母艦設計=「母艦の可視はオフ母艦のタイトルは「クイズ」
母艦のWは640。母艦のHは480。
母艦を$FFFFAAで画面クリア母艦のスタイルは「枠固定」
母艦オフに最大化ボタン有効変更。
母艦中央移動
母艦の可視はオン。
#-------------------------------------------------------------

#-----宣言----------------------------------------------------
データとは配列。
問題とは文字列。
答えとは文字列。
選択肢とは配列。
正解数とは整数。正解数=0。
#-------------------------------------------------------------

「問題集.csv」を開く。
データはそれ。

データを配列シャッフル。
問題数はデータの要素数。

番号を0から問題数-1まで繰り返す

  問題はデータ¥番号,0
  答えはデータ¥番号,1
  選択肢は「{データ¥番号,1}{改行}{データ¥番号,2}{改行}{データ¥番号,3}{改行}{データ¥番号,4}」
  選択肢を配列シャッフル。

  問題を「{選択肢¥0}{改行}{選択肢¥1}{改行}{選択肢¥2}{改行}{選択肢¥3}」でボタン選択。
  もしそれならば
    終わる。
  もしそれが答えならば
      正解数=正解数+1。
    「当たり」と言う
  違えば
    「ハズレ。答えは{答え}」と言う

正解数で条件分岐
  問題数ならば
    ダイアログタイトルは「パーフェクト!」
  0ならば
    ダイアログタイトルは「もっとがんばりましょう」
  違えば
    ダイアログタイトルは「よくできました」

「正解数{正解数}問
誤答数{問題数-正解数}問
正解率は{正解数/問題数*100を四捨五入}%です」と言う終わる。
#-------------------------------------------------------------

【せんせい】

 クイズとしての基本的な機能は、この程度なんですよねー。

 ところが、画像を用いてなんかかんかしようとすると、途端にコードは長くなっていくし、なぜか希望通りの表示にならないしで、見た目がゲームっぽいゲームへの道のりは、高く険しいのです!(>_<)/

ゲスト



トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20090412