Hatena::Groupnadesiko

雪乃☆雫のなでしこ日和

2009-10-04

本当に次のメッセージを表示するよ!

| 22:39

【せんせい】

 仕様に凝るとプログラムが完成しないとゆー格言があるそうです;

 というわけで、それはよろしくないのでとりあえず簡単に、次のメッセージを表示する部分のみを実装していきたいと思います!

【でし】

 おねがいします!

【せんせい】

 手順としては、

マウスクリックを認識

②テキストウィンドウをクリア

③次のメッセージを表示

 となると思います。

 ①と②にかんしては、前やったとおりです。

 しかし、一度クイズでやっていますが、マウス押された時~ のイベントは、別にマウスが押されるまで処理を止めて待っていてくれるという命令ぢゃないので、イベントを待ちながら、次の命令をどんどんこなしていってくれちゃいます。

 だから、メッセージ表示命令は、関数にして、マウス押された時~から呼び出すようにしないといけません。

 ほんの数行のメッセージなら、なでしこのデモみたいに、それぞれ別関数にして、順番に呼び出す形でもいいかもしれませんが、ゲームのシナリオでんなことはやってられませんので、クイズの時と同様、別ファイルにメッセージを用意して、それを一行づつ表示する関数を作ればよさそうです。

【でし】

 長い説明でしたが、ようするに、クイズの時の問題設定~出題と、同様な流れなんですよね?

【せんせい】

 ぶっちゃけのとーりです。こういうことを学ぶために、クイズとか、作ってたわけですからねー。というわけで、こうなりました。


 まず、以下の内容を、「メッセージ.csv」として同じフォルダに保存

我輩はNAKOである。  
名前はまだない。
             (え;)
みぃ・・・・

 コードは、全部載せるとさすがに長いので、変更したトコだけ。

#------------------------------------------------------------
#マウス入力待ち
表画面のマウス押した時は~
  もし、改ページ待機オンならば
    もし、表画面の押されたボタン=左ならば
      テキストウィンドウクリア。
      メッセージ表示。
    違えば
      戻る
  違えば
    戻る
#------------------------------------------------------------

#-----シナリオ開く-------------------------------------------
「メッセージ.csv」を開く。
シナリオはそれ
シナリオ行数はシナリオの要素数。
メッセージ表示。
#------------------------------------------------------------

#-----メッセージ表示-----------------------------------------
*メッセージ表示
  改ページ待機オフ。
  
    メッセージはシナリオ¥番号,0
  番号=番号+1
  もし、番号>シナリオ行数ならば、
    「おわり」と言う。
    終了。
  違えば、
    表画面のテキストウィンドウX+10,テキストウィンドウY+10へメッセージを100でノベルテキスト描画。

#------------------------------------------------------------

【でし】

 おぉ~、先に進みました。

 ところで、この内容で、なんで、二次元配列なんですか? クイズと同様にってのは、分かりますが・・・

【せんせい】

 後のことを考えて、こうなっています。

 はメッセージだけですけど、背景や立ち絵の切り替えとか、すべてシナリオとして外に出さなきゃならなくなるはずなので。

 あと、本当にとりあえずなので、まだ、一行づつしか表示できないです。

 もうちょっと、それらしくしたかったのですが、の前に問題が・・・


 以前、言っていた、無効なポインタ操作のエラーが出てとまっちゃう現象が再発です。

 やっぱり、部品を壊してるところを、全部コメントにしたら直りました。

 前は、一番最初から発生していたのが、は、一はいいけど、二目呼び出されたときに発生するようです。

 部品、壊し忘れて問題が出るなら分かるけど、どういうことなんでしょ。

 とりあえず、当分は部品は壊さないってことにして進めていこうと思います。

chocochoco 2010/03/30 08:33 はじめまして、chocoと申します。

雫さんの連載?楽しみながら読んでます。
今年は大変そうですね、また再開される日を待ってます。

snowdrops89snowdrops89 2010/12/27 17:35 chocoさまはじめまして。
長らくほったらかしですみません;
今年は、ナデシコも、このページもまったく開かずに終わりそうな気配だったのですが、ふと思いついて開けてみたらコメントがあり、びっくりしました!
せっかくなので、ナデシコをバージョンアップしましたww
来年当たりは、ものすごくさりげなく復帰するかもしれませんので、その際はよろしくですm(_ _)m

ゲスト



トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20091004