たっけんの気まぐれ撫子日記 このページをアンテナに追加 RSSフィード

2008年03月20日 木曜日nadesiko_tomonokai :577より

res=""
「{\0}A」を文字列分解反復
	もし、(対象="{\0}")ならば
		res=res&"zero"
	違えば
		res=res&対象
resを言う

上記のプログラムがうまく実行されないとのことだったので、試してみたら、うまくできませんでした。

試しに

「{\0}A」を言う

で実行してみたところ、白で表示されました。

次に\0の0の部分の数字を変えるとどうなるか試してみました。

「{\0}A」を言う
「{\1}A」を言う
「{\2}A」を言う
「{\3}A」を言う
「{\4}A」を言う
「{\5}A」を言う
「{\6}A」を言う
「{\7}A」を言う
「{\8}A」を言う
「{\9}A」を言う
「{\10}A」を言う
「{\11}A」を言う

すると、1目の表示以外は全て、Aの前に変な文字がくっついてました。

本当は500ぐらいまで調べてみたいのですが、時ないのでやめました。

トラックバック - http://nadesiko.g.hatena.ne.jp/takken123/20080320