Hatena::Groupnadesiko

なでしこ開発日記 このページをアンテナに追加 RSSフィード

 | 

2009-04-26勉強会のお題 このエントリーを含むブックマーク このエントリーのブックマークコメント

勉強会のお題でキッチンタイマーを作りました。

#========================
#キッチンタイマー(作:クジラ飛行机)
#========================
「何分ですか?」と尋ねて、指定分に代入。
指定秒は指定分×60。
キッチンタイマーとはタイマー。
その間隔は1
その時満ちた時は~
  指定秒=指定秒-1
  母艦のタイトルは指定秒
  もし、指定秒<0ならば
    キッチンタイマーの有効はオフ。
    「時間です」と言う。
    BEEP
これを開始。
#========================
/*
【解説】
タイマー部品を使って作ってみました。
タイマーの間隔を指定秒後に設定すれば簡単ですが、
カウントダウンした方が親切なので、
カウンタダウンするようにしてみました。
 |