matumatuのなでしこ学習帳

2008-01-05本日は、なでしこ本 P.36~37の学習です

学習レベルを判定した結果 LV = 1 : HP = 70 : MP = 100

03:06

  • 完了予想日数 = 594 → 559 改善
    • 完了予想年月日 = 2009/08/21 → 07/17 改善
      • はてなカウンター値 = 4865 → 4947 もうすぐ、キリ番です。

第1章 基礎編 STEP-6

03:06

「歩いた歩数と消費カロリーをチェック」を学習した。


下記のプログラム「 歩数と消費カロリー.nako 」は、

03:06

なでしこ本CDROM → sample → 01-06

に入っているプログラムです。


「今日は何分間くらい歩いたの?」と尋ねる。
歩いた分数はそれ。
歩数は100×歩いた分数。
カロリーは、3.3×歩いた分数
「{歩数}歩、歩きました。
消費カロリーは{カロリー}kcalです」と言う。

  • 動作結果 : 「歩数と消費カロリー」さすが、サンプルプログラムなので、

        正常に、「 今日は何分くらい歩いたの? 」

         と尋ねられたので、なでしこ本

         のとおり、「 40 」と入力した。

        正常に、「 4000歩、歩きました。 」

             「 消費カロリーは132kcalです 」

         と表示された。


下記のプログラム「 歩数と消費カロリーA.nako 」は、

03:06

逆算結果を表示するようにした、改造版です。


# 万歩単位で歩くには、何分歩く必要があるかを逆算する改造です。
# その時の、消費カロリーも表示します。

「今日は何万歩くらい歩いたの?」と尋ねる。
歩数はそれ。
歩いた分数は歩数×10000÷100。
カロリーは、3.3×歩いた分数
「{歩数}万歩歩くには、{歩いた分数}分かかります。
消費カロリーは{カロリー}kcalです」と言う。

  • 動作結果 : 「歩数と消費カロリーA」

        このプログラムのテスト用データーとして、

         1(万歩)を入力すると、

         1万歩歩くには、100分かかります。

         消費カロリーは330kcalです

         と、全て正常に表示された。


本日2ページ目の学習として、

03:06

なでしこ本 P.37のプログラムに進みました。


下記のプログラム「 卒業年度チェック.nako 」は、

03:06

なでしこ本CDROM → sample → 01-06

に入っているプログラムです。


「生まれた年度(西暦)は?」と尋ねる。# (1)
生年はそれ。

小学校は(生年+13)を和暦変換          # (2)
中学校は(生年+16)を和暦変換
高校は(生年+19)を和暦変換
短大は(生年+21)を和暦変換
大学は(生年+23)を和暦変換

# 結果の表示                          # (3)
「小学校卒業:{小学校}
中学校卒業:{中学校}
高校卒業:{高校}
---
短大卒業:{短大}
大学卒業:{大学}」と言う

  • 動作結果 : 「卒業年度チェック」さすが、サンプルプログラムなので、

        正常に、「 生まれた年度(西暦)は? 」

         と尋ねられたので、なでしこ本

         のとおり、「 1980 」と入力した。

        正常に、「 小学校卒業:平成5年 」

             「 中学校卒業:平成8年 」

             「 高校卒業:平成11年  」

             「 ---          」

             「 短大卒業:平成13年  」

             「 大学卒業:平成15年  」

         と表示された。


下記のプログラム「 卒業年度チェックA.nako 」は、

03:06

和暦入力用にした、改造版です。


# 和暦で入力できるように改造しました。

# 明治  元年     ~ 45年 
# 西暦 1868年1月25日~1912年7月29日

# 大正   元年    ~ 15年 
# 西暦 1912年7月30日~1926年12月24日

# 昭和   元年    ~ 64年 
# 西暦 1926年12月25日~1989年1月7日

# 平成    元年    ~ 
# 西暦  1989年1月8日  ~ 

# 「二択」命令は、なでしこ本 P.42を参考にしました。
# 関数の定義(●明治生まれ用質問処理 等)は、なでしこ本 P.92を参考にしました。

「明治生まれですか?」と二択。
   もし、それが、はいならば、元号 = 1867。 明治生まれ用質問処理。
   違えば、「大正生まれですか?」と二択。
     もし、それが、はいならば、元号 = 1911。 大正生まれ用質問処理。
     違えば、「昭和生まれですか?」と二択。
       もし、それが、はいならば、元号 = 1925。 昭和生まれ用質問処理。
       違えば、「平成生まれですか?」と二択。
         もし、それが、はいならば、元号 = 1988。 平成生まれ用質問処理。
         違えば、「これで、質問を終わります。」と言う。 終わる。

●明治生まれ用質問処理
  「明治何年生まれですか?」と尋ねる。
    年度 = それ
   もし、0 ≧ 年度ならば、「明治より以前に生まれています。」と言う。 終わる。
   違えば
   もし、45 < 年度ならば、「明治より以後に生まれています」と言う。 終わる。
   違えば
   生年 = (年度 + 元号)
   卒業年度チェック処理。

●大正生まれ用質問処理
  「大正何年生まれですか?」と尋ねる。
    年度 = それ
   もし、0 ≧ 年度ならば、「大正より以前に生まれています。」と言う。 終わる。
   違えば
   もし、15 < 年度ならば、「大正より以後に生まれています」と言う。 終わる。
   違えば
   生年 = (年度 + 元号)
   卒業年度チェック処理。

●昭和生まれ用質問処理
  「昭和何年生まれですか?」と尋ねる。
    年度 = それ
   もし、0 ≧ 年度ならば、「昭和より以前に生まれています。」と言う。 終わる。
   違えば
   もし、64 < 年度ならば、「昭和より以後に生まれています」と言う。 終わる。
   違えば
   生年 = (年度 + 元号)
   卒業年度チェック処理。

●平成生まれ用質問処理
  「平成何年生まれですか?」と尋ねる。
    年度 = それ
   もし、0 ≧ 年度ならば、「平成より以前に生まれています。」と言う。 終わる。
   違えば
   生年 = (年度 + 元号)
   卒業年度チェック処理。

●卒業年度チェック処理
   小学校は(生年+13)を和暦変換
   中学校は(生年+16)を和暦変換
   高校は(生年+19)を和暦変換
   短大は(生年+21)を和暦変換
   大学は(生年+23)を和暦変換

# 結果の表示
「小学校卒業:{小学校}
中学校卒業:{中学校}
高校卒業:{高校}
---
短大卒業:{短大}
大学卒業:{大学}」と言う

        改造箇所のデバッグに、手こずりましたが、

        なでしこ本の入力例1980年を、

         和暦に換算した、昭和55年を

         入力すると、

         正常に、「 小学校卒業:平成5年 」

             「 中学校卒業:平成8年 」

             「 高校卒業:平成11年  」

             「 ---          」

             「 短大卒業:平成13年  」

             「 大学卒業:平成15年  」

         と表示された。


明日の予定

03:06

なでしこ本 P.38~40のプログラムに進む予定です。