matumatuのなでしこ学習帳

2008-01-07本日は、なでしこ本 P.41の学習です

f:id:matumatuh18:20080107193909j:image

学習レベルを判定した結果 LV = 2: HP = 28 : MP = 200

22:11

  • 完了予想日数 = 523 → 519 改善
    • 完了予想年月日 = 2009/06/13 → 2009/06/09 改善
      • はてなカウンター値 = 5419
        • 学習開始日から今日までの日数 =54日

本日は、最近ネット上で流行している、

22:11

ミルクシーフードヌードル(画像参照)を食べた後、

残ったスープにご飯を入れて雑炊のようにして食べたので、

なでしこ本の学習が進み、数値が改善した。

初めて食べるので、メーカー品を食べたが、美味だったので、

度は、本格的にシーフードヌードルに、暖めた牛乳を入れて

作れるように、コンビニで食材を購入した。


第1章 基礎編 STEP-6

22:11

「偶数奇数の判定」を学習した。


下記のプログラム「 偶数奇数.nako 」は、

22:11

なでしこ本CDROM → sample → 02-01

に入っているプログラムです。


「判定する数値は?」と尋ねる。
値はそれ。
割り算余りは、値%2
もし、割り算余りが0ならば
  「{値}は偶数」と言う。
違えば
  「{値}は奇数」と言う。

  • 動作結果 : 「偶数奇数」さすが、サンプルプログラムなので、

        正常に、「 判定する数値は? 」

         と尋ねられたので、なでしこ本

         のとおり、「 1192 」と入力した。

        正常に、なでしこ本のとおり、「 1192は偶数 」と表示した。

         

下記のプログラム「 偶数奇数A.nako 」は、

22:11

プログラム行数を、少なくするなるように改造した

プログラムです。


「判定する数値は?」と尋ねる。 値はそれ。 割り算余りは、値%2 # プログラム行数が少なくなるように改造した。
もし、割り算余りが0ならば、「{値}は偶数」と言う。       # プログラム行数が、原本は7行 → 改造後3行になった。
違えば、「{値}は奇数」と言う。

  • 動作結果 : 「偶数奇数A」

        正常に、「 判定する数値は? 」

         と尋ねられたので、なでしこ本

         のとおり、「 1192 」と入力した。

        正常に、なでしこ本のとおり、「 1192は偶数 」と表示した。

         

明日の予定

22:11

なでしこ本 P.42のプログラムと、

メルマガ原稿作成に進む予定です。