matumatuのなでしこ学習帳

2008-01-09本日は、なでしこ本 P.42の学習です

学習レベルを判定した結果 LV = 2: HP = 29 : MP = 200

01:28

  • 完了予想日数 = 519 → 524 悪化
    • 完了予想年月日 = 2009/06/09 → 2009/06/17 悪化
      • はてなカウンター値 = 5814
        • 学習開始日から本日までの日数 =56日

1月2日の日記

01:28

id:matumatuh18:20080102で、

最近「はてな」関係の知識不足を痛感しています。

「はてなダイアリー」を利用して日記を書き始めましたが、

まだ5日なので、「はてなダイアリー市民」とみなされる30日

まで、あと25日かかります。 (^^;)

と書きましたが、裏技を発見しました。

と言っても、たいしたことは無いですが、

いったん、「はてなダイアリー」を利用して日記を書き始め

ても、たまに日記を書き忘れる事がありますが、の時は

日付だけ過去にして書き込むと、過去の日付で日記を書ける

ことを発見しました。

「はてなダイアリー市民」とみなされる30日言うのは、

単純な経過日数でなく、日記をつけた日数なので

過去に遡って、日記の記入漏れ日を無くすと、最短の

30日で、「はてなダイアリー市民」になれることが

分かりました。

また、なでしこ学習帳@はてなのように「はてなグループ」上の

日記は、はてな記法で書くための支援用のメニューが無いのに

対して、「はてなダイアリー」上の日記作成画面には、

文字の大きさ・文字色・フォント等を簡単に変更できる、

支援用のメニューあることに気づきました。

このため、いったん「はてなダイアリー」上で、日記の下書きを

作り、なでしこ学習帳@はてな側の日記に、コピー・ペーストすると、

はてな記法を簡単に使えそうです。


下記のプログラム「 二択.nako 」、「 卒業年度チェック再び.nako 」

01:28

は、なでしこ本CDROM → sample → 02-01

に入っているプログラムです。


「お茶漬けに納豆を入れますか?」と二択。
もし、それが、はいならば
  「納豆茶漬け最高ですよね。」と言う。
違えば
  「美味しいですよ。試してみてください。」と言う。

# データの入力 -----------------------------------(1)
「西暦何年生まれですか?」と尋ねる。
生年はそれ。
「早生まれ(誕生日が1~3月)ですか?」と二択。
もし、それがはいならば、生年は生年-1
# データを下に計算 -------------------------------(2)
小学校は、生年+13
中学校は、生年+16
高校は、生年+19
短大は、生年+21
大学は、生年+23
# 結果の表示 -------------------------------------(3)
「小学校卒業は、{小学校}年:{小学校を和暦変換}
中学校卒業は、{中学校}年:{中学校を和暦変換}
高校卒業は、{高校}年:{高校を和暦変換}
---
短大卒業は、{短大}年:{短大を和暦変換}
大学卒業は、{大学}年:{大学を和暦変換}」と言う。

  • 動作結果 : 「二択」さすが、サンプルプログラムなので、

        正常に、「 お茶漬けに納豆を入れますか? 」

         と尋ねられた。

        「 はい 」ボタンをクリックすると、

        「納豆茶漬け最高ですよね。」と表示した。

        「 いいえ 」ボタンをクリックすると、

        「 美味しいですよ。試してみてください。」と表示した。


  • 動作結果 : 「卒業年度チェック再び」さすが、サンプルプログラムなので、

        正常に、「 西暦何年生まれですか? 」

         と尋ねられたので、なでしこ本

         のとおり、「 1982 」と入力した。

         さらに、「早生まれ(誕生日が1~3月)ですか?」

         と尋ねられたので、なでしこ本

         のとおり、「 はい 」ボタンをクリックすると、

        正常に、「 小学校卒業は、1994年:平成6年 」

             「 中学校卒業は、1997年:平成9年 」

             「 高校卒業は、2000年:平成12年  」

             「 ---               」

             「 短大卒業は、2002年:平成14年  」

             「 大学卒業は、2004年:平成16年  」

         と表示された。


次に、「 二択.nako 」を最近ネット上で流行している、

01:28

ミルクシーフードヌードル用に改造しました。

さらに「 卒業年度チェック再び.nako 」を、和暦で生まれた元号と

年度を入力できるように改造しました。


下記のプログラム「 二択A.nako 」は、

01:28

ミルクシーフードヌードル用に改造した

プログラムです。


# 最近ネット上で流行している、ミルクシーフードヌードル用に改造しました。

「シーフードヌードルに熱いミルクを入れますか?」と二択。
もし、それが、はいならば
  「ミルクシーフードヌードル最高ですよね。」と言う。
違えば
  「美味しいですよ。試してみてください。」と言う。

下記のプログラム「 卒業年度チェック再びA.nako 」は、

01:28

和暦入力用にした、改造版です。


# 和暦で入力できるように改造しました。

# 明治  元年     ~ 45年 
# 西暦 1868年1月25日~1912年7月29日

# 大正   元年    ~ 15年 
# 西暦 1912年7月30日~1926年12月24日

# 昭和   元年    ~ 64年 
# 西暦 1926年12月25日~1989年1月7日

# 平成    元年    ~ 
# 西暦  1989年1月8日  ~ 

# 「二択」命令は、なでしこ本 P.42で学習済みです。
# 関数の定義(●明治生まれ用質問処理 等)は、なでしこ本 P.92を参考にしました。

# データの入力 -----------------------------------(1)
「明治生まれですか?」と二択。
   もし、それが、はいならば、元号 = 1867。 明治生まれ用質問処理。
   違えば、「大正生まれですか?」と二択。
     もし、それが、はいならば、元号 = 1911。 大正生まれ用質問処理。
     違えば、「昭和生まれですか?」と二択。
       もし、それが、はいならば、元号 = 1925。 昭和生まれ用質問処理。
       違えば、「平成生まれですか?」と二択。
         もし、それが、はいならば、元号 = 1988。 平成生まれ用質問処理。
         違えば、「これで、質問を終わります。」と言う。 終わる。

●明治生まれ用質問処理
  「明治何年生まれですか?」と尋ねる。
    年度 = それ
  「早生まれ(誕生日が1~3月)ですか?」と二択。
   もし、それがはいならば、年度は年度-1
   もし、0 ≧ 年度ならば、「明治より以前の年度に生まれています。」と言う。 終わる。
   違えば
   もし、45 < 年度ならば、「明治より以後の年度に生まれています」と言う。 終わる。
   違えば
   生年 = (年度 + 元号)
   卒業年度チェック処理。

●大正生まれ用質問処理
  「大正何年生まれですか?」と尋ねる。
    年度 = それ
  「早生まれ(誕生日が1~3月)ですか?」と二択。
   もし、それがはいならば、年度は年度-1
   もし、0 ≧ 年度ならば、「大正より以前の年度に生まれています。」と言う。 終わる。
   違えば
   もし、15 < 年度ならば、「大正より以後の年度に生まれています」と言う。 終わる。
   違えば
   生年 = (年度 + 元号)
   卒業年度チェック処理。

●昭和生まれ用質問処理
  「昭和何年生まれですか?」と尋ねる。
    年度 = それ
  「早生まれ(誕生日が1~3月)ですか?」と二択。
   もし、それがはいならば、年度は年度-1
   もし、0 ≧ 年度ならば、「昭和より以前の年度に生まれています。」と言う。 終わる。
   違えば
   もし、64 < 年度ならば、「昭和より以後の年度に生まれています」と言う。 終わる。
   違えば
   生年 = (年度 + 元号)
   卒業年度チェック処理。

●平成生まれ用質問処理
  「平成何年生まれですか?」と尋ねる。
    年度 = それ
  「早生まれ(誕生日が1~3月)ですか?」と二択。
   もし、それがはいならば、年度は年度-1
   もし、0 ≧ 年度ならば、「平成より以前の年度に生まれています。」と言う。 終わる。
   違えば
   生年 = (年度 + 元号)
   卒業年度チェック処理。

# データを下に計算 -------------------------------(2)
●卒業年度チェック処理
   小学校は、生年+13
   中学校は、生年+16
   高校は、生年+19
   短大は、生年+21
   大学は、生年+23

# 結果の表示 -------------------------------------(3)
「小学校卒業は、{小学校}年:{小学校を和暦変換}
中学校卒業は、{中学校}年:{中学校を和暦変換}
高校卒業は、{高校}年:{高校を和暦変換}
---
短大卒業は、{短大}年:{短大を和暦変換}
大学卒業は、{大学}年:{大学を和暦変換}」と言う。

  • 動作結果 : 「二択A」

        正常に、「 シーフードヌードルに熱いミルクを入れますか? 」

         と尋ねられた。

        「 はい 」ボタンをクリックすると、

        「ミルクシーフードヌードル最高ですよね。」と表示した。

        「 いいえ 」ボタンをクリックすると、

        「 美味しいですよ。試してみてください。」と表示した。


  • 動作結果 : 「卒業年度チェック再びA」

        プログラムの改造は、昨日中に出来ていましたが

         動作チェックに時がかかりました。

        なでしこ本の入力例1982年を、和暦に換算した、昭和57年と

         さらに、「早生まれ(誕生日が1~3月)ですか?」

         と尋ねられたので、なでしこ本

         のとおり、「 はい 」ボタンをクリックすると、

         正常に、「 小学校卒業は、1994年:平成6年 」

             「 中学校卒業は、1997年:平成9年 」

             「 高校卒業は、2000年:平成12年  」

             「 ---               」

             「 短大卒業は、2002年:平成14年  」

             「 大学卒業は、2004年:平成16年  」

         と表示された。


明日の予定

01:28

なでしこ本 P.43のプログラムに進む予定です。