matumatuのなでしこ学習帳

2008-01-15本日は、なでしこ本 P.47の学習です

下記のプログラム「 散歩A.nako 」は、

23:14

インデントをテストするための、改造版です。


# サンプルプログラムは、天気・気温・インデントが固定なので、質問形式で変化させ
# プログラムが正常に動作しているかテストできるように改造しました。
# なでしこ本 P.61 「条件分岐」を、参考にしました。
# なでしこ本 P.91 「自分で関数を作る」を、参考にしました。

「インデントのテストをします!!

半角スペースをテストしたい時は、1
全角スペースをテストしたい時は、2
タブ文字をテストしたい時は、    3
を入力して下さい」と尋ねる。
IN = それ
「気温は何度ですか?」と尋ねる。
気温はそれ
「天気は、晴れですか?」と二択。
もし、それが、はいならば
	天気は「晴れ」
  # 関数の呼び出し
  INで条件分岐
   	1ならば
   		半角スペース散歩関数
		2ならば
   		全角スペース散歩関数
  		違えば
  			タブ文字スペース散歩関数

違えば
	天気は「雨」
  # 関数の呼び出し
  INで条件分岐
   	1ならば
   		半角スペース散歩関数
		2ならば
   		全角スペース散歩関数
  		違えば
  			タブ文字スペース散歩関数

# 関数の定義
●半角スペース散歩関数
 天気は「{天気}」
 気温は「{気温}」
 もし、天気が「晴れ」ならば
  もし、気温≧18 ならば
   「天気が{天気}で、気温も{気温}度と適温なので、散歩に行く」と表示。
   「半角スペースのインデントは、正常でした」と表示。
  違えば
   「天気は{天気}だが、気温が{気温}度と寒いので、散歩は中止」と表示。
   「半角スペースのインデントは、正常でした」と表示。
 違えば
  「天気が{天気}なので、気温は{気温}度だが、気温が何度でも、散歩は中止」と表示。
  「半角スペースのインデントは、正常でした」と表示。

●全角スペース散歩関数
 天気は「{天気}」
  気温は「{気温}」
  もし、天気が「晴れ」ならば
   もし、気温≧18 ならば
	 「天気が{天気}で、気温も{気温}度と適温なので、散歩に行く」と表示。
   	  「全角スペースのインデントは、正常でした」と表示。
	違えば
	 「天気は{天気}だが、気温が{気温}度と寒いので、散歩は中止」と表示。
   	  「全角スペースのインデントは、正常でした」と表示。
 違えば
   「天気が{天気}なので、気温は{気温}度だが、気温が何度でも、散歩は中止」と表示。
   	「全角スペースのインデントは、正常でした」と表示。

●タブ文字スペース散歩関数
	天気は「{天気}」
	気温は「{気温}」
	もし、天気が「晴れ」ならば
		もし、気温≧18 ならば
			「天気が{天気}で、気温も{気温}度と適温なので、散歩に行く」と表示。
   	  		「タブ文字スペースのインデントは、正常でした」と表示。
		違えば
			「天気は{天気}だが、気温が{気温}度と寒いので、散歩は中止」と表示。
   	  		「タブ文字スペースのインデントは、正常でした」と表示。
	違えば
		「天気が{天気}なので、気温は{気温}度だが、気温が何度でも、散歩は中止」と表示。
   		「タブ文字スペースのインデントは、正常でした」と表示。

  • 動作結果 : 「散歩A」

        まで、プログラムの改造を、短時で仕上げても

         動作チェックに時がかかっていましたが、

        は、プログラムの動作チェックを念頭に置いた

         改造をしたので、動作チェックは短時で終わった。

        「半角スペース」、「全角スペース」、「タブ文字スペース」

         ともに、全て正常に動作した。

        「タブ文字スペース」が一番、インデント箇所が明確になり、

         プログラムが見やすくなることを学習した。