matumatuのなでしこ学習帳

2008-01-26本日は、なでしこ本 P.57~59の学習です

下記のプログラム「数当てゲーム.nako」は、

19:34

なでしこ本CDROM → sample → 02-04

に入っているプログラムです。

偶然ですが、「数当てゲーム.nako」と同じ

ファイル名のプログラムが、なでしこをインストールすると、

sample → ゲームに自動的に初期インストール状態で用意されていました。

ところが、初期インストール状態のプログラムは、207行に達し、

画像も表示する高度な内容でした。


点数=0
1の間
  # ゲーム本体
  答えは3の乱数+1
  「1~3のどれか当てて下さい!」と尋ねる。
  もし、それが答えならば
    「当たり!」と言う。
    点数=点数+1
  違えば
    「残念。{答え}でした。」と言う
  # ゲームを終わるか?
  「点数は{点数}です。続けて遊びますか?」と二択。
  もし、それがいいえならば、抜ける。
  
「点数は{点数}でした!」と言う。

  • 動作結果 : 「数当てゲーム」さすが、

         サンプルプログラムなので、

         正常に、なでしこ本のとおり、

         「1~3」の数字を入力し、

         たまに、「当たり」と表示された。