Hatena::Groupnadesiko

雪乃☆雫のなでしこ日和

2017-11-15

サイコロを転がすよ!

| 15:17

 マイナビ連載15目は、サイコロと擬似乱数についてでした。

http://news.mynavi.jp/series/nadeshiko/015/

 乱数の使い方は、6目のかずあてゲームでやったじゃーん・・・と思ったら、乱数とゆうものを、いかにしてコンピューターで生成するのか的な、より突っ込んだ内容になってました。

 うおおぉぅ、ナンカヨクワカラン・・・(*_*;;;

 ケド、ちょっと賢くなった気がする(気のせい;)


 いいんだい!

 仕組みなんか知らなくたって、サイコロは作れるもね~(こら;)

 とゆうわけで(?!)大好きなサイコロを転がしてみようと思う。

 CSS3のanimationを使って、文字通り転がします。

 って言っても3D(立方体)ではなく2D(正方形)ですケドね~。


 単に要素に転を掛けながら移動させるのは、例によってなでしこなくてもCSSだけで可能でした。

<script type="なでしこ">
#-----------------------------------------------------------------------
# サイコロを転がしたい
#-----------------------------------------------------------------------
</script>

<style type="text/css">
<!--
#dice {
	margin:auto; width:50px; height:50px; background:#FF9999;
	animation:roll-dice 1s linear;
}
@keyframes roll-dice{
	0% {transform: translate(-350px,0px) rotate(0deg);}     /* 初期位置 */
	100%{transform: translate(0px,0px) rotate(360deg);}     /* 終了位置 */
}
 -->
</style>

<H1>CSS3てすと~アニメーションで転がす</H1>
<HR>
<div id="dice">*</div>
<HR>

http://snowdrops.starfree.jp/wnako3_test/11_animation_test.html

 #diceに設定したanimationプロパティでは「roll-dice」とゆうキーフレームに従って、1秒かけて、最初から最後まで一定の速さで変化する的な指定になっています。

 最初の状態(0%)と最後の状態(100%)を指定しただけで、このよーに転がります!

 キーフレームは、アニメーションの開始(0%)から完了(100%)までを自由に区切って、それぞれの時点のスタイルを設定することになっていて、細かく区切って指定すると、ただ転がすだけじゃなく、こんなふうにして弾ますこともできました。

@keyframes roll-dice{
	0% {transform: translate(-350px,-100px) rotate(45deg);}     /* 初期位置 */
	10% {transform: translate(-350px,0px) rotate(90deg);}       /* 落下地点 */
	25% {transform: translate(-300px,-60px) rotate(180deg);}    /* 1st頂点 */
	40% {transform: translate(-250px,0px) rotate(270deg);}      /* 1st着地点 */
	50% {transform: translate(-200px,-40px) rotate(360deg);}    /* 2nd頂点 */
	60% {transform: translate(-150px,0px) rotate(450deg);}      /* 2nd着地点 */
	70% {transform: translate(-100px,-20px) rotate(540deg);}    /* 3rd頂点 */
	80% {transform: translate(-50px,0px) rotate(630deg);}       /* 3rd着地点 */
	100%{transform: translate(0px,0px) rotate(720deg);}         /* 終了位置 */
}

http://snowdrops.starfree.jp/wnako3_test/11_animation_test2.html

 でも、地面から頂点までの指定が直だから、なんか動きがカクカクしてんだよね~;

 こうゆうのも、知恵とセンスが問われるところなんだろう・・・><


 ・・・でっ、取りあえずボタンを押したらサイコロが転がるプログラム。

<script type="なでしこ">
#-----------------------------------------------------------------------
# サイコロ
#-----------------------------------------------------------------------
#-----宣言--------------------------------------------------------------
出目は配列。
サイコロ転数=-1。

#---ダイス設定-----
ダイスサイズ=80。ダイス太=1。角丸=オン。
ダイス色=[
["#FFBBBB","#CC3333","#330000"],
["#BBFFBB","#33CC33","#003300"],
["#BBBBFF","#3333CC","#000033"],
["#FFBBFF","#CC33CC","#330033"],
["#FFFFBB","#CCCC33","#333300"],
["#BBFFFF","#33CCCC","#003333"]
]// "地色","文字色" ,"線色"

#---ダイスアニメーション設定-----
転秒数=0.8。
回数転秒数*10。
初期位置=「-350px,0px」
終了位置=「200px,240px」
初期角度=0。
終了角度=1080。

#-----メイン------------------------------------------------------------
「#play」の「onclick」に「サイコロ振」をDOMイベント設定。
サイコロ初期化。

#-----------------------------------------------------------------------
●サイコロ初期化
  ダイス文字サイズ=ダイスサイズ/3*2。
  もし、角丸=オンならば、角丸サイズ=ダイスサイズ/4。
  違えば、角丸サイズ=0。

  「#dice」の「margin」に「auto」をDOMスタイル設定。
  「#dice」の「width」に「{ダイスサイズ}px」をDOMスタイル設定。
  「#dice」の「height」に「{ダイスサイズ}px」をDOMスタイル設定。
  「#dice」の「text-align」に「center」をDOMスタイル設定。
  「#dice」の「line-height」に「{ダイスサイズ}px」をDOMスタイル設定。
  「#dice」の「font-size」に「{ダイス文字サイズ}px」をDOMスタイル設定。
  「#dice」の「border-radius」に「{角丸サイズ}px」をDOMスタイル設定。

  「#dice」の「transform」に「translate({終了位置}) rotate({終了角度}deg)」をDOMスタイル設定。
  サイコロ転設定=「@keyframes roll-dice{波カッコ}
	0%  {波カッコ}transform: translate({初期位置}) rotate({初期角度}deg);{波カッコ閉じ}     /* 初期位置 */
	100%{波カッコ}transform: translate({終了位置}) rotate({終了角度}deg);{波カッコ閉じ}     /* 終了位置 */
{波カッコ閉じ}」
  「#style」にサイコロ転設定をDOM_HTML設定。
ここまで。

●サイコロ振
  (回数
    rは6の乱数。
    出目[回数-1]はr+1。
  ここまで。
  サイコロ転数=0。
  「#dice」の「animation」に「roll-dice {転秒数}s linear」をDOMスタイル設定。
  サイコロ描画。
ここまで。

●サイコロ描画
  もし、(サイコロ転数≧0)かつ(サイコロ転数<回数)ならば、
    「#dice」の「background」にダイス色[出目[サイコロ転数]-1][0]をDOMスタイル設定。
    「#dice」の「color」にダイス色[出目[サイコロ転数]-1][1]をDOMスタイル設定。
    「#dice」の「border」に「{ダイス太}px solid 」&ダイス色[出目[サイコロ転数]-1][2]をDOMスタイル設定。
    「#dice」に出目[サイコロ転数]をDOMテキスト設定。
    サイコロ転数=サイコロ転数+1。
    「サイコロ描画」を(転秒数/回数)秒後。
  違えば、
    「#dice」の「animation」にDOMスタイル設定。
    サイコロ転数=-1。
  ここまで。
ここまで。
#-----------------------------------------------------------------------
</script>

<H1>なでしこ3てすと~サイコロを振る</H1>
<HR>
<style id="style"></style>
<div id="base" style="margin:auto; height:400px;">
  <button id="play">サイコロを振る</button>
  <div id="dice"></div>
</div>
<HR>

http://snowdrops.starfree.jp/wnako3_test/11_dice_test.html

 結局、転がるだけですw

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20171115

2016-05-20

完成かな?

| 22:17

 ダイスはサイコロキャラメルにし替えて、得点表示部分が白だと、白のサイコロが何だか見づらいから、ちょこっとだけ色替えをして(でもんなに見やすくなったわけでもない;)、勝敗判定の表示と、メッセージ表示を付け加えて・・・

 このメッセージの数々に一番、無駄っぽく行数と時を食っていたり;;;

 ついでに、なこ様を表示させてみたりして、いちおう完成、完成~☆

#-----------------------------------------------------------------------
# 36(Thirty-six)
#-----------------------------------------------------------------------

#-----母艦設計-----------------------------------------------
!母艦設計=「母艦の可視はオフ」

#---メニュー----
『#親部品名,部品名,テキスト,ショートカット,オプション,イベント
なし,ファイルメニュー,ファイル(&F),,,
 -,新規メニュー,新しいゲーム(&N),Ctrl+N,,新規ゲーム
 -,-,,,,
 -,メッセージメニュー,メッセージ速度(&S),Ctrl+S,,
 --,速度1,早い(&1),,,「早い」にメッセージ速度変更。
 --,速度2,普通(&2),,,「普通」にメッセージ速度変更。
 --,速度3,遅い(&3),,,「遅い」にメッセージ速度変更。
 -,-,,,,
 -,閉じるメニュー,閉じる(&X),Ctrl+X,,終わる
なし,ヘルプメニュー,ヘルプ(&H),,,
 -,ルールメニュー,遊び方(&R),Ctrl+R,,遊び方
 -,-,,,,
 -,バージョンメニュー,バージョン情報(&A),Ctrl+A,,バージョン
』をメニュー一括作成。

*メッセージ速度変更(Sに)
  もし、S=「早い」ならば、
    メッセージ速度=0
    速度1のチェックオン。速度2のチェックオフ。速度3のチェックオフ。

  違えばもし、S=「普通」ならば、
    メッセージ速度=30
    速度1のチェックオフ。速度2のチェックオン。速度3のチェックオフ。

  違えばもし、S=「遅い」ならば、
    メッセージ速度=60
    速度1のチェックオフ。速度2のチェックオフ。速度3のチェックオン。
#------------------------------------------------------------

#---母艦----
母艦のタイトルは「36(Thirty-six)」
母艦のクライアント幅は640。母艦のクライアント高さは480。
母艦を$EEAA88で画面クリア母艦のスタイルは「枠固定」
母艦オフに最大化ボタン有効変更。
母艦中央移動。
#------------------------------------------------------------

#-----宣言---------------------------------------------------
プレイヤー名とは文字列=「プレイヤー」
コンピューター名とは文字列=「なこ様」
ナコ様画像とは文字列=「{ランタイムパス}\lib\nako.png」

出目とは配列。
得点とは整数=0
プレイヤー得点とは整数=0
コンピューター得点とは整数=0
プレイヤー罰点とは整数=0
コンピューター罰点とは整数=0

手番とは整数=0
プレイヤーとは整数=0
コンピューターとは整数=1
カウントとは整数=0
ゾロ目とは整数オフ
六ゾロとは整数オフ

マージンとは整数=15
メッセージ速度とは整数=30
速度2のチェックオン。

#---サイコロ設定----
ダイスサイズとは整数=80
ミニダイスとは整数=20

サイコロ赤とは配列。
サイコロ赤=「{ダイスサイズ}
{黒色},{赤色},{白色}
{黒色},{赤色},{白色}
{黒色},{赤色},{白色}
{黒色},{赤色},{白色}
{黒色},{赤色},{白色}
{黒色},{赤色},{白色}」

サイコロ白とは配列。
サイコロ白=「{ダイスサイズ}
{黒色},{白色},{赤色}
{黒色},{白色},{赤色}
{黒色},{白色},{赤色}
{黒色},{白色},{赤色}
{黒色},{白色},{赤色}
{黒色},{白色},{赤色}」

#---サイコロ用イメージ----
線太さ=1
ダイス用¥1にサイコロ赤でサイコロ準備
ダイス用¥2にサイコロ白でサイコロ準備

処理用とはイメージの可視はオフ。

#---サイコロ振るところ----
トレイ幅とは整数=350
トレイ高さとは整数=310
トレイxとは整数。トレイx=(母艦のクライアント幅/2)-(トレイ幅/2)
トレイyとは整数。トレイy=30

ダイストレイとはイメージの可視はオフの幅はトレイ幅。の高さはトレイ高さ。
ダイストレイを$006600で画面クリア。
ダイストレイを母艦のトレイx,トレイyへ画像コピー。

#---メッセージ出すところ----
テキストウィンドウ幅とは整数=610
テキストウィンドウ高さとは整数=115
テキストウィンドウxとは整数=マージン
テキストウィンドウyとは整数。テキストウィンドウy=トレイ高さ+トレイy+マージン

テキストウィンドウとはイメージの可視はオフの幅はテキストウィンドウ幅。の高さはテキストウィンドウ高さ。
テキストウィンドウを$222222で画面クリア。
テキストウィンドウを母艦のテキストウィンドウx,テキストウィンドウyへ画像コピー

#---得点計算するところ----
得点表示幅とは整数=110
得点表示高さとは整数=310
プレイヤーxとは整数=マージン
コンピューターxとは整数母艦のクライアント幅-(マージン+得点表示幅)
得点表示xとは整数。
得点表示yとは整数=マージン

得点表示用とはイメージの可視はオフの幅は得点表示幅。の高さは得点表示高さ。
得点表示用を$FFDDAAで画面クリア。

得点表示用を母艦のプレイヤーx,得点表示y*2へ画像コピー。
得点表示用を母艦のコンピューターx,得点表示y*2へ画像コピー文字書体は「MS ゴシック|12|太字」
母艦のプレイヤーx,0,得点表示幅,得点表示y*2-1へ「{プレイヤー名}」を中央,下で枠内文字描画母艦のコンピューターx,0,得点表示幅,得点表示y*2-1へ「{コンピューター名}」を中央,下で枠内文字描画。

#---サイコロ振るボタン----
ボタンフラグとは整数。  #0=OK、1=ゲーム開始、2=サイコロ振る、3=勝敗判定、4=新規ゲーム

ボタンAとはボタンの可視はオフの幅は100。の高さは30。
のXはトレイx+(トレイ幅/2-ボタンAの幅/2)。のYはトレイ高さ+トレイy-ボタンAの高さ。
ボタンAをクリックした時は~
  ナコ様の可視はオフ。
  もしボタンフラグ=0ならば
    ボタンフラグ=2
    もし、手番=プレイヤーならば、プレイヤー手番。
    違えば、コンピューター手番。
  違えばもしボタンフラグ=1ならば
    ボタンAの有効はオフ。
    「プレイヤーの手番」でメッセージ表示。
    ボタンAのテキストは「ダイスを振る」
    の有効はオン。
    ボタンフラグ=2
  違えばもしボタンフラグ=2ならば
    ボタンAの有効はオフ。
    サイコロ振る。得点計算。得点加算。
  違えばもしボタンフラグ=3ならば
    勝敗判定。
  違えばもしボタンフラグ=4ならば
    ボタンAの有効はオフ
    新規ゲーム。

#---なこ様----
ナコ様とはフォームの可視はオフの親部品は母艦
の画像はナコ様画像。
ナコ様を画像通り変形。
のドラッグ移動オフ。
#------------------------------------------------------------

#-----メインルーチン-----------------------------------------
母艦の可視はオンダイアログIMEIMEオンダイアログタイトルは「名前入力」
「あなたの名前は?(全角7文字以内で教えてね)」と尋ねるもしそれならば、
  プレイヤー名は「プレイヤー」
違えば
  プレイヤー名はそれの14バイト左部分。
  線色は$EEAA88。塗り色は$EEAA88。
  母艦のプレイヤーx,0からプレイヤーx+得点表示幅,得点表示y*2-1へ四角。
  母艦のプレイヤーx,0,得点表示幅,得点表示y*2-1へ「{プレイヤー名}」を中央,下で枠内文字描画。

「挨拶」でメッセージ表示ボタンAのテキストは「よろしく」
の可視はオンボタンフラグ=4
#------------------------------------------------------------
*新規ゲーム
  乱数初期化。
  プレイヤー得点=0
  コンピューター得点=0
  プレイヤー罰点=0
  コンピューター罰点=0
  カウント=0

  得点表示y=マージン。
  得点表示用を母艦のプレイヤーx,得点表示y*2へ画像コピー。
  得点表示用を母艦のコンピューターx,得点表示y*2へ画像コピー。
  ダイストレイを母艦のトレイx,トレイyへ画像コピー。
  描画処理反映。
  手番はプレイヤー。
  「ゲーム開始」でメッセージ表示。
  ボタンAの有効はオン
  ボタンAのテキストは「準備OK!」
  ボタンフラグは1

#-----2Dを振る---------------------------------------------
*サイコロ振る
  2
    処理用をダイスサイズ,ダイスサイズへ画像高速リサイズ。
    r=6の乱数。出目¥(回数-1)=r+1。
    x=r*ダイスサイズ。y=0。
    ダイス用¥回数のx,y,ダイスサイズ,ダイスサイズを処理用の0,0へ画像部分コピー。
    処理用を母艦のトレイx+((トレイ幅/3)*回数-ダイスサイズ/2),トレイy+(トレイ高さ/2-ダイスサイズ/2)へ画像コピー。

    処理用をミニダイス,ミニダイスへ画像リサイズ。
    もし、手番=プレイヤーならば
      得点表示x=プレイヤーx+10+(ミニダイス+10)*(回数-1)
      得点表示y=マージン*2+10+(ミニダイス+10)*(カウント/2)
      処理用を母艦の得点表示x,得点表示yへ画像コピー。
    違えば
      得点表示x=コンピューターx+10+(ミニダイス+10)*(回数-1)
      得点表示y=マージン*2+10+(ミニダイス+10)*((カウント-1)/2)
      処理用を母艦の得点表示x,得点表示yへ画像コピー。
#------------------------------------------------------------
*得点計算
  もし、(出目¥0)=(出目¥1)ならば
    もし、(出目¥0)=6ならば
      得点=36。
      文字色赤色。
    違えばもし、(出目¥0)=1ならば
      得点=0。
      文字色青色。
    違えば
      得点=出目¥0*出目¥1。
      ゾロ目=オン
      文字色黒色。
  違えば
    得点=出目¥0+出目¥1。
    文字色黒色。

*得点加算
  もし、手番=プレイヤーならば
    もし、得点=36ならば
      プレイヤー得点=36
      得点表示。
      「プレイヤー6ゾロ」でメッセージ表示。
      六ゾロ=1
    違えばもし、得点=0ならば
      プレイヤー得点=0
      得点表示。
      「プレイヤー1ゾロ」でメッセージ表示。
    違えば
      プレイヤー得点=プレイヤー得点+得点
      もし、プレイヤー得点>=36ならば
        文字色赤色。
        プレイヤー罰点=プレイヤー得点-36
      得点表示。
      もし、ゾロ目=オンならば
        「プレイヤーゾロ目」でメッセージ表示。
        ゾロ目=オフ
      違えば
        「プレイヤー出目」でメッセージ表示。
    手番=コンピューター。
    ボタンAのテキストは「OK」
    の有効はオン。
    ボタンフラグ=0
    
  違えば
    もし、得点=36ならば
      コンピューター得点=36
      得点表示。
      「コンピューター6ゾロ」でメッセージ表示。
      六ゾロ=六ゾロ+2
    違えばもし、得点=0ならば
      コンピューター得点=0
      得点表示。
      「コンピューター1ゾロ」でメッセージ表示。
    違えば
      コンピューター得点=コンピューター得点+得点
      もし、コンピューター得点>=36ならば
        文字色赤色。
        コンピューター罰点=コンピューター得点-36
      得点表示。
      もし、ゾロ目=オンならば
        「コンピューターゾロ目」でメッセージ表示。
        ゾロ目=オフ
      違えば
        「コンピューター出目」でメッセージ表示。

    もし、(プレイヤー得点>=36)または(コンピューター得点>=36)ならば
      ボタンAのテキストは「勝敗判定」
      の有効はオン。
      ボタンフラグ=3
    違えばもし、カウント=19ならば
      ボタンAのテキストは「無効試合」
      の有効はオン。
      ボタンフラグ=3
    違えば
      手番=プレイヤー。
      ボタンAのテキストは「OK」
      の有効はオン。
      ボタンフラグ=0

*得点表示
  文字書体は「MS ゴシック|16|太字」。
  もし、手番=プレイヤーならば
    得点表示x=プレイヤーx+20+(ミニダイス+10)*2
    得点表示y=マージン*2+10+(ミニダイス+10)*(カウント/2)
    母艦の得点表示x,得点表示y,ミニダイス,ミニダイスへ右,中央でプレイヤー得点を枠内文字描画。

  違えば
    得点表示x=コンピューターx+20+(ミニダイス+10)*2
    得点表示y=マージン*2+10+(ミニダイス+10)*((カウント-1)/2)
    母艦の得点表示x,得点表示y,ミニダイス,ミニダイスへ右,中央でコンピューター得点を枠内文字描画。
#------------------------------------------------------------
*勝敗判定
  #6ゾロでの上がりは累計での上がりに優先する
  もし、六ゾロ=1ならば        #プレイヤーが6ゾロ
    「勝ち」で勝敗表示。「プレイヤー6ゾロ勝利」で勝敗メッセージ表示。
  違えばもし、六ゾロ=2ならば    #コンピューターが6ゾロ
    「負け」で勝敗表示。「コンピューター6ゾロ勝利」で勝敗メッセージ表示。
  違えばもし、六ゾロ=3ならば    #プレイヤーもコンピューターも6ゾロ
    「引き分け」で勝敗表示。「双方6ゾロ」で勝敗メッセージ表示。

  #プレイヤーもコンピューターも6ゾロではない
  違えば
    もし、(プレイヤー得点>=36)ならば        #プレイヤーの点数が36かそれ以上で
      もし、(コンピューター得点<36)ならば        #コンピューターがそれ以下ならば
        「勝ち」で勝敗表示。「プレイヤー勝利」で勝敗メッセージ表示。
      違えばもし、(コンピューター得点>=36)ならば   #コンピューターの点数も36かそれ以上なら
        もし、(プレイヤー罰点<コンピューター罰点)ならば    #罰点のより少ない方が勝ちとなり
          「勝ち」で勝敗表示。「プレイヤー勝利2」で勝敗メッセージ表示。
        違えばもし、(プレイヤー罰点>コンピューター罰点)ならば
          「負け」で勝敗表示。「コンピューター勝利2」で勝敗メッセージ表示。
        違えば                          #それも同じならば引き分け
          「引き分け」で勝敗表示。「引き分け」で勝敗メッセージ表示。
    違えばもし、(コンピューター得点>=36)ならば  #プレイヤーの点数が36に満たずコンピューターの点数が36かそれ以上
      「負け」で勝敗表示。「コンピューター勝利」で勝敗メッセージ表示。
    違えば                        #10でどちらも36を越えなかった場合
      「引き分け」で勝敗表示。「無効試合」で勝敗メッセージ表示。

  六ゾロ=0
  ボタンAのテキストは「もう一度?」
  ボタンフラグ=4

*勝敗表示(Sで)
  ダイストレイを母艦のトレイx,トレイyへ画像コピー。
  文字書体は「MS ゴシック|32|太字」。
  勝敗表示x=(トレイ幅/2)-(Sの文字幅取得/2)+トレイx
  勝敗表示y=トレイy+10
  もし、S=「勝ち」ならば、
    文字色白色母艦の勝敗表示x+2,勝敗表示y+2へ「勝ち」を文字描画。
    文字色赤色母艦の勝敗表示x,勝敗表示yへ「勝ち」を文字描画。
  違えばもし、S=「負け」ならば、
    文字色白色母艦の勝敗表示x+2,勝敗表示y+2へ「負け」を文字描画。
    文字色青色母艦の勝敗表示x,勝敗表示yへ「負け」を文字描画。
  違えばもし、S=「引き分け」ならば、
    文字色白色母艦の勝敗表示x+2,勝敗表示y+2へ「引き分け」を文字描画。
    文字色は$777777。母艦の勝敗表示x,勝敗表示yへ「引き分け」を文字描画。

*勝敗メッセージ表示(Sで)
  文字色白色文字書体は「MS ゴシック|18|太字」。#12文字表示できる
  勝敗表示x=トレイx+30
  勝敗表示y=トレイy+80
  もし、S=「プレイヤー6ゾロ勝利」ならば
    母艦の勝敗表示x,勝敗表示yへ「おめでとう!{改行}6ゾロで{プレイヤー名}の{改行}完全勝利!!」を文字描画。
  もし、S=「コンピューター6ゾロ勝利」ならば
    母艦の勝敗表示x,勝敗表示yへ「残念!!{改行}6ゾロで{コンピューター名}の{改行}完全勝利!」を文字描画。
  もし、S=「双方6ゾロ」ならば
    母艦の勝敗表示x,勝敗表示yへ「双方6ゾロで引き分けです」を文字描画。
  もし、S=「プレイヤー勝利」ならば
    母艦の勝敗表示x,勝敗表示yへ「おめでとう!{改行}{プレイヤー名}の勝ち!!」を文字描画。
  もし、S=「プレイヤー勝利2」ならば
    母艦の勝敗表示x,勝敗表示yへ「{プレイヤー名}の罰点{プレイヤー罰点}点{改行}{コンピューター名}の罰点{コンピューター罰点}点で{改行}{プレイヤー名}の勝ち!」を文字描画。
  もし、S=「コンピューター勝利」ならば
    母艦の勝敗表示x,勝敗表示yへ「残念!!{改行}{コンピューター名}の勝ち!」を文字描画。
  もし、S=「コンピューター勝利2」ならば
    母艦の勝敗表示x,勝敗表示yへ「{プレイヤー名}の罰点{プレイヤー罰点}点{改行}{コンピューター名}の罰点{コンピューター罰点}点で{改行}{コンピューター名}の勝ち!」を文字描画。
  もし、S=「引き分け」ならば
    母艦の勝敗表示x,勝敗表示yへ「引き分けです」を文字描画。
  もし、S=「無効試合」ならば
    母艦の勝敗表示x,勝敗表示yへ「残念でした。{改行}10で決着がつかず{改行}無効試合となります。」を文字描画。
  Sでメッセージ表示。
#------------------------------------------------------------
*プレイヤー手番
  カウント=カウント+1
  ボタンAの有効はオフ。
  ボタンAのテキストは「ダイスを振る」  
  ダイストレイを母艦のトレイx,トレイyへ画像コピー。
  「プレイヤーの手番」でメッセージ表示。
  ボタンAの有効はオン。

*コンピューター手番
  カウント=カウント+1
  ボタンAの有効はオフ。
  ダイストレイを母艦のトレイx,トレイyへ画像コピー。
  「コンピューターの手番」でメッセージ表示。
  サイコロ振る。得点計算。得点加算。
#------------------------------------------------------------
*メッセージ表示(Sで)
  テキストウィンドウを母艦のテキストウィンドウx,テキストウィンドウyへ画像コピー。
  文字色白色文字書体は「MS ゴシック|18|太字」。
  メッセージx=マージン+30。一行目=テキストウィンドウy+30。二行目=テキストウィンドウy+60。
  名前x=マージン。名前y=テキストウィンドウy+5。
  セリフ一行目=テキストウィンドウy+40。セリフ二行目=テキストウィンドウy+70。
  もし、S=「挨拶」ならば
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    ナコ様表示。
    母艦のメッセージx,セリフ一行目へ「こんにちは、{プレイヤー名}!」をメッセージ速度で文字遅延描画。
    母艦のメッセージx,セリフ二行目へ「よろしくね☆」をメッセージ速度で文字遅延描画。
  もし、S=「ゲーム開始」ならば
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「それでは始めよう!」をメッセージ速度で文字遅延描画。
    母艦のメッセージx,セリフ二行目へ「準備はいいかな?」をメッセージ速度で文字遅延描画。 
  もし、S=「プレイヤーの手番」ならば、
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「{プレイヤー名}の番だよ。」をメッセージ速度で文字遅延描画。
    母艦のメッセージx,セリフ二行目へ「ダイスを振ってね。」をメッセージ速度で文字遅延描画。
  もし、S=「コンピューターの手番」ならば、
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「僕の番だね。」をメッセージ速度で文字遅延描画。
    0.5秒待つ。
    母艦のメッセージx,セリフ二行目へ「………… ………… ………… …………」をメッセージ速度で文字遅延描画。
    0.5秒待つ。
    ナコ様の可視はオフ。

  もし、S=「プレイヤー出目」ならば、
    母艦のメッセージx,一行目へ「出目は{得点}です。」をメッセージ速度で文字遅延描画。
    母艦のメッセージx,二行目へ「{プレイヤー名}の点数は{プレイヤー得点}点になりました。」をメッセージ速度で文字遅延描画。
  もし、S=「プレイヤーゾロ目」ならば、
    母艦のメッセージx,一行目へ「{出目¥0}ゾロです。得点は{得点}点。」をメッセージ速度で文字遅延描画。
    母艦のメッセージx,二行目へ「{プレイヤー名}の点数は{プレイヤー得点}点になりました。」をメッセージ速度で文字遅延描画。
  もし、S=「プレイヤー6ゾロ」ならば、
    母艦のメッセージx,一行目へ「6ゾロです!!」をメッセージ速度で文字遅延描画。
    母艦のメッセージx,二行目へ「{コンピューター名}が6ゾロ以外なら{プレイヤー名}の勝ち!」をメッセージ速度で文字遅延描画。
  もし、S=「プレイヤー1ゾロ」ならば、
    母艦のメッセージx,一行目へ「残念!1ゾロです!!」をメッセージ速度で文字遅延描画。
    母艦のメッセージx,二行目へ「{プレイヤー名}の点数が0点になりました。」をメッセージ速度で文字遅延描画。
  もし、S=「コンピューター出目」ならば、
    母艦のメッセージx,一行目へ「出目は{得点}です。」をメッセージ速度で文字遅延描画。
    母艦のメッセージx,二行目へ「{コンピューター名}の点数は{コンピューター得点}点になりました。」をメッセージ速度で文字遅延描画。
  もし、S=「コンピューターゾロ目」ならば、
    母艦のメッセージx,一行目へ「{出目¥0}ゾロです。得点は{得点}点。」をメッセージ速度で文字遅延描画。
    母艦のメッセージx,二行目へ「{コンピューター名}の点数は{コンピューター得点}点になりました。」をメッセージ速度で文字遅延描画。
  もし、S=「コンピューター6ゾロ」ならば、
    母艦のメッセージx,一行目へ「{コンピューター名}が、6ゾロを出しました!!」をメッセージ速度で文字遅延描画。
  もし、S=「コンピューター1ゾロ」ならば、
    母艦のメッセージx,一行目へ「1ゾロです!!」をメッセージ速度で文字遅延描画。
    母艦のメッセージx,二行目へ「{コンピューター名}の点数が0点になりました。」をメッセージ速度で文字遅延描画。

  もし、S=「プレイヤー6ゾロ勝利」ならば
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「ま、負けました・・・」をメッセージ速度で文字遅延描画。
  もし、S=「コンピューター6ゾロ勝利」ならば
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「圧勝だね」をメッセージ速度で文字遅延描画。
  もし、S=「双方6ゾロ」ならば
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「惜しい!」をメッセージ速度で文字遅延描画。
  もし、S=「プレイヤー勝利」ならば
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「ちくしょ~」をメッセージ速度で文字遅延描画。
  もし、S=「プレイヤー勝利2」ならば
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「悔しい~」をメッセージ速度で文字遅延描画。
  もし、S=「コンピューター勝利」ならば
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「ひゃっほう!」をメッセージ速度で文字遅延描画。
  もし、S=「コンピューター勝利2」ならば
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「やったね!」をメッセージ速度で文字遅延描画。
  もし、S=「引き分け」ならば
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「引き分けか・・・」をメッセージ速度で文字遅延描画。
  もし、S=「無効試合」ならば
    ナコ様表示。
    母艦の名前x,名前yへ「【{コンピューター名}】」を文字描画。
    母艦のメッセージx,セリフ一行目へ「なんと?!」をメッセージ速度で文字遅延描画。
#------------------------------------------------------------
*ナコ様表示
  ナコ様のX=母艦のクライアント幅-ナコ様の幅。
  ナコ様のY=母艦のクライアント高さ-ナコ様の高さ。
  ナコ様の可視はオン。ナコ様を最前面表示。
#------------------------------------------------------------
*サイコロ準備({グループ}imgにSで)
  imgをイメージとして作成。
  img→可視はオフ。
  img→幅はS\0*6
  img→高さはS\0
  imgを$00FF00で画面クリア。    #透過色
  目サイズ=S\0/8。
  6
    色設定とは配列。色設定=S\回数。
    線色は色設定¥0。塗り色は色設定¥1。
    外枠(img,S\0)
    線色は色設定¥2。塗り色は色設定¥2。
    もし回数=1ならば
      半径=目サイズ+S\0/40。
      中点(img,S\0)。
    もし回数=2ならば
      半径=目サイズ。
      左上点(img,S\0)。右下点(img,S\0)。
    もし回数=3ならば
      半径=目サイズ。
      中点(img,S\0)。左上点(img,S\0)。右下点(img,S\0)。
    もし回数=4ならば
      半径=目サイズ。
      左上点(img,S\0)。左下点(img,S\0)。右上点(img,S\0)。右下点(img,S\0)。
    もし回数=5ならば
      半径=目サイズ。
      中点(img,S\0)。左上点(img,S\0)。左下点(img,S\0)。右上点(img,S\0)。右下点(img,S\0)。
    もし回数=6ならば
      半径=目サイズ-S\0/80。
      左上点(img,S\0)。左下点(img,S\0)。右上点(img,S\0)。右下点(img,S\0)。左中点(img,S\0)。右中点(img,S\0)。

*外枠({グループ}img,S)
  x=(回数-1)*S。y=0。
  x2=x+S。y2=S。
  imgのx,yからx2,y2へ四角。

*中点({グループ}img,S)
  xx=(x+S/2)-半径。yy=S/2-半径
  xx2=(x+S/2)+半径。yy2=S/2+半径。
  imgのxx,yyからxx2,yy2へ。

*左上点({グループ}img,S)
  xx=(x+S/4)-半径。yy=S/4-半径
  xx2=(x+S/4)+半径。yy2=S/4+半径。
  imgのxx,yyからxx2,yy2へ。

*左下点({グループ}img,S)
  xx=(x+S/4)-半径。yy=(S/4)*3-半径
  xx2=(x+S/4)+半径。yy2=(S/4)*3+半径。
  imgのxx,yyからxx2,yy2へ。

*右上点({グループ}img,S)
  xx=(x+S/4*3)-半径。yy=S/4-半径
  xx2=(x+S/4*3)+半径。yy2=S/4+半径。
  imgのxx,yyからxx2,yy2へ。

*右下点({グループ}img,S)
  xx=(x+S/4*3)-半径。yy=(S/4)*3-半径
  xx2=(x+S/4*3)+半径。yy2=(S/4)*3+半径。
  imgのxx,yyからxx2,yy2へ。

*左中点({グループ}img,S)
  xx=(x+S/4)-半径。yy=S/2-半径
  xx2=(x+S/4)+半径。yy2=S/2+半径。
  imgのxx,yyからxx2,yy2へ。

*右中点({グループ}img,S)
  xx=(x+S/4*3)-半径。yy=S/2-半径
  xx2=(x+S/4*3)+半径。yy2=S/2+半径。
  imgのxx,yyからxx2,yy2へ。
#------------------------------------------------------------
*遊び方
  ダイアログタイトルは「36(Thirty-six)について」
  「【36(Thirty-six)のルール】
   二人で交互に六面ダイス二個を振り合い、点数を累計してゆきます。
   二個の目の和が、のまま点数になり、ゾロ目の場合は二個の目のが点数と
  なりますが、1ゾロの場合はそれまでの点数の累計がクリアされ0点になります。
   早く36点に達した方が勝ちとなりますが、先攻後攻はなく両者同じ回数だけ
  ダイスを振ることが出来るため、双方同時に上がった場合は、36を越えた分が
  罰点となり、より罰点の少ない方が勝ちとなります。
   なお、6ゾロで上がった場合は、36点ぴったりでの上がりとなり罰点はなく、
  また、通常の累計での上がりに優先します。
   罰点も同数の場合や両者ともに6ゾロで上がった場合は、引き分けとなります。」と言う
#------------------------------------------------------------
*バージョン
  ダイアログタイトルは「バージョン情報」
  「{二重カッコ}36(Thirty-six){二重カッコ閉じ}{改行}  Version 1.03{改行}{改行} by 雪乃☆雫」と言う。
#------------------------------------------------------------
●枠内文字描画({グループ=?}OBJのX,Y,W,HへSをA,Vで)
  xxとは整数。yyとは整数。
  もし、A=左ならば
    xx=X
  違えばもし、A=中央ならば
    xx=X+(W-(Sの文字幅取得))/2
  違えばもし、A=右ならば
    xx=(X+W)-(Sの文字幅取得)
  もし、V=上ならば
    yy=Y
  違えばもし、V=中央ならば
    yy=Y+(H-(Sの文字高さ取得))/2
  違えばもし、V=下ならば
    yy=(Y+H)-(Sの文字高さ取得)
  OBJのxx,yyへSを文字描画。
#------------------------------------------------------------

 やっぱり、こうゆう単純なゲームは、自分でサイコロを振ってこ、相手が人であってこって部分があるよねぇ。

 しかし、の時代は各々スマホのアプリって感じで、みんなでこういった埒もない暇つぶしの遊びをしたりはもうしないんだろうね・・・

 なこ様がもう少し、出目に対して一喜一憂した方が、少しは人っぽくて面白いかとも思ったけど、所詮は焼け石に水っていうか、色々メッセージを考えるのがもうさすがに面倒になったていうか、場合によっちゃむしろ腹立つっていうかなので、やめた~www

 画像合成を使わず、画面の書き換えもしなくて済むように、画像通り変形したフォームを重ねてみたんだけど、このなこ様で、デスクトップマスコットを作ってみたらどうだろう。

 またまたひらめいてしまったw(だから、なでコラはどうした;)

 次は、なでコラです(予定)

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20160520

2016-05-16

勝敗判定

| 08:57

 昨日買い物に行った時、ついでに探してみたら、なるほどサイコロキャラメルはどこにも無かった。

 ってか、ついこないだまでは、ふつーにあったような気がするから、やっぱりYahoo!ニュースに載ったがために、みんな買いに走ったのだろうか。

 人って愚かだな・・・(自分のことでしょ!)



 ・・・さて、実際にやればんな難しいことは無いんだけど、単に、累計点数が先に上ったら勝ちという場合と比べて、勝敗のパターンが結構多いです。

 ざっと書き出してみます。

●6ゾロは全てに優先します
・プレイヤーが6ゾロ=プレイヤーの勝ち
・コンピューターが6ゾロ=コンピューターの勝ち
・双方6ゾロ=引き分け

●ふつーに累計で勝負がつく場合
・プレイヤーが36をえ、コンピューターは36未満=プレイヤーの勝ち
・コンピューターが36をえ、プレイヤーは36未満=コンピューターの勝ち

●プレイヤーもコンピューターも、ともに36をえた場合
◎罰点(累計得点-36)の少ない方が勝ち
・プレイヤーの罰点<コンピューターの罰点=プレイヤーの勝ち
・プレイヤーの罰点>コンピューターの罰点=コンピューターの勝ち
・罰点まで同じ=引き分け

●無効試合
 ふつーにサイコロで遊んでいた時にはの制度はなかったのですが、、
得点表示するスペースの都合により、10で勝負が決まらなければ無効試合
とします。
 滅多にんなことないけど、絶妙なタイミングで双方1ゾロしたりすると、
起こりえます。

 して、これをプログラムにすると、こんな感じ。

#------------------------------------------------------------
*勝敗判定
  ダイアログタイトルは「勝敗判定」
  #6ゾロでの上がりは累計での上がりに優先する
  もし、六ゾロ=1ならば        #プレイヤーが6ゾロ
    「おめでとう!{改行}6ゾロで{プレイヤー名}の勝ち!!」を言う。

  違えばもし、六ゾロ=2ならば    #コンピューターが6ゾロ
    「残念!!{改行}6ゾロで{コンピューター名}の勝ち!」を言う。

  違えばもし、六ゾロ=3ならば    #プレイヤーもコンピューターも6ゾロ
    「双方6ゾロで引き分けです」を言う。

  #プレイヤーもコンピューターも6ゾロではない
  違えば
    もし、(プレイヤー得点>=36)ならば          #プレイヤーの点数が36かそれ以上で
      もし、(コンピューター得点<36)ならば          #コンピューターがそれ以下ならば
        「おめでとう!{改行}{プレイヤー名}の勝ち!!」を言う。
      
      違えばもし、(コンピューター得点>=36)ならば      #コンピューターの点数も36かそれ以上なら
        もし、(プレイヤー罰点<コンピューター罰点)ならば    #罰点のより少ない方が勝ちとなり
          「{プレイヤー名}の罰点{プレイヤー罰点}点{改行}{コンピューター名}の罰点{コンピューター罰点}点で{改行}{プレイヤー名}の勝ち!」を言う。

        違えばもし、(プレイヤー罰点>コンピューター罰点)ならば
          「{プレイヤー名}の罰点{プレイヤー罰点}点{改行}{コンピューター名}の罰点{コンピューター罰点}点で{改行}{コンピューター名}の勝ち!」を言う。

        違えば                          #それも同じならば引き分け
          「引き分けです」を言う。

    違えばもし、(コンピューター得点>=36)ならば    #プレイヤーの点数が36に満たずコンピューターの点数が36かそれ以上
      「残念!!{改行}{コンピューター名}の勝ち!」を言う。

    違えば                          #10でどちらも36を越えなかった場合
      「残念でした。{改行}10で決着がつかず{改行}無効試合となります。」を言う。

  ボタンAのテキストは「もう一度?」
#------------------------------------------------------------

 これで、いちおう遊べて、勝ち負けも判定して言ってもらえるようになったけど、未だ活用されていないテキストウィンドウに、は言わせているメッセージを表示したり、ちょぼいちの時みたく、相手のコンピューターに何かしゃべらせたりする予定。

 あと、コンピューターがサイコロを振る時も、自分でダイスを振るボタンを押してやらなければならないってのは、いかがなものか。

 この辺を手直しすれば、とりあえずは完成と言えるかな?

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20160516

2016-05-13

サイコロキャラメルを振るよ!

| 21:29

 ある意味本題(爆)の、サイコロキャラメルが振れるようになりましたw

 別に、んなに再現性は高くないし、もちろん明治のロゴとか入ってるわけじゃなく、単なる赤白のサイコロってだけなんですけれどねぇ~www

 結局、全部の色設定を配列にして引数にすることにした~。

 サイコロキャラメルは、全部の面の色が同じカラーリングなんだから、こんな必要ないじゃんとか、角丸じゃないから画像合成通の必要ないじゃんとかゆう野暮なツッコミは不可です!

 おもちゃみたいな、全面色違いのサイコロとかも作りたいんだよ~ん。


 そうそう、普通の一般的なサイコロの、1の目が赤いのは、日の丸に見立てたものなんだって!

 日本だけだったんだね・・・

 まめちしきぃ~。

 ちなみに、そうなったのは大正時代のことらしいから、もし時代劇の丁半博打の場で、目の赤いサイコロが使われていたら、早速テレビ局に電話しなきゃ!(爆)

#サイコロキャラメル

#-----母艦設計-----------------------------------------------
!母艦設計=「母艦の可視はオフ母艦のタイトルは「2Dを振る」
母艦のクライアント幅は640。母艦のクライアント高さは480。
母艦を$006600で画面クリア母艦のスタイルは「枠固定」
母艦オフに最大化ボタン有効変更。
母艦中央移動。
#------------------------------------------------------------

#-----宣言---------------------------------------------------
ダイスサイズとは整数=80

サイコロ一般とは配列。 #サイズ{~}線色,地色,点色{~}...
サイコロ一般=「{ダイスサイズ}
{黒色},{白色},{赤色}
{黒色},{白色},{黒色}
{黒色},{白色},{黒色}
{黒色},{白色},{黒色}
{黒色},{白色},{黒色}
{黒色},{白色},{黒色}」

サイコロ赤とは配列。
サイコロ赤=「{ダイスサイズ}
{黒色},{赤色},{白色}
{黒色},{赤色},{白色}
{黒色},{赤色},{白色}
{黒色},{赤色},{白色}
{黒色},{赤色},{白色}
{黒色},{赤色},{白色}」

サイコロ白とは配列。
サイコロ白=「{ダイスサイズ}
{黒色},{白色},{赤色}
{黒色},{白色},{赤色}
{黒色},{白色},{赤色}
{黒色},{白色},{赤色}
{黒色},{白色},{赤色}
{黒色},{白色},{赤色}」

サイコロ虹とは配列。
サイコロ虹=「{ダイスサイズ}
{$330000},{$FFBBBB},{$CC3333}
{$003300},{$BBFFBB},{$33CC33}
{$000033},{$BBBBFF},{$3333CC}
{$330033},{$FFBBFF},{$CC33CC}
{$333300},{$FFFFBB},{$CCCC33}
{$003333},{$BBFFFF},{$33CCCC}」

#---サイコロ用イメージ----
線太さ=1
ダイス用¥1にサイコロ赤でサイコロ準備
ダイス用¥2にサイコロ白でサイコロ準備

処理用とはイメージの可視はオフ。

#---サイコロ振るボタン----
ボタンAとはボタンの可視はオンの幅は110。の高さは35。
のXは母艦のクライアント幅/2-ボタンAの幅/2。のYは母艦の高さ-100。
のテキストは「サイコロを振る」

ボタンAをクリックした時は~
  サイコロ振る。
#------------------------------------------------------------

#-----メインルーチン-----------------------------------------
母艦の可視はオン乱数初期化。

サイコロ振る
#------------------------------------------------------------

#------------------------------------------------------------
*サイコロ振る
  処理用をダイスサイズ,ダイスサイズへ画像高速リサイズ。
  2
    r=6の乱数。出目¥(回数-1)=r+1。
    x=r*ダイスサイズ。y=0。
    ダイス用¥回数のx,y,ダイスサイズ,ダイスサイズを処理用の0,0へ画像部分コピー。
    処理用を母艦の((母艦のクライアント幅/4)*(回数))-(ダイスサイズ/2)+(母艦のクライアント幅/8),(母艦のクライアント高さ/2)-(ダイスサイズ/2)へ画像合成通。
#------------------------------------------------------------
*サイコロ準備({グループ}imgにSで)
  imgをイメージとして作成。
  img→可視はオフ。
  img→幅はS\0*6
  img→高さはS\0
  imgを$00FF00で画面クリア。    #透過色
  目サイズ=S\0/8。
  6
    色設定とは配列。色設定=S\回数。
    線色は色設定¥0。塗り色は色設定¥1。
    外枠(img,S\0)
    線色は色設定¥2。塗り色は色設定¥2。
    もし回数=1ならば
      半径=目サイズ+S\0/40。
      中点(img,S\0)。
    もし回数=2ならば
      半径=目サイズ。
      左上点(img,S\0)。右下点(img,S\0)。
    もし回数=3ならば
      半径=目サイズ。
      中点(img,S\0)。左上点(img,S\0)。右下点(img,S\0)。
    もし回数=4ならば
      半径=目サイズ。
      左上点(img,S\0)。左下点(img,S\0)。右上点(img,S\0)。右下点(img,S\0)。
    もし回数=5ならば
      半径=目サイズ。
      中点(img,S\0)。左上点(img,S\0)。左下点(img,S\0)。右上点(img,S\0)。右下点(img,S\0)。
    もし回数=6ならば
      半径=目サイズ-S\0/80。
      左上点(img,S\0)。左下点(img,S\0)。右上点(img,S\0)。右下点(img,S\0)。左中点(img,S\0)。右中点(img,S\0)。

*外枠({グループ}img,S)
  x=(回数-1)*S。y=0。
  x2=x+S。y2=S。
//  imgのx,yからx2,y2へS/3,S/3で角丸四角。
  imgのx,yからx2,y2へ四角。

*中点({グループ}img,S)
  xx=(x+S/2)-半径。yy=S/2-半径
  xx2=(x+S/2)+半径。yy2=S/2+半径。
  imgのxx,yyからxx2,yy2へ。

*左上点({グループ}img,S)
  xx=(x+S/4)-半径。yy=S/4-半径
  xx2=(x+S/4)+半径。yy2=S/4+半径。
  imgのxx,yyからxx2,yy2へ。

*左下点({グループ}img,S)
  xx=(x+S/4)-半径。yy=(S/4)*3-半径
  xx2=(x+S/4)+半径。yy2=(S/4)*3+半径。
  imgのxx,yyからxx2,yy2へ。

*右上点({グループ}img,S)
  xx=(x+S/4*3)-半径。yy=S/4-半径
  xx2=(x+S/4*3)+半径。yy2=S/4+半径。
  imgのxx,yyからxx2,yy2へ。

*右下点({グループ}img,S)
  xx=(x+S/4*3)-半径。yy=(S/4)*3-半径
  xx2=(x+S/4*3)+半径。yy2=(S/4)*3+半径。
  imgのxx,yyからxx2,yy2へ。

*左中点({グループ}img,S)
  xx=(x+S/4)-半径。yy=S/2-半径
  xx2=(x+S/4)+半径。yy2=S/2+半径。
  imgのxx,yyからxx2,yy2へ。

*右中点({グループ}img,S)
  xx=(x+S/4*3)-半径。yy=S/2-半径
  xx2=(x+S/4*3)+半径。yy2=S/2+半径。
  imgのxx,yyからxx2,yy2へ。
#------------------------------------------------------------
●画像合成通({グループ}コピー元を{数値=$00FF00}透過色で{グループ}コピー先のX,Yへ)
  # マスクの作成(キャラの透過部分が白、表示部分が黒の画像)
  マスク画像をイメージとして作成。マスク画像の可視はオフ。
  マスク画像→画像はコピー元→名前
  マスク画像を透過色で画像マスク作成

  # キャラの透過色部分を黒に変換
  # はじめからキャラの透過色を黒にすると髪や目や文字に黒が使用出来なくなる
  キャラ画像をイメージとして作成。キャラ画像の可視はオフ
  キャラ画像→画像はコピー元→名前
  マスク画像を画像ネガポジ
  マスク画像をキャラ画像の0,0へ画像ANDコピー
  マスク画像を画像ネガポジ

  # 合成実行
  マスク画像をコピー先のX,Yへ画像ANDコピー
  キャラ画像をコピー先のX,Yへ画像ORコピー
 
  VCL_FREE(マスク画像)
  VCL_FREE(キャラ画像)
#------------------------------------------------------------

 なにがでるかな? なにがでるかな? .... .... ....

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20160513

2016-05-12

基本的な機能は完成

| 19:24

 前に作った、2Dを振るプログラムと合体させるだけで、実際にボタンAを押したら、サイコロが振れるようになります。

 前、実はこまで出来てはいたんだけど、ダイスの見た目をサイコロキャラメルに合わせたらどうかしらとか、しょーもないことを考えていたんだよね。

 サイコロ準備の線色塗り色を変えれば、ダイスの色は簡単に変更出来るのだけれど、2Dを別々の色で表示することまでは考えていなかった。

 2Dを赤白にするためには、サイコロ用の裏画面を2つ用意しなくちゃならないし、サイコロ準備の色指定はのところ決め打ちなので・・・もちろん、サイコロ準備をコピペして赤白2色分作れば簡単にできるんだけど、それをやったら負けでしょ(?)

 かといって、全部の色設定を引数にするってのもねぇ~。一体いくつ引数がつくことになるんだよ・・・(--;

 なにか、スマートな良い方法はないもんか・・・と考えていたんだけど、よく考えたらもサイコロ準備自体が全くスマートじゃないんだから、ダメだこりゃ;・・・とゆうことに気が付いたので、とりあえず一旦保留にして、元のふつーのダイスのままで先に進むことにした(爆)


 さて、得点計算は、前書いた通り、6ゾロならぴったり36点、1ゾロなら0点。それ以外のゾロ目は、二つの目の、普通の出目なら二つの目の和。

 得点加算で、この計算結果を、プレイヤー得点と、コンピューター得点に、っくり同じ手順で代入しているのは、いかにも無駄っぽいけれど、気にしないで!;;;

 得点表示では、この加算結果をタダ表示するだけだとつまらないので、小さく縮小したサイコロの画像で、実際の出目を一緒に表示することにした。

#・手番交代、得点計算、得点とミニダイスの表示

#-----2Dを振る---------------------------------------------
*サイコロ振る
  カウント=カウント+1
  2
    処理用をダイスサイズ,ダイスサイズへ画像高速リサイズ。
    r=6の乱数。出目¥(回数-1)=r+1。
    x=r*ダイスサイズ。y=0。
    裏画面のx,y,ダイスサイズ,ダイスサイズを処理用の0,0へ画像部分コピー。
    処理用を母艦のトレイx+((トレイ幅/3)*回数-ダイスサイズ/2),トレイy+(トレイ高さ/2-ダイスサイズ/2)へ画像合成通。

    # 得点表示用にミニダイスを表示
    処理用をミニダイス,ミニダイスへ画像リサイズ。
    もし、手番=プレイヤーならば
      得点表示x=プレイヤーx+10+(ミニダイス+10)*(回数-1)
      得点表示y=マージン*2+10+(ミニダイス+10)*(カウント/2)
      処理用を母艦の得点表示x,得点表示yへ画像合成通。
    違えば
      得点表示x=コンピューターx+10+(ミニダイス+10)*(回数-1)
      得点表示y=マージン*2+10+(ミニダイス+10)*((カウント-1)/2)
      処理用を母艦の得点表示x,得点表示yへ画像合成通。
#------------------------------------------------------------
*得点計算
  もし、(出目¥0)=(出目¥1)ならば   # ゾロ目
    もし、(出目¥0)=6ならば      # 6ゾロ
      得点=36。
      文字色赤色。
    違えばもし、(出目¥0)=1ならば  # 1ゾロ
      得点=0。
      文字色青色。
    違えば                 # の他のゾロ目
      得点=出目¥0*出目¥1。
      文字色黒色。
  違えば                   # 平目
    得点=出目¥0+出目¥1。
    文字色黒色。

*得点加算
  もし、手番=プレイヤーならば
    もし、得点=36または得点=0ならば
      プレイヤー得点=得点
      得点表示。
    違えば
      プレイヤー得点=プレイヤー得点+得点
      もし、プレイヤー得点>=36ならば
        文字色赤色。
        プレイヤー罰点=プレイヤー得点-36
      得点表示。
    手番=コンピューター。

  違えば
    もし、得点=36または得点=0ならば
      コンピューター得点=得点
      得点表示。
    違えば
      コンピューター得点=コンピューター得点+得点
      もし、コンピューター得点>=36ならば
        文字色赤色。
        コンピューター罰点=コンピューター得点-36
      得点表示。
    
    # 勝負がついたかどうかを確認
    もし、(プレイヤー得点>=36)または(コンピューター得点>=36)ならば
      ボタンAのテキストは「勝敗判定」
      の有効はオフ。
    違えばもし、カウント=19ならば  # 得点表示用に表示出来る上限が10なので
      ボタンAのテキストは「無効試合」
      の有効はオフ。
    違えば
      手番=プレイヤー。

*得点表示
  文字書体は「MS ゴシック|16|太字」。
  もし、手番=プレイヤーならば
    得点表示x=プレイヤーx+20+(ミニダイス+10)*2
    得点表示y=マージン*2+10+(ミニダイス+10)*(カウント/2)
    母艦の得点表示x,得点表示y,ミニダイス,ミニダイスへ右,中央でプレイヤー得点を枠内文字描画。

  違えば
    得点表示x=コンピューターx+20+(ミニダイス+10)*2
    得点表示y=マージン*2+10+(ミニダイス+10)*((カウント-1)/2)
    母艦の得点表示x,得点表示y,ミニダイス,ミニダイスへ右,中央でコンピューター得点を枠内文字描画。

#------------------------------------------------------------

 とりあえず、今日ここまで。

 一応、もう一通りは遊べるようになりました。

 得点表示の部分を見れば、別に一目で勝ち負けも分かるけど、やはりちゃんとプログラムのほうで判定して、言って欲しいところ。

トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20160512