Hatena::Groupnadesiko

雪乃☆雫のなでしこ日和

2016-05-16

勝敗判定

| 08:57

 昨日買い物に行った時、ついでに探してみたら、なるほどサイコロキャラメルはどこにも無かった。

 ってか、ついこないだまでは、ふつーにあったような気がするから、やっぱりYahoo!ニュースに載ったがために、みんな買いに走ったのだろうか。

 人って愚かだな・・・(自分のことでしょ!)



 ・・・さて、実際にやればんな難しいことは無いんだけど、単に、累計点数が先に上ったら勝ちという場合と比べて、勝敗のパターンが結構多いです。

 ざっと書き出してみます。

●6ゾロは全てに優先します
・プレイヤーが6ゾロ=プレイヤーの勝ち
・コンピューターが6ゾロ=コンピューターの勝ち
・双方6ゾロ=引き分け

●ふつーに累計で勝負がつく場合
・プレイヤーが36をえ、コンピューターは36未満=プレイヤーの勝ち
・コンピューターが36をえ、プレイヤーは36未満=コンピューターの勝ち

●プレイヤーもコンピューターも、ともに36をえた場合
◎罰点(累計得点-36)の少ない方が勝ち
・プレイヤーの罰点<コンピューターの罰点=プレイヤーの勝ち
・プレイヤーの罰点>コンピューターの罰点=コンピューターの勝ち
・罰点まで同じ=引き分け

●無効試合
 ふつーにサイコロで遊んでいた時にはの制度はなかったのですが、、
得点表示するスペースの都合により、10で勝負が決まらなければ無効試合
とします。
 滅多にんなことないけど、絶妙なタイミングで双方1ゾロしたりすると、
起こりえます。

 して、これをプログラムにすると、こんな感じ。

#------------------------------------------------------------
*勝敗判定
  ダイアログタイトルは「勝敗判定」
  #6ゾロでの上がりは累計での上がりに優先する
  もし、六ゾロ=1ならば        #プレイヤーが6ゾロ
    「おめでとう!{改行}6ゾロで{プレイヤー名}の勝ち!!」を言う。

  違えばもし、六ゾロ=2ならば    #コンピューターが6ゾロ
    「残念!!{改行}6ゾロで{コンピューター名}の勝ち!」を言う。

  違えばもし、六ゾロ=3ならば    #プレイヤーもコンピューターも6ゾロ
    「双方6ゾロで引き分けです」を言う。

  #プレイヤーもコンピューターも6ゾロではない
  違えば
    もし、(プレイヤー得点>=36)ならば          #プレイヤーの点数が36かそれ以上で
      もし、(コンピューター得点<36)ならば          #コンピューターがそれ以下ならば
        「おめでとう!{改行}{プレイヤー名}の勝ち!!」を言う。
      
      違えばもし、(コンピューター得点>=36)ならば      #コンピューターの点数も36かそれ以上なら
        もし、(プレイヤー罰点<コンピューター罰点)ならば    #罰点のより少ない方が勝ちとなり
          「{プレイヤー名}の罰点{プレイヤー罰点}点{改行}{コンピューター名}の罰点{コンピューター罰点}点で{改行}{プレイヤー名}の勝ち!」を言う。

        違えばもし、(プレイヤー罰点>コンピューター罰点)ならば
          「{プレイヤー名}の罰点{プレイヤー罰点}点{改行}{コンピューター名}の罰点{コンピューター罰点}点で{改行}{コンピューター名}の勝ち!」を言う。

        違えば                          #それも同じならば引き分け
          「引き分けです」を言う。

    違えばもし、(コンピューター得点>=36)ならば    #プレイヤーの点数が36に満たずコンピューターの点数が36かそれ以上
      「残念!!{改行}{コンピューター名}の勝ち!」を言う。

    違えば                          #10でどちらも36を越えなかった場合
      「残念でした。{改行}10で決着がつかず{改行}無効試合となります。」を言う。

  ボタンAのテキストは「もう一度?」
#------------------------------------------------------------

 これで、いちおう遊べて、勝ち負けも判定して言ってもらえるようになったけど、未だ活用されていないテキストウィンドウに、は言わせているメッセージを表示したり、ちょぼいちの時みたく、相手のコンピューターに何かしゃべらせたりする予定。

 あと、コンピューターがサイコロを振る時も、自分でダイスを振るボタンを押してやらなければならないってのは、いかがなものか。

 この辺を手直しすれば、とりあえずは完成と言えるかな?

ゲスト



トラックバック - http://nadesiko.g.hatena.ne.jp/snowdrops89/20160516